vserver
Goto Top

Debian Jessie verschickt keine Mails

Hallo,

ich habe Debian Jessie installiert, nun erhalte ich keine Mails wenn ich in meinen Wordpress, Woltlab o.ä. Scripte mich Registriere/Passwort zurücksetze.

Ging zuvor bei Wheezy noch einwandfrei.

R=dnslookup T=remote_smtp: SMTP error from remote mail server after initial connection: host mx01.emig.gmx.net [212.XXX.5]: 554-gmx.net (mxgmx103) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit .....

vielen Dank

Content-Key: 309954

Url: https://administrator.de/contentid/309954

Printed on: April 22, 2024 at 06:04 o'clock

Member: Vision2015
Vision2015 Jul 15, 2016 at 20:26:25 (UTC)
Goto Top
Zitat von @vServer:

Hallo,
auch Hallo

ich habe Debian Jessie installiert, nun erhalte ich keine Mails wenn ich in meinen Wordpress, Woltlab o.ä. Scripte mich Registriere/Passwort zurücksetze.
warum sollte Jessie das auch tun ?
das macht wenn überhaupt Sendmail oder ähnlich...
was für einen mailserver hast du Installiert ? Postfix ?
wie ist die Config ?
Stimmt deine DNS config ?
PTR config ... also dein Revers Mapping ? ist da deine domain mit hostname eingetragen ?


Ging zuvor bei Wheezy noch einwandfrei.
tja.. da war dein server richtig eingerichtet...

R=dnslookup T=remote_smtp: SMTP error from remote mail server after initial connection: host mx01.emig.gmx.net [212.XXX.5]: 554-gmx.net (mxgmx103) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit .....
da steht deine lösung: 554 invalid DNS PTR

hättest du mit 2min Google auch selber gefunden...

vielen Dank
Gern
Frank
Mitglied: 117471
117471 Jul 15, 2016 at 21:45:56 (UTC)
Goto Top
Hallo,

unter Debian empfehle ich grundsätzlich, den exim4 für die Verwendung mit einem Smarthost zu nutzen.

Gruß,
Jörg
Member: vServer
vServer Jul 16, 2016 at 08:40:09 (UTC)
Goto Top
exim4 habe ich installiert, das funktioniert auch wenn ich das ausführe:

echo "This is a test - 03-06-2016." | mail -s Tobias mein@mail.de

diese Mail kommt an. Regirstrieren/Passwort zurücksetzen nicht face-sad
Member: kaiand1
kaiand1 Jul 16, 2016 at 09:11:29 (UTC)
Goto Top
Lass mal deine Domain/IP bei
http://mxtoolbox.com/
checken ob es da was gibt.
Member: vServer
vServer Jul 16, 2016 at 10:00:33 (UTC)
Goto Top
Hallo,

SMTP Connect Failed To Connect

Session Transcript:
Connecting to 46.38.244.60
7/16/2016 4:59:19 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.00 sec]

PWS3v2 15002ms

Danke
Member: Vision2015
Vision2015 Jul 16, 2016 at 11:21:07 (UTC)
Goto Top
Zitat von @vServer:

Hallo,

SMTP Connect Failed To Connect

Session Transcript:
Connecting to 46.38.244.60
7/16/2016 4:59:19 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.00 sec]

PWS3v2 15002ms

Danke
ich vermute du hats kein smtp server, oder nicht richtig eingerichtet!
Firewall ?

mach mal ein netstat -npl und poste das mal bitte...
Mitglied: 117471
117471 Jul 16, 2016 at 15:40:18 (UTC)
Goto Top
Hallo,

wenn dein lokaler exim4 funktioniert - warum benutzt Du ihn nicht in deinen Applikationen?

Gruß,
Jörg
Member: vServer
vServer Jul 16, 2016 at 18:53:11 (UTC)
Goto Top
  1. netstat -npl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 3589/rpcbind
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 5377/exim4
tcp 0 0 0.0.0.0:46172 0.0.0.0:* LISTEN 6510/sshd
tcp 0 0 0.0.0.0:46141 0.0.0.0:* LISTEN 422/rpc.statd
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 3608/mysqld
tcp6 0 0 :::58830 :::* LISTEN 422/rpc.statd
tcp6 0 0 :::111 :::* LISTEN 3589/rpcbind
tcp6 0 0 :::80 :::* LISTEN 17126/apache2
tcp6 0 0 ::1:25 :::* LISTEN 5377/exim4
tcp6 0 0 :::46172 :::* LISTEN 6510/sshd
udp 0 0 0.0.0.0:796 0.0.0.0:* 3589/rpcbind
udp 0 0 127.0.0.1:1022 0.0.0.0:* 422/rpc.statd
udp 0 0 0.0.0.0:43042 0.0.0.0:* 422/rpc.statd
udp 0 0 0.0.0.0:68 0.0.0.0:* 384/dhclient
udp 0 0 0.0.0.0:111 0.0.0.0:* 3589/rpcbind
udp 0 0 0.0.0.0:61692 0.0.0.0:* 384/dhclient
udp6 0 0 :::53866 :::* 384/dhclient
udp6 0 0 :::796 :::* 3589/rpcbind
udp6 0 0 :::42825 :::* 422/rpc.statd
udp6 0 0 :::111 :::* 3589/rpcbind
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 2 [ ACC ] STREAM LISTENING 46593 3608/mysqld /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 13086 3589/rpcbind /run/rpcbind.sock
unix 2 [ ACC ] STREAM LISTENING 51780 6088/python /var/run/fail2ban/fail2ban.sock
unix 2 [ ACC ] SEQPACKET LISTENING 8312 1/systemd /run/udev/control
unix 2 [ ACC ] STREAM LISTENING 8315 1/systemd /run/systemd/journal/stdout
unix 2 [ ACC ] STREAM LISTENING 10410 1/systemd /var/run/dbus/system_bus_socket
unix 2 [ ACC ] STREAM LISTENING 10413 1/systemd /run/acpid.socket
unix 2 [ ACC ] STREAM LISTENING 23547 1/systemd /run/systemd/private
Mitglied: 117471
117471 Jul 16, 2016 at 20:06:07 (UTC)
Goto Top
Hallo,

trag doch mal localhost Port 25 im WordPress ein.

Danach sollte der Versand eigentlich funktionieren.

Gruß,
Jörg
Member: vServer
vServer Jul 16, 2016 at 23:03:14 (UTC)
Goto Top
Problem ist ja das ich noch 5 weitere Scripte habe, und da wird glaub nirgends nach dem Port gefragt.
Mitglied: 117471
117471 Jul 17, 2016 at 07:15:40 (UTC)
Goto Top
Hallo,

aus Shellscripten heraus kannst Du wie von Dir beschrieben mit dem mail Utility senden.

In PHP gibst Du entweder einen SMTP-Server an oder Du nutzt die PHp-Mailfunktion, die Du ebenfalls auf den exim4 biegst. Die meisten können auch beides. Wie das jeweilige Verfahren aktiviert und eingestellt wird, steht in der Dokumentation.

So oder so - es läuft alles über deinen lokalen E-Mail-Server und von da aus zum Smarthost.

Gruß,
Jörg
Member: vServer
vServer Jul 17, 2016 at 07:31:16 (UTC)
Goto Top
Hi,

habe zuvor Wheezy drauf gehabt, da hat alles Top funktioniert. Vor 2 Wochen auf Jessie umgesteigen seitdem funktioniert das nicht mehr. Hatte zuvor auch nur exim, aber soweit ich mal gelesen habe wird das von GMX usw nicht unterstützt und muss auf rDNS umgestellt werden, oder reicht das im Mailserver von exim anzupassen?
Mitglied: 117471
117471 Jul 17, 2016 at 07:44:05 (UTC)
Goto Top
Hey,

was willst Du da umstellen? Der exim4 funktioniert laut deiner Aussage.

Du benutzt ihn nur nicht: Offenbar versuchen einige Scripte, E-Mails direkt zuzustellen. Die stellst Du auf den lokalen exim4 um und alles ist in Butter... face-smile

Gruß,
Jörg