Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Debian Jessie verschickt keine Mails

Mitglied: vServer

vServer (Level 1) - Jetzt verbinden

15.07.2016 um 22:03 Uhr, 1752 Aufrufe, 13 Kommentare

Hallo,

ich habe Debian Jessie installiert, nun erhalte ich keine Mails wenn ich in meinen Wordpress, Woltlab o.ä. Scripte mich Registriere/Passwort zurücksetze.

Ging zuvor bei Wheezy noch einwandfrei.

R=dnslookup T=remote_smtp: SMTP error from remote mail server after initial connection: host mx01.emig.gmx.net [212.XXX.5]: 554-gmx.net (mxgmx103) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit .....

vielen Dank
Mitglied: Vision2015
15.07.2016 um 22:26 Uhr
Zitat von vServer:

Hallo,
auch Hallo

ich habe Debian Jessie installiert, nun erhalte ich keine Mails wenn ich in meinen Wordpress, Woltlab o.ä. Scripte mich Registriere/Passwort zurücksetze.
warum sollte Jessie das auch tun ?
das macht wenn überhaupt Sendmail oder ähnlich...
was für einen mailserver hast du Installiert ? Postfix ?
wie ist die Config ?
Stimmt deine DNS config ?
PTR config ... also dein Revers Mapping ? ist da deine domain mit hostname eingetragen ?


Ging zuvor bei Wheezy noch einwandfrei.
tja.. da war dein server richtig eingerichtet...

R=dnslookup T=remote_smtp: SMTP error from remote mail server after initial connection: host mx01.emig.gmx.net [212.XXX.5]: 554-gmx.net (mxgmx103) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit .....
da steht deine lösung: 554 invalid DNS PTR

hättest du mit 2min Google auch selber gefunden...

vielen Dank
Gern
Frank
Bitte warten ..
Mitglied: FA-jka
15.07.2016 um 23:45 Uhr
Hallo,

unter Debian empfehle ich grundsätzlich, den exim4 für die Verwendung mit einem Smarthost zu nutzen.

Gruß,
Jörg
Bitte warten ..
Mitglied: vServer
16.07.2016 um 10:40 Uhr
exim4 habe ich installiert, das funktioniert auch wenn ich das ausführe:

echo "This is a test - 03-06-2016." | mail -s Tobias mein@mail.de

diese Mail kommt an. Regirstrieren/Passwort zurücksetzen nicht
Bitte warten ..
Mitglied: kaiand1
16.07.2016 um 11:11 Uhr
Lass mal deine Domain/IP bei
http://mxtoolbox.com/
checken ob es da was gibt.
Bitte warten ..
Mitglied: vServer
16.07.2016 um 12:00 Uhr
Hallo,

SMTP Connect Failed To Connect

Session Transcript:
Connecting to 46.38.244.60
7/16/2016 4:59:19 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.00 sec]

PWS3v2 15002ms

Danke
Bitte warten ..
Mitglied: Vision2015
16.07.2016 um 13:21 Uhr
Zitat von vServer:

Hallo,

SMTP Connect Failed To Connect

Session Transcript:
Connecting to 46.38.244.60
7/16/2016 4:59:19 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.00 sec]

PWS3v2 15002ms

Danke
ich vermute du hats kein smtp server, oder nicht richtig eingerichtet!
Firewall ?

mach mal ein netstat -npl und poste das mal bitte...
Bitte warten ..
Mitglied: FA-jka
16.07.2016 um 17:40 Uhr
Hallo,

wenn dein lokaler exim4 funktioniert - warum benutzt Du ihn nicht in deinen Applikationen?

Gruß,
Jörg
Bitte warten ..
Mitglied: vServer
16.07.2016 um 20:53 Uhr
  1. netstat -npl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 3589/rpcbind
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 5377/exim4
tcp 0 0 0.0.0.0:46172 0.0.0.0:* LISTEN 6510/sshd
tcp 0 0 0.0.0.0:46141 0.0.0.0:* LISTEN 422/rpc.statd
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 3608/mysqld
tcp6 0 0 :::58830 :::* LISTEN 422/rpc.statd
tcp6 0 0 :::111 :::* LISTEN 3589/rpcbind
tcp6 0 0 :::80 :::* LISTEN 17126/apache2
tcp6 0 0 ::1:25 :::* LISTEN 5377/exim4
tcp6 0 0 :::46172 :::* LISTEN 6510/sshd
udp 0 0 0.0.0.0:796 0.0.0.0:* 3589/rpcbind
udp 0 0 127.0.0.1:1022 0.0.0.0:* 422/rpc.statd
udp 0 0 0.0.0.0:43042 0.0.0.0:* 422/rpc.statd
udp 0 0 0.0.0.0:68 0.0.0.0:* 384/dhclient
udp 0 0 0.0.0.0:111 0.0.0.0:* 3589/rpcbind
udp 0 0 0.0.0.0:61692 0.0.0.0:* 384/dhclient
udp6 0 0 :::53866 :::* 384/dhclient
udp6 0 0 :::796 :::* 3589/rpcbind
udp6 0 0 :::42825 :::* 422/rpc.statd
udp6 0 0 :::111 :::* 3589/rpcbind
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 2 [ ACC ] STREAM LISTENING 46593 3608/mysqld /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 13086 3589/rpcbind /run/rpcbind.sock
unix 2 [ ACC ] STREAM LISTENING 51780 6088/python /var/run/fail2ban/fail2ban.sock
unix 2 [ ACC ] SEQPACKET LISTENING 8312 1/systemd /run/udev/control
unix 2 [ ACC ] STREAM LISTENING 8315 1/systemd /run/systemd/journal/stdout
unix 2 [ ACC ] STREAM LISTENING 10410 1/systemd /var/run/dbus/system_bus_socket
unix 2 [ ACC ] STREAM LISTENING 10413 1/systemd /run/acpid.socket
unix 2 [ ACC ] STREAM LISTENING 23547 1/systemd /run/systemd/private
Bitte warten ..
Mitglied: FA-jka
16.07.2016 um 22:06 Uhr
Hallo,

trag doch mal localhost Port 25 im WordPress ein.

Danach sollte der Versand eigentlich funktionieren.

Gruß,
Jörg
Bitte warten ..
Mitglied: vServer
17.07.2016 um 01:03 Uhr
Problem ist ja das ich noch 5 weitere Scripte habe, und da wird glaub nirgends nach dem Port gefragt.
Bitte warten ..
Mitglied: FA-jka
17.07.2016 um 09:15 Uhr
Hallo,

aus Shellscripten heraus kannst Du wie von Dir beschrieben mit dem mail Utility senden.

In PHP gibst Du entweder einen SMTP-Server an oder Du nutzt die PHp-Mailfunktion, die Du ebenfalls auf den exim4 biegst. Die meisten können auch beides. Wie das jeweilige Verfahren aktiviert und eingestellt wird, steht in der Dokumentation.

So oder so - es läuft alles über deinen lokalen E-Mail-Server und von da aus zum Smarthost.

Gruß,
Jörg
Bitte warten ..
Mitglied: vServer
17.07.2016 um 09:31 Uhr
Hi,

habe zuvor Wheezy drauf gehabt, da hat alles Top funktioniert. Vor 2 Wochen auf Jessie umgesteigen seitdem funktioniert das nicht mehr. Hatte zuvor auch nur exim, aber soweit ich mal gelesen habe wird das von GMX usw nicht unterstützt und muss auf rDNS umgestellt werden, oder reicht das im Mailserver von exim anzupassen?
Bitte warten ..
Mitglied: FA-jka
17.07.2016 um 09:44 Uhr
Hey,

was willst Du da umstellen? Der exim4 funktioniert laut deiner Aussage.

Du benutzt ihn nur nicht: Offenbar versuchen einige Scripte, E-Mails direkt zuzustellen. Die stellst Du auf den lokalen exim4 um und alles ist in Butter...

Gruß,
Jörg
Bitte warten ..
Ähnliche Inhalte
Linux Netzwerk

Debian 8: Services (mail, web,.) sind Serverintern nicht mehr erreichbar

Frage von Mudla2010Linux Netzwerk10 Kommentare

Hallo! Ich habe einen Server basierend auf Proxmox 4.2 unter Debian 8 und darin mehrere VM's für verschiedenen Aufgaben ...

Linux Desktop

Debian Netzwerkmanager

Frage von solardriftwoodLinux Desktop3 Kommentare

Hallo, ich hatte Linux Kodachi live gestartet, kann mich jedoch nicht per WLAN mit dem Internet verbinden, es funktioniert ...

Viren und Trojaner

Von meinem Rechner wurden Spam-Nachrichten verschickt

gelöst Frage von 85807Viren und Trojaner11 Kommentare

Hallo Admins, IT-Techniker, Mädchen-für-alles und Forum-Leser, Von meinem Rechner werden seit geraumer Zeit Spam-Nachrichten verschickt. Das weiß ich wegen ...

Debian

Debian 8.6 Absichern?

Frage von Motte990Debian14 Kommentare

Hallo Leute zurzeit befasse ich mit Debian 8.6 in einer Vmware Umgebung. Zum Einsatz kommen Debian 8.6 mit apache2 ...

Neue Wissensbeiträge
Virtualisierung

VEEAM Instant VM Recovery Datenverlust möglich

Information von sabines vor 20 StundenVirtualisierung

Wer instant VM Recovery unter Veeam nutzt, sollte seine Installation überprüfen. In manchen Fällen könnte es zu Datenverlust kommen, ...

Administrator.de Feedback
Hinweise auf Dienstleister oder auf Suchmaschinen
Information von Frank vor 4 TagenAdministrator.de Feedback71 Kommentare

Lieber User, Admins und Moderatoren, aus gegebenen Anlass möchte ich zwei Dinge endgültig klarstellen und für die Nachwelt festhalten: ...

Router & Routing

PfSense 2.4 IPSec VPN mobile Clients Phase 2 wird plötzlich nicht mehr aufgebaut - So einfach war die Lösung

Tipp von the-buccaneer vor 5 TagenRouter & Routing9 Kommentare

Moinsen! Nachdem ich mir hierbei nen Wolf gesucht habe, möchte ich doch die Welt an dieser simplen Lösung teilhaben ...

Humor (lol)
Wählscheiben Telefon
Information von brammer vor 5 TagenHumor (lol)4 Kommentare

Hallo, Mal wirkliche eine nette Spielerei brammer

Heiß diskutierte Inhalte
Netzwerkmanagement
Softwareverteilung für kleines Unternehmen mit sehr gemixter Hardware
gelöst Frage von BavarianSysadNetzwerkmanagement21 Kommentare

Hallo zusammen^^, ich stehe vor dem Problem das wir im Unternehmen eine Softwareverteilung einführen soll, leider ist dies wie ...

Netzwerkprotokolle
Verständnissfrage IPv6
Frage von killtecNetzwerkprotokolle16 Kommentare

Hi, ich habe mir einen Online-Kurs zu IPv6 angeschaut. Dabei stellt sich mir die Frage der nutzbaren IPv6-Adressen. Bei ...

Exchange Server
Exchange 2019 Wildcard geht nicht
Frage von opc123Exchange Server16 Kommentare

Hallo, ich kann mein Wildcard auf dem Exchange keine Dienste zuweisen??

Windows 10
Dell Optiplex 790 Installation Windows 10
gelöst Frage von Ghost108Windows 1016 Kommentare

Guten morgen zusammen, möchte gerne auf meinem Optiplex 790 Windows 10 installieren (Clean Install). Habe das BIOS von Legacy ...