Diskpart benutzen

Mitglied: nixxok

nixxok (Level 1) - Jetzt verbinden

18.12.2015, aktualisiert 19.12.2015, 2005 Aufrufe, 13 Kommentare

Hallo
kennst sich jemand mit Diskpart gut aus?
Ich habe einen DELL PC mit einem Datenträger, der 2 Volumes hat + eine versteckte. Durch einen Netzteilausfall musste ich ein neues Netzteil einbauen aber irgendwie kamen die Laufwerkbuchstaben durcheinander. Keine Ahnung wieso und warum....
Da war einmal in der Ausgangskonfiguration das OS auf C, der MBR und eine RECOVERY Partition und eine versteckte .
Auf jeden Fall will mir Windows einfach nicht starten. Habe es mit der Computerreparaturfunktion (DVD W7) probiert, ohne Erfolg.
Habe es jetzt mit Diskpart versucht. Laut "List Volume" hat jetzt das OS auf einmal den Laufwerkbuchstaben D und das RECOVERY hat C. Habe versucht die Buchstaben umzutauschen und dann OS (C:) face-smile als ACTIVE zu markieren. Es funktioniert aber nicht.
Was mache ich falsch?

Disk-Informationen von welcher nicht gebootet werden kann:
e98b364eed08e155156eb9d7102fbd47 - Klicke auf das Bild, um es zu vergrößern



Mitglied: Pjordorf
18.12.2015, aktualisiert um 23:04 Uhr
Hallo,

Zitat von @nixxok:
kennst sich jemand mit Diskpart gut aus?
Innerhalb Diskpart hilft dir "help". http://www.tecchannel.de/server/windows/481637/diskpartexe_festplatten_ ... oder https://technet.microsoft.com/de-de/library/cc766465(v=ws.10).aspx

irgendwie kamen die Laufwerkbuchstaben durcheinander
Eher nicht.

Da war einmal in der Ausgangskonfiguration das OS auf C, der MBR und eine RECOVERY Partition und eine versteckte .
MBR ist keine Partition - ein Partitionsschema und Bootcode. https://de.wikipedia.org/wiki/Master_Boot_Record
Welche Partition (Volume) dann als C: bezeichnet wird hängt vom startenden OS ab. C: ist bei DOS/Windows (fast) immer das Systemlaufwerk. Andere Partitionen (Volumes) können einen dir genehmen LW Buchstaben zugeordnet werden.

Auf jeden Fall will mir Windows einfach nicht starten.
Dir ist schon klar das mit dieser Information keiner einen hauch einer Chance hat zu erkennen was dein System fehlt oder was evtl. der fehler sein könnte? Fehlermeldung bzw. Bilder davon?

Habe es mit der Computerreparaturfunktion (DVD W7) probiert, ohne Erfolg.
Was wurde dort damit versucht?

Habe es jetzt mit Diskpart versucht. Laut "List Volume" hat jetzt das OS auf einmal den Laufwerkbuchstaben D und das RECOVERY hat C
Die innerhalb von Diskpart angezeigten LW Buchstaben sind dort nicht zwingend nach deiner normalen OS regeln benannt. Besonders wenn Diskpart nicht vom OS heraus gestartet wurde. Dann ordnet Diskpart die eigenständig zu, so wie du seihst wenn Diskpart per externes LW oder DVD/USB Stick gestartet wird.

Habe versucht die Buchstaben umzutauschen
Vergeblich, geht dort nicht und hat nichts damit zu tun wie dein C: innerhalb deines BCD Store gespeichert ist.

und dann OS (C:) face-smile als ACTIVE zu markieren.
Ein Select Disk xx - Select Partition XX und ein Detail Partition sagen es dir.

Es funktioniert aber nicht.
Tolle Fehlermeldung, nicht wahr:-) face-smile

Was mache ich falsch?
Keine Ahnung.
Wo ist dein BCD Store gespeichert? Eigene Partition (100 - 350 MB) (Normal ohne LW Buchstaben) auf der Platte oder einen Ordner (Versteckt) namens Boot innerhalb deines C:? Dieses Volume muss auf aktiv sitzen. https://technet.microsoft.com/de-de/library/cc709667(v=ws.10).aspx

Fehlerhafte Disk:
Frage oder Feststellung?

Und bitte Bilder direkt hier ins Forum stellen. https://www.administrator.de/faq/20#toc-5

Gruß,
Peter
Bitte warten ..
Mitglied: nixxok
19.12.2015 um 00:10 Uhr
Hi

Auf jeden Fall will mir Windows einfach nicht starten.
Dir ist schon klar das mit dieser Information keiner einen hauch einer Chance hat zu erkennen was dein System fehlt oder was evtl. der fehler sein könnte? Fehlermeldung bzw. Bilder davon?
Ich vermute nur dass es irgendwie mit dem MBR zu tun hat. Als Fehlermeldung steht: Boot missing

Habe es mit der Computerreparaturfunktion (DVD W7) probiert, ohne Erfolg.
Was wurde dort damit versucht?
ich habe versucht die Systemreparatur durchzuführen (MBR zu reparieren) so wie ich es im Web mehrfach gelesen habe

Habe versucht die Buchstaben umzutauschen
Vergeblich, geht dort nicht und hat nichts damit zu tun wie dein C: innerhalb deines BCD Store gespeichert ist.
BCD Store?

und dann OS (C:) face-smile als ACTIVE zu markieren.
Ein Select Disk xx - Select Partition XX und ein Detail Partition sagen es dir.
werde es morgen nochmals versuchen

Was mache ich falsch?
Keine Ahnung.
Wo ist dein BCD Store gespeichert? Eigene Partition (100 - 350 MB) (Normal ohne LW Buchstaben) auf der Platte oder einen Ordner (Versteckt) namens Boot innerhalb deines C:? Dieses Volume muss auf aktiv sitzen. https://technet.microsoft.com/de-de/library/cc709667(v=ws.10).aspx
das weiß ich nicht wo BCD Store gespeichert ist. Wie finde ich es heraus?

Und bitte Bilder direkt hier ins Forum stellen. https://www.administrator.de/faq/20#toc-5
ok, sorry

Grüße
Egon
Bitte warten ..
Mitglied: 122990
122990 (Level 2)
19.12.2015, aktualisiert um 09:12 Uhr
Moin,
also wenn du in das Windows PE gebootet hast und dein Windows dort aktuell auf Partition D residiert, führe folgenden Befehl in der Kommandozeile aus:
BCDboot repariert dabei die kompletten Bootfiles inkl. BCD Partitionsboot-Record/MBR in einem Rutsch. In dem Fall lass ich die Bootfiles auf die OS-Partition schreiben, nur für den Fall das die Recovery-Partition beschädigt sein sollte.

In diskpart markierst du D: dann noch als "active"
anstatt X die jeweiligen Nummern der Disk/Partition eintragen

Wenn das erledigt wurde, rebooten.

Dann im BIOS noch zur Sicherheit checken ob die Bootreihenfolge stimmt, und jegliche USB-Sticks abziehen.

Bootet jetzt dein Windows nicht ist es sehr wahrscheinlich beschädigt und du solltest ein Backup oder Snapshot zurückspielen.

Gruß grexit
Bitte warten ..
Mitglied: Metacrawler
19.12.2015 um 12:35 Uhr
Führe bitte "list partition" aus und poste den screenshot hier. deine OEM_Partition ist scheinbar nicht mehr als jene Makiert!
Bitte warten ..
Mitglied: nixxok
19.12.2015 um 14:22 Uhr
Hallo
Zitat von @122990:
also wenn du in das Windows PE gebootet hast und dein Windows dort aktuell auf Partition D residiert, führe folgenden Befehl in der Kommandozeile aus:
BCDboot repariert dabei die kompletten Bootfiles inkl. BCD Partitionsboot-Record/MBR in einem Rutsch. In dem Fall lass ich die Bootfiles auf die OS-Partition schreiben, nur für den Fall das die Recovery-Partition beschädigt sein sollte.

In diskpart markierst du D: dann noch als "active"
anstatt X die jeweiligen Nummern der Disk/Partition eintragen

Wenn das erledigt wurde, rebooten.

Dann im BIOS noch zur Sicherheit checken ob die Bootreihenfolge stimmt, und jegliche USB-Sticks abziehen.

Bootet jetzt dein Windows nicht ist es sehr wahrscheinlich beschädigt und du solltest ein Backup oder Snapshot zurückspielen.
Das habe ich jetzt gemacht. Der PC startet jetzt aber sobald das WINDOWS LOGO erscheint, bekomme ich für kurze Zeit einen BlueScreen und der PC schaltet alleine ab.
Versteh das nicht
Bitte warten ..
Mitglied: 122990
122990 (Level 2)
19.12.2015, aktualisiert um 14:47 Uhr
Zitat von @nixxok:
Das habe ich jetzt gemacht. Der PC startet jetzt
Gut!
aber sobald das WINDOWS LOGO erscheint, bekomme ich für kurze Zeit einen BlueScreen und der PC schaltet alleine ab.
Versteh das nicht
Dann drücke beim Start F8 und nehm die Option das bei Systemfehler kein Reboot erfolgt und du die Bluescreenmeldung lesen, und hier posten kannst.

Einen Bluescreen kann viele Ursachen haben:
  • defekte Festplatten / Sektoren
  • fehlerhafter RAM
  • korrupte / inkompatible Treiber / Treiber von Virenscannern etc.
  • weitere Hardwarefehler

Deswegen zu aller erst die Hardware ausschließen und einen Hauptspeichertest (memtest86) durchführen. Dann die Festplatte auf defekte Sektoren überprüfen (chkdsk -f -r d: unter Windows PE) oder mit einem Live-Linux. Dazu gehört auch die SMART Parameter der FP zu überprüfen, um ein mögliches Sterben der Platte erkennen zu können.

Wenn das keine Fehler bringt, setze dein Windows auf einen früheren Snapshot zurück, es kann ja auch ein Virus sein der dein System verbogen hat. Also gehört ein Offline-Virenscan (z.B. mit Knoppicilin) ebenso zur Vorsorge

Durch einen Netzteilausfall musste ich ein neues Netzteil einbauen
Du schreibst das du das Netzteil ausgetauscht hast,
  • hast du auch auf die ausreichende Wattage geachtet und alle Anschlüsse richtig gesetzt (Die Prozessor-12V Leitungen und eventuelle zusätzliche Stromversorgungen der Grafikkarte auch nicht vergessen) ?
  • hast du dich beim Austausch ausreichend geerdet (Antistatikarmbändchen)? Ohne kannst du ganz schnell Bauteile bruzzeln, geht schneller als du denkst.
  • alle Anschlüsse auf festen Sitz überprüft ?
  • überprüft ob alle Lüfter sich drehen?

Denn es ist auffällig das der Fehler nach dem Austausch auftritt, also vermute ich hier einen Fehler beim Einbau oder das Netzteil könnte auch einen weg haben, auch wenn es neu ist. Aber überprüfe erst mal alle obigen Dinge.
Bitte warten ..
Mitglied: nixxok
19.12.2015 um 15:05 Uhr
Hallo
nochmal der Reihe nach:
1. PC lässt sich nicht einschalten (was vermuten lässt ob das Netzteil oder Stromkabel oder etwas anderes beschädigt ist). Habe daraufhin ein anderes gebrauchtes Netzteil am PC rangehängt (HDD, Grafikkarte und DVD abgeklemmt) außer die MediaKarte hatte ich drangelassen. Um zu probieren ob es am Netzteil lag, und siehe da, der PC ging an und gab dann nach einigen Sekunden einen längeren Piepton von sich. Daraufhin habe ich ihn wieder ausgeschaltet und ein neues Netzteil gekauft und eingebaut. Daraufhin den PC gestartet und es ging nichts wie schon in den obigen Posts geschrieben....
Habe mir soeben einen USB Stick mit Windows Defender Offline heruntergeladen, mal schauen....



Zitat von @122990:

Zitat von @nixxok:
Das habe ich jetzt gemacht. Der PC startet jetzt
Gut!
aber sobald das WINDOWS LOGO erscheint, bekomme ich für kurze Zeit einen BlueScreen und der PC schaltet alleine ab.
Versteh das nicht
Dann drücke beim Start F8 und nehm die Option das bei Systemfehler kein Reboot erfolgt und du die Bluescreenmeldung lesen, und hier posten kannst.

Einen Bluescreen kann viele Ursachen haben:
  • defekte Festplatten / Sektoren
  • fehlerhafter RAM
  • korrupte / inkompatible Treiber / Treiber von Virenscannern etc.
  • weitere Hardwarefehler

Deswegen zu aller erst die Hardware ausschließen und einen Hauptspeichertest (memtest86) durchführen. Dann die Festplatte auf defekte Sektoren überprüfen (chkdsk -f -r d: unter Windows PE) oder mit einem Live-Linux. Dazu gehört auch die SMART Parameter der FP zu überprüfen, um ein mögliches Sterben der Platte erkennen zu können.

Wenn das keine Fehler bringt, setze dein Windows auf einen früheren Snapshot zurück, es kann ja auch ein Virus sein der dein System verbogen hat. Also gehört ein Offline-Virenscan (z.B. mit Knoppicilin) ebenso zur Vorsorge

Durch einen Netzteilausfall musste ich ein neues Netzteil einbauen
Du schreibst das du das Netzteil ausgetauscht hast,
  • hast du auch auf die ausreichende Wattage geachtet und alle Anschlüsse richtig gesetzt (Die Prozessor-12V Leitungen und eventuelle zusätzliche Stromversorgungen der Grafikkarte auch nicht vergessen) ?
  • hast du dich beim Austausch ausreichend geerdet (Antistatikarmbändchen)? Ohne kannst du ganz schnell Bauteile bruzzeln, geht schneller als du denkst.
  • alle Anschlüsse auf festen Sitz überprüft ?
  • überprüft ob alle Lüfter sich drehen?

Denn es ist auffällig das der Fehler nach dem Austausch auftritt, also vermute ich hier einen Fehler beim Einbau oder das Netzteil könnte auch einen weg haben, auch wenn es neu ist. Aber überprüfe erst mal alle obigen Dinge.

Bitte warten ..
Mitglied: 122990
122990 (Level 2)
19.12.2015, aktualisiert um 15:22 Uhr
Zitat von @nixxok:
1. PC lässt sich nicht einschalten (was vermuten lässt ob das Netzteil oder Stromkabel oder etwas anderes beschädigt ist).
OK
Habe daraufhin ein anderes gebrauchtes Netzteil am PC rangehängt (HDD, Grafikkarte und DVD abgeklemmt)
Was für eins, ein hoffentlich funktionsfähiges nach gefordertem ATX Standard
außer die MediaKarte hatte ich drangelassen.
Was für eine "MediaKarte" ??
Um zu probieren ob es am Netzteil lag, und siehe da, der PC ging an und gab dann nach einigen Sekunden einen längeren Piepton von sich.
Welche Piepreihenfolge ? Vermutlich nicht alle nötigen Komponenten versorgt (Graka), eventuell dadurch auch Bauteile beschädigt ..
Daraufhin habe ich ihn wieder ausgeschaltet und ein neues Netzteil gekauft und eingebaut.
Mehr Details wie Wattage Leistung auf den unterschiedlichen Schienen und Anforderungen deines Mainboards und aller Komponenten ..
Netzteile gibts viele aber nicht jedes ist für jeden Rechner geeignet!
Daraufhin den PC gestartet und es ging nichts wie schon in den obigen Posts geschrieben....
Besser das nächste mal einen erfahrenen Dienstleister ran lassen.
Bitte warten ..
Mitglied: nixxok
19.12.2015 um 15:39 Uhr
Zitat von @122990:
Habe daraufhin ein anderes gebrauchtes Netzteil am PC rangehängt (HDD, Grafikkarte und DVD abgeklemmt)
Was für eins, ein hoffentlich funktionsfähiges nach gefordertem ATX Standard
ja ATX Standard

außer die MediaKarte hatte ich drangelassen.
Was für eine "MediaKarte" ??
ein Cardreader welcher intern am USB hing

Um zu probieren ob es am Netzteil lag, und siehe da, der PC ging an und gab dann nach einigen Sekunden einen längeren Piepton von sich.
Welche Piepreihenfolge ? Vermutlich nicht alle nötigen Komponenten versorgt (Graka), eventuell dadurch auch Bauteile beschädigt ..
das war ein längerer Piepton (genau kann ich mich nicht mehr erinnern) Graka hatte ich nicht angeschlossen....

Mehr Details wie Wattage Leistung auf den unterschiedlichen Schienen und Anforderungen deines Mainboards und aller Komponenten ..
ist ein DELL System

Netzteile gibts viele aber nicht jedes ist für jeden Rechner geeignet!
das neue Netzteil ist ein Be-Quiet 350W.

Daraufhin den PC gestartet und es ging nichts wie schon in den obigen Posts geschrieben....
Besser das nächste mal einen erfahrenen Dienstleister ran lassen.
:-) face-smile hast Recht

also wie gesagt PC startet jetzt aber nach dem WIN Logo erscheint kurz der Bluescreen mit Fehlercode: 0x0000007B
habe den PC mit USB stick gebootet und mit Windows Defender überprüft. Keine Fehler gefunden.... :-( face-sad
Bitte warten ..
Mitglied: 122990
122990 (Level 2)
LÖSUNG 19.12.2015, aktualisiert um 17:14 Uhr
Zitat von @nixxok:
also wie gesagt PC startet jetzt aber nach dem WIN Logo erscheint kurz der Bluescreen mit Fehlercode: 0x0000007B
AHA dann ist mir alles klar, dir hats den Fesplattencontrollermodus im BIOS bei deiner Aktion verstellt ... je nachdem ob du RAID verwendest stell ihn entweder auf IDE, AHCI oder RAID.
Einer von den drei Modi ist es. Ich tippe bei dir aber eher darauf das er jetzt auf IDE steht, stell ihn also auf AHCI. Dann läuft dein Windows wieder ;-) face-wink
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 19.12.2015, aktualisiert um 17:14 Uhr
Hallo,

Zitat von @nixxok:
ein Cardreader welcher intern am USB hing
Sag es doch gleich.

ist ein DELL System
Sagt nur aus wer der Hersteller ist, aber nicht was das teil kann oder an Leistung braucht.

das neue Netzteil ist ein Be-Quiet 350W.
Da wir deinen Rechner nicht kennen , bis auf das Dell dat dingens gebaut hat, kann dir keiner sagen ob die Gesamtleistung von 350 Watt zum Starten reicht. Da werden die meisten Ströme verbraten.

erscheint kurz der Bluescreen mit Fehlercode: 0x0000007B
Der Blue Screen of Death sollte nicht nur kurz erscheinen sondern stehen bleiben bis das du etwas machst. Der geht nicht von alleine weg.

habe den PC mit USB stick gebootet und mit Windows Defender überprüft. Keine Fehler gefunden.... :-( face-sad
Wundert dich das? Virensuche hat mit Hardware nicht gefunden nun mal nichts gemein.

Dein 0x0000007B sagt aus das die Festplatte nicht gefunden wird wo dein Windows installiert ist. Entweder falsche Eintragungen im BCD Store oder in dein BIOS passt IDE / AHCI / RAID nun nicht mehr mit deiner installierten Platte bzw. die verwendeten Treiber mehr überein. War dein BIOS zurückgesetzt worden oder die Werte verstellt nach deiner Netzteil Aktion? Du brauchst entweder IDE oder AHCI oder RAID im BIOS.

Gruß,
Peter
Bitte warten ..
Mitglied: nixxok
19.12.2015 um 16:00 Uhr
Zitat von @122990:

Zitat von @nixxok:
also wie gesagt PC startet jetzt aber nach dem WIN Logo erscheint kurz der Bluescreen mit Fehlercode: 0x0000007B
AHA dann ist mir alles klar, dir hats den Fesplattencontrollermodus im BIOS bei deiner Aktion verstellt ... je nachdem ob du RAID verwendest stell ihn entweder auf IDE, AHCI oder RAID.
Einer von den drei Modi ist es. Ich tippe bei dir aber eher darauf das er jetzt auf IDE steht, stell ihn also auf AHCI. Dann läuft dein Windows wieder ;-) face-wink
ich hatte mal auf dem PC ein RAID 1, habe aber vor einigen Monaten das Raid getrennt und seither nur mehr eine HDD benutzt. Im Bios sehe ich die Möglichkeit zwischen ATA und RAID auszuwählen (war ATA aktiviert). Habe es jetzt auf RAID gesetzt und sehe da: Windows ist gestartet !!!
DU BIST SUPER !! :-) face-smile
Ich danke dir für deine Hilfe und wünsche dir ein schönes Weihnachtsfest
Bitte warten ..
Mitglied: 122990
122990 (Level 2)
LÖSUNG 19.12.2015, aktualisiert um 17:14 Uhr
Zitat von @nixxok:
Ich danke dir für deine Hilfe und wünsche dir ein schönes Weihnachtsfest
Kein Problem dafür sind wir ja da :-) face-smile
Wünsche ebenfalls ein besinnliches Fest.
Bitte warten ..
Heiß diskutierte Inhalte
Off Topic
Ein Weg weg von Microsoft. Wie würde man es angehen? Lasst uns doch etwas spinnen
it-fraggleVor 1 TagAllgemeinOff Topic53 Kommentare

Guten Morgen Kollegen, es treibt mich schon seit einigen Jahren um, dass es sinnvoll wäre langsam einen Weg weg von Microsoftprodukten zu finden. Mir ...

Hardware
Versorgungsengpass Chips
NebellichtVor 1 TagAllgemeinHardware22 Kommentare

Allg. frage ich mich ja warum Apple auf ARM frühzeitig gesetzt hat. Die Automobilindustrie gerade Absatzprobleme hat, weil keine Chips mehr geliefert werden können. ...

Windows Server
Server 2019 RDS-CALs für Domänen-Admins? Ernsthaft?
gelöst anteNopeVor 1 TagFrageWindows Server7 Kommentare

Nabend zusammen, ich habe hier heute einen RDS auf Basis eines Server 2019 STD installiert und mit User-CALs lizenziert. Soweit funktioniert auch alles. Nur ...

Festplatten, SSD, Raid
Wie würdet ihr eine Datenrettung machen?
pd.edvVor 23 StundenFrageFestplatten, SSD, Raid11 Kommentare

Hallo, ich arbeite gerade an einem Blog-Artikel zum Thema Datenrettung und würde mich brennend interessieren wie Ihr eine Datenrettung angehen würdet. Sagen wir mal ...

Windows Server
Lokaler DNS verlangsamt Internet?
gelöst Rattical84Vor 10 StundenFrageWindows Server20 Kommentare

Hallo zusammen, ich habe hier eine Domäne mit dem Domänencontroller als DNS-Server. Das ist der einzige DC und DNS-Server im Netz. Jetzt habe ich ...

Ubuntu
Installiert auf Rechner
khaldrogoVor 14 StundenFrageUbuntu9 Kommentare

Hallo Leute, Wir haben einen neuen Server bekommen, auf dem wir per Remotedesktopverbindung verbunden sind und arbeiten. Auf dem Server sind leider nicht alle ...

Multimedia
PDF Dokumente KOSTENLOS ausfüllen, wie?
Mrhallo19981Vor 1 TagFrageMultimedia12 Kommentare

Hallo, ich möchte PDF Dokumente kostenlos ausfüllen. Anschließend sollen diese Signiert werden. Signieren tu ich mit einem Zertifikat von Adobe. Deswegen ist es wichtig, ...

Windows 10
Blog 2: Mal wieder Microsoft haten?
GrueneSosseMitSpeckVor 1 TagBlogWindows 102 Kommentare

und allseits beliebt: die Kirsche blüht vor dem Haus. Also endlich mal die neue Kamera ausgepackt, ein paar Fotos geknipst, und dann? USB Kabel ...