manuel-r
Goto Top

Druckerzuweisung per GPO - Problem bei Einschränkung auf Gruppe (Zielgruppenadressierung)

Ich mal wieder...
Das Jahr neigt sich dem Ende und ich schau gerade mal wieder, was ich zukünftig anders und viellecht besser umsetzen kann. Deshalb wollte ich mich ganz gerne vom Druckermapping per Logonscript verabschieden und stattdessen über GPO steuern. Gesagt getan.
Ich hab also (unter Server 2008 mit XP-Clients) ein GPO erstellt und darin als Benutzerrichtlinie (Systemsteuerung/Drucker) unsere ganzen am Printserver freigegebenen Drucker eingestellt.
Damit jetzt nicht jeder User alle Drucker bekommt wollte ich die Zuweisung gerne über die Mitgliedschaft in Gruppen einschränken. Dazu hab ich dann im AD je Drucker eine Gruppe angelegt (User_Prt1, User_Prt2,...) und darin dann die User verknüpft, die den jeweiligen Drucker bekommen sollen. Außerdem natürlich im GPO über die Zielgruppenadressierung bei jedem Drucker die zugehörige Druckergruppe angegeben auf die das GPO angewendet werden soll.
Anmerkung: Falls jetzt einer denkt "Warum so kompliziert?" Ganz einfach. Ich habe hier einen schon älteren Mitarbeiter aus NT4 Zeiten. Wenn ich dem was von GPO erzähle haut das nicht so hin. Mit Usern und Gruppen kommt er aber klar und könnte so einem User einen Drucker geben oder wegnehmen.
Zurück zum Problem. Das GPO funktioniert nicht. Zumindest nicht, solange ich bspw. die Prüfung auf die (manuell erstellte) Gruppe User_Prt1 mit eingebaut habe. Nehme ich das raus, werden die Drucker verbunden. Natürlich jedem - was ich nicht will. Schränke ich auf Domänen-Benutzer (also eine BuiltIn-Gruppe) ein geht es. Genauso, wenn ich auf eine bestimmte OU beschränke. Das nutzt mir aber alles nichts.
Daher die Frage aller Fragen: Bin ich irgendwie zu blöd oder stolpere ich über einen Bug?

Manuel

Content-Key: 131695

Url: https://administrator.de/contentid/131695

Printed on: June 16, 2024 at 16:06 o'clock

Member: DerWoWusste
DerWoWusste Dec 15, 2009 at 10:13:03 (UTC)
Goto Top
Wir weisen drucker nach ähnlichem Muster zu (an Rechnergruppen, nicht an Benutzergruppen), probier das mal.
Member: manuel-r
manuel-r Dec 15, 2009 at 10:18:18 (UTC)
Goto Top
Teste ich mal. Melde mich dann zurück...
Member: DerWoWusste
DerWoWusste Dec 15, 2009 at 10:21:23 (UTC)
Goto Top
Natürlich dann auch im Computerteil der GPO einstellen... ;)
Member: manuel-r
manuel-r Dec 15, 2009 at 10:29:27 (UTC)
Goto Top
Das wird schwierig, weil freigegebene Drucker nur beim Benutzer geht. Also muss wohl die Loopbackverarbeitung herhalten face-wink
Member: DerWoWusste
DerWoWusste Dec 15, 2009 at 10:35:18 (UTC)
Goto Top
Äh? Bei mir geht's auch im Computerteil. Policies - Windows Settings - deployed printers
Member: manuel-r
manuel-r Dec 15, 2009 at 10:46:35 (UTC)
Goto Top
Bei mir nicht face-sad

180a2c056550cfcbfd52738c4fd81db3
Member: DerWoWusste
DerWoWusste Dec 15, 2009 at 10:48:32 (UTC)
Goto Top
Nee, nicht im Bereich Einstellungen, das sind die GPPs, die Du am Wickel hast. Im Bereich Richtlinien der Computerabteilung. Dazu muss am DC die Printserverrolle installiert sein.
Member: manuel-r
manuel-r Dec 15, 2009 at 10:52:39 (UTC)
Goto Top
Keine Ahnung, hab ich noch nie probiert, weil mein Printserver nicht der DC ist. Grundsätzlich müsste es aber ja auch über diesen Weg gehen. Dafür hat man das doch eingebaut.
Member: DerWoWusste
DerWoWusste Dec 15, 2009 at 10:56:17 (UTC)
Goto Top
Richtig. Gab aber viel Ärger (unter anderem bei mir : ) während die computergebundene Zuweisung keinen Ärger macht.