elcativoger
Goto Top

Exchange "gelöschte Elemente" Zeit für alle ändern

Moin.

Ich habe versucht per Powershell die Vorhaltezeit für "gelöschte Elemente" anzupassen.
Sie soll von 30 auf 14 Tage herabgesetzt werden.

Also Powershell als Admin gestartet (am MSX) und

eingegeben.

Ergebnis:

WARNUNG: Der Befehl wurde erfolgreich abgeschlossen, es wurden jedoch keine Einstellungen von
'Firma.local/MyBusiness/Users/SBSUsers/James Bond' geändert.


Wo ist mein Fehler?

Gruß
alex

Content-Key: 4019694863

Url: https://administrator.de/contentid/4019694863

Ausgedruckt am: 25.09.2022 um 08:09 Uhr

Mitglied: Hubert.N
Hubert.N 22.09.2022 um 12:15:34 Uhr
Goto Top
Moin

solange Du nicht irgendwie auch mal ein Set-Mailbox einbaust, wird das auch nichts werden. Allerdings verstehe ich Deine Ausgabe dann auch wieder nicht, den die sagt ja, dass Du schon etwas verändern wolltest.

Der von Dir gewünschte Aufruf findet sich aber auch genauestens auf der Webseite von Microsoft, die man in den Suchtreffern ganz oben hat, wenn man nur mal nach RetainDeletedItemsFor sucht:
https://learn.microsoft.com/de-de/exchange/recipients-in-exchange-online ...

Gruß
Mitglied: goscho
Lösung goscho 22.09.2022 um 12:30:34 Uhr
Goto Top
Mahlzeit,

standardmäßig werden gelöschte Elemente ja eh schon nur 14 Tage aufbewahrt, oder irre ich hier?

Wenn das für alle gelten soll, ist diese Aufgabe sehr einfach über die EAC zu lösen:
Server -> Mailbox Datenbank auswählen -> Bearbeiten -> Grenzwerte -> *gelöschte Elemente aufbewahren für (Tage) -> 14 eintragen und speichern

Hier ist die Anleitung von Microsoft.
Mitglied: 3803037559
Lösung 3803037559 22.09.2022 aktualisiert um 13:11:30 Uhr
Goto Top
Da ist kein Fehler, die Warnung sagt doch schon alles, es wurde nichts geändert weil es nichts zu ändern gibt und weil der vorhandene Wert beim User gleich ist wie der den du setzen willlst. ...
Des weiteren wird der individuelle Wert in Mailboxen auch nur benutzt wenn der Parameter -UseDatabaseRetentionDefaults auf $false festgelegt wird.

Btw. Für alle UserMailboxen in der Datenbank machst du das so
Und ja 14 Tage ist eh schon der Default.

Cheers certguy
Mitglied: ElCativoGER
ElCativoGER 22.09.2022 um 13:23:02 Uhr
Goto Top
Sorry. Hab die falsche Zeile hier reinkopiert.
Shame on my head.

Ich habe natürlich die Anleitung von Microsoft befolgt, mit der Set-Mailbox Zeile.


Jedoch bleibt alles auf 30 Tage, nachdem ich geprüft habe.

Gruß
Alex
Mitglied: Dani
Dani 22.09.2022 um 16:27:40 Uhr
Goto Top
Moin,
könnte sein, dass der Wert nicht von der Mailbox sondern von der Mailbox Database (übergeordnet zur Mailbox) übernommen wird. Configure Deleted Item retention and Recoverable Items quotas in Exchange Server


Gruß,
Dani
Mitglied: 3803037559
3803037559 22.09.2022 aktualisiert um 21:09:10 Uhr
Goto Top
Zitat von @ElCativoGER:
Jedoch bleibt alles auf 30 Tage, nachdem ich geprüft habe.
Sieh dir doch mal bitte meinen Hinweis dazu an, wenn du individuelle Retentions setzen willst musst du den o.g. Parameter zusätzlich
auf $false setzen sonst wirkt ein Einstellen des Zeitraums nicht.
Da du aber sowieso alle gleich setzen willst nimm meine Variante mit den Database Retentions und setze den Parameter -UseDatabaseRetentionDefaults auf $true, dann erübrigt sich das Setzen des Wertes in den Mailboxen.
Mitglied: ElCativoGER
ElCativoGER 23.09.2022 um 08:22:20 Uhr
Goto Top
Moin.

Habs es jetzt dank euch lösen können.
Aber die Quotas waren es ja nicht. Es ging NUR um die -RetainDeletedItems.

Danke euch!