kirschi
Goto Top

Fehler beim Patchen von Adobe Reader 9.3.3 für die Verteilung per GPO

Hallo Leute,

versuche gerade die neueste msi zu erstellen mit

msiexec /a C:\Test\AdbeRdr932_de_DE.msi /p C:\Test\AdbeRdrUpd933_all_incr.msp

aber beim Patchen der Datei AcrobatUpdater.exe kommt: "Fehler bei der Anwendung des Patch auf Datei C:\config.msi\xxx.tmp. Die Datei wurde wahrscheinlich bereits auf andere Weise aktualisiert und kann von diesem Patch nicht mehr verändert werden...
3f9a7ac292484744561755df51cef610

Ist das bei euch auch so?

Gruß
Andreas

Content-Key: 146003

Url: https://administrator.de/contentid/146003

Printed on: June 19, 2024 at 00:06 o'clock

Member: DerWoWusste
DerWoWusste Jun 30, 2010 at 14:19:03 (UTC)
Goto Top
Ging bei mir.

Ist in c:\test auch die administrative Installation? Muss sein.
Member: Kirschi
Kirschi Jun 30, 2010 at 16:47:55 (UTC)
Goto Top
Nabend,
ja, habe auf ignorieren geklickt. Aber ich brauche doch die msi zum Verteilen. Komisch ist, daß in einer VM-Testinstallation die gleiche Fehlermeldung kommt. Ich werde nochmal versuchen, alle Patches ab der 9.3.0 anzuwenden.

Gruß
Andreas

EDIT:
Habe gerade unter Win7 auf Basis der frisch runtergeladenen AdbeRdr930_de_DE.msi der Reihe nach die Patches gestartet und das lief soweit fehlerfrei. Warum das auf Arbeit nicht klappten wollte? Da kann ja nur die dortige Patchgrundlage AdbeRdr932_de_DE.msi defekt sein.
Member: schmidtshauser
schmidtshauser Jul 02, 2010 at 09:42:46 (UTC)
Goto Top
Hallo an alle,

ich check das auch nicht!

Beim Update auf 9.3.2 braucht die 9.3. zum updaten, nicht die 9.3.1.
Und bei der 9.3.3 brauche ich jetzt nicht die 9.3. sondern die 9.3.2.

Gruß
Member: DerWoWusste
DerWoWusste Jul 02, 2010 at 11:45:27 (UTC)
Goto Top
Bei mir war alles nach Plan: administrative Installation des 9.3, Patch auf 9.3.1 (vor einiger Zeit), dann auf 9.3.2 und jetzt auf 3 ohne Mucken.
Member: Collard
Collard Jul 05, 2010 at 07:31:46 (UTC)
Goto Top
Hallo,

ich habe dasselbe Problem, Die Files habe nun schon einigen male neu heruntergeladen, sowie verschiede PC's ausprobiert.
Ich bekommen einfach nicht 9.3.3 in die msi.

EDIT: kaum geschrieben, Fehler bei mir entdeckt. Das verzeichniss beim update auf 9.3.1 und 9.3.2 darf unterschiedlich sein, beim Update auf 9.3.3 aber nicht...
Member: Netscape
Netscape Jul 05, 2010 at 08:01:42 (UTC)
Goto Top
Hi,

ich wollte nun auch Updaten, aber beim customizen bekomme ich einen Fehler. Die Patches habe ich nach dieser Anleitung (siehe Link) integriert. Aber wenn ich mit dem Adobe Customization Wizard Einstellungen mache, kommt manchmal: Fehler, Setup.ini nicht gefunden

Link: http://community.spiceworks.com/how_to/show/479
Member: rziemke
rziemke Jul 05, 2010 at 12:23:43 (UTC)
Goto Top
Hi,

Ich installiere immer mit meinem Script ohne Probleme aber natürlich mit Administratorrechten:
###
SET LW="Pfad der Installationsdateien"

ECHO. Installation Adobe Reader 9.3.x
%LW%\Program\AdobeRdr93\Setup.exe /sPB

msiexec.exe /i %LW%\Program\AdbeRdrSD90_all.msi /passive
msiexec.exe /p %LW%\Program\AdobeRdr93\AdbeRdrUpd931_all_incr.msp /passive /noRestart
msiexec.exe /p %LW%\Program\AdobeRdr93\AdbeRdrUpd932_all_incr.msp /passive /noRestart
msiexec.exe /p %LW%\Program\AdobeRdr93\AdbeRdrUpd933_all_incr.msp /passive /noRestart
exit
###

Das entpackte Setup erhält man auch nach einer Installation aus dem Pfad:
C:\Program Files\Adobe\Reader 9.0\Setup Files\{AC76BA86-7AD7-1031-7B44-A93000000001}
Dann kann man gleich mit msiexec arbeiten, doch für mich hat sich die obige Version bewährt, da damit gleich eine Aufräumaktion aller vorherigen 9ner Reader gestartet wird.

man kann die Patchinstallation auch in eine Zeile abarbeiten lassen
msiexec.exe /p %LW%\Program\AdobeRdr93\AdbeRdrUpd931_all_incr.msp; AdbeRdrUpd932_all_incr.msp; AdbeRdrUpd933_all_incr.msp /passive /noRestart

viel Spaß beim testen
Member: Wurstsalat
Wurstsalat Jul 12, 2010 at 08:32:08 (UTC)
Goto Top
Zitat von @Kirschi:
Hallo Leute,

versuche gerade die neueste msi zu erstellen mit

msiexec /a C:\Test\AdbeRdr932_de_DE.msi /p C:\Test\AdbeRdrUpd933_all_incr.msp


hatte das Problem auch...
hab dann die Pakete von Adobe nochmal runtergeladen (930, patch 932 und patch 933) und folgendes gemacht (/p vor /a angegeben, anderstrum hats nicht geklappt)

msiexec /p C:\Test\AdbeRdrUpd932_all_incr.msp /a C:\Test\AdbeRdr930_de_DE.msi
msiexec /p C:\Test\AdbeRdrUpd933_all_incr.msp /a C:\Test\AdbeRdr930_de_DE.msi

Als "Netzwerkspeicherplatz" hab ich den Pfad der Pakete genommen, also hier jetzt C:\Test
Member: X-treme
X-treme Jul 28, 2010 at 09:17:54 (UTC)
Goto Top
Ich habe die Version 9.3.0 per GPO verteilen lassen und später die Patches (msp) der Versionen 9.3.1 und 9.3.2 eingearbeitet und diese auch verteilen lassen. Hat alles wunderbar funktioniert.

Wenn ich jetzt aber die Version 9.3.3 einarbeite und das fertige MSI Paket installieren will, bekomme ich folgende Fehlermeldung:

http://img3.imagebanana.com/img/4jo3h016/AdobeFehler.jpg
Member: Monschu
Monschu Aug 26, 2010 at 07:26:01 (UTC)
Goto Top
versuch mal den 9.3.4 schon einzubinden, wir hatten ein ähnliches problem bei unserem client management system. und zwar erkannte er das erstellte msi mit den msp 9.3.3 bei uns immer als 9.3.0 welches bei uns eben bereits installiert oder älter als 9.3.1 und 9.3.2 erscheint.

wir haben es so gelöst das wir zuerst den installierten reader deinstalliert und dann die msi mit dem 9.3.4 installiert haben.