File Server Windows 2019 Performance Probleme

samet22
Goto Top
Hallo face-smile

ich hoffe, dass mir jemand helfen kann. Mein File-Server ist ein Windows Server 2019 (Virtuell) welche eine 10GB Karte zugewiesen hat (Switch ebenfalls 10GB fähig). Der Server läuft auch einwandfrei und mit einer sehr guten Performance. WENN ABER (Die QM Abteilung muss dies einmal im Monat machen) die QM Abteilung 6GB Daten welche aus 8.500 Dateien besteht auf die Festplatte kopiert dann arbeiten die anderen Kollegen am File-Server mit starken Verzögerungen! Die Leitung selbst kann nicht ausgelastet sein da das arbeiten auf anderen Servern welche an der selben Leitung hängen ohne LAGs funktioniert.

Das einzige was ich bemerkt habe ist, dass beim Ressourcen-Monitor die TCP Verbindungen auf 100 hochschießt. Und die Netzwerk auslast auf 110Mb/s liegt (was ja stimmt da die Clients mit 1GB angeschlossen sind).

CPU und RAM sind beim kopieren mit ca. 40% ausgelastet, also sollte dies auch kein Problem sein. Die RDP Session selbst ist während diesem Kopiervorgang ebenfalls verzögert.

... mir kommt es so vor als gäbe es hier eine Software-Seitige Einschränkung.

Danke schonmal für eure Hilfe!

lg Samet

Content-Key: 636516

Url: https://administrator.de/contentid/636516

Ausgedruckt am: 04.07.2022 um 10:07 Uhr

Mitglied: canlot
canlot 30.12.2020 um 11:49:24 Uhr
Goto Top
Hi,

welches Storage hast du da drunter?
Vielleicht ist es ausgelastet?
was für Festplatten hast du da drunter? SSD oder HDD?
Welches RAID?

Gruß
Mitglied: samet22
samet22 30.12.2020 um 11:52:10 Uhr
Goto Top
Hallo,

Ich habe SAS SSD Festplatten auf RAID 5 darunter, Die Datenträger Auslastung ist minimal! Das Problem liegt mehr daran, dass es viele kleine Dateien sind und anscheinend irgendwo eine bestimmte grenze erreicht wird.

lg
Mitglied: Inf1d3l
Inf1d3l 30.12.2020 um 12:03:18 Uhr
Goto Top
Virenscanner?
Mitglied: themuck
themuck 30.12.2020 um 12:06:58 Uhr
Goto Top
Und wie wird Kopiert? Aus einer Anwendung heraus, mit dem Explorer?

https://www.ip-insider.de/teracopy-robocopy-richcopy-und-xcopy-fuer-schn ...
Mitglied: samet22
samet22 30.12.2020 aktualisiert um 12:13:45 Uhr
Goto Top
Hallo,

Ja Virenscanner ist installiert. Ist der Kaspersky. aber wie gesagt 40% maximal CPU auslast. Netzwerk-Aktivitäts-Kontrolle ist beim Kaspersky deaktiviert.
Mitglied: samet22
samet22 30.12.2020 um 12:12:25 Uhr
Goto Top
Es wird einfach aus dem Explorer raus kopiert. Das sollte ein Normaler Benutzer auch ohne XCOPY und co. machen können und dabei keine Kollegen "blockieren"
Mitglied: anteNope
anteNope 30.12.2020 um 12:22:30 Uhr
Goto Top
Ja Virenscanner ist installiert. Ist der Kaspersky
Deaktivier mal Kaspersky komplett 😏

Ich weiß ja nicht was die da für Daten schieben und wie nachher der Zugriff darauf sein soll, hört sich aber stark nach einer "Archivierung" o.ä. an. Man könnte ja vorschlagen die Daten zu zippen?

Ggf. denen ein Skript an die Hand geben.
Mitglied: DerWoWusste
DerWoWusste 30.12.2020 aktualisiert um 12:24:40 Uhr
Goto Top
Hi.

Das Problem liegt mehr daran, dass es viele kleine Dateien sind und anscheinend irgendwo eine bestimmte grenze erreicht wird.
Das ist mit Sicherheit nicht der Grund. Die Anzahl der übertragenene Daten interessiert nicht die Bohne.

Welcher Prozess schafft denn 40% CPU-Auslastung (von wieviel Kernen) dabei?
Und ist dies wirklich anders, wenn Du statt 6 GB in 8500 Dateien mal eine 6 GB ISO (Win10 Setup) überträgst?

Doch nun zu meinem eigentlichen Punkt: warum sollte dabei die Anzahl der TCP-Connections steigen in resmon? Schreibe ich was auf eine Freigabe, so habe ich eine (1) Verbindung, egal, wie viele Dateien ich übertrage.
Welche Prozesse siehst Du denn in resmon?
Mitglied: samet22
samet22 30.12.2020 um 12:38:31 Uhr
Goto Top
Hallo,

Hier kopiere ich vom Netzlaufwerk auf den PC.

bei einer einzigen 8 GB Datei (Fujitsu SERVERVIEW ISO) läuft die CPU auf 25% (Da ist ganz oben dann der SYSTEM Dienst. Auch hier ist dann beispielsweise beim Navigieren im Netzlaufwerk (Ordner Wechsel, Datei öffnen, Datei speichern) nichts verzögert.

Bei vielen kleinen Dateien "schießt" die CPU auf 30-40% (System 25 und ca. 15% Kaspersky). Kopieren tut der Server jedoch mit voller Leistung (115MB/s) das navigieren am Netzlaufwerk (Ordner Wechsel, Datei öffnen, Datei speichern) ist spürbar langsamer!

Der Server hat 2 CPU's zugewiesen. Eine CPU kann 3,6 GHZ (laut Intel).
Mitglied: DerWoWusste
DerWoWusste 30.12.2020 um 12:43:49 Uhr
Goto Top
Gehst Du auch auf meine Frage nach resmon ein?
Welche Prozesse siehst Du denn in resmon?

Mitglied: Pjordorf
Pjordorf 30.12.2020 um 13:04:34 Uhr
Goto Top
Hallo,

Zitat von @samet22:
ich hoffe, dass mir jemand helfen kann.
Die Hoffnung stirbt zuletzt?

Mein File-Server ist ein Windows Server 2019 (Virtuell) welche eine 10GB Karte zugewiesen hat
Wow. Tolle Leistungsstarke Excellente Hardware. Nur Superman ist stärker face-smile

Die Leitung selbst kann nicht ausgelastet sein
Sagt wer oder welches Messgerät?

da das arbeiten auf anderen Servern welche an der selben Leitung hängen ohne LAGs funktioniert.
Wie können da pro Leitung mehr als ein Gerät dranhängen?

Das einzige was ich bemerkt habe ist, dass beim Ressourcen-Monitor die TCP Verbindungen auf 100 hochschießt. Und die Netzwerk auslast auf 110Mb/s liegt (was ja stimmt da die Clients mit 1GB angeschlossen sind).
Und da du nichts zu der verwendeten Hatdware noch deren Konfiguration verlauten tust, vermuten wir jetzt was? Dein Client der die Daten liefert kann aber nur max. 1 GBit, oder?

CPU und RAM sind beim kopieren mit ca. 40% ausgelastet, also sollte dies auch kein Problem sein. Die RDP Session selbst ist während diesem Kopiervorgang ebenfalls verzögert.
40% von was und wo? Dann nehme doch die freien 60% face-smile

... mir kommt es so vor als gäbe es hier eine Software-Seitige Einschränkung.
Da MS es nun in seine Software eingbacken bekommen hat, Admins und Admins und Admins zu unterscheiden (welche die nur die Mensa besucht haben und welche die ein Unitätsabschluß haben und welche die nur ein Sport stipendium hatten usw.) zu Unterscheiden. Und bei manchen wird dann die Softwarebremse gelöst und alles geht mit WARP.

Dein aufpoppender Flaschenhals scheint dein Storage zu sein, welches nicht mit deiner gewünschten Geschwindigkeit kann.

Gruß,
Peter
Mitglied: samet22
samet22 30.12.2020 um 13:16:00 Uhr
Goto Top
@Pjordorf was für ein unnötiger bist den du? Sonst keine Hobbys oder bist du heute auf Drogen? Füll mit solchen unnötigen Kommentaren nicht die Datenbank von Administrator.de bitte.

Wie können da pro Leitung mehr als ein Gerät dranhängen? Ähhmm wieso nicht, hast du nur Physische Server? wenn ich zu einem V-Switch mehre Virtuelle-Server zuweise dann laufen über eine Leitung mehrere Server... was ist daran nicht zu verstehen? Und der File-Server ist "Langsam" auch über RDP (klickst reagieren verzögert). und am DC / Print-Server funktioniert alles normal schnell.

Und da du nichts zu der verwendeten Hatdware noch deren Konfiguration verlauten tust, vermuten wir jetzt was? Dein Client der die Daten liefert kann aber nur max. 1 GBit, oder? JA er kann nur 1GBit ... und? weiter was?

40% von was und wo? Dann nehme doch die freien 60% Nimm was du willst. Anscheinend ist aber das was du nimmst nicht gut dich! 40% CPU Auslast ist vorhanden. fertig. Wenn du etwas näheres Wissen willst dann einfach fragen...

auf mehr gehe ich nicht ein... bitte versuch anderen zu "helfen"
Mitglied: samet22
samet22 30.12.2020 um 13:17:02 Uhr
Goto Top
Hallo,

Zitat von @DerWoWusste:

Gehst Du auch auf meine Frage nach resmon ein?
Welche Prozesse siehst Du denn in resmon?


Beim Resmon steht an erster Stelle SYSTEM, dann SVCHOST, dann Avp (Antivirus).
Mitglied: jsysde
jsysde 30.12.2020 um 13:46:50 Uhr
Goto Top
Mahlzeit.

Zitat von @samet22:
[...]Bei vielen kleinen Dateien "schießt" die CPU auf 30-40% (System 25 und ca. 15% Kaspersky). Kopieren tut der Server jedoch mit voller Leistung (115MB/s) das navigieren am Netzlaufwerk (Ordner Wechsel, Datei öffnen, Datei speichern) ist spürbar langsamer!
Wo liest du die 115MB/s. denn ab? Bei vielen kleinen Dateien wäre ein "Dauerfeuer" mit konstanten 115MB/s. eher ungewöhnlich.
Und wenn der Virenscanner mit 15% Systemlast arbeitet liegt die Vermutung sehr nahe, dass der sich da sehr wohl einmischt. Auch wenn die "Netzwerk-Aktivitäts-Kontrolle" angeblich abgeschaltet ist.

Nebenbei erwähnt ist ein RAID5 performance-technisch ein ziemlicher Alptraum. Ein guter RAID-Controller kann hier helfen, z.B. durch großen/schnellen Cache etc. Aber auch da ist irgendwann mal Ende mit "Performance".

Last but not least: Was hat die erwähnte RDP-Session mit dem Kopieren zu tun? Wird hier evtl. per Copy&Paste via RDP kopiert? Oder tatsächlich mit dem Explorer von/auf ein(em) Netzlaufwerk?

Cheers,
jsysde
Mitglied: Pjordorf
Pjordorf 30.12.2020 um 13:48:08 Uhr
Goto Top
Hallo,

Zitat von @samet22:
@Pjordorf was für ein unnötiger bist den du? Sonst keine Hobbys oder bist du heute auf Drogen? Füll mit solchen unnötigen Kommentaren nicht die Datenbank von Administrator.de bitte.
Ist ja fast das ende von 2020 face-smile

Ähhmm wieso nicht,
Weil das nicht funktionieren würde mit dieser Verkabelung (Ethernet).

wenn ich zu einem V-Switch mehre Virtuelle-Server zuweise dann laufen über eine Leitung mehrere Server... was ist daran nicht zu verstehen? Und der File-Server ist "Langsam" auch über RDP (klickst reagieren verzögert). und am DC / Print-Server funktioniert alles normal schnell.
Es ist aber trotzdem immer nur ein Gerät pro Ende der Leitung dran, Auch/gerade wenn es ein Switch ist, sonst würden wir noch heute Hubs & Co. nutzen.

JA er kann nur 1GBit ... und? weiter was?
Nur ne Feststellung, sonst nichts.

Wenn du etwas näheres Wissen willst dann einfach fragen...
Kein Bedarf.

auf mehr gehe ich nicht ein... bitte versuch anderen zu "helfen"
D.h. kein Spass mehr?

Gruß,
Peter
Mitglied: ChriBo
ChriBo 30.12.2020 um 13:48:53 Uhr
Goto Top
Hi,
wie schon @anteNope schrieb: Deaktiviere den AV komplett bzw. den on Access Scan auf das entsprechende Verzeichnis.
Dan vergleich mal vorher/nachher.

CH
Mitglied: DerWoWusste
DerWoWusste 30.12.2020 um 13:49:48 Uhr
Goto Top
Du sprachst von 100 tcpip-Verbindungen. Welche sind die anderen 97?
Mitglied: ultiman
ultiman 30.12.2020 um 16:08:25 Uhr
Goto Top
Hallo
mir fällt spontan ein, das es möglicherweise keine Server Netzwerkkarte ist und daher die Rechenarbeit die CPU des Servers machen müsste war das Stichwort da hardware offload bsw.
VG und Erfolg
ulti
Mitglied: farddwalling
farddwalling 30.12.2020 um 21:55:33 Uhr
Goto Top
Vielleicht hilft dir hier was von?
https://administrator.de/forum/hyper-v-server-2019-gast-2016-intel-x722- ...

Wobei ich jetzt bei dir deinen Hypervisor nicht ganz rauslesen kann.