84075
Goto Top

IBM Tivoli Storage Manager auf Windows 7 installieren?

IBM Tivoli Storage Manager
Version 6 Release1 Level 0.02

Hallo,

ich möchte gerne den IBM Tivoli Storage Manager auf einer Windows 7 (x64) installieren. Auf windows XP x64 funktioniert das alles mit folgender Anleitung super, doch Windows 7 geht nicht:

TSM Service einrichten auf XP(64bit):

C:\Program Files\Tivoli\TSM\baclient\dsmcutil install scheduler /name:"TSM Scheduler" /password:<HOSTNAME> /node:<HOSTNAME> /autostart:yes

Scheduler neu einlesen:
dsmcutil update /name:"TSM Scheduler" /node:<HOSTNAME> /password:<HOSTNAME> /autostart:yes

netsh firewall set portopening TCP 1800 ENABLE

Service stoppen/starten:
net stop "TSM Scheduler"
net start "TSM Scheduler"

Gibts ne Anleitung wie ich das ganze auf Windows 7 installiere?

Content-Key: 138522

Url: https://administrator.de/contentid/138522

Printed on: April 21, 2024 at 17:04 o'clock

Member: b-netix
b-netix Mar 18, 2010 at 08:57:46 (UTC)
Goto Top
Hallo,

das muss gleich gehen.

oder du verwendest den setup wizzard in der gui.

wo gibst du das optfile bei der scheduler installation an?

Gruß b-netix
Member: b-netix
b-netix Mar 18, 2010 at 09:00:17 (UTC)
Goto Top
ich mache das so:

dsmcutil install /name:"TSM Central Scheduler Service" /node:%COMPUTERNAME% /password:%COMPUTERNAME% /clientdir:"%DSM_DIR%" /optfile:%DSM_CONFIG% /autostart:yes /validate:no

wo bei die umgebungsvariablen DSM_DIR, DSM_CONFIG auf den install path zeigen und die ..._CONFIG auf den speicherort der dsm.opt

Gruß b-netix
Mitglied: 84075
84075 Mar 18, 2010 at 09:08:12 (UTC)
Goto Top
also wenn ich das über die gui mache und kurz vor abschluss auf apply klicke dann passiert nichts. es wird dann auch kein Scheduler angelegt?!
Member: b-netix
b-netix Mar 18, 2010 at 09:08:59 (UTC)
Goto Top
lässt du das im admin mode laufen?
Mitglied: 84075
84075 Mar 18, 2010 at 09:10:01 (UTC)
Goto Top
ich werde das jetzt mal so ausprobieren. Die Umgebungsvariablen habe ich nciht gesetzt..Konfigurierst du das ganze über cmd oder gui?
Member: b-netix
b-netix Mar 18, 2010 at 09:13:48 (UTC)
Goto Top
Zitat von @84075:
ich werde das jetzt mal so ausprobieren. Die Umgebungsvariablen habe ich nciht gesetzt..Konfigurierst du das ganze über cmd
oder gui?

beides, bei automatisierten per script bei updates per gui wenns klemmt
Mitglied: 84075
84075 Mar 18, 2010 at 09:15:58 (UTC)
Goto Top
nun bringt er mir INVALID ARGUMENT ´FILE´ wenn ich das eigebe:

C:\Users\caeadmin>"C:\Program Files (x86)\Tivoli\TSM\baclient\dsmcutil.exe" inst
all /name:"TSM Central Scheduler Service" /node:%cehost45% /password:%cehost45%
/clientdir:"%DSM_DIR%" /optfile:%DSM_CONFIG% /autostart:yes /validate:no

Umgebungsvariablen habe ich gesetzt! Wie siehts mit dem portopening für TCP aus??? Mit netsh firewall set portopening TCP 1500 ENABLE ??? kommt ne Fehlermeldung ...veralteter Befehl?!
Member: b-netix
b-netix Mar 18, 2010 at 09:20:07 (UTC)
Goto Top
bei mir sagt dieser befehl das:

WICHTIG: "netsh firewall" ist veraltet.Verwenden Sie stattdessen "netsh advfirewall firewall".Weitere Informationen zur Verwendung von "netsh advfirewall firewall" anstellevon "netsh firewall" finden Sie im KB-Artikel 947709unter "http://go.microsoft.com/fwlink/?linkid=121488".Für den angeforderten Vorgang sind erhöhte Rechte erforderlich (Als Administrator ausführen).
Member: b-netix
b-netix Mar 18, 2010 at 09:33:47 (UTC)
Goto Top
Zitat von @84075:
nun bringt er mir INVALID ARGUMENT ´FILE´ wenn ich das eigebe:

C:\Users\caeadmin>"C:\Program Files (x86)\Tivoli\TSM\baclient\dsmcutil.exe" inst
all /name:"TSM Central Scheduler Service" /node:%cehost45% /password:%cehost45%
/clientdir:"%DSM_DIR%" /optfile:%DSM_CONFIG% /autostart:yes /validate:no

ersetze mal /clientdir:"%DSM_DIR%"
mit
/clientdir:%DSM_DIR%

und füre deine commandline im adminmodus aus
Mitglied: 84075
84075 Mar 18, 2010 at 11:10:47 (UTC)
Goto Top
ahaaa nun sieht die SAche doch ganz anders aus. Das hat er jetzt genommen face-smile Nun erscheint die Meldung "C:\Program Files (x86)\Tivoli\TSM\baclient\dsmcutil.exe ist keine zulässige Win32-Anwendung
Habe Windows 7 Professional 64bit und die TSM Version Version 6 Release1 Level 0.02.
Member: b-netix
b-netix Mar 22, 2010 at 12:41:23 (UTC)
Goto Top
du bist dir aber sicher, dass du den richtigen install source verwendet hast?
den fehler bekomm ich nur, wenn ich versuche 32bit installroutinen auf 64 zu verwenden und umgekehrt