thecritter
Goto Top

Keepalived verliert die IP

Hallo,
ich habe auf einem VMware Cluster einen k8s Cluster laufen. Auf den 3 Master Nodes läuft keepalived und HAproxy dass die Anfragen dann auf die 3 apiserver verteilt. Auf 3 Worker Nodes läuft auch jeweils ein keepalived dass die Anfragen an das Ingress des gleichen Nodes weiter gibt. Loadbalancing vom Keepalived wird nicht genutzt.

Jetzt passiert es mir alle paar Wochen dass der Keepalived Master die IP verliert. Diese Floating IP ist dann weder auf dem Master noch auf den Backup Servern zu finden. Das keepalived meldet aber keinen Fehler. Startet man das keepalives auf dem Master neu, so ist die IP wieder da. Das Seltsame ist das dies bei beiden keepalived Clustern in etwa gleichzeitig passiert. Beim letztem Mal mit ca 30min Unterschied. Ich bin Ratlos. Die Configs habe ich schon mehrmals überprüft. An den sollte das nicht liegen. Die Master haben die höchste Prio und werden als Master gestartet. Die anderen als Backup. Ich bin Ratlos. Hat jemand vielleicht eine Idee?
Ich werde jetzt als Workaround erst mal die keepalived Dienste wöchentlich neu starten lassen.

Vielen Dank, Daniel

Content-Key: 483003

Url: https://administrator.de/contentid/483003

Printed on: March 1, 2024 at 18:03 o'clock

Member: Dani
Solution Dani Aug 10, 2019 at 13:18:22 (UTC)
Goto Top
Moin Daniel,
Hat jemand vielleicht eine Idee?
Schau mal hier. Ich konnte es leider nicht genauer spezifieren, da du weder OS noch die eingesetzten Version der genannten Programme genannt hast.


Gruß,
Dani
Member: TheCritter
TheCritter Aug 12, 2019 at 14:51:24 (UTC)
Goto Top
Hallo Dani,
super ich danke dir. Ich nutze Ubuntu 18.04 und das mitgelieferte keepalived 1.3.9.
Ich schaue es mir mal an. Anscheinend gibt es mit der Version 2 einen fix.

Viele Grüße,
Daniel
Member: TheCritter
TheCritter Aug 12, 2019 at 15:35:33 (UTC)
Goto Top
Ich habe mir jetzt ein keepalived Paket für Bionic gebaut. Ich vermute das war des Rätsels Lösung. Daher markiere ich das als gelöst face-smile