basti-berlin
Goto Top

Kleine Fragen zum Cisco SG350-28

Hallo,
auf kleinen Tip in anderem Beitrag erhielt ich den Schwenk, eher auf Cisco SG-250 oder 350 zu gehen, weil ich Layer 3 Switching brauche.
Hier wäre wohl beinahe das falsche Gerät per Post gekommen...
Hier schon mal: Danke @aqui !!!

Mal abgesehen davon, dass mich das Gerät als Einsteiger in die "bessere Switching Welt" förmlich "erschlägt", bin ich von dem Gerät recht angetan.
Generell versuche ich, mir den Kram selber anzueignen - wenn auch erstmal nach Anleitungen.

Dennoch stellt sich mir da im Moment bei der Einrichtung von VLANs (aktuell das wichtigste - weiteres kommt dann Stück für Stück hinzu) eine - nein drei Fragen.

Zuerst kurz der Aufbau und was ich gemacht habe (das ist aktuell jedoch noch nicht Final, befinde mich sozusagen noch in der Sandbox zum Lernen, bevor ich das Gerät auf's Netzwerk los lasse):

- Der Switch hängt hinter einer Fritzbox im Netzwerk 192.168.178.0/24
- FB hat die x.1
- der Switch die x.5
- Dies ist auf dem Switch das Standard VLAN1 nach auspacken.
- Angeschlossen ist die FB am Switch Port GE1

DHCP-CLIENT ist am Switch AUS
DHCP-SERVER ist AN und sollte sich -glaub ich- ausschließlich für die Clienten der VLANs kümmern
(DHCP ist auf der FB auch an - soweit ich weiß, geht der aber ja nicht in die VLANs)

Am Switch sind zum Spielen 4 weitere VLANs eingerichtet. Hierfür gibt es 4 DHCP-Pools
  • VLAN10: 10.10.10.0/24
  • VLAN20: 10.10.20.0/24
  • VLAN30: 10.10.30.0/24
  • VLAN40: 10.10.40.0/24

Gemacht habe ich folgenden Ablauf, um es zum Laufen zu bringen:
- Die vorab per DHCP zugewiesene IP des Switch auf Static umgestellt. DHCP-Client aus...
- Unter IP-Config
  • DHCP Server an und
  • die 4 DHCP-Pools erstellt

- Unter VLAN Management:
  • Die 4 VLANS erstellt
  • Die Ports GE21 - GE24 auf Layer 3 umgestellt
  • Den Ports GE21 - GE24 jeweils ein untagged VLAN zugewiesen (Gleiche logische Reihenfolge)

- zurück unter IP-Config:
  • IPv4 Static Routes auf die FB geschickt (0.0.0.0/0 -> 192.168.178.1)
  • Den PORTS GE21 - GE 24 'ne IP verpasst - jeweils x.1 im jeweiligen VLAN

- Statische Route in der FB:
  • 10.10.0.0/255.255.0.0 Auf die IP des Switch im VLAN der FB (192.168.178.5)

Im Grunde funktioniert das so... Ich habe zwar einen DNS-Server im Netz der FB und das unter den DHCP-Optionen passend angegeben, wirklich Erfolg mit den "Raus ins Internet" hatte ich aber erst, als der nochmals unter IP-Config -> DNS-Settings -> DNS Server Table eingetragen war (OK, vielleicht ein speziellerer Fall...)

Nun die Fragen:
1.
Das VLAN1 Interface GE1 verblieb auf Layer 2. Die Interfaces der selbst erstellten VLANs mussten auf Layer 3, damit es überhaupt funktioniert.
Stelle ich auf Layer 2 zurück ist Ende mit Netzwerk am Port.
Warum kann ich jetzt ins VLAN1 (Standard) routen - Layer 2 sollte doch nicht gehen?!?!

2.
In - ich glaub - allen Anleitungen steht, dass ich den VLANS ne IP verpassen muss. Nicht den Ports.
Tue ich das so, ist nix mit Netzwerken. Wie gesagt, es funktioniert, aber ich verstehe nicht, warum das jetzt anders ist, als überall beschrieben?

3.
Unter VLAN-Management -> VLAN Settings steht für alle selbst erstellten VLANs "VLAN Interface State" "Disabled".
Soweit ich gelesen habe, ist das so lange so, bis an dem Port ein Client hängt. Dem ist aber gerade so (an dem Schreib ich grad)...
Warum ist das so, ist was falsch, hab ich was vergessen?

ach - eine vierte Frage ergibt sich grad...
Ich kann plötzlich nicht zwischen dem VLANs pingen. Ich möchte meinen, das ging gestern... Von VLAN in das "Standard" aber schon...

(Geht sobald Clienten am Port sind)

Bitte seid nachsichtig - ich lerne mich gerade ein...

Content-Key: 453800

Url: https://administrator.de/contentid/453800

Printed on: September 30, 2023 at 21:09 o'clock

Member: aqui
Solution aqui May 21, 2019 at 08:01:35 (UTC)
Goto Top
weil ich Layer 3 Switching brauche.
Ja, das ist richtig, dann brauchst du den 250er oder den 350er.
eine - nein drei Fragen.
Kein Thema...immer her damit !
Der Switch hängt hinter einer Fritzbox im Netzwerk
Das ist vermutlich das immer wieder gleiche Design eines L3 Switching Netzes wie es hier genau beschrieben ist:
Verständnissproblem Routing mit SG300-28
Genau so und nicht anders solltest du es auch umsetzen.
In der L3 Konfig hast du aber Fehler gemacht. So musst du vorgehen
  • Außer deinen 4 VLANs noch ein Transfer VLAN zur FritzBox anlegen z.B. VLAN 99. Wichtig um den Internet Traffic von deinen VLANs sauber zu trennen.
  • Auf dem Switch die untagged (Access) Ports diesen VLANs zuweisen
  • Den VLANs jeweils ein IP Interface zuweisen. Z.B. VLAN 99 = 192.168.178.254, VLAN 10 = 10.10.10.254 /254, VLAN 20 = 10.10.20.254 /254 usw. Diese Switch VLAN IP Adressen sind dann immer die Default Gateways der jeweiligen Endgeräte in diesen VLANs. DNS Server in allen VLANs ist immer die FB = 192.168.178.1
  • Statische default Route auf dem Switch eintragen was du richtigerweise auch gemacht hast
  • WICHTIG: Statische Route für deine VLAN Netz auf der FritzBox eintragen !! Zielnetz: 10.10.0.0, Maske: 255.255.0.0, Gateway: 192.168.178.254 routet dann alle deine VLAN IP Netze über das Transfer VLAN 99 zu deinem Switch ! Hast du ja auch richtig gemacht. Allerdings ohne Transfer VLAN.
  • Fertisch !
Das ist erstmal die simple Grundfunktion.
Zu deinen Fragen:
1.)
IP Adressen gehören zu den VLANs ! Niemals an einen dedizierten Poret. Hier hast du vermutlich einen Konfig Fehler gemacht ?!
2.)
Ja, genau so ist das richtig. Niemals bekommen dedizierte Ports eine IP. Das kann in einem VLAN Umfeld nicht funktionieren.
3.)
Ja, das ist richtig. Wenn kein aktiver Port mehr im VLAN ist ist es logischerweise "disabled". Macht ja auch Sinn.
4.)
???
Bitte seid nachsichtig - ich lerne mich gerade ein...
Immer cool bleiben ! Dafür ist ein Forum ja da...! face-wink
Member: Basti-Berlin
Basti-Berlin May 21, 2019 at 08:56:00 (UTC)
Goto Top
Danke schon mal.

An genau diesem Beitrag hab ich mich orientiert. Ich muss zwar zugeben, dass ich die IPs anders drehe (erst "verwaltende" Geräte, dann Clienten - erscheint mir logischer) aber vielleicht hab ich irgendwas übersehen/überlesen.
Vielleicht stell ich mich auch etwas blöd an - sowas "fliegt mir eigentlich meistens zu". Bei den ganzen Begriffen (wenn mal mal so da durch zappt) raucht mir etwas der Kopf.

Die Sache mit dem Transfer-VLAN...:
Besteht dieses nicht bereits schon durch das VLAN1 (Also das Standard-VLAN, dass im Grunde beim "First-Boot" schon angelegt ist)?

Ich hatte es oben nur kurz nebenbei erwähnt...

Der Switch hängt hinter einer Fritzbox im Netzwerk 192.168.178.0/24
- FB hat die x.1
- der Switch die x.5
- Dies ist auf dem Switch das Standard VLAN1 nach auspacken

Zwar ist es aktuell so, dass der Switch sich die FB noch mit anderen Clienten in IHREM Netz teilt, das soll/wird aber nicht so bleiben.

Generell werd ich das Ding dann wohl noch mal zurücksetzen und neu anfangen. (und vielleicht Deine Logik - router/Switch "hinten" probieren)
Wird dem Lernen eher zuträglich sein.
Member: aqui
Solution aqui May 21, 2019 updated at 09:36:04 (UTC)
Goto Top
dass ich die IPs anders drehe (erst "verwaltende" Geräte, dann Clienten - erscheint mir logischer)
Bahnhof, Ägypten ?? Versteh ich jetzt grad irgendwie nicht...aber egal. Hauptsache getrennte IP Netze.
Besteht dieses nicht bereits schon durch das VLAN1
Ja, wenn du das als Transfer VLAN betreibst. Du solltest in diesem Koppel VLAN keinerlei Produktiv VLAN mit betreiben sondern da rein nur die Anbindung an den Internet Router machen.
Welches VLAN bzw. VLAN ID du dafür nimmst spielt keine Rolle und ist kosmetisch.
dass der Switch sich die FB noch mit anderen Clienten in IHREM Netz teilt, das soll/wird aber nicht so bleiben.
Genau DAS ist der Nachteil und deshalb eben das Transfer bzw. Koppel LAN zur Trennung !
der Switch die x.5
Das ist gefährlich und schlechter bzw. laienhafter Design Stil. Router IPs liegen aus guten Grund entweder immer "ganz oben" oder "ganz unten" im IP Hostbereich des Netzes um sicher Überschneidungen oder Kollisionen mit DHCP Pools zu vermeiden. Eine IP Adressen "mittendrin" zu verwenden wie deine .5 birgt also immer Gefahren. Mal abgesehen davon das es auch übersichtlicher und logischer ist die Endadressen als Gateway IPs zu verwenden. Letztlich aber ist auch das nur ein kosmetischer Tip.
Generell werd ich das Ding dann wohl noch mal zurücksetzen und neu anfangen
Das ist der richtige Weg !
Denk auch daran das aktuellste Firmware Image dann gleich einzuspielen:
Cisco Security Warnung für SoHo Switches der SG Serie
Dann so vorgehen wie oben beschrieben !

Hier nochmal die richtige Konfig der VLAN IP Adressierung:
vlanip

Hier taucht das VLAN 10 dann mit auf:
vlanip2
Member: Basti-Berlin
Basti-Berlin May 21, 2019 updated at 09:27:38 (UTC)
Goto Top
Bahnhof, Ägypten ?? Versteh ich jetzt grad irgendwie nicht...aber egal. Hauptsache getrennte IP Netze.

Das war so gemeint:

Router IPs liegen aus guten Grund entweder immer "ganz oben" oder "ganz unten" im IP Hostbereich des Netzes

Ich meinte, dass ich es eben statt wie Du schreibst (Auch im verlinkten Beitrag) statt .254 (hinten) eben vorne (x.1 - x.10) gemacht hab.
Eben "anders rum"
Die x.5 ergab sich "leider" durch Repeater. Die hat mich grad nicht so "gejuckt", da noch nicht Final.
Wenn auch letztlich "kosmetisch", den Rat nehm ich gern an. Vielleicht nehme ich mal eher "Deine" Weise, erspart das Umdenken

Denk auch daran das aktuellste Firmware Image dann gleich einzuspielen:
Schon passiert face-wink Das war der erste Punkt nach dem Auspacken letzte Woche. Letztlich wohl auch ganz gut, wie in Deiner "warnung" heute gesehen.

EDIT:
Das Teilen des FB-Netzwerks erledigt sich dann, wenn der Switch im Grunde konfiguriert ist. Dann erst will/kann ich "umkabeln" usw.
Ich muss dann anschließend für eine DB ein paar Clienten umkonfigurieren, dass wollte ich mir bis dahin sparen
Member: aqui
aqui May 21, 2019 at 09:40:14 (UTC)
Goto Top
Die x.5 ergab sich "leider" durch Repeater.
Igitt, der Todesstoß für WLANs.
Halbieren per se die Bandbreite und geben dem WLAN durch die Hidden_Station Problematik dann den Rest. Immer ein NoGo in WLANs, aber völlig andere Baustelle... !
Aber die .254 ist doch sicher noch frei ?! Dann passt es ja wieder. face-wink
Member: Basti-Berlin
Basti-Berlin May 21, 2019 updated at 10:08:50 (UTC)
Goto Top
Hidden_Station Problematik...

Wieder was gelernt...

Kurz OT:
Ich ziehe bald um. Ein Grundstück. 2 Häuser, 4 Parteien. Alles Familie...

DAFÜR wird das ganze. Gleichzeitig nutze ich eben auch die Gelegenheit, das ganze gleich überlegt und ordentlich zu machen. Was ich ja auch in meiner letzten Frage angedeutet hab.
Bis dahin ist Spielwiese. Der Switch wird dann ein Zentrales Gerät (weshalb ich auch einen etwas größeren Switch genommen hab). Bis dahin ist "optimum" noch nicht wirklich nötig, will es aber vorbereiten.
Ich habe dafür noch ein paar Monate Zeit. Einzig das Home-Office müsste dann in einem Rutsch rüber und eigentlich sofort wieder startklar sein.

Wenn Du wüsstest, das dort (wo es dann hin geht) aktuell für Chaos im aktuellen Netz ist, würdest Du Dir die Haare raufen (LAN (ein bißchen), WLAN, "doofe Switches", Repeater, D-Lan). Und nach dem Möbel stellen ist das Netzwerk der erste Akt, der dort passiert.

Da bin ich mit meinem Repeater hier noch human. Wenn's nach mir ginge, hätte ich an jedem Gerät hier 'n Kabel (außer Handys natürlich).
Da hat aber die Frau "ein klein wenig" was dagegen.
Member: Basti-Berlin
Basti-Berlin May 21, 2019 updated at 11:46:04 (UTC)
Goto Top
So... ich GLAUBE, Erfolg vermelden zu können!

Der Punkt scheint zu sein, dass ich wohl bei den ersten Gehversuchen etwas falsch konfiguriert habe UND in eine kleine Falle getappt bin.
Wenn ich jetzt das so mache wie oben vor Dir beschrieben, was im Grunde sich mit dem Deckt, was ich auch gemacht habe, AUSSER statt dem Port nun dem VLAN die IP zuzuweisen (was vorher nicht ging bzw keine IP zugewiesen wurde) geht das jetzt auch so.

Die Falle war:
Unter VLAN Management -> Interface Settings lässt sich pro Port der "Switchport Mode" einstellen.

Steht der auf "Layer 3", bekomme ich keine IP bzw. sowas 169.254.x.x
Zurückgestellt auf "Layer 2" rennt die Sache.

An dieser Stelle scheint "Layer 3" also irgendetwas anderes zu bewirken
Member: aqui
Solution aqui May 21, 2019 updated at 11:52:08 (UTC)
Goto Top
Wieder was gelernt...
Na ja das weiss man ja aber als Netzwerker. Oder sollte es zumindestens.
Ich ziehe bald um. Ein Grundstück. 2 Häuser, 4 Parteien
Dann achte darauf das du entsprechend Kabel ziehst in den Häusern. Wenn alle einen gemeinsamen Internet Zugang nutzen, dann ggf. ein Glasfaserkabel zw. den Häusern verlegen. Kann man in einem Gartenschlauch gezogen schön vergraben.
Alternativ eine 5Ghz WLAN Funkstecke aber geroutet wie sie z.B. hier beschrieben ist:
Mit einem WLAN zwei LAN IP Netzwerke verbinden
Da hast du ja dann eine tolle Spielwiese alle diese Konzepte auszuprobieren face-wink
will es aber vorbereiten.
Sehr sinnvoll und der richtige Weg !!
Einzig das Home-Office müsste dann in einem Rutsch rüber und eigentlich sofort wieder startklar sein.
Ist ja kein Thema wenn die Internet Verbindung vorhanden ist !
Wenn Du wüsstest, das dort (wo es dann hin geht) aktuell für Chaos im aktuellen Netz ist
Nein das möchten wir bitte NICHT wissen !! Es reicht schon was sich an Dramen und Netzwerk Chaos hier täglich bei administrator.de ansammelt !
Da hat aber die Frau "ein klein wenig" was dagegen.
Die kann man ja überzeugen das sie ihre Schmachtfetzen und Liebesschnulzen aus der Mediathek dann ruckelfreier in HD sieht.
Minimal solltest du dann aber Power LAN nehmen wenn du partout keine Kabel ziehen kannst.
Kopplung von 2 Routern am DSL Port
Niemals mehr Repeater, das ist ein absolutes NoGo was performance und Durchsatz angeht in deinem Umfeld !
Ziehe Kabel solange du noch kannst und da wo es geht. Es helfen auch Flachkabel die man problemlos hinter den Fussleisten und in Parkettritzen verlegen kann:
https://www.amazon.de/10m-CAT-Netzwerkkabel-Flach-Flachbandkabel-schwarz ...
Gibts auch in anderen Farben.

dass ich wohl bei den ersten Gehversuchen etwas falsch konfiguriert habe UND in eine kleine Falle getappt bin.
Das haben wir ja schon geahnt hier face-wink
Interface Settings lässt sich pro Port der "Switchport Mode" einstellen.
Das ist der Punkt !! Wenn du den auf L3 stellst, dann hast du einen Router mit 24 oder 48 Ports. Das will man ja genau NICHT.
"L2" und die IP Adressen auf den VLAN Interfaces ist richtig !!
An dieser Stelle scheint "Layer 3" also irgendetwas anderes zu bewirken
Ja, das bewirkt das du eine Port basierte IP Adressierung hast. Quasi dann Router only und an jedem Port ein IP Netz. Genau das will man in einem Switching Umfeld NICHT !
bekomme ich keine IP bzw. sowas 169.254.x.x
Das "sowas" ist eine APIPA oder Zeroconf IP wenn dein Client keinen DHCP Server finden kann. Dann vergeben sich die Clients solche Adresse aus der APIPA Range selber:
https://www.itwissen.info/APIPA-automatic-private-IP-addressing-Auto-IP- ...
Lesen und verstehen.... face-wink
Member: Basti-Berlin
Basti-Berlin May 21, 2019 at 12:26:01 (UTC)
Goto Top
das du entsprechend Kabel ziehst in den Häusern ... man in einem Gartenschlauch gezogen schön vergraben
Das hintere ist Neubau. Darauf habe ich schon hingewiesen. Da (werden) liegen 3 Cat7 Leitungen plus 1x Ersatz.
Auch IM Haus wird verlegt.

Niemals mehr Repeater, das ist ein absolutes NoGo was performance und Durchsatz angeht in deinem Umfeld !
Das versuche ich zu vermeiden. Leider gibt die Aktuelle Verkabelung im bereits stehenden Haus nicht soooo viel her.
Da HOFFE ich noch, dass die vorhandenen Leitungen zumindest halbwegs funktionieren. Da wird auch nicht so viel Datendurchsatz benötigt werden.
Wichtig ist dann nur das Homeoffice, da muss evtl mal Dampf auf dem Kessel sein. Das steht aber in der Nähe vom Switch. Da kann ich auch 'n Kabel ziehen.

APIPA oder Zeroconf IP
Das ist mir irgendwann, irgendwo schon mal über den Weg gelaufen, weshalb ich schon "bekomme keine IP" geschrieben habe...

Ich bin schon ganz froh, in diese Falle getappt zu sein. Das vergesse ich sicher nicht wieder. Darum versuch ich lieber erst allein.

ALSO: DANKE!!!!