otsche1g
Goto Top

Komme auf Server nur per VPN

Hallo,

ich bin auf dem Bereich leider nicht sonderlich versiert und habe ein Zugriffsproblem auf einen Server.
Ich komme mit dem Internet in meiner Firma nicht auf einen speziellen Server von einem Dienstleister (Magnalister App über Shopify Webshop). Der Dienstleister behauptet es liegt daran, dass entweder intern bei uns in der Firma der Server irgendwelche Firewall Regeln hat die Ports oder IPs sperren, oder die Sperre geht vom Provider aus. Ich habe meinen Serveradmin, wie auch den Provider kontaktiert, beide haben es wohl geprüft und sagen es liegt nicht an Ihnen. Vom Dienstleister habe ich mir die entsprechenden IPs geben lassen, die gewhitelistet sein müssen.

Wenn ich es mit CMD per tracert teste komme ich ohne Probleme auf alle 3 betroffenen IPs.
Wenn ich hingegen versuche im Shopifybackend auf die App/den Magnalister Server zuzugreifen kommt nur ein weißer Bildschirm. Nehme ich beispielsweise mein Smartphone mit den mobilen Daten lädt es ohne Probleme, im Firmenwlan lädt es nicht. Wenn ich im Firmennetzwerk einen VPN benutze funktioniert es.

Jetzt meine Frage, wenn es mit einem VPN geht, bedeutet das nicht automatisch, dass es nicht an meinem Provider oder Servereinstellungen in der Firma liegt, sondern daran das meine IP beim Dienstleister Magnalister gesperrt ist? Oder kann die Ursache trotzdem intern bei der Konfiguration unseres Servers liegen?

mfg

Content-Key: 72047606378

Url: https://administrator.de/contentid/72047606378

Printed on: July 16, 2024 at 19:07 o'clock

Member: nachgefragt
nachgefragt Jul 09, 2024 updated at 09:46:54 (UTC)
Goto Top
Moin.

These #1
Wenn ich bestimmte IPs sperren möchte mache ich das
a) an der Firewall
b) und/oder der Endpoint Protection

In jedem Fall gibt es ein Log in dem steht, dass der Aufruf der IP geblockt wird. Dein Serveradmin sollte dir diesen Auszug geben können, z.B. den LIVE Firewall Log wenn du die IP aufrufst, dass die Anfrage rausgehen darf.

These #2
Wenn du den VPN nutzt hast du
c) evtl. ne andere IP Adresse,
d) deine Firewall ist evtl. nicht mehr im Weg (any-to-any Regel)
e) ,...
da muss man dann der Reihe nach abklopfen.
Member: ukulele-7
ukulele-7 Jul 09, 2024 updated at 11:24:40 (UTC)
Goto Top
Steht ja nicht sehr viel konkretes drin. Baust du die Connection über die IP des Servers auf oder über einen DNS Namen? Antwortet der Server auf Ping und kommt der durch? Baust du eine HTTPS Verbindung auf oder welcher Port ist das? Ist dein Admin unfähig oder nicht motiviert?
Member: Otsche1g
Otsche1g Jul 10, 2024 at 09:07:00 (UTC)
Goto Top
Mein Admin ist leider wirklich unmotiviert, kaum erreichbar.
Habe mir mal TCP View runtergeladen, laut dem versucht er die connection über den DNS Namen aufzubauen.
Auf den Ping antwortet der Server, der kommt durch.
magnalister
Member: ukulele-7
ukulele-7 Jul 10, 2024 updated at 09:24:16 (UTC)
Goto Top
Naja wenn du in Chrome eine DNS-Adresse eingibst, dann nutzt er DNS. Du könntest auch alternativ die IP-Adresse des Zielservers nehmen, die du ja bekommen hast lt. Post #1, nur nicht verraten hast. Stimmt denn die IP mit der per DNS aufgelösten IP überein?

Dir ist auch der Unterschied zwischen herkules.magnalister.com und hermes.magnalister.com aufgefallen? Bei mir antwortet:

herkules.magnalister.com 148.251.136.22
hermes.magnalister.com 213.133.102.175 (wie bei dir)

Hast du mal schlicht einen anderen Browser versucht oder den Browser zurück gesetzt? Oder einen anderen Rechner im selben Netz?
Member: Otsche1g
Otsche1g Jul 10, 2024 updated at 10:26:11 (UTC)
Goto Top
Magnalister hatte mir 4 IPs genannt die ich prüfen sollte, was ich getan habe, habe erst danach gesehen, dass der herkules relevant ist und dann den falschen Screen angehängt, die Herkules funktioniert aber genauso.

Ich habe 3 Browser (Chrome, Firefox, Edge) und auch einen anderen PC im Netzwerk getestet, alles hat nicht funkioniert. Mit meinem Smartphone übers Firmenwlan geht es auch nicht, mit den mobilen Daten geht es. Mit VPN im Firmenetz geht es wie oben geschrieben auch.

Den relevanten Zugriff auf den Magnalisterserver kann muss ich letztendlich nur übers Shopifybackend herstellen und wenn ich da darauf klicke, verwendet er die DNS. Wenn ich die DNS direkt im Browser eingebe, funktioniert es logischerweise ebenfalls nicht. Wenn ich direkt die IP im Browser ansteuer scheint er mich nicht direkt abzuweisen.

Ich habe keine Ahnung wo und wie ich prüfen kann, ob die aufgelöste IP mit der DNS übereinstimmt.
herkules.magnalister
Member: ukulele-7
ukulele-7 Jul 10, 2024 at 12:47:00 (UTC)
Goto Top
https://dnschecker.org/ + ein Ping auf die IP verraten dir ja schon, das der DNS Name bei dir genauso aufgelöst wird, wie überall auch. DNS wird es wohl nicht sein.

Auch stimmt es ja nicht das die Seite "nicht lädt", die weiße Seite kommt von dem Server und falls es dir entgangen ist auch eine Anmeldemaske! Das sieht bei mir genauso aus. Also wird schon eine https Seite vom Server an dich ausgeliefert. Firewall ist nach wie vor möglich wenn irgendwelche anderen Ports oder Seiten ins Spiel kommen aber mir scheint das der Webserver genau das bei dir ausliefert was er überall sonst auch tut.

Was passiert denn, wenn du dich anmeldest? Was erwartest du denn, was passieren soll? Auf jeden Fall bekommst du eine Seite.

Hast du Adblocker im Einsatz? Oder gehst du über einen Proxy?