Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst LAN-Übertragungsrate zu niedrig

Mitglied: stephan902

stephan902 (Level 1) - Jetzt verbinden

18.06.2016, aktualisiert 03:13 Uhr, 1575 Aufrufe, 18 Kommentare, 1 Danke

Hallo,

beim Übertragen großer Daten erreiche ich nur 55 MB/s, also ziemlich genau der Hälfte des praktischen Maximums.

Interessant ist, dass mein EdgeRouter Pro dabei bei 100% CPU-Auslastung steht.

Ansonsten verwende ich Switche aus der Cisco SG300-Reihe, die eigentlich nie ein Problem machten.

Des weiteren befinden sich die zwei Geräte, zwischen denen die Datenübertragung stattfand, in zwei verschiedenen Subnetzen.

Nichtsdestotrotz kann ich mir nicht erklären, warum der EdgeRouter bei 100% Auslastung steht, blos weil eien simple Datenübertragung im lokalen Netzwerk stattfindet.

Eigentlich sollte die Übertragung doch gar nicht über den Router, sondern über die Switche stattfinden und selbst wenn sie durch den Router liefe, müsste immer noch Gigabit drin sein?!

Hat jemand vielleicht eine Idee?
Mitglied: chrisiweber
18.06.2016 um 08:39 Uhr
Moin,

kurz und knapp.... Router ausschalten, testen.

LG
Bitte warten ..
Mitglied: quax08
18.06.2016 um 08:57 Uhr
Hey,
Den Router-Mode, sprich die Layer 3 Funktion ist aktiviert? Geliefert werden sie immer im Switch-Modus, sprich es stehen bloß Layer 2 Funktionen zur Verfügung, damit auch kein Routing.

Ich vermute mal das bei dir momentan noch der EdgeRouter zwischen den beiden Netzen routet.
Bitte warten ..
Mitglied: stephan902
18.06.2016, aktualisiert um 12:39 Uhr
Ne, die Cisco SG300 sind noch im Layer 2 Modus, aber reicht das nicht?

Wieso geht der Traffic dann über den Router? Und wieso sind da bloß 55 MB/s möglich?

Wenn die SG300 in den Layer 3 Modus versetzt werden, inwiefer greifen dann noch die Firewall-Regeln am EdgeRouter?
Bitte warten ..
Mitglied: aqui
18.06.2016, aktualisiert um 12:41 Uhr
beim Übertragen großer Daten erreiche ich nur 55 MB/s, also ziemlich genau der Hälfte des praktischen Maximums.
Bezogen auf WAS ??
10 Mbit Ethernet, 100Mbit, 1000Mbit, 10Gigabit... ??
Das ist doch eine völlig sinnfreie Aussage.
55MB = 440Mbit/s Bezogen auf 1G ist das schonmal ganz akzeptabel. Wenn du einen Billigswitch einsetzt und einen Billigchipsatz auf der NIC hast ala Realtek ist der Wert schon ganz gut.
Bezogen auf das was bei guter Hardware möglich wäre ist er schlecht.
nteressant ist, dass mein EdgeRouter Pro dabei bei 100% CPU-Auslastung steht.
Sagt ja dann schon alles...vollkommen überbucht.
Nichtsdestotrotz kann ich mir nicht erklären, warum der EdgeRouter bei 100% Auslastung steht, blos weil eien simple Datenübertragung im lokalen Netzwerk stattfindet.
Zu 99,8% eine Fehlkonfiguration deinerseits. Ohne Details kann man hier aber nur wild raten im freien Fall
Eigentlich sollte die Übertragung doch gar nicht über den Router, sondern über die Switche stattfinden
Wenn man es richtig konfiguriert, ja !
Ne, die Cisco SG300 sind noch im Layer 2 Modus, aber reicht das nicht?
Oha oha... du weisst aber schon was du da tust oder ??
Vermutlich aber nicht wie diese Aussage verrät.
Lerne bitte erstmal die einfachsten Grundlagen zu Switching und Routing (Layer 2 und Layer 3)
Dann können wir hier sinnvoll weitermachen.
Guckst du auch hier:
https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ...
Statt externen Router machst DU das auf deinem Cisco SG 300...logisch !!
Bitte warten ..
Mitglied: quax08
18.06.2016 um 12:45 Uhr
Hey,
Schau dir mal das OSI-Modell an. Ein Layer 2 Switch besitzt keine Routing Funktion.
Die Cisco 300er Serie kann auch auf Layer 3 Ebene arbeiten, dann kann er auch zwischen Netzen routen. Wenn du die Funktion nicht aktiviert hast und die Routen eingestellt hast dann Switcht er und kann nicht zwischen den Netzen vermitteln.
Bitte warten ..
Mitglied: stephan902
18.06.2016 um 12:45 Uhr
Es handelt sich um Gigabit Ethernet und die Geräte sind netzwerkseitig:

EdgeRouter Pro, 2 x SG300 (jeweils im Layer 2 Modus)

Die getestete Verbindung war zwischen einer Synology NAS und ein Desktop-Computer, der selbstverständlich ebenfalls über Kabel verbunden war. Bei einer Direktverbindung schaffen die beiden ca. 115 MB/s.

Das Netzwerk sieht folgendermaßen aus:

EdgeRouter <--> SG300 (hier hängt NAS) <--> SG300 (hier hängt PC).

Die Subnetze für die verschiedenen VLANs werden im EdgeRouter verwaltet, ebenso die Firewall, etc.

Die Verbindung zwischen Router und Switch bzw. Switch und Switch ist tagged mit allen benötigten VLANs.

Welche Informationen benötigst du noch, bzw. was sollte ich als nächstes tun?
Bitte warten ..
Mitglied: quax08
18.06.2016 um 12:53 Uhr
Zitat von stephan902:
Die Subnetze für die verschiedenen VLANs werden im EdgeRouter verwaltet, ebenso die Firewall, etc.

Die Verbindung zwischen Router und Switch bzw. Switch und Switch ist tagged mit allen benötigten VLANs.


Wie du gerade geschrieben hast verwaltet der Router die Vlan's das heißt er Routet bei dir momentan auch zwischen den VLan's.
Ich kenne zwar den EdgeRouter nicht, aber das er dann eine höhere CPU last hat ist klar.
Bitte warten ..
Mitglied: stephan902
18.06.2016 um 12:57 Uhr
Ja, das ist mir soweit klar, aber:

1. https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ... wird selbst im entsprechenden Tutorial nur ein SG200 (Layer 2 Switch) eingesetzt und
2. müsste der EdgeRouter Pro doch selbst 10 verschiedene Übertragungen mit Gigabit-Speed ohne 100% CPU-Last übertragen können?
Bitte warten ..
Mitglied: quax08
18.06.2016, aktualisiert um 13:09 Uhr
Ja man kann mit einem Layer 2 Switch Vlan's erstellen und die Ports entsprechend konfigurieren. Aber nicht Routen!

In der Überschrift steht ja auch welche Geräte das dort übernehmen: " VLAN Installation und Routing mit pfSense, Mikrotik, DD-WRT oder Cisco RV Routern "

Edit: Zitat von @aqui: " Das folgende Tutorial beschreibt in einzelnen und einfach nachvollziehbaren Schritten, wie man die o.a. Firewall oder Router in eine bestehende, oder auch neu zu installiernde VLAN-Switch Infrastruktur, integriert bzw. an VLAN fähige Switches anschliesst um zwischen VLANs routen zu können, wenn kein Layer 3 (Routing) Switch verfügbar ist."

Das ist gleich der erste Absatz unter der überschrift.
Bitte warten ..
Mitglied: stephan902
18.06.2016, aktualisiert um 13:21 Uhr
Ja, aber so will ich es ja eigentlich auch belassen, den Router fürs Routing und die Firewall-Regeln und die SG300 nur als Switches. Sonst muss ich ja auch alle Firewall-Regeln (z.B. fürs Gastnetz) an mehreren Stellen verwalten oder?
Bitte warten ..
Mitglied: aqui
18.06.2016 um 14:32 Uhr
Mal ne dumme Frage: Warum hast du dir dann einen SG-300 beschafft ??
Das ist ja dann ziemlich sinnfrei wenn du mit dem L3 Switch gar nicht routen willst. Ein SG-200 wäre da doch dann allemal besser gewesen ?!
Und ja...wenn du zentral die Firewall rRgeln verwalten willst und vor allen Dingen stateful sein willst, dann musst du das zentral auf dem Router machen, sonst musst du in der Tat an 2 Stellen managen und zudem sind die ACLs des Switches nicht stateful.
Ein bischen Performance holst du noch raus wenn du der Firewall pro VLAN dedizierte Ports gibst und keinen tagged Uplink verwendest.
Ein tagged Uplink nutzen ja dann alle VLANs und sämtlicher zu routender Traffic kumuliert hier auf dem Link.
Man kann das etwas entzerren wenn man dedizierte Links benutzt. Jedefalls da wo der meiste Traffic anfällt.
Das ist verkabelungstechnisch nicht schön bringt aber etwas an Performance.
Bitte warten ..
Mitglied: stephan902
18.06.2016 um 14:36 Uhr
Danke!

Das bringt mir aber auch nichts, wenn die CPU des EdgeRouters so schon bei 100% ist oder?

Es kann doch nicht sein, dass der EdgeRouter nichtmal eine Verbindung mit Gigabit-Speed routet?
Bitte warten ..
Mitglied: Terminatorthree
LÖSUNG 18.06.2016 um 15:21 Uhr
Hi,

ich versuche hier mal was zum eigentlichen Problem beizutragen: Wenn dein EdgeRouter bei normalem Routing so viel CPU verbraucht, hast du vermutlich vergessen, das Hardware Offloading zu aktivieren. Bitte prüfe das mal nach. Damit solltest du fast keine CPU Last mehr auf dem Edgerouter sehen wenn die Päckchen nur zwischen 2 Subnets/VLANs geroutet werden.

Etwa so sollte das in der Konfiguration aussehen:
offload {
ipv4 {
forwarding enable
vlan enable
}
}

Prüfen kannst du mit:
user@EdgeRouter:~$ show ubnt offload

Quelle: https://community.ubnt.com/t5/EdgeMAX/Hardware-offloading/td-p/1203709

Grüße
Terminatorthree
Bitte warten ..
Mitglied: 108012
18.06.2016 um 15:35 Uhr
Es handelt sich um Gigabit Ethernet und die Geräte sind netzwerkseitig:
EdgeRouter Pro, 2 x SG300 (jeweils im Layer 2 Modus)
Also man kann sicherlich die zwei Switche auf ca. 50 unterschiedliche Arten und Weisen anschließen
aber, warum nur sollte man zwei Layer3 Switche nur als Layer2 Switche verwenden? Da würde ich noch
einmal drüber nachdenken wollen und auch darüber wie ich die Switche an den Router anbinde.

Die getestete Verbindung war zwischen einer Synology NAS und ein Desktop-Computer,
der selbstverständlich ebenfalls über Kabel verbunden war. Bei einer Direktverbindung
schaffen die beiden ca. 115 MB/s.
125 MBit/s sind die theoretische Höchstübertragungsrate! Und 115 MBit/s davon zu erreichen
ist doch schon schick, oder verwechselst Du hier die MBit/s und MB/s bei der Angabe von den
Geschwindigkeiten?

Das Netzwerk sieht folgendermaßen aus:
EdgeRouter <--> SG300 (hier hängt NAS) <--> SG300 (hier hängt PC).
EdgeRouter Pro und an je einem LAN Port davon kommt ein Cisco SG300, das wäre bei mir die
Reihenfolge und dann nur als Layer3 Switche und nicht als Layer2 Switche. Denn die Switche
können garantiert zwischen den VLANs und IP Adressbereichen mit "wire speed" routen!

Die Subnetze für die verschiedenen VLANs werden im EdgeRouter verwaltet, ebenso die Firewall, etc.
Die Subnetze und die VLANs würde ich nur über die Layer3 Switche laufen und auch routen lassen.
Das geht schneller und ist auch von der Reaktionszeit um ein vielfaches schneller.

Die Verbindung zwischen Router und Switch bzw. Switch und Switch ist tagged mit allen
benötigten VLANs.
Es wäre einmal gut zu wissen was denn alles an welchem Switch dran angeschlossen ist und
zwar alle Geräteklassen wie zum Beispiel WLAN APs, PCs, NAS und SAN und Server usw.

Welche Informationen benötigst du noch, bzw. was sollte ich als nächstes tun?
Also man kann das alles einmal durch testen wer wie viel und zwischen wem alles wie schnell routet.
Router > NAS und PC
Router > WLAN AP > WLAN Klienten
Router > SG300 (Layer2)
Router > SG300 (Layer3)
SG300 (Layer3) > NAS und PC
SG300 (Layer3) > NAS und PC in einem VLAN
SG300 (Layer3) > NAS und PC in zwei VLANs
SG300 (Layer3) - SG300 (Layer2) NAS und PC in einem VLAN
SG300 (Layer3) - SG300 (Layer2) NAS und PC in zwei VLANs
SG300 (Layer3) - SG300 (Layer2) NAS und PC in einem VLAN auf jedem Switch!

Da kann man nur sagen es kommt immer auf das Gesamtkonzept an und das was man im einzelnen
erreichen möchte, ob auf dem EdgeRouter Pro ein Radius Server installiert ist und/oder ob eine kleine
Firewall in der Ecke den Part des Captive Portals übernimmt oder gar alle VLANs an den EdgeRouter
Pro heran geführt werden müssen. Aber so wie sich das jetzt hier gestaltet und/oder beschrieben
wird finde ich das einmal gelinde ausgedrückt "suboptimal".

Nutze die beiden Switche als Layer3 Switche und zwar an je einem LAN Port des EdgeRouter Pro´s
das wäre meine Lösung zu der gesamten Sache. Oder aber einen Layer3 Switch und einen Layer2
Switch die dann am Router hängen, aber der Layer3 Switch routet eben das LAN und der Router
ist nur für das WAN - LAN und WAN - DMZ Routing zuständig.

Gruß
Dobby
Bitte warten ..
Mitglied: stephan902
18.06.2016, aktualisiert um 15:41 Uhr
Herzlichen Dank! Das war die Lösung.

Wieso ist Hardware-Offload für VLAN-Routing standardmäßig deaktiviert?

Hat die Aktivierung irgendwelche Nachteile?

Jetzt erziele ich zumindest ohne nennenswerte Load 97 MB/s. Nicht optimal, aber zumindest deutlich besser.
Bitte warten ..
Mitglied: Terminatorthree
18.06.2016 um 15:47 Uhr
Normalerweise hat die Aktivierung keine Nachteile. Hardware offload ist nur mit einigen wenigen Features nicht kompatibel. Diese werden jedoch mit jedem Update weniger und sind für den normalen Gebrauch (meiner Meinung nach) zu vernachlässigen.
Bitte warten ..
Mitglied: stephan902
18.06.2016 um 15:50 Uhr
Zitat von 108012:
125 MBit/s sind die theoretische Höchstübertragungsrate! Und 115 MBit/s davon zu erreichen
ist doch schon schick, oder verwechselst Du hier die MBit/s und MB/s bei der Angabe von den
Geschwindigkeiten?
Gruß
Dobby


Also laut meinem Verständnis entspricht Gigabit-Ethernet 1000 Mbit/s und das sollten doch 125 Megabyte/s (MB/s) sein oder etwa nicht? Abzüglich Overhead sind also 115 MB/s etwa das Netto-Maximum, würde ich sagen.
Bitte warten ..
Mitglied: stephan902
18.06.2016, aktualisiert um 15:58 Uhr
Zitat von Terminatorthree:

Normalerweise hat die Aktivierung keine Nachteile. Hardware offload ist nur mit einigen wenigen Features nicht kompatibel. Diese werden jedoch mit jedem Update weniger und sind für den normalen Gebrauch (meiner Meinung nach) zu vernachlässigen.

Alles klar, danke. Vielleicht wird ja auch mit dem nächsten Update die Geschwindigkeit noch etwas besser, sodass ich >100 MB/s erziele. Aber bis dahin, geb ich mich erstmal damit zufrieden.

EDIT: Ohne Hardware-Offload sind übrigens selbst dann nicht mehr als 55 MB/s möglich, wenn das NAS ohne VLAN an den Router angeschlossen wird. Interessanterweise reduziert sich dann zwar die CPU-Load auf rund 33%, was aber nichts an der Übertragungsgeschwindigkeit ändert. Vermutlich müsste auch der PC ohne VLAN an den Router angeschlossen werden, damit die volle Datenrate zur Verfügung steht.

EDIT2: Wie macht man das denn in großen Netzwerken, wo man unzählige Switches hat und eine stateful Firewall möchte? Kopiert man die Firewall-Regeln einfach von einem zum nächsten Switch, wobei man Switches mit stateful Firewalls verwendet oder benutzt man einfach sehr leistungsfähige Router, die über 10 Gigabit oder mehr mit den Switches verbunden sind?
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk

LAN-Write-Geschwindigkeit sehr niedrig bzw langsam

gelöst Frage von christophkoelnWindows Netzwerk10 Kommentare

Liebe Gemeinde, kurze Problemschilderung: 2 Rechner Win7 an Win-Server 2012. Einer von beiden (die Rechner sind von gleicher Hardware ...

Netzwerkmanagement

Pfsense - Bandbreite niedrig

gelöst Frage von micsonNetzwerkmanagement22 Kommentare

Hallo, Ich habe bereits seit 5 Jahren pfsense im Einsatz - als Firewall und mit Captive Portal für das ...

Switche und Hubs

Netzwerk-Bandbreite zu niedrig

Frage von Fenris14Switche und Hubs12 Kommentare

Hallo, habe jetzt vor kurzem mehere Switche in Betrieb genommen. Mein Setup besteht aus zwei Brocade ICX-7250-24 als "Core-Switche" ...

Server-Hardware

Luftfeuchtigkeit im Rechenzentrum zu niedrig

gelöst Frage von clint60Server-Hardware13 Kommentare

Hallo zusammen, ich habe letzte Woche ein paar Temperatursensoren und ein Sensor für die Luftfeuchtigkeit in unserem RZ installiert. ...

Neue Wissensbeiträge
Erkennung und -Abwehr
Emotet mit Rspamd und Oletools bekämpfen
Tipp von Dani vor 12 StundenErkennung und -Abwehr1 Kommentar

Moin, Um oletools während der Annahme einer E-Mail die bereits angehängten Office-Dateien analysieren lassen zu können, haben wir für ...

Viren und Trojaner

Gratis-Entschlüsselungstool für STOP-Ransomware verfügbar

Information von AnkhMorpork vor 19 StundenViren und Trojaner

Der Sicherheitsanbieter Emisoft hat ein kostenloses Tool veröffentlicht, mit dem sich Dateien entschlüsseln lassen, die die Ransomware STOP unbrauchbar ...

Off Topic
8 zoll disketten
Information von brammer vor 1 TagOff Topic5 Kommentare

Hallo, ob das so gut ist brammer

Off Topic
Noch mehr was ich nicht brauche
Information von brammer vor 4 TagenOff Topic6 Kommentare

Hallo, WOFÜR? WARUM? brammer

Heiß diskutierte Inhalte
Windows 7
Alter PC abgebrannt - Festplatte im neuen PC führt zum Bluescreen
gelöst Frage von CAT404Windows 725 Kommentare

Moin ich habe seit heute mittag einen PC aufm Tisch stehen, total verzweifelter Eigentümer. Der Rechner ist so ein ...

Server-Hardware
Welches Betriebssystem für DL380p Gen8 für den Heimgebrauch
Frage von peter91gServer-Hardware17 Kommentare

Hallo zusammen, betreibe Zuhause einen Dl380p G8 derzeit mit ESXI in der Testversion. Es läuft je nach Bedarf Ubuntu ...

Windows Server
Powershell Skript kann nicht geladen werden
Frage von renatus85Windows Server14 Kommentare

Hallo, ich habe folgendes Anliegen: In unserer Organisation setzen wir AlwaysOn VPN ein. Das funktioniert soweit auch ohne Probleme. ...

Router & Routing
ARCHER C7 als Open VPN-Server im Netwerk einer Fritzbox 6490
Frage von thburkhartRouter & Routing14 Kommentare

Guten Tag, ich habe bei UnityMedia eine Fritzbox 6490, die die Verbindung zur WAN-Seite herstellt. Einen VPN-Zugriff realisiere über ...