stefan007
Goto Top

Lenovo Twist S230U mit Kubuntu - Tastatur und Touchpadproblem

Hi Leute,

ich habe auf dem Lenovo Twist 230U Linux Kubuntu 19.10 installiert und stelle dort ebenfalls die Problematik fest, die hier https://forums.linuxmint.com/viewtopic.php?f=49&t=157115&p=81340 ... angesprochen wurde.

Das Touchpad und die Tastatur funktionieren nicht mehr. Das Touchdisplay funktioniert problemlos. Unter Ubuntu konnte ich das mit der Anleitung lösen, bei Kubuntu jedoch leider nicht. Dort funktioniert auch
sudo gedit /etc/default/grub
nicht.

Wenn ich stattdessen über
sudo vi /etc/default/grub
gehe, dann komme ich zwar in das Menü aber die dort getätigten Änderungen haben leider keinen Effekt.


Hat vielleicht jemand noch eine Idee? Ich weiß, dass das Gerät nicht mehr supportet ist, es soll auch nur mit Kubuntu zu Testzwecken bestückt werden.


Gruß,

Stefan

Content-Key: 601266

Url: https://administrator.de/contentid/601266

Printed on: June 24, 2024 at 17:06 o'clock

Member: Lochkartenstanzer
Lochkartenstanzer Sep 02, 2020 updated at 16:43:40 (UTC)
Goto Top
Zitat von @Stefan007:

sudo gedit /etc/default/grub
nicht.

Wenn ich stattdessen über
sudo vi /etc/default/grub
gehe, dann komme ich zwar in das Menü

In welches Menü? Vi ist ein Editor, kein Menüprorgamm.

aber die dort getätigten Änderungen haben leider keinen Effekt.

Es ist unerheblich ob man die Konfigurationsdatei /etc/default/grub mit vi, gedit, emacs, ed oder einem sonstigen Texteditor bearbeitet.

Hast Du denn anschließend noch ein "update-grub" durchgeführt oder auch verifiziert, ob Du keine Tippfehler hast?

lks
Member: Stefan007
Stefan007 Sep 02, 2020 at 18:25:35 (UTC)
Goto Top
Hi lks,


update-grub funktioniert leider nicht. Anscheinend kennt er den Befehl nicht.

Die Bearbeitung habe ich über das Terminal gemacht.
Member: Lochkartenstanzer
Lochkartenstanzer Sep 02, 2020 at 19:23:22 (UTC)
Goto Top
Zitat von @Stefan007:

Hi lks,


update-grub funktioniert leider nicht. Anscheinend kennt er den Befehl nicht.

Die Bearbeitung habe ich über das Terminal gemacht.

kann bei kubuntu eigentlich nicht sein. Ist Grub überhaupt installeiert? Und führst Du es als root aus?

lks
Member: GNULinux
GNULinux Sep 05, 2020 at 10:41:53 (UTC)
Goto Top
Mach mal

$ which update-grub
/usr/sbin/update-grub

Unabhängig davon würde ich aber erst mal auf die v20 LTS upgraden, denn 19.10 ist schon seit Juli EOL und bekommt dementsprechend keine Updates mehr. Möglicherweise löst sich das Problem dadurch auch.
Member: Stefan007
Stefan007 Sep 06, 2020 at 06:53:06 (UTC)
Goto Top
Hi zusammen,

also mit der v20 gehts auch nicht. Ich habe dann Ubuntu in der aktuellen Version installiert und dort funktioniert es!

Was ich komisch finde: Ich dachte Kubuntu ist einfach nur eine optische Anpassung von Ubuntu.

Ich teste das nochmal mit Kubuntu weil mich das nicht in Ruhe lässt face-smile
Member: Stefan007
Stefan007 Sep 06, 2020 at 11:06:30 (UTC)
Goto Top
Also:


der Befehl
Sudo gedit /etc/default/grub

funktioniert bei Ubuntu sofort. Bei Kubuntu nicht. Wo ist jetzt das Problem? Normal müsste Kubuntu doch gedit auch kennen oder nicht?

Beide Installationen wurden gleich durchgeführt.
Member: Lochkartenstanzer
Solution Lochkartenstanzer Sep 06, 2020 updated at 11:19:51 (UTC)
Goto Top
Zitat von @Stefan007:

funktioniert bei Ubuntu sofort. Bei Kubuntu nicht. Wo ist jetzt das Problem? Normal müsste Kubuntu doch gedit auch kennen oder nicht?

Nur wenn gedit auch installiert ist und auch im Suchpfad der Befehle enthalten ist.

Mach doch einfach mal ein
apt install gedit
und versuch es dann.

Kubuntu hat vermutlich andere defaults als Ubuntu.

lks
Member: Stefan007
Stefan007 Sep 06, 2020 at 17:41:14 (UTC)
Goto Top
Hi LKS,

Danke! Es kann manchmal so einfach sein face-smile