gelöst MikroTik - Bonjour routing

Mitglied: Alex29

Alex29 (Level 1) - Jetzt verbinden

09.05.2019 um 21:13 Uhr, 3282 Aufrufe, 10 Kommentare

Hallo zusammen!

ich habe mal wieder eine Frage für mein Heimnetz.

In dem Netz werkelt ein MikroTik RB3011 als Router zwischen verschiedenen VLAN's. In einem VLAN hängt nun ein "fertiger" SAT>IP-Server von "Triax", ein "TSS400". Dieser ist so konfiguriert, dass er max. 4 Clients mit einem Fernsehprogramm versorgt und zwar als Unicast. Wenn ein Windows-Client mit der Software "DVB-Viewer" aus einem anderen VLAN zugreifen will funktioniert dies. Ich habe also die Firewall bzw. das Routing am MikroTik hierfür richtig konfiguriert.

Will ich jedoch mit einem Apple-Gerät (z.B. iPad) aus dem gleichen VLAN wie der Windows-Client auf den Sat>IP-Server zugreifen funktioniert es nicht. Ich bin mir sicher, dass es ja nicht am Routing liegt - vielmehr habe ich in der App keine Möglichkeit die IP des Sat>IP-Servers einzustellen. Sind iPad und Sat>IP-Server im gleichen VLAN funktioniert es - der Server wird sofort angezeigt.

Da mein "Google" nicht defekt ist, habe ich schon viel gelesen aber noch keine richtige Lösung gefunden.

Es liegt meines Wissens daran, dass Bonjour (mit dem das iPad vom Server erfährt) nicht geroutet wird - da es Multicast ist. Meine Recherche hat ergeben, dass ich "PIM" oder einen "IGMP-Proxy" brauche - leider weis ich nicht was von beidem.

Vieleicht kann ja hier jemand Licht in mein Dunkel bringen - und mir erläutern was ich am MikroTik alles einstellen muss.

Ergänzend würde mich noch interessieren ob ich an meinen Cisco-Switchen (SG-Reihe) das IGMP-Snooping anschalten soll - wenn es nur Vorteile hat warum ist es im Default aus?

Viele Grüße
Alex
Mitglied: chgorges
LÖSUNG 09.05.2019 um 21:32 Uhr
Hi,
aufpassen, für Apple Geräte brauchst du mDNS Support, das ist was anderes, als IGMP Snooping.
Schau mal hier https://forum.mikrotik.com/viewtopic.php?t=105651
Bitte warten ..
Mitglied: Alex29
09.05.2019 um 22:02 Uhr
Danke, aber...

...das ist einer von den Artikeln, die mich verwirrt haben.

Wenn ich es hier richtig verstehe funktioniert es mit MikroTik aktuell gar nicht. Bei anderen Beiträgen hätte man jedoch meinen können, das es doch funktioniert.

???

Hier steht zum Beispiel, dass es mit einem Proxy funktioniert

https://administrator.de/forum/apple-bonjour-protokoll-routen-278480.htm ...
Bitte warten ..
Mitglied: 139708
LÖSUNG 09.05.2019, aktualisiert um 22:09 Uhr
Zitat von Alex29:

Wenn ich es hier richtig verstehe funktioniert es mit MikroTik aktuell gar nicht.
Korrekt! Dieser versteht sich nicht mit mDNS.

Hier steht zum Beispiel, dass es mit einem Proxy funktioniert

https://administrator.de/forum/apple-bonjour-protokoll-routen-278480.htm ...
Ja, aber eben nicht alleine mit dem Mikrotik, außer man packt sich eine Metarouter Instanz mit einem Avahi-Daemon auf die Kiste, oder eben ein mDNS Reflector auf einen zusätzlichen Raspberry.


Gruß wireguard
Bitte warten ..
Mitglied: Alex29
09.05.2019 um 22:17 Uhr
Danke,

also muss ich nicht weiter suchen.

Dann muss der Sat>IP-Server nun im gleichen VLAN wie die Apple-Geräte laufen - Schade aber ich kann damit leben.

Gruß
Alex
Bitte warten ..
Mitglied: aqui
10.05.2019, aktualisiert um 07:34 Uhr
mDNS ist nicht routebar, da es eine Local Link Multicast Gruppenadresse verwendet. Was du brauchst ist ein Bonjour Proxy. Viele WLAN APs supporten sowas schon von sich aus mit einem Mausklick. Ansonsten ist es mit einem RasPi ganz schnell aufgesetzt:
https://administrator.de/wissen/netzwerk-management-server-raspberry-pi- ...
Bitte warten ..
Mitglied: 144260
04.06.2020, aktualisiert um 18:17 Uhr
Hab das Prozedere für einen Reflektor und den Mikrotik mal schnell zusammengetippt, vielleicht hilft es ja eventuell denjenigen die hier im Beitrag noch vorbei kommen:

Step by Step: Mikrotik mDNS (Bonjour) reflector between different VLANs with avahi daemon and a linux machine on a tagged trunk port

Example is for 2 VLANs with IDs 10 and 20, but it can be extended to as much VLANs you need to include in the mDNS Broadcast Domain.

  • On the Mikrotik make sure you are already using bridge with vlan_filtering enabled.
  • Now assign the ethernet port wich comes from our avahi reflector to the vlans (replace the red placeholders with your names)
    • /interface bridge port add bridge=[YOUR_BRIDGE] frame-types=admit-only-vlan-tagged interface=[ETHERNET_PORT_TO_AVAHI]
    • /interface bridge vlan add bridge=[YOUR_BRIDGE] tagged=[ETHERNET_PORT_TO_AVAHI],[YOUR_BRIDGE] vlan-ids=10
    • /interface bridge vlan add bridge=[YOUR_BRIDGE] tagged=[ETHERNET_PORT_TO_AVAHI],[YOUR_BRIDGE] vlan-ids=20
  • Now setup a Linux-Device of your choice
  • Install the avahi package with the package manager of your distribution (example in Archlinux: pacman -S avahi)
  • Edit the avahi configuration in /etc/avahi/avahi-daemon.conf
    • Now find the line that says #enable-reflector=no and change it to enable-reflector=yes and save. Do not change any other settings .
  • Create VLAN-Interfaces on the ethernet interface wich is connected to the Mikrotik bridge (in this example we are using VLAN IDs 10 and 20 and interface eth0 (exchange with your values))
Instant Configuration
    • sudo ip link add link eth0 name eth0.10 type vlan id 10
    • sudo ip link add link eth0 name eth0.20 type vlan id 20
Persistent Configuration
    • Consult the documentation of your distribution and/or network manager
  • Now setup DHCP or a static IP-Configuration on the VLAN interfaces
  • Test connectivity on both VLANs (e.g. ping stations or gateway of the matching vlan)
  • Now (re)start the avahi-daemon
    • sudo systemctl restart avahi-daemon
    • For service restart after reboot, enable link in systemd: sudo systemctl enable avahi-daemon
  • Make sure the Mikrotik Firewall allows traffic flow between the specific VLANs, and the firewall on the linux device does not filter traffic on the mDNS port 5353 UDP.
  • Now mDNS-Packets should be reflected between the VLAN IDs 10 and 20, and devices of each vlan should be able to discover services of the other VLAN.
  • The service discovery can be tested for example with the command avahi-browse -alvt
Bitte warten ..
Mitglied: aqui
05.06.2020, aktualisiert um 09:07 Uhr
Danke für den sehr hilfreichen Post !
Die Bonjour/mDNS Geschichte wird hier immer wieder angefragt im Forum in segmentierten Netzen. Es ergänzt den oben schon zum RasPi Setup geposteten Link zu dem Thema.
Zusätzlich sollte man noch sagen das bessere WLAN APs (z.B. Ruckus) und Router solche Fähigkeiten von sich aus schon an Bord haben. Wie immer einen Frage der Feature Ausstattung bzw. des Budgets.
Bitte warten ..
Mitglied: 144260
05.06.2020, aktualisiert um 09:22 Uhr
Zitat von aqui:

Danke für den sehr hilfreichen Post !
Die Bonjour/mDNS Geschichte wird hier immer wieder angefragt im Forum in segmentierten Netzen. Es ergänzt den oben schon zum RasPi Setup geposteten Link zu dem Thema.
Immer gerne, das war meine Intention .
Zusätzlich sollte man noch sagen das bessere WLAN APs (z.B. Ruckus) und Router solche Fähigkeiten von sich aus schon an Bord haben. Wie immer einen Frage der Feature Ausstattung bzw. des Budgets.
Ja das ist wahr, habe von einem Kollegen aber wohl schon Leuten hören das mDNS unter anderem wohl schon auf der Agenda von Mikrotik steht, aber mit welcher Prio lässt sich leider nicht genau sagen, Router OS 7 lässt sich ja auch ziemlich Zeit, aber gut Ding will halt Weile haben. Da die Jungs sich offensichtlich hauptsächlich auf eigene Implementierungen der Software stützen dauert das ganze eben länger, dafür kosten die Dinger aber auch nur einen Bruchteil und mal ehrlich, der nötige Speicherbedarf bei dem großen Featureset ist schon beachtlich gering und das ist wohl eine der Herausforderungen um den Großteil der Devices an den Neuerungen teilhaben zu lassen .
Bitte warten ..
Mitglied: skyacer
22.09.2020 um 13:12 Uhr
Hi,

also ich hab jetzt einmal versucht nach deiner Anleitung vorzugehen aber irgendwo hakt es da noch und ich bräuchte da einmal Hilfe. Also Vlans 10,30,40 hab ich schon eingerichtet gehabt und funktionieren auch. Den Avahi Server habe ich auf einen IntelNuc in einem Lxc Container unter Debian 10.5 in VLan 40 tagged installiert und auch den Reflector eingeschaltet und das # entfernt.
Dann habe ich folgende Links erstellt:
sudo ip link add link eth0 name eth0.10 type vlan id 10
sudo ip link add link eth0 name eth0.30 type vlan id 30
Ich habe unter Proxmox dann die jeweiligen Linknamen mit einer IP und dem jeweiligen Vlan eingetragen.

Ein Ping vom Avahi Server zu den anderen Vlans geht auch.
Unter avahi-browse -alvt bekomme ich folgendes:

Versuche ich jetzt von meinem Handy z.b. meine Nanoleafs zu finden dann findet er die nicht. Mit einer Discovery App auf dem Iphone findet er auch nur die Geräte im Vlan 10 wo sich das Iphone auch befindet.
In der Firewall wurde der Port UDP 5353 auf alle Vlans freigeben.

Ich weiß jetzt nicht mehr wo ich suchen kann oder soll. Wahrscheinlich ist es nur eine kleine Einstellung. Was habe ich also vergessen oder falsch gemacht?

Grüße
Jascha
Bitte warten ..
Mitglied: aqui
24.09.2020 um 11:50 Uhr
Hast du denn deine Bonjour Geräte auch im AVAHI Setup konfiguriert und den Server entsprechen neu gestartet ?
https://administrator.de/tutorial/netzwerk-management-server-raspberry-p ...
Zudem kannst du die die AVAHI Boradcasts mit dem Wireshark im jeweiligen Netzsegment ansehen. Dort im Paket Inhalt kannst du dann auch im Klartext die announcten Geräte und IP Adressen sehen.
Ohne diese Pakete und ihr Inhalt kommt natürlich an den Endgeräten nix an...logisch.
Bitte warten ..
Heiß diskutierte Inhalte
Hardware
Schwarmwissen gefragt: Rätselstunde am Samstag Abend - LWL Verkabelung
gelöst Xaero1982FrageHardware32 Kommentare

Nabend Zusammen, heute Abend gibt es ein kleines Rätsel für euch was es zu lösen gilt. Die Lösung werde ...

Backup
Veeam Backup-Server aus der Domäne nehmen
redhorseFrageBackup26 Kommentare

Guten Morgen, da in unserer Backupumgebung ein Hardwaretausch ansteht, konzipiere ich gerade Möglichkeiten die Sicherheit zu erhöhen. Konkret geht ...

Vmware
ESXi für Raspberry Pi
sabinesInformationVmware18 Kommentare

VMware hat den ESXi für den Raspberry Pi (zu Testzwecken) vorgestellt, läuft 180 Tage auf dem Pi 4 mit ...

Windows Server
Server mit AMD EPYC 7F52 (1Socket) wird als 2 Socket Server angezeigt
LordXearoFrageWindows Server11 Kommentare

Hallo Zusammen, ich komme mit meinem Problem nicht so recht weiter und hoffe aufjemanden der noch weitere Ideen hat. ...

Notebook & Zubehör
Surface pro 3 oder aktueller
devazubiFrageNotebook & Zubehör11 Kommentare

Moin moin zusammen, ich möchte eine kurze Umfrage/Feedbackrunde starten. Ich habe gerade angefangen Wirtschaftsinformatik berufsbegleitend zu studieren. Ich würde ...

Outlook & Mail
Mails Farblich kennzeichnen für mehrer PCs ohne Exchange
gelöst luzifermbFrageOutlook & Mail10 Kommentare

Guten Tag, ich brauche Hilfe zu MS Outlook! Ich habe eine kleines Firmennetzwerk und möchte gerne mit 3 PCs ...

Ähnliche Inhalte
Router & Routing
MikroTik - Routing, Bridging, Switching
gelöst Alex29FrageRouter & Routing9 Kommentare

Hallo in die Runde, als Hobby-Admin würde ich bitte mal wieder Eure Hilfe benötigen. Seit der Umstellung auf RouterOS ...

Netzwerkprotokolle
Mikrotik - Ohne Routing Ports blocken
BoomBoomBenFrageNetzwerkprotokolle5 Kommentare

Hallo zusammen, ich möchte mit einem Mikrotik ein einzelnes Gerät vom Netzwerk abschotten. Dieses darf nur noch einen einzelnen ...

Router & Routing
Mikrotik Switching und Routing Problem
gelöst aquiFrageRouter & Routing11 Kommentare

Mikrotik Experten an die Front ! Folgendes Switching Design mit VLAN Routing soll zum Fliegen kommen und bereitet mir ...

LAN, WAN, Wireless
Routing + VLANs mit Mikrotik Routerboard
gelöst klattiFrageLAN, WAN, Wireless6 Kommentare

Hallo zusammen, Ich nutze aktuell das Mikrotik Routerboard 750G r2 (FW: 6.41) als Router/Firewall. Aktuell läuft das ohne VLANs: ...

LAN, WAN, Wireless
Multicast Bonjour Airlino WLAN
AmateurverkablerFrageLAN, WAN, Wireless2 Kommentare

Hallo Administratoren, ich habe mir ein Airlino Plus WLan Musikempfänger gekauft um per Handy meine Musikanlage zu speisen. Problem: ...

Router & Routing

Inter VLAN Routing Problem mit Mikrotik RB4011

gelöst daniel.sFrageRouter & Routing12 Kommentare

Hallo Community, ich habe etwas vollmundig versprochen meiner Frau bei einer Model-VLAN Konfiguration zu helfen und stehe schon seit ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud