its.work
Goto Top

MS Azure Connect bring bei Einrichtung Fehlermeldung

Hallo Leute,

will gerne mein offline AD mit MS365 synchronisieren, und bekomme immer eine Fehlermeldung:

ad-fehler

Infos zur Umgebung:

Mein Richtige Domainname und den MS365-Name wurde für diesen Beitrag auf FRIMA.com abgeändert

Windows Server 2022 Standard ist DC
Aktuell aus Testzwecken kein AV und keine FW aktiv.

Ich bin als FIRMA\Administrator angemeldet und habe alle Rechte, diese auch beim Connector benützt und den Global-Admin von MS365 angeben.

Bei MS365 Azure auch die Lizenz vorhanden und den Connector aus den Admin-Portal geladen und mittel Express Installation ausgeführt.

Hier noch die trace.log:
TraceLog.txt

Die Meldung das die Anmeldeinformationen falsch sind kann nicht sein habe diese mittels CopyandPast eingefügt und 4 mal kontrolliert.

Hat jemand eine Idee?

Vielen Dank in Voraus.

Daniel

Content-Key: 6225951412

Url: https://administrator.de/contentid/6225951412

Printed on: July 17, 2024 at 19:07 o'clock

Member: Mystery-at-min
Mystery-at-min Mar 05, 2023 at 11:15:39 (UTC)
Goto Top
Sagt er doch schon - Kennworte passen nicht. - Egal ob drei oder 10x kopiert.
Member: its.work
its.work Mar 05, 2023 updated at 11:24:40 (UTC)
Goto Top
Zitat von @Mystery-at-min:

Sagt er doch schon - Kennworte passen nicht. - Egal ob drei oder 10x kopiert.

Die Kennwörter sind zu 100% korrekt wie schon geschrieben, kann mach i ja auch mit diesen einloggen.

Weiteres wenn ich absichtlich das Kennwort falsch angebe kommt gleich die Fehlermeldung siehe Foto:
ad-fm2
Member: Cloudrakete
Cloudrakete Mar 05, 2023 at 11:39:25 (UTC)
Goto Top
Servus,

Firma.com\Administrator?

Also zum einem kommt da wenn überhaupt die NetBIOS Domain (ohne tld) rein.
Zum anderen würde ich einen AD-Connect nicht mit dem User "Administrator" installieren.

Schau hier mal rein, wenn du es richtig machen willst: https://learn.microsoft.com/en-us/azure/active-directory/hybrid/referenc ...
Member: its.work
its.work Mar 05, 2023 updated at 11:55:31 (UTC)
Goto Top
Zitat von @Cloudrakete:

Servus,

Firma.com\Administrator?

Also zum einem kommt da wenn überhaupt die NetBIOS Domain (ohne tld) rein.
Zum anderen würde ich einen AD-Connect nicht mit dem User "Administrator" installieren.


Danke für diese Info habe bereits mit den NetBIOS ohne TLD versuchen, leider gleicher Fehler.
Hatte nur diesen Eingeben weil MS diesen so vorschlägt:
ad-fm3

Ich habe nur den "Administrator" verwendet als Testzwecken.

Schau hier mal rein, wenn du es richtig machen willst: https://learn.microsoft.com/en-us/azure/active-directory/hybrid/referenc ...

Danke den Link kenne ich bereits.
Member: Cloudrakete
Cloudrakete Mar 05, 2023 at 12:02:56 (UTC)
Goto Top
Hi,

komisch. Ich hatte hier insofern die Creds korrekt waren noch nie Probleme.
Aktiviere bitte aber wieder die Windows-Firewall, die macht deaktiviert mehr Probleme als aktiviert, vorallem wenn sich um domain joined Server handelt. Da sollte per default die gesamte AD-Kommunikation offen sein.

Du könntest mal im AD nachschauen, ob die Sign-In Versuche hier geloggt werden und einen entsprechenden Fehler ausgeben. Insofern die Authentifikation dort ankommt, sollte hier etwas sichtbar sein,
Member: its.work
its.work Mar 05, 2023 at 12:19:16 (UTC)
Goto Top
Zitat von @Cloudrakete:

Hi,

komisch. Ich hatte hier insofern die Creds korrekt waren noch nie Probleme.
Aktiviere bitte aber wieder die Windows-Firewall, die macht deaktiviert mehr Probleme als aktiviert, vorallem wenn sich um domain joined Server handelt. Da sollte per default die gesamte AD-Kommunikation offen sein.

Du könntest mal im AD nachschauen, ob die Sign-In Versuche hier geloggt werden und einen entsprechenden Fehler ausgeben. Insofern die Authentifikation dort ankommt, sollte hier etwas sichtbar sein,

Sign-In Versuche kommen im AD und im Azure an, er erstellt leider nur keinen Connector. Habe Windows-Firewall mal aktiviert, leider der selbe Fehler.
Member: Cloudrakete
Cloudrakete Mar 05, 2023 at 12:27:16 (UTC)
Goto Top
Azure AD spielt hier gerade ja keine Rolle.
Im Audit Log des ADs müsste ja drin stehen, ob die Anmeldung erfolgreich war, oder nicht.
Was steht denn hier?
Mitglied: 2423392070
2423392070 Mar 05, 2023 at 12:31:02 (UTC)
Goto Top
Wie bereits erwähnt ist der User Administrator nicht optimal. Optimal ist er (Admin) deaktiviert.

Noch optimaler ist ein Dienstuser, der nur die Rechte hat, die der Connector benötigt.
Member: its.work
its.work Mar 05, 2023 at 12:37:33 (UTC)
Goto Top
Zitat von @2423392070:

Wie bereits erwähnt ist der User Administrator nicht optimal. Optimal ist er (Admin) deaktiviert.

Noch optimaler ist ein Dienstuser, der nur die Rechte hat, die der Connector benötigt.

Ist mir bewusst aber als Testzwecken wird der Administrator verwendet, aber dies Löst leider nicht mein Problem.
Member: its.work
its.work Mar 05, 2023 at 12:37:43 (UTC)
Goto Top
Zitat von @Cloudrakete:

Azure AD spielt hier gerade ja keine Rolle.
Im Audit Log des ADs müsste ja drin stehen, ob die Anmeldung erfolgreich war, oder nicht.
Was steht denn hier?

Schau ich mir an
Member: its.work
its.work Mar 05, 2023 at 13:14:09 (UTC)
Goto Top
Zitat von @Cloudrakete:

Azure AD spielt hier gerade ja keine Rolle.
Im Audit Log des ADs müsste ja drin stehen, ob die Anmeldung erfolgreich war, oder nicht.
Was steht denn hier?

Leider finde ich hierzu keine Logs obwohl die An- und Abmeldeüberwachung in den GPO aktiviert ist.
Danke dir in Voraus!
Member: 7Gizmo7
7Gizmo7 Mar 06, 2023 at 12:03:53 (UTC)
Goto Top
Hi,

Wird Azure Ad Connect auf einem DC versucht zu installieren?

Mit freundlichen Grüßen
Member: its.work
its.work Mar 07, 2023 at 13:02:24 (UTC)
Goto Top
Zitat von @7Gizmo7:

Hi,

Wird Azure Ad Connect auf einem DC versucht zu installieren?

Mit freundlichen Grüßen

Ja genau
Member: 7Gizmo7
7Gizmo7 Mar 07, 2023 at 18:38:19 (UTC)
Goto Top
Hi,

Das ist nicht supported oder gern gesehen , mach es auf einen extra Server.
Mit freundlichen Grüßen
Member: Cloudrakete
Cloudrakete Mar 07, 2023 at 18:56:45 (UTC)
Goto Top
Der AD-Connect kann theoretisch überall installiert werden, solange es sich um ein AD-joined Server handelt.
MS sagt nicht ausdrücklich, dass es auf einem AD-Server nicht supported sei.

Abseits dessen hat Gizmo aber recht, rein von der Architektur ist nicht klug, den AD-Connect auf dem AD-Server zu installieren.

Ich weiße mal auf die Prerequisites von MS hin:

https://learn.microsoft.com/en-us/azure/active-directory/hybrid/how-to-c ...

z.B. wird hier auch erwähnt, dass Umgebungen mit "dotted" NetBIOS Domains nicht supportet sind, scheinbar hast Du solch eine Domäne.
Prüfe auch die restlichen Punkte in diesem Beitrag.