drnatur
Goto Top

Outlook 2016 + Exchange: Zugriff von extern zuerst auf interne Exchange-IP

Hallo,

ich bin als 1st-Level für ein kleines Unternehmen (<300 Mitarbeiter) tätig.
Unsere Umgebung ist ein bisschen gewachsen.

EDIT vom 24.01.
Nach den Hinweisen in den Kommentaren hab ich folgendes festgestellt:
Wir verwenden noch die Host-Datei, (%windir%\system32\drivers\etc\hosts) da war der Exchange eingetragen.
Nachdem ich den da entfernt hatte, ging der externe Zugriff auch ganz schnell

Client: Notebooks mit Windows 10 und Outlook 2016
Exchange 2010 mit Microsoft TMG, extern erreichbar unter https://webmail.domain.tld

Outlook braucht beim externen Start (außerhalb des Firmennetzes) teilweise bis zu 50 Sekunden, bis es sich öffnet und sich mit dem Exchange verbindet.
Intern geht das ganze innerhalb von ein paar Sekunden.
Natürlich abhängig von der Postfachgröße dauert es länger, aber selbst bei neuen Usern ist der externe Zugriff extrem langsam.

Ich habe also mal mit dem Ressourcen-Monitor und einer Stoppuhr geschaut, was da passiert.
Outlook probiert bei externen Zugriff zuerst die interne IP des Exchange zu erreichen und nach ca. 30 Sekunden weicht es auf die externe des TMG's aus.

Wisst ihr, ob dieses Verhalten beinflussbar ist, oder dass ich quasi einen Timeout setzen kann, wenn die interne IP nicht erreichbar ist?

Es wurden schon folgende Registry-Einträge bez. AutoDiscovery gesetzt, ohne Erfolg:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover]
"ExcludeHttpsAutoDiscoverDomain"=dword:00000001  
"ExcludeHttpsRootDomain"=dword:00000001  
"ExcludeScpLookup"=dword:00000001  
"ExcludeExplicitO365Endpoint"=dword:00000001  
"ExcludeSrvRecord"=dword:00000001  
"Timeout"="10"  

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover\RedirectServers]
"autodiscover-s.outlook.com"=hex(0):  
"autodiscover.outlook.com"=hex(0):  

LG

Content-Key: 643017

Url: https://administrator.de/contentid/643017

Printed on: April 19, 2024 at 15:04 o'clock

Mitglied: 147323
Solution 147323 Jan 21, 2021 updated at 12:10:09 (UTC)
Goto Top
Das liegt dann wohl eher am Windows-DNS Cache. Setze für den internen SPLIT DNS-Record eine kürzere TTL dann sollte Windows hier auch schneller umschalten wenn zwischen dem Wechsel der User von Intern nach Extern kein Reboot erfolgt. Alternativ ipconfig /flushdns in die Konsole eintippeln.
Member: Dani
Solution Dani Jan 23, 2021 at 16:16:34 (UTC)
Goto Top
Moin,
Outlook probiert bei externen Zugriff zuerst die interne IP des Exchange zu erreichen und nach ca. 30 Sekunden weicht es auf die externe des TMG's aus.
die grundsätzliche Frage ist, wird überhaupt Split DNS genutzt. Schließlich kann man interne und externe Domains angeben. Denn die Aussage deutet meiner Deutung nicht darauf hin.


Gruß,
Dani
Member: drnatur
drnatur Jan 24, 2021 at 11:03:23 (UTC)
Goto Top
Zitat von @Dani:

Moin,
Outlook probiert bei externen Zugriff zuerst die interne IP des Exchange zu erreichen und nach ca. 30 Sekunden weicht es auf die externe des TMG's aus.
die grundsätzliche Frage ist, wird überhaupt Split DNS genutzt. Schließlich kann man interne und externe Domains angeben. Denn die Aussage deutet meiner Deutung nicht darauf hin.


Gruß,
Dani
Hallo,

ne Split DNS wird nicht genutzt.
Intern heißt der Server "exchange.intern.local"
Extern "https:://webmail.interntedomain.tld/owa"

Ich hab das also mit dem
Zitat von @147323:

Das liegt dann wohl eher am Windows-DNS Cache. Setze für den internen SPLIT DNS-Record eine kürzere TTL dann sollte Windows hier auch schneller umschalten wenn zwischen dem Wechsel der User von Intern nach Extern kein Reboot erfolgt. Alternativ ipconfig /flushdns in die Konsole eintippeln.

probiert, aber es gab keine Besserung.
Die Stoppuhr sagt ca. 45 Sekunden beim Zugriff von Extern, darauf entfallen 30 Sekunden auf den Zugriffsversuch auf den internen Server.

Ich habe da noch was vergessen zu erwähnen (tu ich gleich in den Ursprungsbeitrag rein)
Wir verwenden noch die Host-Datei, (%windir%\system32\drivers\etc\hosts) da war der Exchange eingetragen.
Nachdem ich den da entfernt hatte, ging der externe Zugriff auch ganz schnell

Vielen Dank trotzdem für die Hinweise mit dem DNS, das hat mich auf die Spur gebracht