OWA - Javascript Fehler

Mitglied: corecode

corecode (Level 1) - Jetzt verbinden

10.08.2006, aktualisiert 07.09.2006, 7565 Aufrufe, 2 Kommentare

Javascript fehler beim Versenden von Nachrichten

Hallo Forum!

Ich habe ein massives Problem mit OWA und hoffe hier meine Antworten zu finden.

Szenario:
Internet -> Reverse Proxy -> MS Exchange 2003 SP2 (OWA) -> Active Directory

Exchange und Outlook funktionieren soweit 1a! Basic Modus funktioniert auch.


Allerdings beim Connect via Premium-Mode bekomme ich bei manchen Seiten javascript errors.

Einen kaputten IE kann ich ausschließen, da das Problem bei allen getesteten Rechnern auftritt. Beim Erstellen einer neuen Nachricht bekomme ich beim "Senden" sofort ein Popup mit dem Inhalt "Unknown". Klick ich 3-4 mal auf "Senden" wird die e-Mail gesendet.

OWA verwendet offensichtlich ActiveX elemente. Brauchen diese eigene ports? Welche ports müssen sonst geroutet werden?

Das System befindet sich auf dem aktuellsten Stand per Dato.


Wie hier im Forum beschrieben, habe ich auch den Bug mit den komprimierten IIS Temp Files ausschließen können.


Hoffe um baldige, weiterführende Tipps und bedanke mich schon vorab.


Liebe Grüße,
2C/AW
Mitglied: Yoshi-GP
17.08.2006 um 07:45 Uhr
Hallo corecode,

ich habe seit einer Woche an einer Maschine ein ähnliches Problem. Der Basic-Modus des OWA funktioniert problemlos. Im Premium-Modus erfolgen JavaScript-Fehler beim Abmelden, beim Antworten auf Mails sowie beim Löschen. Beim Öffnen von Mails durch Doppelklick wird im neuen Fenster das komplette Frameset des OWA neu geladen.

Gibt`s eventuell schon Lösungsansätze?

Gruss Jan
Bitte warten ..
Mitglied: shub
07.09.2006 um 16:33 Uhr
Hi Gruppe,

habe exakt das gleiche Problem:
Client per ssl -> suse linux 10.0 ssl reverse proxy -> Exchange 2003 Std+SP1

OWA funktioniert einwandfrei, bis auf das Versenden von Mails.
Beim ersten Klick auf "Senden" geht eine IE6.0 Fehlermeldung auf: "Unknown"
Nach klick auf OK und erneutem Versenden der Mail geht diese raus und wird verschickt.
Mit dem Opera Browser 9.0 kommt diese Fehlermeldung NICHT.
OWA Versendet für den Versand http Protokol1.1.
Im Script des OWAs werden im http Protokoll folgende Befehle wärend der Arbeit mit OWA benötigt:

General Maximum headers length is 32768.
Allow any payload length is selected.
Maximum URL length is 260.
Maximum query length is 4096.
Verify normalization is selected.
Block high bit characters is not selected.
Methods Select Allow only specified methods, and specify:
GET
POST
PROPFIND
PROPPATCH
BPROPPATCH
MKCOL
DELETE
BDELETE
BCOPY
MOVE
SUBSCRIBE
BMOVE
POLL
SEARCH
Extensions Select Block specified extensions (allow all others), and specify:
.exe
.bat
.cmd
.com
.htw
.ida
.idq
.htr
.idc
.shtm
.shtml
.stm
.printer
.ini
.log
.pol
.dat
Headers No changes from the default.
Signatures
(Request URL) Select Block content containing these signatures, and specify:
./
\
%
&


Der IE6.0 hat da so seine Probleme, wenn alle SSL Anfragen über ein Linux Derivat weitergeleitet werden.

Mit einem ISA Server 2004 funktioniert übrigens alles fehlerfrei egal mit welchem Browser.

client per ssl -> isa server 2004 per ssl Witerleitung-> exchange 2003 per ssl

Es ist wie immer, MS hält sich NICHT an die definierten RFC´s und packt wieder alles in den Header was geht :( face-sad

Wo genau das Problem liegt habe ich bis jetzt auch noch nicht gefunden.
Ist in meinem Fall aber eindeutig ein Kommunikationsproblem zw. Windowswelt SSL und Linuxwelt SSL.

Workaround: Nutze den Opera Browser!

mfg

shub
Bitte warten ..
Heiß diskutierte Inhalte
Switche und Hubs
Probleme im Netzwerk Switche teilweise nicht erreichbar
hukimanVor 1 TagFrageSwitche und Hubs30 Kommentare

Guten Morgen, seit Monaten haben wir hier immer wieder Probleme mit dem Netzwerk, das Problem konnte ich leider aber noch immer nicht finden. Es ...

Zusammenarbeit
Klimaschutz
NebellichtVor 11 StundenTippZusammenarbeit43 Kommentare

Hallo friends, (friends in Anlehnung an die vielen Fs in dem englischen von FFF: fridays for future. Übrigens am 19.03.2021 gibts wieder einen globalen ...

Batch & Shell
Tabellarische Ausgabe der Netzwerkschnittstellen
gelöst dysti99Vor 1 TagFrageBatch & Shell20 Kommentare

Mit - ip a - werden ja die Netzwerkschnittstellen angezeigt. Ich möchte mit ein Batchscript folgende Ausgabe erreichen: 1 eth0 192.168.1.1 AD:13:67:56:14:D1 2 eth1 ...

Notebook & Zubehör
Tipp für festgefressene Scharniere bei Lenovo V120 Notebook?
gelöst LochkartenstanzerVor 1 TagFrageNotebook & Zubehör20 Kommentare

Moin Kollegen, Ich habe hier ein Lenovo V120 mit einem laut Internet üblichen Problem von "festgefressenen" Scharnieren. Ich könnte jetzt aufwendig das Notebook zerlegen ...

Microsoft Office
Microsoft365 und Outlook verbinden
ratzekahl1Vor 14 StundenFrageMicrosoft Office29 Kommentare

Guten Morgen zusammen, ich habe einige Probleme / Fragen. Ich habe Office 365 auf den ersten Rechnern installiert. Admin angelegt, Benutzer usw. Da ich ...

Microsoft Office
Wechsel von Office - Exchange on premise zu Office 365 - Exchange Online
jann0rVor 1 TagAllgemeinMicrosoft Office12 Kommentare

Moin, ich weiß nicht so richtig, unter welche Überschrift man dieses Thema hier am besten packen kann, daher mal als allg. Beitrag / Erfahrungsbericht. ...

Netzwerkgrundlagen
Netzwerksaufbau bei nahezu auschließlichem Zugriff auf NAS bzw. Server
Ghent74Vor 1 TagFrageNetzwerkgrundlagen11 Kommentare

Hallo zusammen, in unserem kleinen Büro (6 Arbeitsplätze, Netzwerkdrucker, Netzwerkplotter, NAS) stellen immer mehr Softwarefirmen ihre Programme auf eine Art Datenbank um. Eine Art ...

Internet
Sichere Verbindung von zu Hause zu einem Firmenpc
haiflosseVor 1 TagFrageInternet6 Kommentare

Hallo! Ich suche eine Lösung mit der ich eine sichere Verbindung (ohne das ein Virus, Trojaner oder Ransom Virus den Computer bzw. Netzwerk zerstört) ...