Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OWA - Javascript Fehler

Mitglied: corecode

corecode (Level 1) - Jetzt verbinden

10.08.2006, aktualisiert 07.09.2006, 7422 Aufrufe, 2 Kommentare

Javascript fehler beim Versenden von Nachrichten

Hallo Forum!

Ich habe ein massives Problem mit OWA und hoffe hier meine Antworten zu finden.

Szenario:
Internet -> Reverse Proxy -> MS Exchange 2003 SP2 (OWA) -> Active Directory

Exchange und Outlook funktionieren soweit 1a! Basic Modus funktioniert auch.


Allerdings beim Connect via Premium-Mode bekomme ich bei manchen Seiten javascript errors.

Einen kaputten IE kann ich ausschließen, da das Problem bei allen getesteten Rechnern auftritt. Beim Erstellen einer neuen Nachricht bekomme ich beim "Senden" sofort ein Popup mit dem Inhalt "Unknown". Klick ich 3-4 mal auf "Senden" wird die e-Mail gesendet.

OWA verwendet offensichtlich ActiveX elemente. Brauchen diese eigene ports? Welche ports müssen sonst geroutet werden?

Das System befindet sich auf dem aktuellsten Stand per Dato.


Wie hier im Forum beschrieben, habe ich auch den Bug mit den komprimierten IIS Temp Files ausschließen können.


Hoffe um baldige, weiterführende Tipps und bedanke mich schon vorab.


Liebe Grüße,
2C/AW
Mitglied: Yoshi-GP
17.08.2006 um 07:45 Uhr
Hallo corecode,

ich habe seit einer Woche an einer Maschine ein ähnliches Problem. Der Basic-Modus des OWA funktioniert problemlos. Im Premium-Modus erfolgen JavaScript-Fehler beim Abmelden, beim Antworten auf Mails sowie beim Löschen. Beim Öffnen von Mails durch Doppelklick wird im neuen Fenster das komplette Frameset des OWA neu geladen.

Gibt`s eventuell schon Lösungsansätze?

Gruss Jan
Bitte warten ..
Mitglied: shub
07.09.2006 um 16:33 Uhr
Hi Gruppe,

habe exakt das gleiche Problem:
Client per ssl -> suse linux 10.0 ssl reverse proxy -> Exchange 2003 Std+SP1

OWA funktioniert einwandfrei, bis auf das Versenden von Mails.
Beim ersten Klick auf "Senden" geht eine IE6.0 Fehlermeldung auf: "Unknown"
Nach klick auf OK und erneutem Versenden der Mail geht diese raus und wird verschickt.
Mit dem Opera Browser 9.0 kommt diese Fehlermeldung NICHT.
OWA Versendet für den Versand http Protokol1.1.
Im Script des OWAs werden im http Protokoll folgende Befehle wärend der Arbeit mit OWA benötigt:

General Maximum headers length is 32768.
Allow any payload length is selected.
Maximum URL length is 260.
Maximum query length is 4096.
Verify normalization is selected.
Block high bit characters is not selected.
Methods Select Allow only specified methods, and specify:
GET
POST
PROPFIND
PROPPATCH
BPROPPATCH
MKCOL
DELETE
BDELETE
BCOPY
MOVE
SUBSCRIBE
BMOVE
POLL
SEARCH
Extensions Select Block specified extensions (allow all others), and specify:
.exe
.bat
.cmd
.com
.htw
.ida
.idq
.htr
.idc
.shtm
.shtml
.stm
.printer
.ini
.log
.pol
.dat
Headers No changes from the default.
Signatures
(Request URL) Select Block content containing these signatures, and specify:
./
\
%
&


Der IE6.0 hat da so seine Probleme, wenn alle SSL Anfragen über ein Linux Derivat weitergeleitet werden.

Mit einem ISA Server 2004 funktioniert übrigens alles fehlerfrei egal mit welchem Browser.

client per ssl -> isa server 2004 per ssl Witerleitung-> exchange 2003 per ssl

Es ist wie immer, MS hält sich NICHT an die definierten RFC´s und packt wieder alles in den Header was geht

Wo genau das Problem liegt habe ich bis jetzt auch noch nicht gefunden.
Ist in meinem Fall aber eindeutig ein Kommunikationsproblem zw. Windowswelt SSL und Linuxwelt SSL.

Workaround: Nutze den Opera Browser!

mfg

shub
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Abgelaufene Passwörter Ändern in OWA schlägt fehl

gelöst Frage von HamsertExchange Server1 Kommentar

Hallo, ich habe bereits diesen Eintrag in der Registry getätigt: und den IIS neugestartet. Man kommt im OWA nun ...

JavaScript

Javascript Funktionen

gelöst Frage von agowa338JavaScript5 Kommentare

Hallo, habe gerade mehrere schönen Javascripte per mail bekommen und frage mich gerade, was eigentlich folgendes in einem Javascript ...

JavaScript

JavaScript Map

Frage von tobmesJavaScript7 Kommentare

Hi, ich bins mal wider :). Ich spiele immernoch mit JavaScript herum und hänge jetzt mal wieder. Ich habe ...

JavaScript

JavaScript hochladen

gelöst Frage von Patrick-ITJavaScript12 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Seite, wo ich meine JavaScript Datei hochladen kann und die ...

Neue Wissensbeiträge
Windows 10

Windows 10 - Programme laufen schneller, wenn Sie mit Administratorrechten ausgeführt werden !

Erfahrungsbericht von 1Werner1 vor 3 StundenWindows 106 Kommentare

Moin, das wollte ich erst nicht glauben, aber es ist so. Wenn Ihr ein Programm mit Administratorrechten unter Windows ...

Sicherheits-Tools
Putty hat heftige Bugs korrigiert!
Information von Lochkartenstanzer vor 1 TagSicherheits-Tools5 Kommentare

Moin, Wie man aus herauslesen kann, sind in den Versionen vor 0.71 gravierende Bugs, die es angeraten erscheinen lassen, ...

Off Topic
Sachen die die Welt nicht braucht - Platz 1
Tipp von brammer vor 4 TagenOff Topic20 Kommentare

Hallo, ich habs als Tipp angelegt als Erfahrungsbericht nein Danke brammer

Humor (lol)
Spirit of Health-Kongress in Berlin
Information von AnkhMorpork vor 4 TagenHumor (lol)6 Kommentare

tgif! Beim dritten Spirit of Health-Kongress trafen sich am Wochenende Alternativmediziner und Naturheilkundler im Maritim Hotel Berlin, um sich ...

Heiß diskutierte Inhalte
Windows Server
Eingeschränkte Gruppen - Spezielle Benutzergruppe hinzufügen
Frage von killtecWindows Server14 Kommentare

Hallo, ich möchte gerne folgendes Realisieren: Ich habe bei mir Eingeschränkte Gruppen via GPO aktiv und möchte nun der ...

LAN, WAN, Wireless
Switch als Verbindung von 2 Netzwerken
gelöst Frage von Lutz-ReLAN, WAN, Wireless12 Kommentare

Guten Tag Ich hab folgendes Problem 2 Rechner und 2 IP Kameras sind ohne dhcp in einen IP4 Netzwerk ...

DNS
Größere DNS Probleme nach zweitem DC. Eigentlich sollte es auch dadurch besser werden
Frage von TeWutzDNS12 Kommentare

Hallo zusammen, nachdem ich letzte Woche erfolgreich einen zweiten DC ) an den Start gebracht habe melden sich weiterhin ...

Netzwerkgrundlagen
Reicht 10GBit Uplink Port für Stacking für ein 10GBit Switch?
gelöst Frage von walnickNetzwerkgrundlagen12 Kommentare

Hallo, Ich habe eine frage. Ich überlege gerade 2 neue Switche von CiscoSG350XG-24F  zu kaufen und die als Core ...