Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst PFSense auf Proxmox. VM hat Internet, VM-Host nicht?

Mitglied: pixel24

pixel24 (Level 2) - Jetzt verbinden

14.12.2019 um 17:53 Uhr, 465 Aufrufe, 7 Kommentare

Hallo zusammen,

auf einem Test-System habe ich mir Proxmox VE installiert und als VM PFSense. Für das Netwerk auf dem VM-Host habe ich zwei Bridges eingerichtet und an die jeweilige Schnittstelle gebunden.
Was diese tap100i0 und tap100i1 sind ist mir ein Rätsel.

vmbr0 zeigt ins LAN und vmbr1 hängt am GF-Anschluss.

Anschließend habe ich PFSense installiert, die Schnittstellen konfiguriert und die VDSL-Einwahl. Per Shell auf der PF-Sense funktioniert alles. ich erreiche alle lokalen Hosts sowohl unter ihrer IP wie auch unter ihrem Hostnamen. Ich kann auch vom PFSense aus der Shell externe Hosts unter Ihrem Namen erreichen.

Was nicht geht ist:

- Den PFSense aus den Proxmox-Host unter dem seinem Namen pingen (IP geht)
- Vom Proxmox-Host aus raus ins WAN pingen (egal ob Name oder IP)

Was mich verwundert ist die Ausgabe der routen auf dem Proxmox-Host:
Da fehlt das Dehault Gateway damit mein loakel Netz 192.168.24.0 raus kommt über die 192.168.24.253

Im Webinterface habe ich in der vmbr0 dieses Default-Gateway eingetragen.

Ich finde nicht heraus ob es am Proxmox oder PFSense liegt. Hat jemand einen Tipp für mich?

Viele Grüße
pixel24
Mitglied: aqui
LÖSUNG 14.12.2019, aktualisiert um 18:16 Uhr
Anschließend habe ich PFSense installiert, die Schnittstellen konfiguriert und die VDSL-Einwahl
Sprich du nutzt ein reines Modem dann an dem WAN Bridge Port und machst direkt PPPoE von der pfSense ?
Oder nutzt du dort eine Router Kaskade mit einem vor dem WAN Port kaskadierten NAT Internet Router ?? Das ist leider recht unklar wegen der oberflächlichen Beschreibung.

Kannst du vom Firewall Menü Diagnostics --> Ping denn eine nackte Internet IP wie 8.8.8.8 mit Source Interface "WAN" pingen ?
Wenn ja, kannst du auch einen Hostnamen z.B. www.heise.de aus dem Diagnostics Menü pingen ?
Erst wenn das geht zeigt es das du eine funktionierende Internet Verbindung hast !
Dann kannst du aus dem gleichen Menü die beiden o.a. Adressen nochmal pingen dann aber mit dem LAN Interface als Source !
Das pingt dann mit der LAN IP über das Firewall NAT ins Internet. Ein Traceroute wäre auch hilfreich sofern der Ping scheitert.
Erst wenn das fehlerfrei klappt hast du eine funktionierende Internet Verbindung. Soweit solltest du also kommen.
Eigentlich kommt man auf solche simplen Basics auch von selber zuerst und prüft diese Basis Connectivity BEVOR man hier einen Thread eröffnet !

Der Proxmox Host müsste also mit seinen Management Interface an der LAN Port Bridge der pfSense hängen und das natürlich im gleichen IP Netz des LAN Ports der pfSense.
Du nutzt hier ja NICHT das Default IP Netz der FW 192.168.1.0/24 wie man unschwer erkennen kann und wir können dann davon ausgehen das du den pfSense LAN Port umkonfiguriert hast.
Das bedeutet aber das dann die dortige Default LAN Regel ebenfalls gelöscht wird die den Zugriff aus dem LAN Netz erlaubt.
Wenn du dann keine entsprechend neue LAN Port Scheunentor Regel ala:
PASS Prot.: IP, Source: LANnet, Destination: ANY, Port: ANY
auf der Firewall einrichtest wird sämtlicher ! Traffic, wie es bei einer Firewall bekanntermaßen generell üblich ist, per Default geblockt. Logisch, ohne Regel.
Ein entspr. Screenshot fehlt hier leider so das man nur raten kann.
Wenn also der Host selber im LAN Net ist, sich selber pingen kann, dann sollte er auch das pfSense LAN Interface pingen können. Obige Regel am FW LAN Port vorausgesetzt !
Die Ping Checks oben und das Regelwerk würden helfen für eine zielführende Hilfe.
Bitte warten ..
Mitglied: pixel24
14.12.2019, aktualisiert um 19:49 Uhr
Sprich du nutzt ein reines Modem dann an dem WAN Bridge Port und machst direkt PPPoE von der pfSense ?

Vom WAN-Bridge-Port geht es direkt zum MEdia-Konverter des Glasfaser-Anschluss. PPPoE-Einwahl macht PFSense und am PFSense loakl komme ich raus (unter Name & IP)


Kannst du vom Firewall Menü Diagnostics --> Ping denn eine nackte Internet IP wie 8.8.8.8 mit Source Interface "WAN" pingen ?
Wenn ja, kannst du auch einen Hostnamen z.B. www.heise.de aus dem Diagnostics Menü pingen ?
Erst wenn das geht zeigt es das du eine funktionierende Internet Verbindung hast !

Ja, hatte ich ja geschrieben. Vom PFSense aus geht Diagnostig DNS, Ping.

Dann kannst du aus dem gleichen Menü die beiden o.a. Adressen nochmal pingen dann aber mit dem LAN Interface als Source !

Mit LAN-Schnittstelle als Source geht es nicht mehr.

Ein Traceroute wäre auch hilfreich sofern der Ping scheitert.


[Mit Quell-Adresse = alle]
[Mit Qeúell-Adresse = LAN]
Bitte warten ..
Mitglied: pixel24
14.12.2019 um 20:10 Uhr
Zitat von aqui:
Der Proxmox Host müsste also mit seinen Management Interface an der LAN Port Bridge der pfSense hängen und das natürlich im gleichen IP Netz des LAN Ports der pfSense.

Ja, den habe ich wie zuvor meine Ubunt-KVM-Hosts an die Bridge für's LAN:

Zitat von aqui:
Du nutzt hier ja NICHT das Default IP Netz der FW 192.168.1.0/24 wie man unschwer erkennen kann und wir können dann davon ausgehen das du den pfSense LAN Port umkonfiguriert hast.
Das bedeutet aber das dann die dortige Default LAN Regel ebenfalls gelöscht wird die den Zugriff aus dem LAN Netz erlaubt.
Wenn du dann keine entsprechend neue LAN Port Scheunentor Regel ala:
PASS Prot.: IP, Source: LANnet, Destination: ANY, Port: ANY
auf der Firewall einrichtest wird sämtlicher ! Traffic, wie es bei einer Firewall bekanntermaßen generell üblich ist, per Default geblockt. Logisch, ohne Regel.
Ein entspr. Screenshot fehlt hier leider so das man nur raten kann.

Nein, die LAN IP ändere ich ja immer dass Sie zum vorhanden Netz passt, also in dem Fall 192.168.24.253. Eine Firewall-Regel habe ich erzeugt da ich das bisher bei IPFire bei gleicher vorgehensweise nicht gebraucht habe und es wie gesagt mein PFSense-Erstkontakt ist. Das wusste ich schlichtweg nicht.

Habe nun eine LAN-Regel "Erlauben, Quelle=LAN, Dest=Any" eingichtet was die o.g. Diagnostig Ping mit Source=LAN - Problematik jedoch nicht behebt.
Bitte warten ..
Mitglied: pixel24
14.12.2019 um 20:18 Uhr
Regel gab es aber schon. Siehe Bild
bildschirmfoto vom 2019-12-14 20-17-28 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
15.12.2019, aktualisiert um 11:25 Uhr
Dann stimmt die internet Zuordnung zwischen den virtuellen Bridge Interfaces und den physischen Interfaces der Firewall nicht.
Dadurch das es dort keine Bridging Verbindung gibt, kannst du dann logischerweise nicht pingen.
Sprich das Management IP Interface des VM Hosts und das LAN Interface der Firewall sind nicht an eine gemeinsame Bridge gebunden.
Vermutlich dann auch der WAN Port der Firewall auch nicht an den Internet Router !
Eins sollte dir auch klar sein.
Der Management Port des VM Hosts und der Internet Router dürfen sich logischerweise nicht in einem gemeinsamen IP Netz befinden !
Klar, denn sonst überbrückt man ja die Firewall und macht sie völlig sinnfrei.
Grob skizziert sähe die logische Zuordnung so aus (NIC 1 ist das Management Interface des VM Hosts):

routing2 - Klicke auf das Bild, um es zu vergrößern

(Druckfehler: Rechte vBridge muss natürlich "vBridge-2" heissen !)
Bitte warten ..
Mitglied: pixel24
15.12.2019 um 13:14 Uhr
Hallo zusammen,

also am Proxmox-Host lag keine Fehlkonfiguration vor. Ich habe die VM mit PFSense nochmal neu gemacht und wieder auf dem Terminal, nach dem ersten Reboot gleich die Zuordnung der Schnittstellen gemacht und die LAN IP wieder auf die 192.168.24.253 gesetzt. Anschließend den Assistenten im Web-UI, Einwahldaten rein.

Kleiner Hinweis: Durch diese Änderung werden keine Default-Regeln gelöscht wie oben gesagt. Danach hat vom PFSense aus (Diagnose) der Ping (unter Hostname & IP) funktioniert und auch wenn dieser mit Quelle = LAN abgesetzt wird. Dann ging auch ohne Zutun gleich auch alles andere. Somit hat sich das erledigt.

Warum er beim ersten mal nicht funktionierte kann ich nicht dagen.

Viele Grüße
pixel24
Bitte warten ..
Mitglied: aqui
15.12.2019 um 14:20 Uhr
Gut wenn nun alles klappt wie es soll !
Case closed !

Bitte dann auch
https://administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Proxmox VM zugrif auf Ports vom Host (Proxmox Routing)

Frage von merlin2k11Router & Routing8 Kommentare

Hallo, vielleicht kann mir jemand von euch weiterhelfen. Ich habe das Problem das die VMs von einem Proxmox Host ...

Vmware

VM Ware Host Hardware

Frage von novregenVmware4 Kommentare

Hallo, ich würde auf einem VM Ware Host 6.x gerne 3 Maschinen laufen lassen, die Bestandteil einer Monitoringsoftware sind ...

Virtualisierung

Konvertierung VM - von Proxmox nach ESX

gelöst Frage von honeybeeVirtualisierung3 Kommentare

Hallo, hat jemand schon mal eine Proxmox-VM in eine ESX-VM konvertiert? Wenn ja, wie geht das? Das Ziel ist, ...

Vmware

VM auf einn anderen Host verschieben

gelöst Frage von DasistdasEndeVmware12 Kommentare

Hallo zusammen. Ich wollte mal fragen, wie man es am einfachsten macht eine VM vom einen ESX zu einem ...

Neue Wissensbeiträge
Viren und Trojaner
Emotet: IT-Totalschaden beim Kammergericht Berlin
Information von StefanKittel vor 23 StundenViren und Trojaner7 Kommentare

Interne Daten wurden geklaut und "ein kompletter Neuaufbau der IT-Infrastruktur wird angeraten", heißt es im forensischen Bericht zum ...

Viren und Trojaner
Avast verkauft anscheinend browserdaten
Tipp von magicteddy vor 1 TagViren und Trojaner14 Kommentare

Moin, da es immer wieder Anfragen zu Virenscannern gibt denke ich das der Artikel von Heise Avast verkauft Bowserdaten ...

Router & Routing

Statische Route dauerhaft einrichten unter Ubuntu 18.04 LTS

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing2 Kommentare

"Kann ja nicht so schwer sein, unter Ubuntu 18.04 LTS ne statische Route einzurichten", denkt der Windows-Admin und gelegentliche ...

Microsoft

Effect on customer websites and Microsoft services and products in Chrome version 80 or later

Information von Dani vor 3 TagenMicrosoft

Guten Abend zusammen, The Stable release of the Google Chrome web browser (build 80, scheduled for release on February ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Installation USG
Frage von jo23487LAN, WAN, Wireless47 Kommentare

Hallo zusammen, nach den beiden anderen Fragen habe ich mir den Cloud Key und auch ein USG gekauft - ...

Microsoft
All-Cloud für KMU (Management, Backup, etc.)
Frage von NRGNRGMicrosoft20 Kommentare

Hallo zusammen, kurze Interessensfrage an Euch in die Runde, da ich hierzu gerade interessante Diskussionen mit Kollegen habe: Szenario: ...

Router & Routing
NAS im VPN zu langsam mit FritzBox 7490
Frage von holger3208Router & Routing19 Kommentare

Hallo, ich habe eine Telekom VDsl Leitung mit einer 50/10 Leitung. Einen Qnap NAS TS-231P2 (4GB RAM) Eine FritzBox ...

TK-Netze & Geräte
Empfehlung DSL Modem
Frage von CorraggiounoTK-Netze & Geräte18 Kommentare

Hi Leute, könntet ihr mir eine Empfehlung für ein DSL Modem aussprechen? Provider ist die Telekom dahinter steht gleich ...