Probleme mit meinem VM-Server und keine Idee

Mitglied: worker2000

worker2000 (Level 1) - Jetzt verbinden

26.10.2020, aktualisiert 17:33 Uhr, 1110 Aufrufe, 19 Kommentare

Moin zusammen,

ich brauche mal ein wenig Input weil mir langsam die Ideen ausgehen.

Am Ende vermute ich dass es ggf. an der Serverkonfig selber liegen könnte.

Ich habe einen Server bei Hetzner mit einer nachbestellten 1 G NIC und installiertem ESXi 7.0.
Generell kenne ich mich mit so etwas aus. Aber hier komme ich nicht weiter.
Ich habe zwei zusätzliche IP´s bestellt und die MAC - Adressen generieren lassen.
Dann habe ich innerhalb der VM einen Debian aufgesetzt und ihm zwei Netzwerkkarten zugeordnet mit den entsprechenden MAC-Adressen.

Der Server ist installiert und zieht sich per DHCP auch die richtigen IP-Adressen. Es stimmt alles. Trotzdem ist der Server nur über eine IP erreichbar.
Auf die zweite IP kann ich weder pingen noch anderweitig erreichen.

Wenn ich die erste Netzwerkkarte deaktiviere erreiche ich die zweite IP und dann funktioniert es wieder Tadellos.

Ich habe schon sämtliche Ideen probiert. Ich habe die zweite Netzwerkkarte in ESXi deaktiviert und die zweite IP als eth0:1 eingetragen. Es bringt alles nichts.

Brauch ich am Ende DUAL 1G NIC (Intel i350) und weiß einer schon gleich ob die Karte mit ESXi kompatibel ist?
Mitglied: Vision2015
26.10.2020 um 13:03 Uhr
moin....

Zitat von worker2000:

Moin zusammen,

ich brauche mal ein wenig Input weil mir langsam die Ideen ausgehen.
oha..

Am Ende vermute ich dass es ggf. an der Serverkonfig selber liegen könnte.
hmmm...

Ich habe einen Server bei Hetzner mit einer nachbestellten 1 G NIC und installiertem ESXi 7.0.

Generell kenne ich mich mit so etwas aus. Aber hier komme ich nicht weiter.
mit so etwas... aha
Ich habe zwei zusätzliche IP´s bestellt und die MAC - Adressen generieren lassen.
Dann habe ich innerhalb der VM einen Debian aufgesetzt und ihm zwei Netzwerkkarten zugeordnet mit den entsprechenden MAC-Adressen.
wozu, eine NIC würde reichen!

Der Server ist installiert und zieht sich per DHCP auch die richtigen IP-Adressen. Es stimmt alles. Trotzdem ist der Server nur über eine IP erreichbar.
klar...
Auf die zweite IP kann ich weder pingen noch anderweitig erreichen.
auch klar...

Wenn ich die erste Netzwerkkarte deaktiviere erreiche ich die zweite IP und dann funktioniert es wieder Tadellos.
klar...

Ich habe schon sämtliche Ideen probiert. Ich habe die zweite Netzwerkkarte in ESXi deaktiviert und die zweite IP als eth0:1 eingetragen. Es bringt alles nichts.
sicher das es eth0:1 ist?
das wäre eigentlich der richtige weg...

Brauch ich am Ende DUAL 1G NIC (Intel i350) und weiß einer schon gleich ob die Karte mit ESXi kompatibel ist?
ja.. aber wirklich brauchen tust du die karte nicht....

Frank
Bitte warten ..
Mitglied: SlainteMhath
26.10.2020 um 13:03 Uhr
Moin,

Dann habe ich innerhalb der VM einen Debian aufgesetzt und ihm zwei Netzwerkkarten zugeordnet mit den entsprechenden MAC-Adressen.
hm? Sind die NICs denn als Uplink für einen vSwitch konfiguriert? Und hat der vSwitch entsprechende Portgroups? Und sind die PortGroups dann mit den vNICs in der VM verbunden?

Oder machst du hier was komplett anderes und ich bin auf dem falschen Dampfer?!

lg,
Slainte
Bitte warten ..
Mitglied: worker2000
26.10.2020 um 13:27 Uhr
Moin Frank,

deine Antwort ist zumindest.... originell .

Aber so richtig eine Antwort lieferst du mir auch nicht. Oder aber ich hab sie nicht erkannt ^^.

Vielleicht kannst du mir eine Erleuchtung liefern.
Bitte warten ..
Mitglied: Vision2015
26.10.2020, aktualisiert um 13:44 Uhr
moin...
Zitat von worker2000:

Moin Frank,

deine Antwort ist zumindest.... originell .
jo... sacht meine Frau auch immer....

Aber so richtig eine Antwort lieferst du mir auch nicht. Oder aber ich hab sie nicht erkannt ^^.
doch...

Vielleicht kannst du mir eine Erleuchtung liefern.

Ich habe schon sämtliche Ideen probiert. Ich habe die zweite Netzwerkkarte in ESXi deaktiviert und die zweite IP als eth0:1 eingetragen. >> Es bringt alles nichts.
sicher das es eth0:1 ist?
war meine frage...
Dann habe ich innerhalb der VM einen Debian aufgesetzt und ihm zwei Netzwerkkarten zugeordnet mit den entsprechenden MAC-Adressen.
du schreibst, das du eine Linux VM hast, und in dieser Linix VM(Debian) eine weitere VM erstellt hast... also nested vm? oder was....

schreib doch mal deine richtige config, mit wir helfen können!

Frank
wir reden doch von dem Gast, oder?

Frank
Bitte warten ..
Mitglied: worker2000
26.10.2020 um 16:48 Uhr
Okay.. ich versuch es mal

Ich habe den ESXi und darin ein Linux Debian 10 mit zwei Netzwerkkarten und zwei IP´s von Hetzner.

Zur Vereinfachung
Debian eth0 : 10.0.0.1
Debian eth1 : 10.0.0.2

Ich habe beide in der Config von Debian auf DHCP gelassen. Er zieht sich die IP und alles sauber und wie schon geschrieben ist er auch über die eth0 erreichbar.
Die eth1 zieht er sich per DHCP auch sauber. Die IP stimmt, das Gateway stimmt selbst die Netmask und Broadcast stimmt mit den Vorgaben von Hetzner überein.
Trotzdem kann ich eth0 pingen und eth1 nicht. Wenn ich die Netzwerkkarte eth0 deaktiviere kann ich den Server über eth1 erreichen.

Als ob er immer nur eine physische Netzwerkkarte benutzen will.
Deshalb hab ich dann, wie schon geschrieben einmal testweise aus eth1 ein eth0:1 gemacht. Aber auch das hat nichts gebracht .

Aber auf deine Frage nein, es ist keine VM innerhalb der VM.
Bitte warten ..
Mitglied: Vision2015
26.10.2020, aktualisiert um 19:06 Uhr
moin...

Zitat von worker2000:

Okay.. ich versuch es mal

Ich habe den ESXi und darin ein Linux Debian 10 mit zwei Netzwerkkarten und zwei IP´s von Hetzner.
das mit den 2 Netzwerk Karten ist zu 99 % blödsinn... was willst du genau machen, wiso braucht dein debian host 2 ip adressen?
und wiso macht Hetzner so einen blödsinn mit?!?!?!?!?

Zur Vereinfachung
Debian eth0 : 10.0.0.1
Debian eth1 : 10.0.0.2
poste doch mal deine config.

Ich habe beide in der Config von Debian auf DHCP gelassen. Er zieht sich die IP und alles sauber und wie schon geschrieben ist er auch über die eth0 erreichbar.
Die eth1 zieht er sich per DHCP auch sauber. Die IP stimmt, das Gateway stimmt selbst die Netmask und Broadcast stimmt mit den Vorgaben von Hetzner überein.
Trotzdem kann ich eth0 pingen und eth1 nicht. Wenn ich die Netzwerkkarte eth0 deaktiviere kann ich den Server über eth1 erreichen.

Als ob er immer nur eine physische Netzwerkkarte benutzen will.
Deshalb hab ich dann, wie schon geschrieben einmal testweise aus eth1 ein eth0:1 gemacht. Aber auch das hat nichts gebracht .

Aber auf deine Frage nein, es ist keine VM innerhalb der VM.
Frank
Bitte warten ..
Mitglied: tech-flare
26.10.2020 um 19:10 Uhr
Zitat von worker2000:

Moin zusammen,
Moin
ich brauche mal ein wenig Input weil mir langsam die Ideen ausgehen.
*bitte
Am Ende vermute ich dass es ggf. an der Serverkonfig selber liegen könnte.
Sicherlich
Ich habe einen Server bei Hetzner mit einer nachbestellten 1 G NIC und installiertem ESXi 7.0.
Schön, ich ebenfalls
Generell kenne ich mich mit so etwas aus. Aber hier komme ich nicht weiter.
Oha
Ich habe zwei zusätzliche IP´s bestellt und die MAC - Adressen generieren lassen.
Soweit erstmal korrekt
Dann habe ich innerhalb der VM einen Debian aufgesetzt und ihm zwei Netzwerkkarten zugeordnet mit den entsprechenden MAC-Adressen.
Warum 2? Willst du damit Routen?


Der Server ist installiert und zieht sich per DHCP auch die richtigen IP-Adressen. Es stimmt alles.
Na dann ist doch gut
Trotzdem ist der Server nur über eine IP erreichbar.
Wozu brauchst du die Zweite?
Auf die zweite IP kann ich weder pingen noch anderweitig erreichen.
Stichwort:
Mehrere gefault gateways
Wenn ich die erste Netzwerkkarte deaktiviere erreiche ich die zweite IP und dann funktioniert es wieder Tadellos.
Siehe eine Zeile weiter oben

Ich habe schon sämtliche Ideen probiert. Ich habe die zweite Netzwerkkarte in ESXi deaktiviert und die zweite IP als eth0:1 eingetragen. Es bringt alles nichts.

Brauch ich am Ende DUAL 1G NIC (Intel i350) und weiß einer schon gleich ob die Karte mit ESXi kompatibel ist?
Intel Karten sind kompatibel. Aber brauchst du nicht

Ich hab eine Intel Nic im Hetzner ins habe 10 IP Adressen. Geht auch
Bitte warten ..
Mitglied: SlainteMhath
27.10.2020 um 09:44 Uhr
Ich habe den ESXi und darin ein Linux Debian 10 mit zwei Netzwerkkarten und zwei IP´s von Hetzner.
Sind jetzt im Host 2 NICs oder im Gast? Oder in beiden?

Als ob er immer nur eine physische Netzwerkkarte benutzen will.
Dei VM "benutzt" i.d.R. ger kein phys. NICs, sondern nur virtuelle!

Ich frag deshalb nochmal: Wie sind deinen pNICs, vSwitches und Portgroups konfiguriert?!
Bitte warten ..
Mitglied: worker2000
27.10.2020 um 10:53 Uhr
So, ich versuch mal alle Fragen der reihe Nach zu beantworten.

1. Frank:

Meine Config sieht so aus:

source /etc/network/interfaces.d/*

  1. The loopback network interface
auto lo
iface lo inet loopback

  1. The primary network interface
auto eth0
iface eth0 inet dhcp


auto eth1
iface eth1 inet dhcp

2. tech-flare

Warum zwei IP auf einem Server:

Weil er auch als Nameserver fungieren soll. Und spätestens da sind bei meinem Domainhoster zwei Nameserver fordert die auch unterschiedliche IPs haben. Deshalb das ganze Thema.

Das es am Ende "nur" ein Workarround ist macht es nicht schön. Aber ich würde es halt gerne so gelöst haben und bei meinem jetzigen Hoster hat es ja geklappt.

3. SlainteMhath

Es sind im Hostsystem 1 NIC verbaut und in der VM zwei VNIC.

In den ganzen Einstellungen von ESXi hab ich nicht soviel geändert weil ich bis jetzt die Erfahrung gemacht habe dass die Einstellungen automatisch immer gepasst haben.

Hier einmal meine Config in ESXI im Bezug auf Netzwerk

https://administrator.de/images/c/1/6/09d31311b9b43921595fd9421e8a4468.j ...

https://administrator.de/images/c/1/6/1ef215b7bca5005899c780d89f5577a1.j ...

https://administrator.de/images/c/1/6/87b79b881328b72022c0684c120528ff.j ...

https://administrator.de/images/c/1/6/7edabf96fe92ddf2c5dcaa587110e670.j ...
esxi bild 1 - Klicke auf das Bild, um es zu vergrößern
esxi bild 2 - Klicke auf das Bild, um es zu vergrößern
esxi bild 3 - Klicke auf das Bild, um es zu vergrößern
esxi bild 4 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: worker2000
27.10.2020 um 10:55 Uhr
Noch ein kleiner Nachtrag, auch wenn pfsense hier mit zu sehen ist. Der Server hat keine Verbindung zu pfsense. Er nutzt nur das öffentliche Netzwerk. Für pfsense gibt es einen zweiten virtuellen Switch.
Bitte warten ..
Mitglied: tech-flare
27.10.2020 um 11:29 Uhr
2. tech-flare

Warum zwei IP auf einem Server:

Weil er auch als Nameserver fungieren soll. Und spätestens da sind bei meinem Domainhoster zwei Nameserver fordert die auch unterschiedliche IPs haben. Deshalb das ganze Thema.

Du weißt aber schon das man das eigentlich nicht so macht.

1 NS unter 2 IP Adressen und dann noch auf einem Host.
Aber egal ;)

Sind die 2 zusätzlichen IP Adressen aus dem gleichen Subnetz? Wenn ja wirde es nicht gehen, da Linux sonst 2 x das gleiche Gateway im gleichen Subnetz hat.

Grundsätzlich regelt man das bei solchen Konstellationen über vmware / ESXI, welches im Netz stehen eh anders. dies habe ich hier bereits schon mal beschrieben.

Beispiel Hetzner:

IP 1 -> ESXI Host
IP 2 -> Firewall (*sense)
weitere IP oder Subnetz -> Routing durch Hetzner auf IP2

Nichtdestotrotz wird es funktionieren, wenn die 2 IP Adressen aus unterschiedlichen Subnetz sind. Du kannst bei Hetzner eine IP über das Ticket aus einem anderen Subnetz betellen.
Bitte warten ..
Mitglied: Vision2015
27.10.2020 um 12:07 Uhr
moin...

Weil er auch als Nameserver fungieren soll. Und spätestens da sind bei meinem Domainhoster zwei Nameserver fordert die auch unterschiedliche IPs haben. Deshalb das ganze Thema.

dann würde ich an deiner stelle ein VM für den DNS Server erstellen....
alles auf einem Server ist nicht gut!

Frank
Bitte warten ..
Mitglied: worker2000
27.10.2020 um 22:49 Uhr
So nu bin ich dann wirklich ratlos .

Ich habe heute Abend einfach mal die IP´s auf einen Windows19 Server gesetzt über ESXi und der Server war über beide IP´s erreichbar.
Das gleiche Spiel wieder zurück auf Debian und die Kiste war nur noch über eine IP erreichbar.

Also muss es irgendwo in Debian eine Einstellung sein.
Bitte warten ..
Mitglied: tech-flare
28.10.2020 um 06:32 Uhr
Zitat von worker2000:

So nu bin ich dann wirklich ratlos .

Ich habe heute Abend einfach mal die IP´s auf einen Windows19 Server gesetzt über ESXi und der Server war über beide IP´s erreichbar.
Das gleiche Spiel wieder zurück auf Debian und die Kiste war nur noch über eine IP erreichbar.

Also muss es irgendwo in Debian eine Einstellung sein.

Du hast ja immernoch nicht geschrieben, ob die Beiden IP im gleichen Subnetz sind. Wenn ja liegt es daran. Wie bereits mehrfach geschrieben
Bitte warten ..
Mitglied: worker2000
28.10.2020, aktualisiert um 07:37 Uhr
Sorry tech-flare,

du hast recht. Ich bin euch für jeden Tipp und jeden Input dankbar.

Aber ich habe beide varianten Probiert (ich habe mehr als eine zusätzliche IP).

Ich habe es erst mit zwei IP´s aus unterschiedlichen Subnetzen probiert. Ohne Erfolg.
Danach habe ich es mit zwei IP´s im gleichen Subnetz versucht gleiches Fehlerbild (was ja eigentlich logisch sein sollte).

Wie geschrieben. Gestern Abend habe ich das ganze dann mit Windows Server 2019 versucht und kann beide IP´s (im gleichen Subnetz) gleichzeitig anpingen.

Da ich noch nie solch einen Kummer beim aufsetzen eines Servers hatte werde ich nachher mal eine andere Distro ausprobieren.
Bitte warten ..
Mitglied: tech-flare
28.10.2020, aktualisiert 01.11.2020
ich habe Beide Varianten getestet(ich habe mehr als eine zusätzliche IP).

Ich habe es erst mit zwei IP´s aus unterschiedlichen Subnetzen probiert. Ohne Erfolg.
Danach habe ich es mit zwei IP´s im gleichen Subnetz versucht gleiches Fehlerbild (was ja eigentlich logisch sein sollte).
Naja standardmäßig kannst du nur ein Default Gateway in einem System nutzen...du musst da noch etwas entsprechend konfigurieren. Windows "verzeiht" dir den Fehler.

Ich habe durch eine IP Umstellung hier im LAN auch bei einem Debian Server auch 2 IP Adressen und anfangs war er nur über 1 erreichbar.

Befolge die Anleitung von ThomasKrenn und dann wird es laufen
Zwei Default Gateways bei Linux


Da ich noch nie solch einen Kummer beim aufsetzen eines Servers hatte werde ich nachher mal eine andere Distro ausprobieren.
Das wir vermutlich was egal sein
Bitte warten ..
Mitglied: primary
01.11.2020 um 21:35 Uhr
Zitat von tech-flare:

er ich habe beide varianten Probiert (ich habe mehr als eine zusätzliche IP).

Ich habe es erst mit zwei IP´s aus unterschiedlichen Subnetzen probiert. Ohne Erfolg.
Danach habe ich es mit zwei IP´s im gleichen Subnetz versucht gleiches Fehlerbild (was ja eigentlich logisch sein sollte).
Naja
Standardmäßig kannst du nuur ein Default Gateway in einem System haben...du musst da noch etwas entsprechend konfigurieren. Windows "verzeiht" dir den Fehler.

Ich habe durch eine IP Umstellung hier im LAN auch bei einem Debian auch 2 IP Adressen und anfangs war er nur über 1 erreichbar.

Befolge die Anleitung von ThomasKrenn und dann wird es laufen
Zwei Default Gateways bei Linux


Da ich noch nie solch einen Kummer beim aufsetzen eines Servers hatte werde ich nachher mal eine andere Distro ausprobieren.
Das wir vermutlich was egal sein


Was ist mit deinem Sprachschatz passiert tech-flare?
Bitte warten ..
Mitglied: tech-flare
01.11.2020 um 21:43 Uhr
Naja ich habe es nur schnell übers Handy getippt. Asche auf mein Haupt
Bitte warten ..
Mitglied: primary
01.11.2020 um 21:46 Uhr
Akzeptiert.

;)
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Externes Ziel nicht erreichbar vom internen Netzwerk
Stibe88FrageLAN, WAN, Wireless16 Kommentare

Hallo Community Ich habe bei mir Homematic IP installiert. Nun kann ich seit 4 Tagen mich nicht mehr in ...

Hardware
Genauigkeit DCF77
Der-PhilFrageHardware12 Kommentare

Hallo! Es geht hier eher um eine akademische Frage, denn um eine Notwendigkeit für die IT, aber vielleicht interessiert ...

Windows Server
Fehler beim Starten Gruppenrichlinien
gelöst OSelbeckFrageWindows Server11 Kommentare

Hi, seid kurzen habe ich (Ich glaube nach einem Update bzw. Erweiterung der GPO Dateien) folgende Meldung Was köönet ...

Datenbanken
SQL Datum Uhrzeit 2 Spalten
Florian86FrageDatenbanken11 Kommentare

Hallo Zusammen, ich möchte aus einer SAP Datenbank über Datum und Zeit Daten abfragen. Datum und Zeit sind aber ...

Hardware
Neue Hard- und Software für kleine Kanzlei mit RA-Micro
SchrumpfiFrageHardware10 Kommentare

Hallo zusammen, ich lese schon länger im Forum mit und konnte so einige Probleme durch eure Hilfe lösen, dafür ...

Batch & Shell
Zeichen suchen und in die nächste Zeile was kopieren
Klaus20FrageBatch & Shell10 Kommentare

Hallo Forum, hätte mal wieder eine Frage an die Batch Profis. Habe mir mehrere Playlisten erstellt und die immer ...

Ähnliche Inhalte
Windows Server
Problem mit Auslagerungsdatei auf VM
lcer00FrageWindows Server6 Kommentare

Hallo zusammen, wir hatten heute "aus dem Nichts heraus" einen Performanceeinbruch unserer Answendungsdatenbank auf dem Server (propietäre Software). Die ...

Windows Server
Printserver VM ?
gelöst Adnan88FrageWindows Server6 Kommentare

Hallo, wir besitzen hier im Unternehmen 8 Netzwerkdrucker, auf unserem "WSUS" ist aktuell die Rolle "Druck - und Dokumentendienst" ...

Vmware

Problem nach VM-Verschiebung von ESX 4.1 auf 6.0

gelöst Leo-leFrageVmware3 Kommentare

Hallo Forum, ich habe mal wieder ein Problem mit VMware. Insgesamt habe ich schon etliche Vms verschoben , convertiert ...

Windows 7

VM Lizenzierung

gelöst SystemDownFrageWindows 71 Kommentar

Hallo Leute, Wir wollen auf einigen Laptops, mehrere virtuelle Windows Systeme installieren. Hostbetriebssystem ist Windows 7 Ultimate (ist bereits ...

KVM

Zugriff auf VM

gelöst CaptainDuskyFrageKVM2 Kommentare

Guten Morgen, ich möchte mir hier mittels KVM auf Ubuntu-Server-Basis so ein paar Server fertig machen. Ich verzweifel aber ...

Backup

ALTARO VM Backup

gelöst GreysonFrageBackup1 Kommentar

Hallo Forum, ich habe als Backuplösung Altaro VM Backup auf einem 2012R2 im Einsatz. Nun interessierte es mich ob ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud