franc
Goto Top

Remote Desktop mit Konsole geht nicht mehr

Ich habe auf einem entfernten Windows Server 2003 (SP2, erst nachträglich installiert, damit könnte es zu tun haben) mal UltraVNC installiert, das ging aber nicht gescheit (namentlich gabs beim Dateitransfer Probleme).

Dann kam ich mit einer Konsole-Verbindung mit Remote Desktop nicht mehr drauf und erhielt den fiesen Fehler:

Fehler beim Herstellen einer Verbindung mit der vorhandenen Sitzung für franc (Id 0).Der Vorgang wurde erfolgreich beendet.

Ohne Konsole gings noch. Nach folgendem Link:

http://groups.google.de/group/microsoft.public.windows.server.sbs/brows ...

schloss ich also, dass UltraVNC schuldig sei und deinstallierte es wieder. Aber der Fehler blieb.
Ich hab dann dort jemanden den Server neustarten lassen und sich direkt anmelden (also nicht über RD). Nun kam ich wieder drauf. Jetzt habe ich den Server nach dem gestrigen Update neugestartet (aber vorher auch schon mal) und habe wieder den gleichen Fehler.
Zudem komme ich nicht mehr ohne den Konsole-Schalter drauf, ich erhalte dann:

Die Verbindung mit der Remotesitzung wurde getrennt, da keine Terminalserver-Clientzugriffslizenzen für diesen Computer vorhanden sind.
Wenden Sie sich an den Serveradministrator.

Das könnte am SP2 liegen, weil es davor noch sehr wohl ging. Und eigentlich sind meines Wissens 2 gleichzeitige RD-Verbindungen (ohne Konsole!) mit dem Windows Server 2003 möglich.

Weiss jemand wie ich nun vorgehen kann? Ich kann den Rechner noch remote neustarten, da ich noch eine funktionierende SSH-Verbindung habe. Aber das behebt den Fehler nicht. Vermutlich nur wieder das lokale Anmelden, aber das ist ja kein Zustand.

Ich wäre für einen Rat sehr dankbar.

Gruss,
franc

Content-Key: 59660

Url: https://administrator.de/contentid/59660

Printed on: May 19, 2024 at 04:05 o'clock

Member: chris67
chris67 May 23, 2007 at 19:46:29 (UTC)
Goto Top
"...sind meines Wissens 2 gleichzeitige RD-Verbindungen (ohne Konsole!) mit dem Windows Server 2003 möglich."

Richtig. Möglicherweise wurden die 2 anderen Sessions aber nicht richtig (durch abmelden) beendet, dann belegen sie weiterhin jeweils eine Lizenz und können nur durch den/die angemeldeten User aufgerufen werden.
Member: franc
franc May 23, 2007 at 19:50:35 (UTC)
Goto Top
Wie kann ich denn sogenannte 'schnarchende Verbindungen' am besten per SSH-Terminal beenden?
Oder aufzählen, also sichtbar machen? Weil ich in der Terminaldiensteverwaltung keine scharchende Verbindung gesehen habe.

Ausserdem kann man in den Benutzereinstellungen einstellen, ob eine schnarchende Verbindung automatisch nach x Minuten beendet wird.
Member: chris67
chris67 May 23, 2007 at 19:52:20 (UTC)
Goto Top
Wenn es welche gäbe, würden sie in der Terminaldiensteverwaltung angezeigt.

Hast du mal nachgeschaut, ob die Lizenzen noch alle registriert sind?
Member: franc
franc May 23, 2007 at 19:53:27 (UTC)
Goto Top
Wo sehe ich das? Und wo registriere ich die? Ich dachte die sind implizit?
Member: Dynadrate
Dynadrate May 23, 2007 at 21:15:56 (UTC)
Goto Top
Ich habe grade keine Möglichkeit das zu testen, aber: In der Verwaltung gibts irgendwas wie Terminalserverkonfiguration. Diese ist nicht besonders umfangreich, gehe die Menüs mal durch. Irgendwo steht dann, ob man den Server als Terminalserver oder nur für Konfigurationszwecke einsetzt. Hier wählst du Konfigurationszwecke und ab dann solltest du auch keine Lizenzen mehr benötigen.

Da kannst du auch einstellen, das "nicht-verbundene Sessions", d.h. Sessions, bei denen alle Anwendungen weiterlaufen, (z.B. bei einem Absturz des Client oder wenn man den Terminalserverclient hart beendet) nach einer bestimmten Zeit beendet werden.
Member: sysad
sysad May 23, 2007 at 21:35:01 (UTC)
Goto Top
Wo sehe ich das? Und wo registriere ich die?
Ich dachte die sind implizit?

Machs Dir einfach, ganz ohne rumgedödle in den TS-Diensten: Log Dich als Admin ein, starte den Taskmanager und trenn die RD-Verbindungen, durch Abmelden, falls vorhanden.
Member: franc
franc May 23, 2007 at 22:42:59 (UTC)
Goto Top
Hm. Danke, aber es gibt keine anderen Verbindungen und der Server ist auch 500 km entfernt.
Mit SSH komm ich noch in eine DOS-Konsole...
Member: franc
franc May 24, 2007 at 00:02:14 (UTC)
Goto Top
Ich habe grade keine Möglichkeit das zu
testen, aber: In der Verwaltung gibts
irgendwas wie Terminalserverkonfiguration.
Diese ist nicht besonders umfangreich, gehe
die Menüs mal durch. Irgendwo steht
dann, ob man den Server als Terminalserver
oder nur für Konfigurationszwecke
einsetzt. Hier wählst du
Konfigurationszwecke und ab dann solltest du
auch keine Lizenzen mehr benötigen.

Da kannst du auch einstellen, das
"nicht-verbundene Sessions", d.h.
Sessions, bei denen alle Anwendungen
weiterlaufen, (z.B. bei einem Absturz des
Client oder wenn man den Terminalserverclient
hart beendet) nach einer bestimmten Zeit
beendet werden.

Ich sehe was du meinst, habe mir das mal mit Virtual PC angesehen:
unter Verwaltung / Terminaldienstekonfiguration (tscc.msc) / Servereinstellungen / Lizenzierung
gibt es das Attribut: Remotedesktop für Verwaltung (wohl im Gegensatz zu TS)
und unter / Verbindungen / RDP-Tcp / Eigenschaften kann man die maximalen Verbindungen einstellen
diese Einstellungen finden sich dann in der Registry unter:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\
wieder.
Member: franc
franc May 24, 2007 at 23:44:08 (UTC)
Goto Top
Also jetzt gehts wieder. Ohne SSH-Tricks. Wie?
Zunächst hab ich mal von einem anderen Rechner eine nicht-konsole Sitzung probiert und das ging plötzlich.
Auf dem Server hab ich unter den Terminalserverkonfigurationen festgestellt, dass die Lizenzen auf die Geräte und nicht auf die Benutzer liefen.
Dieses also umgestellt und nun konnte ich mich mit meinem Rechner wieder nicht-konsole anmelden. Gut.
Dann hab ich eine automatische Anmeldung des Administrators entfernt (die hat der dortige Admin wohl für ein Backup-Programm erstellt, das nicht als Dienst läuft) und neugestartet. Damit war dann auch diese Fehlermeldung
'Fehler beim Herstellen einer Verbindung mit der vorhandenen Sitzung für ... (Id 0)'
nicht mehr da. Schliesslich hab ich mit der W2k3 Version von TweakUI PowerToy den AutoLogon wieder eingeschaltet und nach dem nächsten Hochfahren gings noch. Uff.
Gruss franc
Member: sysad
sysad May 25, 2007 at 10:42:48 (UTC)
Goto Top
Terminalserverkonfigurationen festgestellt,
dass die Lizenzen auf die Geräte und
nicht auf die Benutzer liefen.
Dieses also umgestellt und nun konnte ich
mich mit meinem Rechner wieder nicht-konsole
anmelden. Gut.

Normalerweise kannst Du TS-Lizenzen nicht von per-User auf per-Device umstellen??

Dann hab ich eine automatische Anmeldung des
Administrators entfernt (die hat der dortige
Admin wohl für ein Backup-Programm
erstellt, das nicht als Dienst läuft)
und neugestartet. Damit war dann auch diese
Fehlermeldung
'Fehler beim Herstellen einer
Verbindung mit der vorhandenen Sitzung
für ... (Id 0)'

Bei der Gelegenheit würde ich noch den Mehrfachlogin unter der selben Kennung ermöglichen, somit kommst Du als Admin rein ohne eine evtl. laufende Session zu übernehmen.

nicht mehr da. Schliesslich hab ich mit der
W2k3 Version von TweakUI PowerToy den
AutoLogon wieder eingeschaltet und nach dem
nächsten Hochfahren gings noch. Uff.
Gruss franc

Glückwunsch. Ist ja der Horror, wenn ein weit weg stehender Server was hat. Mein weitester ist 8km, aber das nervt schon manchmal.
Member: franc
franc May 25, 2007 at 11:58:08 (UTC)
Goto Top
Ja, komischerweise kann ich dort (zu finden in der Verwaltung) unter:

Terminaldienstekonfiguration / Servereinstellungen / Lizenzierung

auswählen zwischen "Pro Benutzer" und "Pro Gerät". Und das wird auch übernommen.
In einem VirtualPC-Windows Server 2k3 (aber SP1) hab ich allerdings nur eine Option: "Remotedesktop für Verwaltung"

Ich kann auch unter

Terminaldienstekonfiguration / Verbindungen / RDP-Tcp -> Eigenschaften / Netzwerkadapter / Unbegrenzte Verindungen

aktivieren. Oder auch eine beliebige Anzahl, wenn ich "Maximale Verbindungen" aktiviere.
Vielleicht hat das der dortige Administrator so installiert. Weiss nicht, Hauptsache es geht face-smile