samvanratt
Goto Top

Seagate NAS Pro Alternative

Hallo zusammen
ich hänge gerade an einer 6 Bay Version der oberen NAS. Problempunkt ist die fehlende Onboardfunktion einer verschlüsselten Archivierung. Via ssh ist zwar gpg vorhanden, aber für das AutoBackup besteht lt Seagate Support keine Möglichkeit das bisher einzustellen und kommt evtl. aber evtl auch nicht.
Nun habe ich mich daran gemacht das sehr spärliche NAS OS4.2 durch ein freieres zu setzen (im NAS OS ist weder cron als root zugreifbar, noch irgendein Binary (SE Linux) einbindbar) und beklage die fehlende USB Bootfunktion (lt Seagate Support gut so,was ich auch verstehen kann). Wenn man den internen Recovery Modus entfernt (USB) bootet er auch im Recovery (ausschalten+Reset drücken) von Stick. Bisher gelang mir das einmal (PartedMagic) und seither ist mir kein weiterer USB Boot möglich gewesen; fehlende USB-Stick mit LED machen das Blind-sehen recht schwierig. Gut, dann halt eine Zusatz HD da SGT auch von HD komplett bootet. Leider scheint mein DELL Aufsetzsystem um andere zu testen (NAS4free 10.2, Rockstor3 und FreeNAS 9.3) jeweils beim Booten dann im SGT NAS hängen zu bleiben, da keiner eine DHCP Discover Anfrage sendet. Der Intel i211 Adapter im NAS ist eigentlich in allen dreien Unterstützt. Ich höre bei der BootHD jeweils Zugriff für rund 10-30 Sekunden, dann ist Stille (und keine IP Anfrage). Beim Rockstor ist explizit ein UID Mounter am werke (fstab) wodurch ein neuer AHCI Adapter sonst einer Art kein Thema darstellen sollte; Netz mag problematisch sein, seit die generischen ethx ungern eingesetzt werden. Bei BSD ist das durch die Adapterbezeichnung (wie bei den neueren Linuxen) mit im mounter.... ohne Sicht unmöglich zu lösen.
Das verbaute SuperBee v3.0 Mainboard wird auch bei einer anderen W2k12R2 NAS von Seagate benutzt, leider besteht dazu kein Zugriff um eine blinde BIOS 1:1 Umsetzung anzugehen.

Fällt euch noch was ein?
Ziel muß sein ein verschlüsseltes Datensystem zu haben was regelmäßig auf angeschlossene USB3 HDs Archive anlegt. git/svn wären noch schön zu haben. Rest (DHCP, DNS, LDAP, RADIUS .....) ist schon vorhanden. Speicher ist reiner CIFS. RAM wollte ich auf 8GB hochrüsten um dedup evtl zu nutzen (BTRFS/ZFS).

Gruß
Sam

Content-Key: 298652

Url: https://administrator.de/contentid/298652

Printed on: June 15, 2024 at 00:06 o'clock

Member: broecker
broecker Mar 09, 2016 at 20:42:52 (UTC)
Goto Top
Moin, sieht das nervig aus, vernünftige Hardware und dann datengefährdende ClosedSource-Software "Linux eingebettet"

- Mainboard hab ich eben nicht gefunden - gibt's dazu noch eine bessere Beschreibung? - Ansatz könnte wie bei HP-Microservern sein, einen VGA-Anschluß und/oder eine Serielle Schnittstelle on Board nur mit Kabel auszustatten oder einen PCI/PCIe-Slot vorübergehend mit VGA-Karte auszustatten, Linux zu installieren und dann wieder zurückzubauen.

Ich würde sonst keine >10TB dieser Lösung anvertrauen.

Generell könnte man mit Duplicity verschlüsselte Backups rausschreiben - setzt aber Installation auf dem Linux voraus.

HG
Mark
Member: SamvanRatt
SamvanRatt Mar 09, 2016 at 21:45:55 (UTC)
Goto Top
Hallo Mark
wäre schön wenn das Board VGA (wie einige QNAPs) hätte oder Seriell oder irgend was abgesehen von dem LCD Terminal mit Registerablauf. VGA ist nicht nur nicht ausgeführt sondern der Chip wurde gespart. PCI/PCIe ist nicht. Ich komme also um eine Fremdbetankung nicht drum rum, ABER ich sehe eben nicht wo er stehen bleibt um wieder nachzubessern. USB Boot nimmt er ja (scheinbar) nicht zuverlässig an. OMV (eine der Optionen) hat Duplucity mit als Option und fällt in engere Wahl. Solange ich aber nicht sehe an welcher Stelle er stehen bleibt ist das pures rumgerate, was ihm nicht passt. Das Mainboard scheint von SGT als OEM angefertigt worden zu sein, da ich auch keine Info fand. Im NAS OS habe ich leider keine BIOS Infos auslesen können noch irgendeine FCC zu irgendeiner Doku finden können. Ein paar Kontaktreihen sind ja auf dem Board drauf...
Gruß
Sam
Member: broecker
broecker Mar 09, 2016 updated at 21:59:30 (UTC)
Goto Top
drei Lötstellen nebeneinander sind bestimmt die interne RS-232: TX,RX,GND ;face-wink
finster ist's - PXE vielleicht - wider erwarten - möglich?
HG
Mark
Member: SamvanRatt
SamvanRatt Mar 10, 2016 at 05:20:18 (UTC)
Goto Top
Hi MArk
4 Pol. und 9 Pol stehen zur Auswahl. Der 4pol dürfte eher JTAG sein. Da keinerlei Init auf dem Netzport passiert dürfte auch Seriell tot sein oder eher gar nicht ausgeführt, da Legacy Schnittstellen ja seit einem Jahr wirklich weg kommen (PS2, LPT, COM, PCI). Ohne Doku halt reines Rätselraten.
Ich suche eher eine Distri die da evtl native läuft wenn installiert. USB kommt ja leider nicht in Frage face-sad
Gruß
Sam
Member: broecker
broecker Mar 10, 2016 at 07:08:17 (UTC)
Goto Top
9 pol paßt ja gut, da kann man doch auf Verdacht 'mal ein Multimeter drannhalten - irgendwie muß der Hersteller ja auch das "NAS-oS" weiterentwickeln - daher halte ich es schon für realistisch, daß die Schnittstelle auch aktiv ist.
Eine Distri zur Nutzung von RS-232 beim Booten zu bringen, ist gut dokumentiert.
HG
Mark
Member: SamvanRatt
SamvanRatt Mar 11, 2016 at 18:31:35 (UTC)
Goto Top
Hallo Mark
die Problemursache habe ich heute gefunden: Das BIOS hat ein (Software) RAID der ersten beiden HDs aktiv, egal was da für HDs drinnen hängen. Eine einzelne HD hat er damit nie gebootet, selbst ein Minisystem wie DOS um auf NTFS zuzugreifen (habe ich vor knapp 20 Jahren man geschrieben und warte es bis heute). Setze ich die zweite HD mit den selben Formatdaten rein bootet er. Scheinbar (ich habe ja 4 HDs drinnen) setzte die Erstinstallation diese Werte im BIOS. Naja. Mit dem Ergebnis konnte ich dann ein PartedMagic sicher zum starten bringen (FAT32+Syslinux), damit dann ssh und dann endlich Zugriff via Netz auf die Hardware. PM weil es eine RAMDisk per Default nimmt und damit von der unteren Hardware dann voll abstrahiert ist.
Dann ein NAS4free (10.2) auf die beiden draufgespielt; das ext2 System gemountet, die Netzwerkkarte (en0p1) dann eingebunden und gut wäre es gewesen.
WENN da nicht ein UEFI auf mich warten würde und die 4 Daten HDs (da ist auch das NAS OS drauf) erkennt und sofort davon bootet. Nach dem dd'en der Bootbereiche war der Spuk vorbei und die Box bootet tatsächlich. Das Software RAID macht mir noch sorgen, da es im schlimmsten Fall dann davon booten will (HD0 defekt). Nehme ich eine der beiden (Slot0+1) HDs raus bootet die Mühle wieder nicht mehr. grummel
Ich gehe am Montag nochmal an das NAS mit NAS OS und nur eine HD zu recovern (dazu muß ich erst wieder den USB Stick einbauen).
Dann noch 7zip in die NAS Distri rein (da sind nur ein paar MB im Bootsystem übrig) und der Job ist fertig nach altem Schema oder gleich mit GEOM encryption und simplen rsync danach. Mit ZFS kenne ich mich bei weitem besser aus als btrfs. Dann noch auf 8GB hochrüsten (erstmal Steine als SoDIMM mit ECC finden) und die Box ist gerettet. Die Ausstattung mit der Intel i211 Karte ist durchaus hervorragend gegen die sonst üblichen Realtek/Marvell Karten.
Beim durchsuchen mit lsusb und lspci fand ich keinerlei Zusatzchips außer USB2/3 Hubs, kein LPC oder sonst was. Der 9pol geht in den CPU direkt (vermtue aus dem 6MHz Signal was da anliegt LVDS) der vier Pol eben JTAG um das BIOS zu setzen/flashen. Das Display hängt direkt an einem USB Kanal; alles also sehr modern.

Gruß
Sam
Ein langer fast 20h Weg um einen schönen Einschubrahmen zu haben.... naja
Member: SamvanRatt
SamvanRatt Mar 12, 2016 at 11:07:10 (UTC)
Goto Top
P.S.: Diese distries hatte ich probiert:
-FreeNAS 9.3: da USB3 da sehr spezifisch unterstützt wird (im Vergleich zu FreeBSD10.x) zweite Wahl
-NAS4Free 10.2: da USB3 an der Box laufen soll und Backups darüber schiebt war die Performance recht wichtig; es war das einzige was ich im Endeffekt ab Werk hinbekam
-OpenMediaVault 2.1: leider wurde weder in meinem Testsystem die Broadcom Karte noch in dem Zielsystem dann deren Intel NIC erkannt. Mit Marks Vorschlag via Seriell das dann zu reparieren wäre evtl gehbar. Ohne natives Netz kein Spaß
-Rockbox 3.8.12: leider wurde in meinem Testsystem die Intel 82574 erkannt, aber die i211 nicht. Mit Marks Vorschlag via Seriell das dann zu reparieren wäre evtl gehbar. Ohne natives Netz kein Spaß