bolle01
Goto Top

Selbsterstellte Verknüpfungen werden über Windows Start nicht mehr angezeigt

Hallo Leute,

beim paketieren passiert es mir häufiger das selbst erstellte Verknüpfungen über Windows Start nicht angezeigt werden. Geht man direkt über ProgramData zum Start Menu wird die Verknüpfung angezeigt. Dabei ist es unerheblich, ob die direkt im Start Menu erstellt oder noch einen Unterordner erstellt wird. Im Netz wurde mir vorgeschlagen, in der Registry unter Current_User/Software/Microsoft/Windows/CurrentVersion/UFH/SHC zu bereinigen. Da waren viele Verknüpfungen drin von Programmen die schon gar nicht mehr auf dem Rechner waren. Das löschen hat aber nichts gebracht. Woran kann das noch liegen ? Installiert man Software vom Hersteller taucht immer eine Verknüpfung über Windows Start auf. Schreiben die sich noch woanders mit rein ?

$WshShell = New-Object -ComObject WScript.Shell
$Sc = $WshShell.CreateShortcut("$envCommonStartMenuPrograms\XXX.lnk")
$Sc.TargetPath = "$envProgramFilesX86\XXX\XXX.exe"
$Sc.IconLocation = “$envProgramFilesX86\XXX\XXX.ico”
$Sc.save()

mfg

bolle01

Content-Key: 7695456708

Url: https://administrator.de/contentid/7695456708

Printed on: May 22, 2024 at 14:05 o'clock

Member: user3086
user3086 Jun 30, 2023 at 08:15:13 (UTC)
Goto Top
Ich vermute ja du suchst am verkehrten Ort. Habe mal kurz gegoogelt:

Helfen diese Hinweise?
https://superuser.com/questions/960406/where-are-all-locations-of-start- ...
https://www.giga.de/tipp/speicherort-der-startmenue-verknuepfungen-windo ...

Ich mach die Verknüpfungen über GPO's, da klappt das für meine Zwecke eigentlich immer.
Member: bolle01
bolle01 Jul 04, 2023 at 09:10:25 (UTC)
Goto Top
Hallo,
danke user3086, ich verstehe dich nicht ganz. Wenn ich die Links anklicke, ist die Rede von Verknüpfungen die über Windows Start angezeigt werden, aber wenn er unter C:\ProgramData\Microsoft\Windows\Start Menu\Programs schaut findet er sie nicht, ergo liegen sie wohl unter current user. Bei mir sind ja die Verknüpfungen vorhanden, aber werden über Windows Start nicht angezeigt, also genau das Gegenteil, aber trotzdem danke.

mfg
bolle01