bolle01
Goto Top

Frage zum Powershell Set-Active Setup

Hallo,

ich bin gerade dabei mit PSADT SQL Server Management Studio 18.9.2 zu paketieren, die Installation funktioniert super. Nun gibt es die Vorgabe das Auto Update zu entfernen. Dies geht aber nur im User Anteil. Darauf hin hab ich mir eine Set-Active Setup gebaut. Wenn ich nun die Deploy-Application ausführe wird SSMS installiert, dann der Temp Ordner angelegt, die ssms1.reg nach Temp kopiert und in der Registry das Active Setup angelegt. Melde ich mich Ab- und wieder An wurde der Registry nicht erzeugt. Habe ich irgendwo einen Denkfehler ?

Execute-Process -path 'SSMS_Setup_DEU_18_9_2.exe' -Parameters '/install /quiet /norestart /log "%WINDIR%\Temp\SSMS-Install.log"'

New-Item -ItemType directory -Path "$env:allusersprofile\temp"

Copy-File -Path "$dirSupportFiles\ssms1.reg" -Destination "$env:allusersprofile\temp"

Set-ActiveSetup -StubExePath "$envWinDir\regedit.exe" -Arguments "/S `"c:\progamdata\temp\ssms1.reg`"" -Description 'disable auto update' -Key 'SMSS 18.9.2' -ContinueOnError $true

ssms1.reg
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\SQL Server Management Studio\18.0_IsoShell\UpdateChecker]
"Enabled"="False"

mfg

bolle01

Content-Key: 1232094486

Url: https://administrator.de/contentid/1232094486

Printed on: May 22, 2024 at 15:05 o'clock

Member: Tezzla
Solution Tezzla Sep 06, 2021 at 13:15:26 (UTC)
Goto Top
Moin.

Es heißt $env:WinDir ... also mit Doppelpunkt.

VG
Member: bolle01
bolle01 Sep 06, 2021 at 13:40:00 (UTC)
Goto Top
@Tezzla danke für den Hinweis, ich hab noch den Systemordner gegen c:\temp getauscht und es funktioniert.

mfg

bolle01