kreuzberger
Goto Top

SMB Zugriff auf Server 2008R2 per MacOS

Mahlzeit liebe Digitalgemeinde,

ich hab da seit längerem ein SMB-Problem mit einem alten Server 2008R2 und dem Zugriff per Mac auf dem alten ding. Und gleich vorweg: NEIN, ich will das System auf dem Server nicht upgraden auf was neueres, da das Ding nur gelegentlich per Bedarf netzintern als Archiv-Daten-Box dient. Es besteht also keine große Sicherheitsgefahr.

Mit Windows Clients habe ich unter Account XYZ problemlos Zugriff, das klappt super. Mit Macs ging das alles mal, aber mit den neueren MacOS-Systemen geht es mit dem selben Account XYZ nicht. Mit einem Uralt-Mac und MaxOS 10.6.8 (kann nur SMB1) geht es aber. Verbinden mit „SMB://Servername“ funktioniert auf dem Uralt-Mac.

Es ist also wohl ein SMB Problem, dem ich es nicht schaffe auf den Grund zu gehen. Ggf. muss man an den Einstellungen auf dem Server etwas ändern. Derzeit ist SMB1 sowie SMB2/3 eingeschaltet.

https://learn.microsoft.com/de-de/windows-server/storage/file-server/tro ...

Hier habe ich ausgeführt:

Get-Item HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters | ForEach-Object {Get-ItemProperty $_.pspath}

und

Get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters | ForEach-Object {Get-ItemProperty $_.pspath}

Ergebnis: Alle SMB-Protokolle aktiv.

Dennoch bekomme ich mit dem Account XYZ nicht per Monterey oder Mojave Zugang. Mit dem alten 10.6.8 aber durchaus.

Hat da jemand eine pfiffige Idee?

Kreuzberger

Content-Key: 7675431696

Url: https://administrator.de/contentid/7675431696

Printed on: July 19, 2024 at 17:07 o'clock

Member: ForgottenRealm
ForgottenRealm Jun 28, 2023 at 10:21:47 (UTC)
Goto Top
Wenn der Server nur als Datengrab verwendet wird und Probleme macht, wäre es vielleicht eine Überlegung wert, auf ein NAS umzusteigen?
Gibt es denn, außer "ich will nicht" einen triftigen Grund, warum Firmendaten auf einer 15 Jahre alten Gurke die seit 3 Jahren keine Sicherheitsupdates mehr bekommt und zudem noch SMB1 aktiviert hat, liegen?
Nur Netzintern schön und gut, aber wenn ihr was im Netz habt, kommts trotzdem auf den Server drauf.
Member: kreuzberger
kreuzberger Jun 28, 2023 at 10:25:29 (UTC)
Goto Top
@ForgottenRealm

Danke für den Beitrag, wie gesagt: "Ich will nicht.“

Das teil tut stabil seinen dienst wenn es soll und wie es soll. Auch wenn es alt ist gibt es keine n Grund, ein gelegentlich mal benutztes Daten-Grab zu erneuern.

Kreuzberger
Member: godlie
godlie Jun 28, 2023 at 10:56:16 (UTC)
Goto Top
Hallo,

nun das kann eig. nur an der SMB Config von der Windows Gurke liegen, evtl kann dir das hier helfen:

https://discussions.apple.com/thread/254343241

Alternative NFS da hat sich nicht so viel getan in letzter Zeit......

grüße
Member: kreuzberger
Solution kreuzberger Jun 28, 2023 at 11:40:42 (UTC)
Goto Top
Aaaaaaaaaaaalso, dis ja ne dolle Sache dit:

Es war kein Protokollproblem, sondern ein Zeitproblem. Der alte Server hatte seine Uhrzeit/Datum vergessen und war somit ausserhalb der Toleranz.
Ich hab auf dem Ding die Zeit korrigiert und schon war alles wieder i.o.

Danke an die Schreibenden.

Kreuzberger