Sophos XG Sophos Virtual Appliance in Hyper-V starten

decehakan
Goto Top
Hallo Zusammen,

für Testingzwecke habe ich vor Sophos Virtual Appliance als Vm laufen zu lassen und vielleicht kann jemand der Erfahrung hat mir dabei helfen.

auf mein Hyper-V (Windows 10), habe ich Sophos XG installiert und ihm zwei Netwerkkarten WAN(externer Switch) und LAN ( interner Switch ) zugeordnet. Wobei die WAN Schnittstelle mit dem Host, die Netzwerkkarte teilt( geshared)

Der Installer: Virtual Installer Sophos für Hyper-V
Anleitung: https://docs.sophos.com/nsg/sophos-firewall/18.5/Help/en-us/webhelp/onli ...

Soweit läuft alles.
vm_console

Der interner Netzwerkkarte für den internen Switch (LAN) von Hper-V (Host) habe ich die IP Adresse 172.16.16.1 zugeordnet, sodass er das Webinterface 172.16.16.16:4444 255.255.255.0 erreichen soll.

v-ethernet

Ich kann leider die IP von Sophos 172.16.16.16:4444 nicht erreichen.

Auch pingen von Host zu Sophos ist irgendwie merkwürdig.

ping

Meine VM-Einstellung:

vm_einstellung

Hyper-V Switch-Einstellung:

netzwerkschnittstelle


Auch die Konsoleneinstellung zeigt, dass die statische IP 172.16.16.16 ist:


sophos_console_network

Auf dem Hyper-V habe ich ein weiteren Guest-Vm (DEBIAN) laufen, auf dem läuft ein webapplikation und der ist über den internen Switch (LAN) mit der IP 172.16.16.2 ereichbar, daher schließe ich Konfigurationsproblem über den internen Switch aus.

Kann es daran liegen, dass er nur auf einen Windows Server Hyper-V statt Windows 10 läuft ?
Bei meiner Konfiguration wird die WAN-Schnittstelle mit dem Host geshared, brauchst es unbedingt zwei dedicated Nic ?
Nach meiner Google-Recherche müsste es auch so funktionieren.

Gruss
decehakan

Content-Key: 2009576663

Url: https://administrator.de/contentid/2009576663

Ausgedruckt am: 02.07.2022 um 20:07 Uhr

Mitglied: tech-flare
tech-flare 26.02.2022 um 11:06:26 Uhr
Goto Top
Hallo,

Die 172.16.16.16 ist die Initial Ip der Sophos.

Du musste diese erstmal komplett einrichten und konfigurieren.

Bestensfalls mit einer VM, welche im gleichen VLAn wie die Sophos hängt.

Danach der VM eine IP ikngleichen Subnetz wie die Sophos geben und dann fertig konfigurieren.
Mitglied: decehakan
decehakan 26.02.2022 aktualisiert um 11:26:57 Uhr
Goto Top
@tech-flare:
Wie ich schon sagte Host,Debian und Sophos sind im gleichen VLAN (interner Switch LAN) zugeordnet. Debian erreicht Host, Host erreicht Debian.
Auch mit Debian erreiche ich den Sophos nicht,
Mitglied: LeReseau
LeReseau 26.02.2022 um 11:41:26 Uhr
Goto Top
Hast du auch das "s" nicht vergessen im URL also https:/ /172.16.16.16:4444 ?
Mitglied: decehakan
Lösung decehakan 26.02.2022 um 11:57:37 Uhr
Goto Top
Fehler gefunden.

Ich hab bei meiner Einstellung: Zuerst WAN und Anschließend LAN Karte hinzugefügt.

Da hat Zufolge, dass SOPHOS daraus resultierend, die WAN-Schnittstelle die IP 172.16.16.16/24 zugewiesen hat und somit nicht erreichbar.

Hätte ich anfangs zuerst LAN und anschließend WAN hinzugefügt wäre das Problem schon längst gelöst.

Komischer ist es nur über https (also nicht mehr 4444 ) erreichbar.

sophos_schnittstelle

ich muss sagen, dass Sophos sein Documentation Uptodate halten sollte.
Trotzdem danke für eure Unterstützung.
Mitglied: tech-flare
tech-flare 26.02.2022 aktualisiert um 16:07:00 Uhr
Goto Top
Zitat von @decehakan:

Fehler gefunden.

Ich hab bei meiner Einstellung: Zuerst WAN und Anschließend LAN Karte hinzugefügt.

Da hat Zufolge, dass SOPHOS daraus resultierend, die WAN-Schnittstelle die IP 172.16.16.16/24 zugewiesen hat und somit nicht erreichbar.

Hätte ich anfangs zuerst LAN und anschließend WAN hinzugefügt wäre das Problem schon längst gelöst.

Komischer ist es nur über https (also nicht mehr 4444 ) erreichbar.

sophos_schnittstelle

ich muss sagen, dass Sophos sein Documentation Uptodate halten sollte.
Trotzdem danke für eure Unterstützung.

Das was du ausrufst ist das User Portale und nicht das Admin Interface.steht ja sogar da

Die Sophos macht alles richtig