pn-schrauber
Goto Top

TV überschreibt Auflösung vom Pi

Moin Gemeinde,

ich bin hier gleich am verzewifeln.

Wr haben heute ein Display (Samsung BE50C-H) und einen Raspberry Pi 4 (Debian 12) im Wartebereich aufgebaut.

Die Aufrufanlage lauft mit einer Auflösung von 1920x1080px, der TV will aber davon nix wissen und stellt den Pi immer auf 4K um.

Ich habe die Einstelleung in der grafischen oberfläche umgetellt, in raspi-conf 4K deaktiviert und auch die /boot/firmware/config.txt angepasst.

hdmi-group=1 (2), habe ich beides probiert, ohne Erfolg
hdmi-mode ist ja bei Group1 die 5 (1080i)

Wenn ich den TV abklemme und mich mich via VNC aufschalte, stimmt die Auflösung, ist der TV dran, ist die Auflösung wieder bei 4K (sowohl am TV, als auch im VNC, logischerweise)

Hat irgendwer eine Idee, wie ich das Konstrukt dazu bekomme, mit der Auflösung 1920 x1080px zu laufen, sprich das der Pi den TV ignoriert?

Content-Key: 21306023398

Url: https://administrator.de/contentid/21306023398

Printed on: May 18, 2024 at 03:05 o'clock

Member: NordicMike
NordicMike Mar 15, 2024 at 11:13:08 (UTC)
Goto Top
ist
/boot/firmware/config.txt
richtig?

Sollte es nicht
/boot/config.txt
sein?

https://revolutionpi.com/de/tutorials/software/bildschirmaufloesung-eins ...
Member: MirkoKR
MirkoKR Mar 15, 2024 at 11:22:13 (UTC)
Goto Top
An meinen TVs kann ich 4K/UHD abschalten ...
... dann laufen 4K Streaming Sticks und PC mit max FHD ...
Member: TwistedAir
TwistedAir Mar 15, 2024 at 14:09:35 (UTC)
Goto Top
Moin,

ist xrandr verfügbar? So könntest du nach dem Booten die Auflösung verändern:
xrandr --display :0 --size 1920x1080
Das kann von der Kommandozeile aus abgesetzt werden; am einfachsten ist es aber den Befehl irgendwo im Autostart-Prozess einzubauen.

Gruß
TA
Member: aqui
aqui Mar 15, 2024 updated at 15:26:54 (UTC)
Goto Top
"formware" ist garantiert falsch! Freitag ­čÉč lässt grüßen! ­čśë
Du hast aber Recht das das Verzeichnis falsch ist.
https://www.foxplex.com/sites/raspbian-aufloesung-auf-1920x1080-aendern/
Member: TwistedAir
TwistedAir Mar 15, 2024 at 16:10:56 (UTC)
Goto Top
Moin,

zur "Ehrenrettung" von @PN-Schrauber:

NOTE
Prior to Bookworm, Raspberry Pi OS stored the boot partition at /boot/. Since Bookworm, the boot partition is located at /boot/firmware/.

https://www.raspberrypi.com/documentation/computers/config_txt.html#what ...

Und ja, das "o" liegt neben dem "i" auf der Tastatur. face-wink

Schönes Wochenende
TA
Member: TwistedAir
TwistedAir Mar 15, 2024 at 16:46:00 (UTC)
Goto Top
Hello again,

um noch Mal auf dein eigentliches Problem zurück zu kommen - vielleicht hilft dir dieses weiter:

display_auto_detect
With this setting enabled (it is enabled by default in Raspberry Pi OS), the firmware will automatically load overlays for DSI displays that it recognises. Set display_auto_detect=0 to disable.
https://www.raspberrypi.com/documentation/computers/config_txt.html#comm ...

HDMI mode
In order to support dual 4k displays, the Raspberry Pi 4 has updated video hardware, which imposes minor restrictions on the modes supported.

The HDMI settings used to be configured by firmware via settings in config.txt; now the settings are configured by KMS via settings in cmdline.txt.

Viel Erfolg
TA
Member: ASP.NET.Core
ASP.NET.Core Mar 16, 2024 at 22:45:21 (UTC)
Goto Top
Zitat von @NordicMike:
Sollte es nicht
/boot/config.txt
sein?
Nein, schon länger nicht mehr. Ist in Raspberry Pi OS 12 umgezogen, zeitweise gab es einen symlink: https://u-labs.de/portal/kleines-raspberry-pi-os-update-grosse-probleme- ...
Member: aqui
aqui Mar 17, 2024 at 08:00:38 (UTC)
Goto Top
Das fehlende Feedback des TO zeigt ja auch das er das Interesse an einer Lösung verloren hat. face-sad

How can I mark a post as solved?
Member: PN-Schrauber
Solution PN-Schrauber Mar 18, 2024 at 08:24:56 (UTC)
Goto Top
Das fehlende Feedback, hat damit zu tun, dass ich den Post am Freitag kurz vor Feierabend noch aufgegeben habe, damit ich am Montag, also heute, gleich einen Ansatzpunkt habe, wo ich eventuell noch nicht gesucht habe.

Da dies hier anscheinend bitter aufgestoßen ist, möchte ich mich dafür in aller Form entschuldigen und gelobe hierrmit, nie wieder einen Post über das Wochenende unbeobachtet zu lassen.

BTT

Im Prinzipt habt ihr ihr alles aufgelistet, was ich auch gefunden habe.

zum Thema config.txt. Zumindest bei mir, steht in der /boot/config.txt, dass diese jetzt unter /boot/firmware/config.txt zufinden sist, wan diese änderung kamm, kann ich nicht sagen, aber das wurde ja bereits disktutiert.


Ich habe die Lösung jetzt eher zufällig gefunden.

Ich lasse den Browser ja automatisch starten und habe daher in der wayfire.ini einen entsprechenden Eintrag gesetzt. als ich mir diese ini näher angesehen habe, habe ich die Einträge für den headless-Mode gefunden. Also wieder Tnate Google gequält und folgenden Eintrag gefunden

https://forums.raspberrypi.com/viewtopic.php?t=357708

Das hier gefundene an meine Auflösung angepasst und siehe da nach dem Speichern sprang die Auflösung um und auch nach mehreren reboots war die Auflösung immer richtig.

Grüße