Ubuntu Verbindungsabbrüche nach hinzufügen einer weiteren Netzwerkkarte und Konfiguration mit Netplan

Hallo zusammen,

ich habe folgendes Problem. Ich betreibe momentan eine VM auf einem ESXi 6.7 als Docker Host auf einem Ubuntu 20.04 LTS. Bislang mit nur einer vom ESXi zugewiesenen Virtuellen Netzwerkkarte. Nun habe ich folgendes Problem. Ich habe eine zweite Virtulle Netzwerkkarte die in einem anderen Netzsegment bzw. Portgruppe und anderem VSwitch liegt mit folgender Netplan Netzwerk Konfiguration:


Die Kommunikation funktioniert grundlegend über beide IPs. Das Problem liegt darin das seit der neuen Netzkarte Permanante Verbindungsabbrüche erfolgen, die vorallem merkbar sind logischerweise per SSH. In dem Moment in dem ich die Netzwerkkarte auf dem ESXi trenne ist wieder alles in Ordnung.

Vielen dank im vorraus für sämtliche hilfe :) face-smile

Content-Key: 752240621

Url: https://administrator.de/contentid/752240621

Ausgedruckt am: 28.07.2021 um 05:07 Uhr

Mitglied: aqui
aqui 20.06.2021 aktualisiert um 16:20:55 Uhr
Goto Top
Kann es sein das du beide NICs fälschlicherweise mit einem Default Gateway versehen hast ?!
Das geht natürlich nicht weil es logischerweise immer nur ein einziges Default Gateway auf einem Rechner oder Server geben kann !!
Guckst du dazu auch hier:
https://administrator.de/tutorial/routing-von-2-und-mehr-ip-netzen-mit-w ...
Auch ein 2ter Name Server Eintrag ist dort sinnfrei wenn das schon auf der ersten NIC passiert ist. In der Regel hat eine 2te NIC nur IP Adresse und Maske und weiter nichts.
Auch solltest du natürlich im Hypervisor den korrekten Kartentyp setzen für die Ubuntu VM !
https://docs.vmware.com/de/VMware-vSphere/6.5/com.vmware.vsphere.vm_admi ...

Beispiele für vSwitch Konfigs auch hier:
https://administrator.de/content/detail.php?id=639239&nid=1030243#co ...
https://administrator.de/forum/sophos-software-appliance-utm-vlan-cisco- ...
Mitglied: Sioren1998
Sioren1998 20.06.2021 um 16:35:28 Uhr
Goto Top
Wie in der Netplan Konfiguration zu sehen ist gibt es nur auf dem Interface ens160 welches für den Internetzugang verwendet wird ein Standardgateway. Auf dem zweiten Interface ens192 gibt es nur die IP Addresse ohne DNS oder gateway.

Als Netzwerkkarte wird eine VMXNET 3 Karte benutzt die bei den restlichen Linux VMs tadellos funktioniert.

Die Vorhandene vSwitch Konfiguration funktioniert. Es gibt zwei vSwitches. Einer dienst als "WAN" vSwitch für die Virtualisierte Firewall und der andere vSwitch fungiert als LAN segment, welcher noch mit Vlans unterteil ist. Dies funktioniert bei den anderen VMs tadellos. Das Routing übernimmt bei mir auch die Firewall und ist korrekt eingerichtet.
Mitglied: papa-luigi
papa-luigi 20.06.2021 um 20:05:15 Uhr
Goto Top
Servus!

Bleibt es denn ein Problem wenn du e.g. den SSH Service nur auf die 10.250 bindest?
Deine Docker Umgebung verwendet schon einen anderen Range - bzw. bleibt das Problem wenn du die Container/ Service herunterfährst?

Läuft auf dem Server eine GUI, so dass sich evtl. die Network-Manager in die Quere kommen?
(in Netplan wäre das ein Eintrag für renderer: XY)

Gruß
Luigi
Mitglied: Sioren1998
Sioren1998 20.06.2021 um 23:21:20 Uhr
Goto Top
Moin,

danke dir für die Hilfe. Das Problem bleibt. SSH habe ich an die 192.168.10.250 gebunden und das Problem besteht weiter. Ich habe auch testweise mal den SSH Port abgeändert aber das Problem besteht weiterhin. Eine GUI ist nicht instaliert.

Grüße
Mitglied: Sioren1998
Sioren1998 20.06.2021 um 23:35:56 Uhr
Goto Top
Ich habe nochmal etwas rumprobiert. Ich habe nun mal eine andere IP Adresse aus einem völlig anderen subnetz vergeben und nun funktioniert es ohne Verbindungsabbrüche. Das wundert mich um ehrlich zu sein etwas. Nun meine Frage. Die vorherige IP Adresse also die 192.168.2.251 ist eine IP aus dem Subnetz, welches vor der Virtualisierten Firewall verwendet wird, also vor dem NAT praktisch in der "WAN" Zone der Firewall. Das dürfte aber ja dank NAT der pfSense keine Probleme bereiten. Ich brauche den Docker Host in diesem Teil des Netzsegmentes wegen Wake on LAN Broadcast, diesen kann ich mit der Virtuellen pfSense logischerweise nicht durchrouten. Hat jemand eine Idee wie ich das Problem verhindern kann ? Die Lokale routing Tabelle des Docker hostes ist auch in Ordnung.

Grüße
Mitglied: NordicMike
NordicMike 21.06.2021 um 08:27:29 Uhr
Goto Top
Die IP (die mit den Abbrüchen) ist nicht zufällig doppelt vergeben?

Versuche es mal in eine Bridge zu legen...

Brauchen VM's wirklich WoL? Oder sendet es welche raus?
Mitglied: Sioren1998
Sioren1998 21.06.2021 um 17:53:55 Uhr
Goto Top
Die VM sendet die Wol raus.
Die IP gibt es nicht doppelt. Selbst wenn gäb es nur auf der 192.168.2.251 und nicht auch auf der 192.168.10.250. Mit ner Bridge läuft es auch nicht ^^
Mitglied: NordicMike
NordicMike 22.06.2021 um 07:43:16 Uhr
Goto Top
Mit "läuft nicht" meinst du es funktioniert, aber die Abbrüche kommen noch vor?
Mitglied: Sioren1998
Sioren1998 22.06.2021 um 10:58:54 Uhr
Goto Top
Genau die abbrüche sind immernoch da
Heiß diskutierte Beiträge
question
Zentrale Lösung für Antivirus, Patchmanagement, Monitoring in einem?Andre82msVor 1 TagFrageSicherheits-Tools24 Kommentare

Hallo Zusammen, ich suche schon seit längerem eine gute Lösung, welche ein gut funktionierendes Patchmanagement, Anti-Virenscanner mit EDR sowie ein Monitoring in einem Dashboard beinhaltet ...

question
Signatur-Programm gesuchtArchanVor 1 TagFrageOutlook & Mail20 Kommentare

Hi zusammen, vorab als Info: Wir haben eine Mischung aus Office365 und 2016, sowie einen Exchange 2016 Server. Ich bin nun auf der Suche nach ...

question
Mitarbeiter ab gewisser Uhrzeit am arbeiten hindern gelöst passy951Vor 22 StundenFrageWindows Netzwerk19 Kommentare

Guten Morgen zusammen, ich wurde gestern von unseren Betriebsrat gefragt ob es möglich ist ab z.B. 20 Uhr die Mitarbeiter daran zu hindern zu arbeiten. ...

question
Mikrotik vs. Unify - Warum mögt Ihr Unify nicht? gelöst tagol.deVor 1 TagFragePeripheriegeräte10 Kommentare

Hallo immer wieder lese ich, das hier auf Administrator.de Mikrotik bevorzugt wird. Aktuell habe ich zuhause 2 AP von Unify + Controller auf einem Rasberry ...

question
Domänencontroller von Windows Server 2016 auf Windows Server 2019 migrierenEstefaniaVor 15 StundenFrageWindows Server24 Kommentare

Hi. Kann mir ein Admin bei folgendem Problem weiterhelfen !? Wir haben insgesamt 5 Domänencontroller, die auf einem Windows Server 2016 laufen. Nun ist es ...

question
Home-Office Laptop kann DNS nicht auflösenLubosNovyVor 1 TagFrageWindows Netzwerk15 Kommentare

Hallo zusammen, Situation: Manche Kolleginnen arbeiten im Home-Office und sind über Sophos SSL Client verbunden. Die Notebooks sind von mir vorbereitet, in die Domänen aufgenommen ...

report
Positive Erfahrung mit VodafoneitebobVor 1 TagErfahrungsberichtFlatrates3 Kommentare

Hallo zusammen, vieles, was ich im Beitrag Erfahrungsbericht Vodafone - Die endlose Vertragsänderung und in Kommentaren lese, deckt sich mit meinen persönlichen Erfahrungen mit Vodafone. ...

question
Kein ActiveSync über Mobilfunknetz gelöst darodeskVor 1 TagFrageExchange Server14 Kommentare

Hallo zusammen, Wir haben einen Windows Server 2016 mit Exchange 2016 aktuell gepatched (Stand 26.07.2021). Gültiges Zertifikat, feste IP, funktionierendes Autodiscover und MS Connectivity Test ...