Veeam 11 und vSphere 7.0.2

Mitglied: Looser27

Looser27 (Level 3) - Jetzt verbinden

23.04.2021 um 09:01 Uhr, 1082 Aufrufe, 12 Kommentare

Moin,

ich habe seit dem Upgrade auf vSphere 7.0.2 (ESXi 7.0.2 und vCenter Appliance 7.0.2) ein Phänomen, für das ich noch keine Erklärung gefunden habe.
Wir sichern unsere Umgebung mit Veeam 11 (aktueller Patch-Level).

Jetzt kommt es gelegentlich vor (bei unterschiedlichen VMs), dass ich die Meldung erhalte, im ersten Versuch war das Erstellen oder Sichern des Snapshots nicht möglich.
Zum Einsatz kommen bei uns 3(!) Backup-Proxies für 17 produktive Maschinen. Ich weiß, dass ist overpowered, aber weniger kann ich immer noch bauen.
Die Proxies sind 2x Ubuntu 20.04. LTS VMs und 1x Windows VM (unser WSUS).

Die VMs, die Probleme machen bei der Sicherung, sind sowohl Hardware-Level 6.7U2, als auch 7.0.2.

Seltsamerweise gibt es Tage, da läuft es ohne Fehlermeldung durch, dann wieder tagelang mit min. 1 VM erst im 2. Versuch.
Die Sicherung an sich funktioniert und das Recovery auch (musste ich leider schon mal testen.....).

Die Fehlermeldung im Detail:

Der vCenterServer läuft bei mir schon mit 2 Cores und 16GB RAM (was über der Empfehlung für unsere Umgebung liegt).

Die Proxies sind auf 2 parallele Tasks / Proxy limitiert.

Hat das noch jemand beobachten können in dieser Konfiguration? Vergleiche zu 6.7U2-Umgebungen bringen nichts, denn dort funktionierten 10 parallele Tasks über 1 (!) Proxy reibungslos, weswegen ich auf das vCenter tippe.

Gruß

Looser
Mitglied: Deepsys
23.04.2021 um 09:29 Uhr
Hi,

zu dem Fehler weiß ich leider nichts, aber ich rate dir dich einfach bei dem Veeam Support zu melden.
Die waren bisher bei mir immer sehr kompetent und die Fehler konnten gelöst werden :-) face-smile

VG
Deepsys
Bitte warten ..
Mitglied: Looser27
23.04.2021 um 10:15 Uhr
Moin,

ich habe mal ein Ticket aufgemacht. Mal sehen, mit welchen Vorschlägen die um die Ecke kommen.... :-) face-smile

Gruß

Looser
Bitte warten ..
Mitglied: ElmerAcmeee
23.04.2021 um 11:55 Uhr
Hallo,

m.W wird ESXi 7 Update 2 noch nicht mit Veeam V11 supported.
Zudem hatte VMWare doch das ESXi Update 2 zurückgezogen, oder?

Gruß
Bitte warten ..
Mitglied: em-pie
23.04.2021 um 13:18 Uhr
Moin,

exakt diese Meldung hatten wir auch schon einmal - mit VEEAM 10 und ESXi 7.0.x (hab vergessen, ob es schon due U2 war oder nicht).

Ich meine mich erinnern zu können, dass ich die VM nicht mehr via VSS (also stillegen der VM) sichere, sondern "normal".
Oder es war umgekehrt.

Prüfe mal, ob die VMware-Tools in der VM auf aktuellem Stand sind.

Gruß
em-pie
Bitte warten ..
Mitglied: Looser27
23.04.2021 um 13:38 Uhr
Moin,

@em-pie: Meinst Du die Funktion VMWare Tools quiescence? Das ist bislang deaktiviert.

VM-Ware-Tools werden allesamt vom OS verwaltet (Linux-Maschinen mit Cent-OS und Ubuntu).
Scheinen aber aktuell zu sein, denn nach einer Aktualisierung und anschließendem Neustart ergibt sich keine Änderung der Versionsnummer.

Gruß

Looser
Bitte warten ..
Mitglied: Looser27
23.04.2021 um 13:47 Uhr
Je länger ich darüber nachdenke, umso mehr tippe ich auf den vCenterServer als Fehlerquelle.
Aus dem Bauch heraus würde ich mal behaupten, dass der mit der CPU/RAM-Ausstattung das gleichzeitige Verarbeiten von 4 SnapShots manchmal nicht hinbekommt (bei evtl. "doofer Kombi").

Ich habe der VM mal CPU&RAM verdoppelt und nur noch einen Task/Proxy eingestellt. Mal sehen ob das damit besser läuft.

Da der Fehler aber nicht permanent auftritt, muss man halt immer ein paar Datensicherungen abwarten.
Bitte warten ..
Mitglied: em-pie
23.04.2021 um 16:24 Uhr
Zitat von @Looser27:
@em-pie: Meinst Du die Funktion VMWare Tools quiescence? Das ist bislang deaktiviert.
Ja, genau.
Wir nutzen die für manche VMs. Bin ir wie gesagt gerade nur nicht sicher, ob die Lösungg war, die betroffenen VMs damit zu sichern oder damit nicht mehr zu sichern...

VM-Ware-Tools werden allesamt vom OS verwaltet (Linux-Maschinen mit Cent-OS und Ubuntu).
Scheinen aber aktuell zu sein, denn nach einer Aktualisierung und anschließendem Neustart ergibt sich keine Änderung der Versionsnummer.
OK. dann sollte es ja passen. Wir machen es genauso: hier setzen wir die Open-VM-Tools ein (geht via apt-get installl...)
Das vCenter würde in der WebGUI auch "meckern" wenn eine aktuellere Version verfügbar wäre - fällt mir gerade ein.


Ich schaue mal, ob ich noch herausfinde, was bei uns die Lösung war. genau das habe ich mir damals nicht notiert *grml*
Bitte warten ..
Mitglied: Looser27
27.04.2021 um 08:33 Uhr
Kurzer Zwischenstand....mal läuft es fehlerfrei durch....mal nicht. Betroffen sind unterschiedliche Linux-Maschinen. Ich habe jetzt mal die Funktion VMWare Tools quiescence aktiviert und teste mal, ob das Backup damit besser läuft.
Aktuell nach wie vor 3 Proxies mit je 2 Tasks maximal (das das Backup-Ziel aber nur 4 parallele Tasks zuläßt, ist das vernachlässigbar.

Gruß

Looser

P.S.: Im Retry 1 des Backup-Jobs werden die im ersten Versuch fehlgeschlagenen Backups aber problemlos gesichert. Ich habe nur das Nadelöhr noch nicht gefunden, was den Fehler verursacht.
Bitte warten ..
Mitglied: Looser27
28.04.2021 um 08:58 Uhr
Gestern habe ich Antwort vom Veeam-Support erhalten, die mich leider NULL weiter gebracht hat. Deren Meinung ist: Es liegt am VCenter.
Heute gab es das erste Patch für das VCenter (7.0U2a). Das spiele ich gerade ein.
Das Backup lief gestern mit der zuletzt gemachten Änderung ( VMWare Tools quiescence aktiviert) fehlerfrei durch.

An dieser Stelle Danke an alle, die geholfen haben. Ich werde die Infos hier ergänzen, sowie ich neue Erkenntnisse gewonnen habe.

Gruß

Looser
Bitte warten ..
Mitglied: em-pie
28.04.2021 um 09:02 Uhr
Moin Looser27

Danke dir der Rückmeldung.
Ernüchternde Antwort seitens VEEAM - bin mal gespannt, ob das Problem dann nu wech ist.
Wobei dann die Frage ist: lag es am 7.0U2a oder am aktivierten quiescence !?

Gruß
em-pie
Bitte warten ..
Mitglied: Looser27
28.04.2021 um 09:03 Uhr
Wobei dann die Frage ist: lag es am 7.0U2a oder am aktivierten quiescence !?

Das werde ich dann noch herausfinden. ;-) face-wink
Bitte warten ..
Mitglied: Looser27
29.04.2021 um 11:26 Uhr
Nachdem mir das Update-Patch meine vCenter Installation zerballert hat, habe ich eben zurückgesichert und belasse es jetzt bei der Version 7.0U2 mit aktiviertem quiescence.

Weitere Tests erst mit der nächsten Version ;-) face-wink
Bitte warten ..
Heiß diskutierte Inhalte
Datenschutz
FAX ist nicht mehr Datenschutzkonform
brammerVor 1 TagInformationDatenschutz52 Kommentare

Hallo, jetzt sollte es jeder begreifen FAX ist nicht mehr Datenschutzkonform brammer

Humor (lol)
Na, kann euer Toaster auch schon WLAN?
ITlerin95Vor 1 TagAllgemeinHumor (lol)16 Kommentare

Also ich frag mich ja selbst echt oft, ob wirkliche alle technischen Neuerungen auch wirklich notwendig sind. Hintergrund ist, ich brauch einen neuen Toaster. ...

Netzwerkgrundlagen
Statische Route auf UTM
gelöst Ex0r2k16Vor 14 StundenFrageNetzwerkgrundlagen31 Kommentare

Moin! Ich habe an meiner Sophos UTM an einem physischen Interface einen Switch angeschlossen. Dieser läuft im Netz 10.1.1.0/24. Ich kann von meinem aktuellen ...

Windows Update
Keine Updates zum Mai-Patchday über WSUS?
gelöst CoreknabeVor 1 TagFrageWindows Update12 Kommentare

Moin, wir laden über unseren WSUS die Windows Updates herunter (Server 2012R2). Jetzt stelle ich gerade verwundert fest, dass es Stand jetzt (19:45 Uhr) ...

Exchange Server
Sicherheitsupdates für Exchange Server 11. Mai 2021
kgbornVor 1 TagInformationExchange Server4 Kommentare

Sicherheitsupdates für Exchange Server 11. Mai 2021 Technet-Beitrag Meine Zusammenstellung: Sicherheitsupdates (KB5003435) für Microsoft Exchange Server (11. Mai 2021)

Exchange Server
Office 365 ohne lokalen Exchange
RicoPausBVor 1 TagFrageExchange Server8 Kommentare

Moin zusammen wir sind erst vor kurzem ins Office 365 eingestiegen und hatten vorher auch keinen Exchange Server im Einsatz. Ein Hybrid-Setup liegt also ...

SAN, NAS, DAS
Synology-NAS DS1813+: Lebensdauer des Gerätes?
OrmensonVor 1 TagFrageSAN, NAS, DAS10 Kommentare

Hallo Forum! In unserer Firma nutzen wir ein Synology NAS DS1813+ als zentraler Datenspeicherort. Konfiguriert ist er als RAID mit Ausfallsicherheit einer Platte. Die ...

Microsoft Office
Weiterleitung bestimmter Emails während Urlaubszeit
gelöst imebroVor 1 TagFrageMicrosoft Office11 Kommentare

Hallo, verschiedene Rechnungen werden an meine Email-Adresse gesendet. Daher habe ich vor einiger Zeit eine Outlook-Regel in meinem Outlook-Postfach erstellt, die automatisch Emails mit ...