michelle
Goto Top

Veeam Backup Performance auf LTO 8 Ultrium

Hallo zusammen,

wir betreiben hier eine Serverstruktur von HPE.
Das ganze läuft mit Hyper-V. Wir haben zwei Server mit jeweils internen SSD Platten.
Das Storage wird über VSA realisiert. Hyper-V läuft direkt auf den Servern.
An einem der Server ist ein HPE Ultrium 8 LTO Laufwerk über SAS angeschlossen.


Nun zu meinem Problem.
Wir sichern auf ein QNAP alle VM's. Das QNAP ist per 10 GB angeschlossen. Genauso wie die Server.
Nach dem eigentlichen Backup (Reverse Incremental) läuft eine Kopie auf das Band. Das aber leider nur mit ~ 110 MB/s
Eigentlich hätte ich eine Performance von 330 MB/s oder zumindest ~ 250 MB/s erwartet?

Kennt jemand von euch das Problem?

Die Treiber und Firmware des Laufwerks sind aktuell.
Encryption und Compression am Laufwerk sind aus.

Hat jemand noch einen Tipp?

Liebe Grüße
Micha

Content-Key: 7750060671

Url: https://administrator.de/contentid/7750060671

Printed on: March 1, 2024 at 18:03 o'clock

Member: Looser27
Looser27 Jul 05, 2023 at 13:07:24 (UTC)
Goto Top
Moin,

Was sagt veeam denn wo das bottleneck ist?
Da kannst Du ansetzen.

Gruß

Looser
Member: Michelle
Michelle Jul 05, 2023 at 13:48:04 (UTC)
Goto Top
Hi,

Source = 0%
Proxy = 2%
Network = 20%
Target = 70%

liegt also am Tape, nur wo ;)
Member: clSchak
clSchak Jul 05, 2023 at 14:03:20 (UTC)
Goto Top
Hi

mit wie vielen "Pfaden" ist das SAS angebunden? 1 oder 2? Was für ein SAS Controller? 6G oder 12G Variante? Hängt an dem Controller nur das Bandlaufwerk oder noch weitere Systeme?

110 MB klingt nach einer 1Gbit Verbindung, hast du mal während der Sicherung auf Band geprüft welchen Netzwerkpfad das System zur QNAP nimmt?

Wir sichern direkt vom Backupserver auf Tape mit rund 260MB/s je Bandlaufwerk (2 im Einsatz), die sind über einen 12G SAS Controller angeschlossen, mit jeweils einem Pfad.
Member: cwr
cwr Jul 05, 2023 at 14:26:57 (UTC)
Goto Top
Wir haben das Bandlaufwerk und eine Synology 923+ 10G direkt am Backupserver angeschlossen.

Die Sicherungen der VM´s erreich Geschwindigkeiten von bis zu 780 MB/s, im Schnitt aber so 350 MB/S

Von der Synology auf das Band LTO8 erreicht es dann Spitzen von 360 MB/s, im Schnitt aber so ca. 245 MB/s

Als das ganze noch übers LAN mit 1G gelaufen ist hatten wir auch ca. die 110 MB ... was natürlich klar war ... die Sicherung dauerte ca. 20h, jetzt ist sie wieder in wenigen Stunden fertig ... so wie es sein sollte (zumindest bei uns).
Member: em-pie
em-pie Jul 05, 2023 at 15:07:41 (UTC)
Goto Top
Moin,

Das QNAP ist per 10 GB angeschlossen. Genauso wie die Server.
und zwischen QNAP und VEEAM-Server ist auch alles durchgängig auf 10GBit ausgelegt?
Oder hängen da irgendwo noch (zwei) Switche drin, die untereinander nur einen Uplink mit X* 1Gbit haben?

Gruß
em-pie
Member: MirkoKR
MirkoKR Jul 05, 2023 at 15:18:38 (UTC)
Goto Top
... und wiederkehrend die Frage:10 GBit oder 10 GB[yte] ?
Member: Michelle
Michelle Jul 05, 2023 at 15:21:31 (UTC)
Goto Top
@clSchak

mit wie vielen "Pfaden" ist das SAS angebunden? 1 oder 2?
Mit einem Pfad

Was für ein SAS Controller? 6G oder 12G Variante?
HPE Smart Array P408i-a SR Gen10 12G SAS Controller

Hängt an dem Controller nur das Bandlaufwerk oder noch weitere Systeme?
Nur das Bandlaufwerk

hast du mal während der Sicherung auf Band geprüft welchen Netzwerkpfad das System zur QNAP nimmt?
Wie prüfe ich das?

@em-pie
und zwischen QNAP und VEEAM-Server ist auch alles durchgängig auf 10GBit ausgelegt?
Yep
Member: Michelle
Michelle Jul 05, 2023 at 15:23:03 (UTC)
Goto Top
Zitat von @MirkoKR:

... und wiederkehrend die Frage:10 GBit oder 10 GB[yte] ?

10 GBit
Member: regnor
regnor Jul 05, 2023 at 17:32:50 (UTC)
Goto Top
Wie schnell könnt ihr denn Daten der QNAP vom Tapeserver aus lesen? Einfach mal den direkten Zugriff testen, z.B. mit Diskspd wie hier beschrieben: https://www.veeam.com/kb2014
Member: tech-flare
Solution tech-flare Jul 05, 2023 at 20:26:42 (UTC)
Goto Top
Hallo,

wie ist das QNAP angebunden? SMB oder ISCSI? Welches Dateisystem, falls es sich dabei um ein LUN handelt?

Welche Komprimierung ist auf dem Repository eingestellt?

komprimierst du nochmal zusätzlich die Tape Sicherung ?

Wir hatte ein ähnliches Problem....da war das QNAP als BackupSource für das Tape als LUN via ISCSI gemountet und als Dateisystem war das LUN mit REFS formatiert.

Nachdem wir von REFS weg sind ( wird nur für Lokal Datenträger offiziell unterstützt), schreiben wir mit maximaler Schreibgeschwindigkeit auf LTO-8.

Gruß
Member: Michelle
Michelle Jul 10, 2023 at 10:24:56 (UTC)
Goto Top
Halli Hallo,

Ich bedanke mich bei allen die sich an diesem Thread beteiligt haben und mir mit Ratschlägen versucht haben zu helfen. ich will nicht zu früh einen Erfolg melden, aber der Tipp von tech-flare scheint gold richtig gewesen zu sein.

Seine Beschreibung gleicht 1:1 unserer Umgebung

QNAP, iSCSI, LUN, REFS

Wir haben nun die LUN mit NTFS formatiert und siehe da, die ersten Tests sehen vielversprechend aus.

Doppelt so schnell bei der Sicherung aufs NAS und 3 fache Geschwindigkeit bei der Copy aufs Band face-smile

DANKE!