franc
Goto Top

Vmware - Guest wird im lokalen Netzwerk nicht gefunden

Hallo

ich habe einen Windows 10 Pro Rechner mit Vmware Workstation 16.2.4, dort eine VM mit Ubuntu 22.04.
Im Ubuntu habe ich xrdp installiert, das kann ich auch vom Host (also von diesem Windows 10 PC) aus aufrufen.

Die VM (Ubuntu) hat in den Netzwerkeinstellungen (Network adapter > Network connection) "NAT: used to share the host's IP address" eingestellt (mit Bridged kriege ich kein Internet im Ubuntu).
Als IP hat die vm 192.168.30.130 mein lokales Netz (mit FritzBox 7490 als Router) hat die Adresse 192.168.0.0/24

Von einem anderen Rechner (auch W10 Pro) im lokalen Netz (IP: 192.168.0.150) komme ich allerdings nicht auf die VM. Weder per RDP noch über Ping. Vom Ubuntu VM komme ich aber über Ping auf die IP dessen, das wiederum geht, nur in die Richtung auf die VM nicht.

Was kann das sein?
Auf den Host PC komme ich problemlos, der ist aber im Router-Netz (192.168.0.118).

Wie kann ich dem Router beibringen, wo er die 192.168.30.130 findet?

Danke für Tipps.

franc

EDIT: jetzt habe ich Hyper-V auf dem Windows 10 PC installiert, also da wo auch Vmware Workstation drauf ist und (super einfach) Ubuntu 22.04 installiert, wird einem ja hinterhergeworfen, beim Starten wird man schon gleich mit dem vorinstallierten xrdp empfangen, also alles schon da.
Mit ifconfig habe ich die lokale IP gefunden: 172.20.100.2 aber wieder wird die nicht erreicht von anderen Geräten im lokalen 192.168.0.0 Netz.
Das ist doch was grundsätzliches, oder?

Content-Key: 5954533609

Url: https://administrator.de/contentid/5954533609

Printed on: April 18, 2024 at 02:04 o'clock

Member: aqui
Solution aqui Feb 12, 2023 updated at 14:57:24 (UTC)
Goto Top
Du machst sehr wahrscheinlich einen Denkfehler...
Wenn du mit der VM im lokalen LAN arbeiten willst wo auch der Hypervisor ist muss der Mode logischerweise immer auf "Bridged" gesetzt sein.
Damit wird die VM dann über eine einfache Layer 2 Bridge mit dem Hypervisor Netzwerk verbunden. Sprich die VM arbeitet dann wie ein Host im gleichen lokalen LAN wie auch der Hypervisor selber.
Wenn also dein Ubuntu auf DHCP steht zieht er sich dann auch eine IP vom lokalen Router.

Im NAT Mode arbeitet die VmWare als NAT Router wie auch ein Internet Router. Das interne VM IP Netz, was dann natürlich immer unterschiedlich zu deinem lokalen LAN sein muss, wird auf die Hypervisor IP geNATet. Lokale Endgeräte "sehen" so die VMs immer mit der Absender IP des Hypervisors und "denken" die VM ist ein lokales Gerät.
Allerdings hast du mit NAT dann, wie bei NAT üblich, eine aktive NAT Firewall. Die VM kommt dann zwar auf Endgeräte im lokalen LAN und auch ins Internet. Lokale Geräte im LAN können aber die VM durch die dann aktive NAT Firewall nicht erreichen. Gleiches Prinzip wie beim Internet Router.
NAT macht man also nur dann wenn man das interne VM Netz isolieren möchte von externen Zugriffen.
Ganz einfache Netzwerk Logik also im Hypervisor.... face-wink
Fazit: Setze in der VmWare den Mode auf Bridge und dann rennt das auch alles sofort. ­čśë
Mit ifconfig habe ich die lokale IP gefunden:
Das macht man in aktuellen Distros nicht mehr mit ifconfig sondern mit ip a (Routing zeigt dir dann ip r)
Member: Spirit-of-Eli
Spirit-of-Eli Feb 12, 2023 at 16:58:09 (UTC)
Goto Top
Moin,

was tatsächlich passieren kann, so z.b. bei HyperV, ist das Eingreifen einer Firewall auf dem Host.
Diese kann unter Umständen die Kommunikation zur VM blocken. Bei mir resultierte es darin, dass die VM keine Antwort vom DHCP Server erhalten hat.

Gruß
Spirit
Member: Crusher79
Crusher79 Feb 12, 2023 updated at 20:30:14 (UTC)
Goto Top
Hallo laptop oder PC mit mehreren NICs?

Du kannst in den Netzwerk Einstellungen die Karte auswählen. Bei WLAN und Ethernet am Laptop gibt's logisch Probleme wenn man die Schnittstelle wechselt.

Das würde ggf. Bridge verhindern wenn Automatik falschen NIC für Netz X setzt.

Ansonsten kann der host alleine stehen oder in einer Domäne sein. Bridge auf der korrekten Karte und es geht. Korrekt ist die, die mit den Netzwerk verbunden ist. Klapp doch mal die Einstellungen für. VM Network auf und schau dir die zugewiesene Karte an.

Ansonsten gilt alles, was auch für ein ph. Netz gilt. IP nicht doppelt. Feste IP oder DHCP....

Mfg Crusher
Member: franc
franc Feb 13, 2023 updated at 11:21:25 (UTC)
Goto Top
Bridged (auf Vmware) ging halt nicht, da sagt die Ubuntu VM, sie habe kein Internet.
Ich habe ja eigentlich nur eine Netzwerkkarte (Ethernet, LAN).

Ich hab es dann mit Hyper-V probiert, dort dann eine zusätzliche virtuelle Netzwerkkarte installiert, jetzt kriegt die Hyper-V-VM (Ubuntu) auch eine IP vom Router, aber dennoch kann ich diese Ubuntu-VM im lokalen Netz von einem anderen Rechner aus per RDP nicht erreichen.

Firewall hatte ich auch ausgeschaltet (erst geschaut, ob da was blockiert würde), das hatte aber nichts geändert, außer dass der Rechner dann halt dauernd meckert.

Nun hab ich wieder mit VMware probiert, auf Bridge, jetzt geht es plötzlich, also Ubuntu hat mit Bridge auch Internet und kriegt vom Router auch eine IP (DHCP).
Ich komme auch per RDP drauf, hurra!

Allerdings nur als root (ich habe root auf Ubuntu aktiviert, ja).
Als normaler Benutzer kriege ich so eine komische Meldung:

Connecting to sesman IP 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login failed for display 0


dann kommt die xrdp Login Maske und dort komme ich auch wieder nur mit root (plus Passwort) rein.
Der normale Benutzer geht nicht.

Aber das ist ein anderes Problem.
Member: Crusher79
Crusher79 Feb 13, 2023 at 12:23:40 (UTC)
Goto Top
Member: aqui
aqui Feb 13, 2023 at 14:20:27 (UTC)
Goto Top
Als normaler Benutzer kriege ich so eine komische Meldung:
Guckst du hier:
Netzwerk Management Server mit Raspberry Pi
Netzwerk Management Server mit Raspberry Pi
Halte dich daran, dann klappt auch das fehlerlos.
Member: franc
franc Feb 13, 2023 updated at 18:29:18 (UTC)
Goto Top
Zitat von @aqui:

Als normaler Benutzer kriege ich so eine komische Meldung:
Guckst du hier:
Netzwerk Management Server mit Raspberry Pi
Netzwerk Management Server mit Raspberry Pi
Halte dich daran, dann klappt auch das fehlerlos.

Auf dem Raspberry Pi habe ich keine Probleme mit RDP. Da komme ich sowohl mit dem Benutzer pi als auch mit root drauf.
Aber das Web-Terminal kannte ich noch nicht, hab ich gleich mal installiert, also:
apt install shellinabox minicom
und dann:
192.168.0.160:4200/
Login mit root geht da nicht, muss man danach su machen.
Member: Crusher79
Crusher79 Feb 13, 2023 at 19:42:37 (UTC)
Goto Top
???

Dachte war mehr so gedacht, dass du die Lösung adaptierst- für dich umünst auf die VM?

https://askubuntu.com/questions/1164456/18-04-3-lts-xrdp-login-failed-fo ...

Da wurde es auf die Nummer im Namen geschoben.

Hab leider kein Ubuntu hier. Und wenn meist nur über SSH. Aber so sehe ich schon einen haufen brauchbare Antworten. Lies es dir doch mal in Ruhe durch.

Irgendwas läuft grad wieder durcheinander face-big-smile
Member: franc
franc Feb 13, 2023 updated at 19:49:14 (UTC)
Goto Top
Ja, die Antworten auf diese Frage habe ich schon vermutlich die meisten gelesen und versucht anzuwenden, hat bisher noch nichts gebracht.
Aber wie schon gesagt, das ist nicht mehr das Thema, da würde ich dann eine eigene Frage aufmachen.
Danke!
Member: Crusher79
Crusher79 Feb 13, 2023 at 19:57:18 (UTC)
Goto Top
Hmm würde frischen Input bringen face-wink

Aber ich Tippe fast, dass dich die Antwort schon fast beißt. Iimmer blöd wenn man nicht direkt davor sitzt. Irgend ein Unsinnn wird nicht übergeben? Englisches Tastatur-Layout? Nur ins blaue....

Denke mal ist wirklich nur eine Kleinigkeit. Rate aber auch nur rum.
Member: franc
franc Feb 19, 2023 at 13:34:42 (UTC)
Goto Top
Mittlerweile verstehe ich auch, was ich falsch gedacht hatte.
Ich hatte immer auf NAT gestellt, das ging dann natürlich auf dem Host immer prima, RDP oder VNC auf diese VM.
Aber von einem anderen PC hatte ich das ja noch gar nicht probiert, per RDP o.ä. drauf zugreifen, immer nur vom Host PC selbst. Da geht es natürlich, die NAT macht ja vermutlich die virtuelle Vmware Netzwerkkarte, aber davon hat naürlich der Router im internen Netz keine Ahnung.
Klar Bridge.
Das ging nur oft nicht auf Anhieb, vermutlich hätte ich da mal der ganze Rechner neu starten müssen o.ä., daher hab ich immer auf das zuverlässige NAT gestellt.
Jetzt ist klar.
Member: Crusher79
Crusher79 Feb 19, 2023 at 15:10:57 (UTC)
Goto Top
Hatte dir @aqui gaaanz weit oben schon gesagt. Was war da los face-big-smile