bloodstix
Goto Top

Win10 Zugriff auf Linux-Samba nur per Hostname nicht aber per IP

Hallo zusammen,

ich habe hier ein etwas kurioses Problem, wo ich denke, eigentlich müsste es wenn dann doch genau andersherum sein.
Ich kann von einem Win10 Rechner nur auf ein Samba-Share zugreifen, wenn ich den Hostnamen des Server verwende.
Wenn ich die IP verwende wird der Netzwerkpfad nicht gefunden.
Hat dafür jemand eine Erklärung?

Grüße
bloody

Content-Key: 621896

Url: https://administrator.de/contentid/621896

Printed on: May 21, 2024 at 10:05 o'clock

Member: Pjordorf
Pjordorf Nov 13, 2020 at 15:22:08 (UTC)
Goto Top
Hallo,

Zitat von @bloodstix:
Hat dafür jemand eine Erklärung?
Zu welcher IP löst dein Hostname auf, welche IP versuchst du zu erreichen, Router, ReverseProxy oder so im Einsatz?

Gruß,
Peter
Member: bloodstix
bloodstix Nov 13, 2020 at 17:14:54 (UTC)
Goto Top
Hi @Pjordorf,

der Hostname löst auf die gleiche IP auf. Client und Server hängen am selben Switch, da ist nichts zwischen.

Grüße
bloody
Member: Pjordorf
Pjordorf Nov 13, 2020 at 17:52:15 (UTC)
Goto Top
Hallo,

Zitat von @bloodstix:
der Hostname löst auf die gleiche IP auf. Client und Server hängen am selben Switch, da ist nichts zwischen.
Welcher Dienst oder Anwendung soll denn angesprochen werden? Konfigurationsfehler deines SAMBA? Wie lautet die genaue Fehlermeldung?

Gruß,
Peter
Member: bloodstix
bloodstix Nov 13, 2020 at 18:27:39 (UTC)
Goto Top
Einfach eine Samba-Freigabe soll angesprochen werden. Fehlermeldung per IP "Der Netzwerkpfad wurde nicht gefunden". Konfigurationsfehler kann ich denke ich ausschließen da es bis vor ner Woche astrein auf beiden Wegen funktioniert hat.
Member: godlie
godlie Nov 13, 2020 at 18:48:09 (UTC)
Goto Top
Hallo,

kann es sein das du evtl. ein Windows Update bekommen hast u. dir der SMB 1 Support weggebrochen ist?
Member: Lochkartenstanzer
Lochkartenstanzer Nov 13, 2020 updated at 19:30:56 (UTC)
Goto Top
Zitat von @godlie:

Hallo,

kann es sein das du evtl. ein Windows Update bekommen hast u. dir der SMB 1 Support weggebrochen ist?

Dann müßte das aber auch beim Auflösen über den hostname passieren!

lks
Member: Lochkartenstanzer
Lochkartenstanzer Nov 13, 2020 updated at 19:32:43 (UTC)
Goto Top
Moin,

was passiert, wenn Du im explorer einfach nur \\ip.ad.re.sse\ ohne weiteren Sharenamen oder Pfad eingibst?

lks
Member: godlie
godlie Nov 13, 2020 at 19:34:52 (UTC)
Goto Top
Hallo LKS,

ja aber die wege von Windows sind unergründlich manchmal face-smile
Member: gammelobst
gammelobst Nov 14, 2020 at 18:26:50 (UTC)
Goto Top
Hallo,

das hatte ich auch schon ein paar mal. Deaktiviere SMB1 am "Server" und gut is.

cya
Member: aqui
aqui Nov 14, 2020 updated at 19:23:59 (UTC)
Goto Top
Sehr hilfreich und zielführend fürs Troubleshooting wäre ja auch mal gewesen die smb.conf Datei hier zu posten.
Aber dem TO scheint die Kristallkugel und freies Raten ja lieber zu sein... face-sad
client min protocol = SMB3
client max protocol = SMB3
Member: bloodstix
bloodstix Nov 17, 2020 at 20:46:50 (UTC)
Goto Top
@Lochkartenstanzer da passiert genau das gleiche wie ich oben schon schrieb. "Der Netzwerkpfad wurde nicht gefunden".
@aqui das funktioniert leider nicht, der samba server ist zu alt.
es funktionierte ja auch bis letzte woche vor einem stromausfall mit ip und hostname.
Member: Pjordorf
Pjordorf Nov 17, 2020 at 22:10:25 (UTC)
Goto Top
Hallo,

Zitat von @bloodstix:
@aqui das funktioniert leider nicht, der samba server ist zu alt.
Und auf einen aktuellen SAMBA wechseln kannst du nicht?

es funktionierte ja auch bis letzte woche vor einem stromausfall mit ip und hostname.
Meine Oma hat letzte woche auch noch geatmet. Seitdem nicht mehr. Was kann das sein? Einstellungen waren bei dir wohl NICHT gespeichert und in einer Datei abgelegt...

Gruß,
Peter