Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Windows 2000 Server Problem mit DNS

Mitglied: itnet04

Keine Auflösung der aufgerufenen Internetseiten??!!!

Hallo kann mir jemand helfen??

Folgender Ausgangspunkt.

Windows 2000 Server, als erster DC mit statischen IP's. Der Server ist ebenfalls DNS Server und hat als DNS die eigene IP Adresse eingetragen. Alle Clients im Netzwerk haben seine IP als DNS eingetragen. Gateway ist ein Router, der mit dem Internet verbunden ist.
Alle Clients und der Server haben als Gateway den Router eingetragen.

Nun gibt es folgendes Problem:

- Keine Internetseite wird mehr aufgelöst, nur, wenn man die IP eingibt!
- Wenn man nslookup ausführt, kommen Fehlermeldungen, es werden keine Namen, z.B. google.de aufgelöst!

Nun meine Fragen:

1. Kann es sein, dass der Server vom 1. DC zurückgestuft wurde, da die versehentlich einen Win2003 SBS mit ins Netz gehängt haben,welcher die selbe Konfiguration (IP, DNS, Gateway) wie der Win 2000 Server hat??

2. Können diese Probleme auftreten, sollte der Server zurückgestuft worden sein?

3. Wäre in diesem Falle nicht auch das AD weg?

4. Oder liegt das am DNS??

5. Wie kann ich den DNS "reparieren" ohne den Server neu konfigurieren zu müssen??


Bitte um schnelle Hilfe!!!!

Danke Euch!!

Content-Key: 6285

Url: https://administrator.de/contentid/6285

Ausgedruckt am: 27.09.2021 um 16:09 Uhr

Mitglied: kawazu
kawazu 31.01.2005 um 08:49:26 Uhr
Goto Top
Moin;

Die Problembeschreibung läßt darauf schließen, daß die externe DNS-Auflösung nicht funktioniert - geht denn DNS für lokale Namen? Ist der lokale DNS ein "vollwertiger" DNS, der auch externe Adressen selbst auflösen, oder wird dort der Provider-DNS oder ein DNS-Cache auf dem Gateway für die externe Auflösung verwendet? _Theoretisch_ sollte die Konfiguration dieser funktionalen Bereiche nichts mit der Einstufung des Servers als DC zu tun haben, da DNS selbst unabhängig von der Microsoft-Domain-Geschichte ist. Ist denn der Windows2003-Server wieder weg und/oder richtig konfiguriert worden? Was sagen die Protokolleinträge auf der W2k-Maschine?

Cheers,
Kris
Mitglied: itnet04
itnet04 31.01.2005 um 09:09:13 Uhr
Goto Top
Der Win2003 Server wurde nur versehentlich kurz gestartet, ist wieder vom Netz.

Folgendes steht im Ereignisprotkoll: Die dynamische Registrierung oder die Aufhebung der Registrierung ein oder mehrerer DNS-Einträge ist fehlgeschlagen.
Für das System wurde kein DNS-Server konfiguriert!

Also ist doch der DNS flöten gegangen.

Wenn isch ein nslookup mache kommt die Meldung:

Der Standardserver ist nicht verfügbar!!

In der DNS Konsole ist keine Reserve-Lookup-Zone vorhanden.

Muss die da sein?

Soll ich die wieder erstellen??

Ich denke die muss dann AD integreirt sein?!!

Ändert sich dann an meinem vorhandenen AD etwas, oder an den Usern die da drin stehen???

Danke für Eure Hilfe!
Mitglied: Atti58
Atti58 31.01.2005 um 09:22:59 Uhr
Goto Top
Konntest Du denn den alten Server nach dem Win2k3 Serverstart mal durchbooten? Ich glaube nicht, dass er es mag, wenn jemand mit seiner IP arbeiten will ;-) face-wink ... oder wenigstens den DNS-Dienst?

Gruß

Atti
Mitglied: itnet04
itnet04 31.01.2005 um 09:31:03 Uhr
Goto Top
ja, das konnte ich!!!

Ab dann kamen die Probleme!!

Also, muss nun eine REserve-Lookup Zone eingeichtet werden??
Mitglied: Atti58
Atti58 31.01.2005 um 09:51:27 Uhr
Goto Top
Die Reverse Lookup Zone kann nicht schaden, wird Dein Problem aber nicht beseitigen ... Ich würde an Deiner Stelle den DNS-Server temporär deinstalliere und dann neu einrichten. Das ist sicher nicht ganz "ungefährlich", ich habe es kürzlich auch machen müssen und es gab (zum Glück) keine Probleme, DNS-Replikation dauert immer ein bisschen im Netz ...

Hast Du mal überprüft, ob Dein Server noch alle fünf "Roles" hat (Schemen Master, Domain Naming Operation Master, RID Master, PDC und Infrastruktur Master)?

Gruß

Atti.
Mitglied: itnet04
itnet04 31.01.2005 um 10:12:50 Uhr
Goto Top
Was bedeutet in dem Fall temporär?? Kann ich es nicht einfach neu konfigurieren??
Gehen mir da meine AD einträge flöten??

die Roles sind soweit ich sehen kann vollständig!!

Was kann im schlimmsten Fall passieren, wenn ich das mache?
Mitglied: DJS
DJS 31.01.2005 um 10:25:45 Uhr
Goto Top
Also, muss nun eine REserve-Lookup Zone eingeichtet werden??

Ja ,sieht so aus.
Ich hab zwar keine Ahnung von DNS, aber 2 leidlich vermurkste Domänen übernommen. Vielleicht können dir meine jüngsten Erfahrung etwas helfen. Der DNS-Server der einen Domäne hat eine Reverse-Lookup-Zone, der der anderen nicht. Ohne Reverse-Lookup-Zone können die Clients nur dann Internetseiten laden, wenn der Router nicht nur als Gateway, sondern auch als zweiter DNS-Server eingetragen ist.
Mitglied: Atti58
Atti58 31.01.2005 um 10:41:19 Uhr
Goto Top
Wenn Dein DNS sowieso nicht funktioniert, sollten die User gar nicht merken, wenn Du den DNS deinstallierst und danach neu installierst. Du wirst vom DNS-Wizzard gleich aufgefordert, eine neue DNS-Zone einzurichten (die sollte natürlich so heißen, wie Deine alte ;-) face-wink ) und kannst danach gleich die Reverse Lookup Zone erstellen ... Sieh Dir aber vorher noch mal alle Einstellungen an, damit Du sie dann wieder replizieren kannst ...

Das mit den "neu konfigurieren" ist immer etwas problematisch - Du weißt ja nicht, was Dir der andere Server intern zerhauen hat ...

Du solltest nur sicherstellen, dass Du wirklich nur den einen DNS-Server im Netz hast. Am AD geht dabei nicht kaputt ;-) face-wink ...

Gruß

Atti.
Mitglied: itnet04
itnet04 31.01.2005 um 11:01:38 Uhr
Goto Top
Habe jetzt eine Reserve-lookup zone erstellt, hat auch geklappt :) face-smile))

Wenn ich jetzt nslookup mache, wird der Server als Standard erkannt, ich kann auch interne Clients auflösen, aber externe, wie zb google geht noch nicht, auch können keine Internetseiten angezeigt werden!!

Was muss ich denn nu noch machen????

help, help
Mitglied: Atti58
Atti58 31.01.2005 um 11:16:51 Uhr
Goto Top
Hast Du eine Zone in Deinem DNS, die nur aus einem "." besteht, wenn ja, lösche sie. Hast Du "Weiterleitung" konfiguriert auf der Eigenschaften-Seite Deiner DNS-Zone? Wenn nein, trage hier bei "Alle anderen Domänen" Deinen Router oder ISP-DNS-Server ein ...

Gruß

Atti
Mitglied: nimda65
nimda65 31.01.2005 um 11:18:52 Uhr
Goto Top
Hallo

wenn jetzt alles intern klappt fehlt die wahrscheinlich noch die Weiterleitung auf einen externen DNS Server.

Gruß
nimda
Heiß diskutierte Beiträge
info
Bundeswehr lässt Retro Funkgeräte für 600 Millionen Euro produzierenhacktorVor 1 TagInformationHardware11 Kommentare

Dachte zuerst das ist ein verspäteter Aprilscherz Die saufen da offensichtlich zu viel Club-Cola au banan. ...

question
Neue Verschlüsselung TLS 1.3eberhartIIVor 1 TagFrageDrucker und Scanner17 Kommentare

Hallo, es geht um eine Verschlüsselung, die die Telekom seit 02. September 2021 einsetzt. Ab diesem Datum müssen die E-Mails mit dem Schlüssel TLS 1.3 ...

question
Zentrales Nutzermanagement Windows ServerDeltaDragonVor 1 TagFrageWindows Server6 Kommentare

Hallo zusammen, Ich suche hier heute Euren Rat zum Thema Nutzermanagement auf einem Windows-V-Server Kenntnisse Ich bin zwar seit zehn Jahren Softwareentwickler (Java), habe jedoch ...

question
Hyper-V 2016 shutdown VM bei niedrigem Akkustand der USV gelöst keine-ahnungVor 1 TagFrageWindows Server3 Kommentare

Moin at all, mir hat es heute meine 15 Jahre alte APC Smart-UPS zerschossen - steht ihr zu, wie ich meine. Habe so ein Ding ...

question
In der Suche nach einem IPsec Lan-to-Lan Travel RouterJohanspbVor 1 TagFrageRouter & Routing4 Kommentare

Hallo zusammen, zuhause habe ich einen FritzBox 7590, auf welchem ich VPN-Server eingerichtet habe. Die Aufgabe ist folgendes: Ich reise gern und übernachte oft in ...

question
Partition reparieren, oder löschen ?Hermann73Vor 21 StundenFrageWindows 107 Kommentare

Vielleicht ist das für manche eine dumme Frage. Kann man eine defekte Partition löschen? Ich habe das Problem, dass ich auf die Partition "E" durch ...

general
Frage an die IT-Administratoren in UnternehmenFuchor2020Vor 2 StundenAllgemeinOff Topic9 Kommentare

Hallo Leute, freue mich hier im Forum dabei sein zu dürfen. Da ich noch relativ neu in der IT Branche bin, befasse ich mich aktuell ...

question
Keine Internet mit IPv6 in den VLANs (FritzBox auf SG350)derBenVor 1 TagFrageRouter & Routing5 Kommentare

Hallo zusammen, ich brauch bitte eure Hilfe im Bezug auf VLAN und IPv6. Problem: Keine Internetverbindung mit IPv6 in den VLAN´s Netzwerkaufbau: Internet (VodafoneCable + ...