Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WOL funktioniert - geht aber auch automatisch an. wieso?

Mitglied: freeuser616

freeuser616 (Level 1) - Jetzt verbinden

31.12.2016 um 12:50 Uhr, 1950 Aufrufe, 24 Kommentare

Hi all,

ich hoffe ihr könnt mir da weiter helfen..

ich habe bei mir zu hause WOL soweit eingerichtet, dass es meinen laptop (dell latitude E6330 mit aktuellem bios) von intern und extern vom sleep modus aufwecken kann.

soweit so gut..

das einzige problem...

der laptop schaltet sich aus unerklärlichen gründen nach kurzer zeit automatisch aus dem sleep modus wieder ein, obwohl von mir kein WOL signal gesandt wurde.
das passiert aber nur, wenn der laptop am netzteil angeschlossen ist. läuft dieser über den akku, schaltet er sich auch nicht automatisch ein.


kann mir jemand sagen, woran das liegen könnte.. ich habe schon überall (in den energie optionen, netwerkkarten eigenschafte und bios einstellungen) geschaut...

danke schon mal im voraus.

ps: wake timers in den energieoptionen sind ausgeschaltet.
Mitglied: aqui
31.12.2016, aktualisiert um 13:06 Uhr
Möglich das andere Events den Wakeup triggern (Bluetooth, Drucker, Tastatur, Maus usw.) Das solltest du querchecken.
Möglich auch das die NIC von jeglichem Traffic getriggert wird. Falls das der Fall ist solltest du das auf das WoL Magic Packet beschränken.

P.S.: Deine Shifttaste am Rechner ist defekt !
Solltest du mal reparieren, denn es ist nicht gerade angenehm solche Texte zu lesen. Nicht aus Rechtschreibsicht sondern schlicht von der Strukturierung !
Bitte warten ..
Mitglied: Xerebus
31.12.2016 um 13:08 Uhr
Mit powercfg -devicequery wake_armed kannst du überprüfen was alles aufwecken kann.
Bitte warten ..
Mitglied: Pjordorf
31.12.2016 um 13:52 Uhr
Hallo,

Zitat von freeuser616:
der laptop schaltet sich aus unerklärlichen gründen nach kurzer zeit automatisch aus dem sleep modus wieder ein, obwohl von mir kein WOL signal gesandt wurde.
Du kannst per Wireshark (Paketmittschnitt am Router / Switch / HUB) doch schnell Feststellen ob an dein Rechner ein WOL Paket gesendet wurde, von wem auch immer, dann hast du schnell gewissheit ob es ausschließlich an den Einstellungen deines Laptops liegt oder ab andere dir unbekannten Quellen, wie aus dem Internet (Du hast ja das Internet für WOL erlaubt - wie auch immer) das aufwecken veranlassen. Was ist wenn du das LAN Kabel entweder am Switch oder am Laptop entfernst wenn der Schläft? Wird der dann auch aufgeweckt?

Gruß,
Peter
Bitte warten ..
Mitglied: freeuser616
07.01.2017, aktualisiert um 02:43 Uhr
Also es liegt definitiv am Router (Fritz!Box 6490 von UM). Ist dieser nämlich ausgeschaltet, geht auch der Laptop nicht an.

Schalte ich den Router ein, und schließe an diesem nur den Laptop an, geht der wieder an...

Komisch finde ich, dass der Laptop nur an geht, wenn am Netzteil angeschlossen.

Weiterhin komisch finde ich, dass obwohl auf dem Router die Ports nicht aktiviert sind, welche für WOL eingerichtet wurden, der Laptop dennoch an geht.
Bitte warten ..
Mitglied: aqui
07.01.2017 um 13:16 Uhr
Schalte ich den Router ein, und schließe an diesem nur den Laptop an, geht der wieder an...
Nimm einen Wireshark und sieh dir das an was die FB da dann sendet was den PC triggert.
Es ist sehr, sehr unwahrscheinlich das die FB von sich aus durch Zauberei, ohne jegliche Konfig ein passendes WoL Paket an den PC sendet.
Sowas gehört ins Reich der Märchen ! Fazit: Mit dem Wireshark nachsehen, das schafft sofortige Klarheit !
Bitte warten ..
Mitglied: freeuser616
07.01.2017 um 23:45 Uhr
Ich werde mich mal später mit Wireshark beschäftigen..


dennoch, auch wenn es nach Märchen klingt,...
fakt ist, dass wenn der Router abgeschaltet ist, der Laptop auch aus bleibt.
Und ist die WLAN Karte aus, geht der Laptop auch nicht an.
Bitte warten ..
Mitglied: Pjordorf
08.01.2017 um 00:42 Uhr
Hallo,

Zitat von freeuser616:
Ich werde mich mal später mit Wireshark beschäftigen..
Das wird dir sagen ob du an Märchen weiterhin glauben darfst oder nicht.

fakt ist, dass wenn der Router abgeschaltet ist, der Laptop auch aus bleibt.
OK.

Und ist die WLAN Karte aus, geht der Laptop auch nicht an.
Sollte so sein.

Schalte ich den Router ein, und schließe an diesem nur den Laptop an, geht der wieder an...
Da kann ein Wireshark dir helfen. Mache mit deiner Fritte an Packettrace der betroffen Interne Schnittstelle und werte mit Wireshark aus. Dein Rechner ist ja am Schlafen....

Und ist die WLAN Karte aus, geht der Laptop auch nicht an.
Du hast also eine WLAN Karte welche per WOL einen Rechner aufwecken kann? Welche Karte ist es denn? Wie ist die und dein BIOS und dein OS denn eingestellt. Und wenn dein WOL nur dann aufweckt wenn an der Stromsteckdose könnte auf ein sonst nicht funktionierendes WLAN vom Client hinweisen. Das braucht doch einiges an Strom, alleine schon um das WLAN permanent abzuhorchen.

Da dein Rechner schläft, Paketmittschnitt auf der Fritte, die entsprechenden Interfaces mitgeschüffelt und anschließend per Wireshark auswerten.
Ob deine 6490 von UM da mitspielt? Eine 6490 direkt von AVM soll es können.
https://avm.de/service/fritzbox/fritzbox-7490/wissensdatenbank/publicati ...
http://www.wehavemorefun.de/fritzbox/Paketmitschnitt

Gruß,
Peter
Bitte warten ..
Mitglied: freeuser616
08.01.2017 um 14:27 Uhr
auf meinem Dell E6330 ist eine Intel(R) Dual Band Wireless-AC 7260 Karte eingebaut.

Laut diverser Infos aus dem Internet, ist es auch korrekt, dass WOL nicht funktioniert, wenn nicht am AC angeschlossen; was mich auch nicht weiter stört, da ständig am Netz.

In den Eigenschaften der Netzwerkkarte habe ich m.E. soweit alles richtig eingestellt. siehe Bilder...
Im BIOS habe ich festgestellt, ist es vollkommen egal, was ich dort einstelle; WOL funktioniert, egal mit welchen Einstellungen.

Leider hat die UM Fritzbox 6490 nicht die Möglichkeit wie bspw. bei der 7490, die Pakete mitzuschneiden.
Da muss ich wohl einen zusätzlichen Laptop nehmen auf dem ich Wireshark laufen lasse, während sich der eigentliche Laptop im Sleep Modus befindet.

Habe heute Nacht auch nochmal geschaut, ob sich WOL über den LAN Port genau so verhält. Über LAN Port funktioniert es aber wie gewollt. Kein automatisches Einschalten ohne vorher ein MagicPacket gesandt zu haben.

Ich kann das Ganze später auch mal mit einem anderen Laptop testen.
Denn wenn WOL an einem anderen Laptop problemlos funktioniert, dann kann es ja nur an meinem Laptop liegen.
screenshot_2017.01.08_14_02_56_001 - Klicke auf das Bild, um es zu vergrößern
screenshot_2017.01.08_14_18_19_001 - Klicke auf das Bild, um es zu vergrößern
screenshot_2017.01.08_14_18_34_001 - Klicke auf das Bild, um es zu vergrößern
screenshot_2017.01.08_14_18_43_001 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Pjordorf
08.01.2017, aktualisiert um 16:00 Uhr
Hallo,

Zitat von freeuser616:
Laut diverser Infos aus dem Internet, ist es auch korrekt, dass WOL nicht funktioniert, wenn nicht am AC angeschlossen; was mich auch nicht weiter stört, da ständig am Netz.
Kannst du selbst einstellen, aber da wird die Battery nur leergesaugt

In den Eigenschaften der Netzwerkkarte habe ich m.E. soweit alles richtig eingestellt. siehe Bilder...
http://www.intel.eu/content/www/eu/en/support/network-and-i-o/wireless- ...

Gruß,
Peter
Bitte warten ..
Mitglied: freeuser616
09.01.2017 um 12:54 Uhr
Gestern Abend dann nochmal mit einem anderen Laptop ausprobiert, und auch dort geht der Laptop nach kurzer Zeit von alleine an.

Auch ein Dell Latitude mit einer Intel Centrino Ultimate-n 6300 AGN WLAN Karte.

Also der Verursacher kann dann nur noch der Router sein.

Habe das Ganze dann nochmal mit Wireshark mitgeschnitten.. Muss es später mal in Ruhe analysieren und dann hier posten.
Bitte warten ..
Mitglied: aqui
09.01.2017 um 13:47 Uhr
Wir sind gespannt....!
Bitte warten ..
Mitglied: freeuser616
09.01.2017 um 15:39 Uhr
Also ich sehe jetzt nicht wirklich etwas, was mir da irgendwie Hilfestellung geben könnte, herauszufinden, wer der Verursacher ist.
Vielleicht sehe ich auch gerade den Wald vor lauter Bäumen nicht...
Auf jeden Fall, die IP Adresse des Laptops um den es geht ist die 192.168.111.110
1 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Pjordorf
09.01.2017 um 16:02 Uhr
Hallo,

Zitat von freeuser616:
Also ich sehe jetzt nicht wirklich etwas, was mir da irgendwie Hilfestellung geben könnte, herauszufinden, wer der Verursacher ist.
1. Wie hast du mittgeschnitten? z.b. Irgendwelche Filter beim Sammeln schon gesetzt?
2. Wo hast du mittgeschnitten? Auf den betreffenden Rechner der immer per WOL aufgeweckt wird? Wenn ja, war der nicht am Schlafen und du hast somit kein Zeitpunkt wo du sagen kannst "da müsste ein Paket im Äther gewesen sein (Zeitpunkt).
3- Womit hast du mittgeschnitten?
4. Ist das der Traffic deiner WLAN Schittstelle deines betroffenen Laptops oder dessen LAN?
5. Schon mal IPv6 an der betroffenen Netzwerkkarte deaktiviert? Aber nur wenn IPv6 bei dir im LAN keine weitere gewollte Rolle spielt.
6. Kann dein Mittschneideprogramm auch beim mittschneiden Filter anwenden? Z.B. https://wiki.wireshark.org/WakeOnLAN

Teste dein Capture Filter zuerst an deine LAN Karte, danach auf deine WLAN Schittstelle anpassen und laufen lassen. Es kann sein das du dort mehrere Stunden geduld und Daten sammeln must. Das WOL over WiFi kommt bei dir jan wohl nur nachts einmal.....

Auf jeden Fall, die IP Adresse des Laptops um den es geht ist die 192.168.111.110
Der sollte 2 IPs haben. LAN und WLAN.... Und in deinen uns geposteten Daten sind auch WOL Pakete enthalten oder? Mit den paar dürftigen Informationen ist keinerlei aussage möglich. Und da du etwas suchst was wohl nur sporadisch auftritt wenn dein Laptop schläft, wirst du mehr als 50 Datenzeilen als Protokoll haben, vor allem wenn alles Protokoliiert wird. Grenze beim Sammeln auf deine gesuchten WOL Pakete ein.

Gruß,
Peter
Bitte warten ..
Mitglied: freeuser616
11.01.2017 um 00:21 Uhr
Hi,

der Mitschnitt lief über den anderen Laptop, währen mein Laptop sich im Sleep Modus befand.
Dort habe ich Wireshark angeschmissen, und geschaut, was über die WLAN Karte für Traffic rein läuft (im Promiscuous Mode).

Hierbei habe ich zuerst den Laptop, wo WOL läuft in den Sleep Modus versetzt, und kurz bevor dieser sich wieder eingeschaltet hat, den Traffic Scan auf den anderen Laptop gestartet. Sobald der Laptop wieder an ging, habe ich den Traffic Scan wieder gestoppt.
Der Laptop geht glücklicherweise direkt nach ca. 5 - 10 Minuten an, sodass ich nicht viel Traffic aufzeichnen muss.

IPv6 habe ich auf dem Router und den WLAN Karten ausgeschaltet.
Bei so einem modifizierten UnityMedia Router, weis ich aber nicht, ob nicht doch noch etwas im Hintergrund aktiv ist, was ich über die Optionen nicht sehen bzw. abschalten kann....

Ich benutze nur die WLAN Schnittstelle an dem Laptop, weshalb die LAN Schnittstelle zu ignorieren ist. Diese hatte ich, wie zu Anfang erwähnt nur zu Testzwecken eingeschaltet.

Leider bin ich nicht allzu vertraut mit Paket Analyse und das letzte mal, dass ich Wireshark benutzt habe, ist schon einige Jahre her.

Jedoch sind mir diese beiden Pakete (siehe Bilder) aufgefallen, welche kurz bevor der Laptop automatisch wieder an ging, aufgezeichnet wurden.

Kann es sein, dass die Fritzbox von UnityMedia doch irgendwie IPv6 Pakete broadcasted?
screenshot_2017.01.11_00_16_47_001 - Klicke auf das Bild, um es zu vergrößern
screenshot_2017.01.11_00_17_07_001 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Pjordorf
11.01.2017 um 01:56 Uhr
Hallo,

Zitat von freeuser616:
Bei so einem modifizierten UnityMedia Router, weis ich aber nicht, ob nicht doch noch etwas im Hintergrund aktiv ist, was ich über die Optionen nicht sehen bzw. abschalten kann....
Nachschauen....

Jedoch sind mir diese beiden Pakete (siehe Bilder) aufgefallen, welche kurz bevor der Laptop automatisch wieder an ging, aufgezeichnet wurden.
Du wirst schon in den Packeten reinschauen müssen. So kann dir keiner sagen was tatsächlich dort enthalten ist. Wenns ein MagicPacket sein soll dann ist es evtl. an der Broadcast Addresse gerichtet, nutzt z.B. UDP (7 oder 9 oder 80 oder was auch immer der WOL Programmierer sich dachte) und enthält im Payload dann sechsmal FF und dann die Ziel MAC 16mal hintereinander. Auszug
https://de.wikipedia.org/wiki/Wake_On_LAN

Kann es sein, dass die Fritzbox von UnityMedia doch irgendwie IPv6 Pakete broadcasted?
Schau nach wer der Absender deiner IPv6 Multicast ist. Da gibbet immer noch MACs. Irgendeiner in dein LAN macht IPv6.
Hier mal ein Wireshark wo per UDP auf Port 12287 ein WOL per MagicPacket empfangen wurde.
wol received capture udp port 12287 - Klicke auf das Bild, um es zu vergrößern

Gruß,
peter
Bitte warten ..
Mitglied: freeuser616
19.01.2017 um 19:08 Uhr
Hallo Peter,

Danke für deine Hilfestellung..

Ich habe heute nochmal ein Paar Pakete mit geschnitten und das Ganze etwas gefiltert, sodass nur Pakete von und zu Router angezeigt werden.

IPv6 Pakete habe ich beim Mitschnitt keine mehr gesehen... warum auch immer... Kann mich nicht erinnern, irgendwelche weitere Änderungen diesbezüglich gemacht zu haben...

Bei beiden Tests (jedes Screenshot eins) wurden vom Laptop, wo Wireshark drauf lief, keine WOL Pakete abgefangen.

Lediglich die Pakete, die auf den Bildern zu sehen sind, kurz bevor der Laptop mit der IP Adresse 192.168.111.150 geweckt wurde.


Was mir auch wieder kurios aufgefallen ist...
Der Laptop geht nicht an, wenn ich diesen in den Sleep Modus setze,kurz aus der Docking Station entferne und wieder einstecke.
screenshot_2017.01.19_18_12_47_001 - Klicke auf das Bild, um es zu vergrößern
screenshot_2017.01.19_18_17_01_001 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
19.01.2017 um 19:14 Uhr
WoL nutz in der Regel UDP 9 (discard). Davon ist weit und breit in deinem Trace nicht ein einziges Packet zu sehen !
Bist du sicher das der Client überhaupt WoL sendet ?
Bitte warten ..
Mitglied: freeuser616
19.01.2017 um 20:58 Uhr
Eben das macht die ganze Sache ja noch merkwürdiger.

Weit und breit keine WOL Pakete zu finden beim Mitschnitt über den anderen Laptop.

WOL funktioniert ja und Pakete kommen auch an, wenn ich diese sende.
Denn wenn ich den WOL Monitor laufen lasse, kommen alle Pakete die ich sende (intern/extern) ja auch an.

Ich benutze einen alternativ Port (4343), da die NAS Port 7 bekommen hat.
Hatte es aber auch schon für den Laptop mit Port 7 getestet gehabt. Gleiche Ergebnis.

Der einzige Port, der bei mir zu Hause nicht funktioniert ist Port 9.


Gruß
Bitte warten ..
Mitglied: Pjordorf
19.01.2017 um 23:06 Uhr
Hallo,

Zitat von freeuser616:
Weit und breit keine WOL Pakete zu finden beim Mitschnitt über den anderen Laptop.
Und du siehst definitiv alle WLAN Packete.

WOL funktioniert ja und Pakete kommen auch an, wenn ich diese sende.
Wer sendet wo und womit? Alles im internen LAN? Diese Packete kannst du im Mitschnitt sehen?

Denn wenn ich den WOL Monitor laufen lasse, kommen alle Pakete die ich sende (intern/extern) ja auch an.
Welchen WOL Monitor? Wie viel Zoll Diagonale hat der denn?

Ich benutze einen alternativ Port (4343), da die NAS Port 7 bekommen hat.
Von extern auf deine Fritte (WAN) oder intern in denin LAN / WLAN? Du brauchst nicht für jedes Gerät einen eigenen Port. Das geht immer an die Braodcast Adresse und enthält nach 6 mal FF dann noch 16 mal die Ziel MAC wenn es WOL per Magic Packet sein soll.

Hatte es aber auch schon für den Laptop mit Port 7 getestet gehabt. Gleiche Ergebnis.
Womit bzw. was erzeugt denn dein Magic Packet? Kannst du das denn im Packetmittschnitt sehen?

Der einzige Port, der bei mir zu Hause nicht funktioniert ist Port 9.
Von Extern oder intern? Am Sender des WOL oder beim Empfänger. Was ist denn bei dir Port 9 am nutzen?

Du kannst auch von der Fritten GUI das WOL auslösen wenn der Laptop läuft. Dann muss sich das Packet aufzeichnen lassen. Nutzt du die Funktion "Automatischen Computerstart bei Internetzugriff" der Fritte? Sicher das dort nicht ein Portscan an dein WAN Port das WOL auslößt?

Warum keine einwahl per VPN auf deine Fritte, die GUI starten und manuell das WOL für den Rechner auslösen? Dann kann auch kein Portscan ....

Es macht kein Sinn Packetmittschnitte zu analysieren wenn du nicht weisst wonach du suchst.

Gruß,
Peter
Bitte warten ..
Mitglied: freeuser616
20.01.2017 um 10:33 Uhr
Zitat von Pjordorf:

Hallo,

Zitat von freeuser616:
Weit und breit keine WOL Pakete zu finden beim Mitschnitt über den anderen Laptop.
Und du siehst definitiv alle WLAN Packete.

alle, bis auf die SSDP Pakete sowie der Traffic von der NAS zum Router und umgekehrt



WOL funktioniert ja und Pakete kommen auch an, wenn ich diese sende.
Wer sendet wo und womit? Alles im internen LAN? Diese Packete kannst du im Mitschnitt sehen?

Ich sende die Pakete über mein Handy sowohl über LAN als auch WAN und diese sind dann auch alle im Wireshark zu sehen.


Denn wenn ich den WOL Monitor laufen lasse, kommen alle Pakete die ich sende (intern/extern) ja auch an.
Welchen WOL Monitor? Wie viel Zoll Diagonale hat der denn?

ich hab mal ausgemessen.. der WOL Monitor ist 6,5" groß
Bild liegt im Anhang!


Ich benutze einen alternativ Port (4343), da die NAS Port 7 bekommen hat.
Von extern auf deine Fritte (WAN) oder intern in denin LAN / WLAN? Du brauchst nicht für jedes Gerät einen eigenen Port. Das geht immer an die Braodcast Adresse und enthält nach 6 mal FF dann noch 16 mal die Ziel MAC wenn es WOL per Magic Packet sein soll.

Ich brauche WOL eigentlich nur um von Extern die Systeme hochzufahren.
Wenn ich nicht für jedes einzelne Gerät eine eigene Port Nummer belegen muss, wie definiere ich denn dann auf der Fritzbox entsprechend die Portfreigabe damit ich von extern die Geräte hochfahren kann?
Muss ich dann einfach unter Portfreigabe die 192.168.111.255 als IP definieren?



Hatte es aber auch schon für den Laptop mit Port 7 getestet gehabt. Gleiche Ergebnis.
Womit bzw. was erzeugt denn dein Magic Packet? Kannst du das denn im Packetmittschnitt sehen?
Wie bereits oben erwähnt, benutze ich zum generieren diverse Tools auf meinem Handy sowohl mit LAN als auch mit WAN Verbindung.
Die Tools funktionieren sehr zuverlässig!
Und wenn ich ein Magic Packet sende, kommt dieses auch sofort auf dem Laptop an und wird auf dem WOL Monitor und Wireshark entsprechend angezeigt.


Der einzige Port, der bei mir zu Hause nicht funktioniert ist Port 9.
Von Extern oder intern? Am Sender des WOL oder beim Empfänger. Was ist denn bei dir Port 9 am nutzen?

Sowohl Intern als auch Extern.
Port 9 wird bei mir nicht anderweitig verwendet.
Für WOL werden ja grundsätzlich Port 7 und 9 verwendet, und beim Einrichten der ganzen WOL Thematik hatte ich beide Ports getestet und festgestellt, dass Port 9 nicht funktioniert. Ist ja auch nicht weiter tragisch, solange andere Ports für WOL funktionieren.


Du kannst auch von der Fritten GUI das WOL auslösen wenn der Laptop läuft. Dann muss sich das Packet aufzeichnen lassen.

Die Funktion gibt es auf der Fritzbox zwar, wenn ich unter Heimnetz auf die einzelnen Systeme draufgehen, jedoch nur für Kabelgebundene Geräte.

Nutzt du die Funktion "Automatischen Computerstart bei Internetzugriff" der Fritte? <
Diese Option gibt es nicht auf meiner Fritzbox.

Sicher das dort nicht ein Portscan an dein WAN Port das WOL auslößt? <
Wenn es so wäre, dann müsste der Wireshark dies ja sehen.

Warum keine einwahl per VPN auf deine Fritte, die GUI starten und manuell das WOL für den Rechner auslösen? Dann kann auch kein Portscan ....

Das würde das Problem nicht beheben, weil die Netzwerkkarte ja trotzdem Magic Packets empfangen muss um den Laptop hochzufahren, und der Laptop sich von alleine hochfährt, auch wenn ich die Portregeln für WOL von der Fritzbox lösche. Alles schon getestet.
Ging der letzte Satz von dir noch weiter?


Es macht kein Sinn Packetmittschnitte zu analysieren wenn du nicht weisst wonach du suchst.<
Dem stimme ich teilweise zu.



....
Wenn man das Ganze mal genauer betrachtet, könnte man ja behaupten, dass es nicht unbedingt an der Fritzbox liegen muss...
aber .. wieso gehen die diversen Geräte, bei denen ich es getestet habe nur von alleine an, wenn ich die Fritzbox eingeschaltet habe?
Ist die Fritzbox aus, besteht das Problem ja nicht!
screenshot_2017.01.20_09_52_44_001 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
20.01.2017 um 15:23 Uhr
sowohl über LAN als auch WAN
WAN kann eigentlich nicht funktionieren, denn WoL sind UDP Broadcasts die niemals geroutet werden. Oder sollte das WAN ein WLAN sein ?
Für WOL werden ja grundsätzlich Port 7 und 9 verwendet,
Nein !
Niemals zusammen sondern nur entweder oder !! Wenn dein Client ein UDP 9 sendet der Empfänger erwartet aber UDP 7 kommen die logischerweise niemals zueinander.
Normal ist UDP 9 (Discard). 7 eher ungewöhnlich aber letztlich kosmetisch wenn beide Seiten den gleichen Port nutzen.
Ist die Fritzbox aus, besteht das Problem ja nicht!
Wenn diese Schlussfolgerung richtig wäre, dann müsste die FB ja aktiv in das Layer 2 Format der WoL Frames eingreifen und dort Daten manipulieren !
Das müsstest du mit dem Wireshark ja ganz klar zeigen können wenn du am Empfänger mitsifferst. Dort müssten WoL Pakets ohne FB im Netz anders aussehen als mit.
Theoretisch ist das möglich, denn die WoL Pakete sind ja UDP Broadcasts mit einer 255.255.255.255 all IP Broadcast Adresse.
Der embeddete 4Port Switch in der Fritzbüx MUSS zwangsweise diesen Frame 3mal kopieren und an den anderen Ports raussenden wie es für Broadcasts üblich ist.
Wenn sie da was mainpulieren würde hätte das schon ein Geschmäckle...!
Bitte warten ..
Mitglied: freeuser616
20.01.2017, aktualisiert um 21:17 Uhr
Zitat von aqui:

sowohl über LAN als auch WAN
WAN kann eigentlich nicht funktionieren, denn WoL sind UDP Broadcasts die niemals geroutet werden. Oder sollte das WAN ein WLAN sein ?

Da muss ich dir aber widersprechen, denn WOL über WAN funktioniert sehr wohl...
wieso sollte das auch nicht funktionieren..


Für WOL werden ja grundsätzlich Port 7 und 9 verwendet,
Nein !
Niemals zusammen sondern nur entweder oder !! Wenn dein Client ein UDP 9 sendet der Empfänger erwartet aber UDP 7 kommen die logischerweise niemals zueinander.
Normal ist UDP 9 (Discard). 7 eher ungewöhnlich aber letztlich kosmetisch wenn beide Seiten den gleichen Port nutzen.

Natürlich war gemeint, dass entweder Port 7 OOOODDDEEERRR Port 9 genutzt wird/wurde.
Ist doch logisch, dass das niemals zusammen funktioniert. Sorry, wie sollte das auch funktionieren..
Dennoch, habe gelesen, dass es eher sinnvoll ist Port 9 anstatt Port 7 zu benutzen, weshalb ich nochmal versuchen werde, es auf Port 9 umzustellen....

Nachtrag.: ich habe mittlerweile versucht das Ganze nochmal über Port 9 laufen zu lassen... Es geht einfach nicht..
Alle Geräte im Haus kann ich über LAN und WAN (jaaa. WAN und nicht WLAN) aufwecken... egal mit welchem Port..
Ob Port 4343.. Port 7... Port 99 ... was auch immer... alle funktionieren, außer Port 9.
Selbst dann nicht, wenn ich das Zielgerät in die DMZ packe.

Ist die Fritzbox aus, besteht das Problem ja nicht!
Wenn diese Schlussfolgerung richtig wäre, dann müsste die FB ja aktiv in das Layer 2 Format der WoL Frames eingreifen und dort Daten manipulieren !
Das müsstest du mit dem Wireshark ja ganz klar zeigen können wenn du am Empfänger mitsifferst. Dort müssten WoL Pakets ohne FB im Netz anders aussehen als mit.
Theoretisch ist das möglich, denn die WoL Pakete sind ja UDP Broadcasts mit einer 255.255.255.255 all IP Broadcast Adresse.
Der embeddete 4Port Switch in der Fritzbüx MUSS zwangsweise diesen Frame 3mal kopieren und an den anderen Ports raussenden wie es für Broadcasts üblich ist.
Wenn sie da was mainpulieren würde hätte das schon ein Geschmäckle...!
naja.. schwierig zu testen... ist die fritzbox nämlich aus, nützt auch der broadcast nichts..
Bitte warten ..
Mitglied: aqui
21.01.2017, aktualisiert um 13:20 Uhr
denn WOL über WAN funktioniert sehr wohl...
De facto Nein !
Oder nur sehr bedingt mit ziemlichen Klimmzügen über Proxy. Guckst du hier:
https://www.heise.de/ct/artikel/Wake-on-WAN-221718.html
Liegt aber eigentlich auch auf der Hand wenn man weiss wie sich UDP Broadcasts in einem gerouteten IP Netz standardmässig verhalten !
weshalb ich nochmal versuchen werde, es auf Port 9 umzustellen....
Das kannst du gar nicht. Jedenfalls nicht beim Empfänger, denn auf welchen Port der "hört" ist im Prom der Netzwerkkarte bzw. des Chipsets eingebrannt und somit Teil der Hardware. Das dürfte dann schon eine Herausforderung sein sowas zu verändern ?!
Selbst dann nicht, wenn ich das Zielgerät in die DMZ packe.
Das kann dann technisch auch niemals klappen, denn dann hast du eine geroutete Firewall Umgebung wo UDP Broadcasts wieder NICHT passieren können.
Wenigstens nicht eine eine UDP Relay oder Helper Funktion auf dem Router !!
naja.. schwierig zu testen... ist die fritzbox nämlich aus, nützt auch der broadcast nichts..
Du könntest ja mal einen billigen 5 Euro LAN Switch aus dem Blödmarkt verwenden statt des embeddeten der FB !!
Bitte warten ..
Mitglied: Pjordorf
21.01.2017 um 21:19 Uhr
Hallo,

Zitat von freeuser616:
Da muss ich dir aber widersprechen, denn WOL über WAN funktioniert sehr wohl...
Sobald ein Router da im wege ist der Broadcasts verwirft, geht es nicht mehr. Und dein Fritte auch das. Es geht native und ohne andere mechanismen nicht. Das ist fakt und auch Design vom Internet so gewollt und geplant. Da kommst auch du nicht dran vorbei, egal mit welcher und unbekannter Software du das von dein z.B. Smartphone versuchst.

wieso sollte das auch nicht funktionieren..
Das steht in allen Lektüren zum WOL und in allen Lektüren welche Broadcasts und Router in einen Satz verwenden drin. Lies dich erst mal in den TCP/IP Grundlagen ein.

Nachtrag.: ich habe mittlerweile versucht das Ganze nochmal über Port 9 laufen zu lassen... Es geht einfach nicht..
Weil deine Fritte es nicht zulässt, so wie fast jeder heimrouter. Da wird die Fritten eigene WOL Funktion sich den Port freihalten und nutzen sodass der anderweitig nicht genutzt werden kann.

Alle Geräte im Haus kann ich über LAN und WAN (jaaa. WAN und nicht WLAN) aufwecken... egal mit welchem Port..
Aber nur weil du andere Mechanism einbindest. Ich frage mich nur wie du den WOL Empfänger adressierst. Ein Portforwarding auf einer MAC kann die nicht. Wie also macht deine Fritte das dann?

Selbst dann nicht, wenn ich das Zielgerät in die DMZ packe.
DMZ? Fritte und DMZ? Hast du deine Fritte selbst zusammengelötet? Eine Fritte kann maximal ein DMZ Host ansprechen, aber es kennt keine DMZ. Was also tust du dort?

Ist die Fritzbox aus, besteht das Problem ja nicht!
Und was passiert wenn n ur das WLAN deiner Fritte aabgeschaltet wird? Du weckst doch deine Clients perr WWOL (WLAN-WOL oder WOL over WLAN) auf?

Du kannst dein WWOL Pakte am betreffenden Client per Wireshark mitsniffen, auch wenn dieser Client eingeschaltet ist. Das Packet bewirkt dann einfach nichts. Gesendet und Empfangen wird es trotzdem.

Gruß,
Peter
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
Wake-On-Lan (WOL) funktioniert nicht
gelöst Frage von dehein2Netzwerkmanagement3 Kommentare

Hallo zusammen, ich nutze schon eine Weile WOL um meinem PC aufzuwecken. Nun klappt es "plötzlich" nicht mehr nachdem ...

Windows Server

AD Gastkonto unter Win10 funktioniert nicht, wieso?

Frage von McLionWindows Server2 Kommentare

Hallo, ich habe drei Win7 und ein Win10 PCs in einer Domäne. Das Gastkonto ist aktiviert und funktioniert unter ...

Router & Routing

WOL über zwei Router - Ping funktioniert nicht

gelöst Frage von erdmeloneRouter & Routing3 Kommentare

Hallo zusammen, Ich habe vor meinen Rechner im Heimnetzwerk mit WOL so einzurichten, dass ich on überll her ihr ...

Netzwerkmanagement

WOL herunterfahren ?

gelöst Frage von HenereNetzwerkmanagement8 Kommentare

Servus zusammen, ich suche aktuell nach einer Lösung für WOL auf einem HP Pavillon Power Laptop 15-cb0NG. Dabei bin ...

Neue Wissensbeiträge
E-Books

Ausgewählte Rheinwerk-Bücher jetzt online lesen! Kostenfrei

Information von Maxima2005 vor 1 TagE-Books1 Kommentar

Vielleicht hat ja jemand Interesse sein Wissen zu erweitern. Ausgewählte Rheinwerk-Bücher jetzt online lesen! Grüße Max

Instant Messaging
Jitsi Meet - April Update verfügbar
Information von Frank vor 1 TagInstant Messaging4 Kommentare

Im Rahmen des April-Updates erhält Jitsi Meet mehrere interessante Features. Anwender können nun nicht mehr nur ihren Bildschirm, sondern ...

Rechtliche Fragen

Rechtliche Grundlagen: Datenschutz und Datensicherheit im Homeoffice

Information von AnkhMorpork vor 2 TagenRechtliche Fragen

Sollte bekannt sein, aber

Router & Routing
"Upgrade" Fritte 7520 zu Fritte 7530 :-)
Information von Lochkartenstanzer vor 2 TagenRouter & Routing6 Kommentare

Moin, wie sich herausgestellt hat, ist die 7520 eine per Software kastrierte Version der 7530. Per "Chiptuning", um es ...

Heiß diskutierte Inhalte
Server-Hardware
Wie viel Speicher braucht eine Wissensdatenbank für bis zu 50 User?
Frage von Mrhallo19981Server-Hardware39 Kommentare

Hallo, könnt ihr mir sagen wieviel Speicherplatz eine Wissensdatenbank braucht (die physikalisch speichert, also nicht mit einer Datenbank zusammen) ...

Festplatten, SSD, Raid
Festplatten Datenvernichtung Server
Frage von survial555Festplatten, SSD, Raid30 Kommentare

Hallo, ich habe noch ein paar alte Server, wo ich die verbauten Festplatten gerne datentechnisch "sicher" löschen möchte. Leider ...

Linux
Internetprobleme mit Wine für Linux um .exe Dateien auszuführen
Frage von WinLiCLILinux22 Kommentare

Hallo zusammen, ich möchte auf meinem debian 10 einen client für cloud-telefonie (cloud pbx) installieren, den es nur für ...

Server-Hardware
Dimensionierung Server-Hardware
Frage von MurpelServer-Hardware17 Kommentare

Moin Moin, ich möchte einen Server besorgen und aufsetzen. Auf dem Server soll Branchensoftware laufen, auf die 4-6 Nutzer ...