Zugriff auf WindowsXP-Freigabe nur per Eingabeaufforderung möglich

altmetaller
Goto Top
Hallo,

ich installiere gerade in einer VM WindowsXP; um dort eine "antike" Anwendung zu betreiben. Mit dieser werden historische Dokumente (falls noch einmal benötigt) geöffnet und peus á peus in ein neues Format konvertiert. Die VM hat und bekommt grundsätzlich keinen Internetzugriff, teilt sich aber ein separates Netz mit dem Host.

In der XP-VM habe ich einen Ordner freigegeben, auf dem Host (Windows 10 1903) ist SMBv1 installiert.

Wenn ich mit dem Windows-Explorer vom Host via \\xp-vm\Freigabe auf die Freigabe zugreife, bekomme ich die Meldung, dass die Zugangsdaten falsch sind.

Wenn ich vorab via Eingabeaufforderung das hier eingebe, funktioniert der Zugriff:

Ich habe die Zugangsdaten auf dem Host gespeichert:

Im Ergebnis kann ich die Freigabe jetzt auch ohne Zugangsdaten via "net use" ansprechen, um zukünftigen Zugriff via Explorer zu ermöglichen:

Aaaaber: Sobald ich neu boote, ist (wieder) alles "vergeben und vergessen". D.h., ich muss immer einen Umweg über "net use" gehen um danach mit dem Explorer Zugriff zu erhalten.

Warum ist das so?

Gruß,
Jörg

P.S.: Bitte keine Diskussionen bezüglich Windows XP. Ich weiß, was ich tue, warum ich es tue und wie ich das Ganze absichere.

Content-Key: 516100

Url: https://administrator.de/contentid/516100

Ausgedruckt am: 18.08.2022 um 22:08 Uhr

Mitglied: Penny.Cilin
Penny.Cilin 16.11.2019 um 12:27:00 Uhr
Goto Top
Hallo,

die Firewall auf der XP VM ist ausgeschaltet?
Von welche Virtualisierungslösung ist die Rede (du weißt schon - fehlende Informationen face-wink )
Ok, mal so nebenbei - Du greifst via UNC auf die Freigabe zu. Hast Du es mal mit einem Laufwerksbuchstaben versucht?

Gruss Penny.
Mitglied: altmetaller
altmetaller 16.11.2019 um 13:37:13 Uhr
Goto Top
Hallo,

mit der Firewall hat das nichts zu tun - es funktioniert ja, wenn ich "net use" anwende. Ich habe die Firewall aber auch mal testweise ausgeschaltet face-smile

Wenn ich die Freigabe als Laufwerk mounte, habe ich ebenfalls Erfolg. Aber das möchte ich ja nicht, da die VM nur selten läuft.

Ich habe versucht, das Share via Windows-Explorer zu verbinden (um hier die Abfrage / Speicherung der Zugangsdaten via GUI zu erzwingen). Das schlägt ebenfalls fehl.

Es erweckt fast dein Eindruck, als wenn der Zugriff via "net use" für das Share eine Art Fallback auf ein älteres Authentifizierungsverfahren auslöst, dass aber nur bis zum nächsten Neustart vorgehalten wird.

Die VM läuft wie gesagt unter Windows 10 1903 (Hyper-V).

Gruß,
Jörg
Mitglied: godlie
godlie 16.11.2019 um 14:39:52 Uhr
Goto Top
Hallo,
was hindert dich daran einfach ein batch Script mit dem net use in den Autostart zu hängen?
Mitglied: Visucius
Visucius 16.11.2019 aktualisiert um 14:57:55 Uhr
Goto Top
Naja, das ist ja nicht so wirklich smart ;)

Bin begeistert, dass das geht. Ich hatte irgendwo gelesen, dass XP nicht auf HyperV virtualisiert werden kann. Da fallen mir gleich ein paar Oldtimer ein, die ich ausmiste.

(Danke für die Inspiration - wenn es auch keine Hifle für Dein Problem darstellt face-wink
Mitglied: altmetaller
altmetaller 16.11.2019 um 15:55:06 Uhr
Goto Top
Hallo,

ganz einfach - ich benötige das wirklich nur extrem selten und es weckt ja auch irgendwie meine Neugierde.

Gruß,
Jörg
Mitglied: lh2jo7zQhl
lh2jo7zQhl 16.11.2019 aktualisiert um 19:51:21 Uhr
Goto Top
Lieber Jörg,

das hört sich verdächtig danach an, dass dein Host SMBv1 nicht voll erlaubt bzw der Explorer im Host SMBv1 nicht verwendet. Du schreibst, SMBv1 hast du am Host installiert, eventuell gibt es noch eine Richtlinie/Einstellung, an die du ran musst. Schau dir mal auf der MS Site zu SMBv1 "Erkennen, Aktivieren und Deaktivieren von SMBv1, SMBv2 und SMBv3 in Windows und Windows Server" den Part mit der Registry an (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters, sowie HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\mrxsmb10), welchen du für den Win10 Host ggf. anpassen musst.

Ich freu mich auf einen Test und Feedback.

LG,
Jens
Mitglied: Dilbert-MD
Dilbert-MD 16.11.2019 um 22:41:19 Uhr
Goto Top
Zitat von @altmetaller:
ich benötige das wirklich nur extrem selten

Hallo,
wäre Windows 7 + XP-Modus eine Option?
Mitglied: altmetaller
altmetaller 16.11.2019 um 23:59:18 Uhr
Goto Top
Hallo,

danke - da werde ich mal draufschauen. Wichtig ist mir natürlich, dass es kein "generelles Fallback" gibt. D.h., der Host sollte natürlich immer die aktuellstmögliche SMB-Version für das jeweilige Share nutzen.

Gruß,
Jörg
Mitglied: NordicMike
NordicMike 17.11.2019 aktualisiert um 00:31:26 Uhr
Goto Top
Zitat von @Visucius:
Bin begeistert, dass das geht. Ich hatte irgendwo gelesen, dass XP nicht auf HyperV virtualisiert werden kann.

Wo hast Du das gelesen? Auf Der Postilion?
Mitglied: lh2jo7zQhl
lh2jo7zQhl 17.11.2019 um 02:34:50 Uhr
Goto Top
Lieber Jörg,

bisher ging ich stets davon aus, dass WinXP alleinig SMBv1 kann. Und Win10 SMBv1 von Hause aus nicht und nur mit Sonderbehandlung (nachinstallieren, konfigurieren).

Hast du es geschafft, WinXP SMBv2 und v3 beizubringen? Den Weg würde ich gern kennen.

LG,
Jens
Mitglied: Penny.Cilin
Penny.Cilin 17.11.2019 um 10:12:01 Uhr
Goto Top
Zitat von @lh2jo7zQhl:

Hast du es geschafft, WinXP SMBv2 und v3 beizubringen? Den Weg würde ich gern kennen.
Wie kommst Du darauf, daß in der Vm (WinXP) SMBv2 resp. v3 aktiviert wurde?
Davon wurde nie etws geschrieben.

LG,
Jens

Gruss Penny.