Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Zwei Teilnetzwerke - eins davon soll über zweites ins Internet

Mitglied: slickwilly2000
Hallo,


ich hätte folgendes Problem.

Ich habe insgesamt 3 PC's in meinem Haus.


Diese 3 PC's sind allesamt noch mit einem alten BNC-Kabel verkabelt. Dieses 10Mbit-Netzwerk funktioniert einwandfrei. Die IP-Adressen sind statisch:

PC1: 192.168.1.1 (BNC)
PC2: 192.168.1.2 (BNC)
PC3: 192.168.1.3 (BNC)


Und da ich erst seit neuem DSL habe, soll jetzt eine Änderung am PC1 erfolgen:


PC1 erhält eine neue WEITERE Netzwerkkarte, diese erhält ebenfalls eine statische IP, aber aus einem anderen Bereich.

PC1: (Windows XP Professional)
LAN1: 192.168.0.1 (RJ-45 an Router)
LAN2: 192.168.1.1 (BNC, keine Änderung, wie gehabt)

PC2: 192.168.1.2 (BNC, keine Änderung, wie gehabt)
PC3: 192.168.1.3 (BNC, keine Änderung, wie gehabt)


LAN1 von PC1 wird über RJ-45 an den Router (192.168.0.254) angeschlossen. Folgende Einstellungen habe ich unter Windows XP Professional am PC1 vorgenommen:

IP: 192.168.0.1
Subnet: 255.255.255.0
Gateway: 192.168.0.254
DNS: 192.168.0.254

Damit komme ich wunderbar ins Internet.



Mein Problem liegt jetzt darin, daß sowohl PC2 also auch PC3 ins Internet können sollen. Hier liegen ja im Endeffekt zwei separate Netzwerke vor, also 192.168.0.? und 192.168.1.?



Bin jetzt schon mehrere Stunden damit beschäftigt und habe mich auch mit dem Thema Bridge/Brücke unter Windows XP auseinander gesetzt. Allerdings verstehe ich das Prinzip, welches da dahintersteckt nicht. Oder geht das in diesem Fall überhaupt nicht mit der Brücke? Evtl. doch routen?


Es wäre sehr nett, wenn mir jemand eine Lösung für dieses Problem geben könnte.


Am besten in dieser Form, damit ich die Daten in die jeweiligen Felder der Netzwerkkarten eintragen kann.

PC1:

LAN1:
IP:
Subnet:
Gateway:
DNS:

LAN2:
IP:
Subnet:
Gateway:
DNS:

Brücke: (auch hier kann man Daten eintragen)
IP:
Subnet:
Gateway:
DNS:



PC2:
IP:
Subnet:
Gateway:
DNS:

PC3:
IP:
Subnet:
Gateway:
DNS:



Vielleicht verstehe ich dann an diesem Beispiel das Prinzip.


Vielen Dank im voraus


Mfg
slickwilly2000

Content-Key: 5642

Url: https://administrator.de/contentid/5642

Ausgedruckt am: 27.09.2021 um 08:09 Uhr

Mitglied: Atti58
Atti58 15.01.2005 um 14:31:32 Uhr
Goto Top
Zuerst einmal ein großes Kompliment, an Deiner Beschreibung ist kaum etwas auszusetzen, wenn alle so wären, hätten wir es wesentlich leichter...

Die erste Frage: Warum nimmst Du zwei unterschiedliche Netze? Wenn alle Netzwerkkarten in einem Netz wären, wäre es sicher einfacher:

PC1:

LAN1:
IP: 192.168.0.1 (an Router 192.168.0.254)
Subnet: 255.255.255.0
Gateway: 192.168.0.254
DNS: 192.168.0.254

LAN2:
IP: 192.168.0.2
Subnet: 255.255.255.0
Gateway: ohne
DNS: 192.168.0.254

Brücke: (auch hier kann man Daten eintragen) - keine
IP:
Subnet:
Gateway:
DNS:



PC2:
IP: 192.168.0.3
Subnet: 255.255.255.0
Gateway: 192.168.0.254
DNS: 192.168.0.254

PC3:
IP: 192.168.0.4
Subnet: 255.255.255.0
Gateway: 192.168.0.254
DNS: 192.168.0.254

Wenn Du das nicht möchtest, poste bitte wieder,

Gruß

Atti
Mitglied: slickwilly2000
slickwilly2000 15.01.2005 um 17:00:04 Uhr
Goto Top
Hi,

erstmal danke für deine Antwort!
Ich werde das jetzt gleich mal probieren...


Warum ich zwei Netze benutze hat folgenden Grund:
Im PC1 sind ja zwei Netzwerkkarten verbaut, eine für den Router über RJ45 und eine für die anderen 2 PC's über BNC. Wenn jetzt beide im selben Netz/IP-Bereich liegen, dann weiß PC1 ja nicht mehr, über welches Netz er ins Internet gehen soll?


Eines habe ich aber an deiner Beschreibung nicht ganz verstanden! Muß ich jetzt eine Brücke einrichten zwischen den beiden Karten in PC1 oder nicht und einfach nur keine Daten in den IP-Einstellungen oder die Brücke erst gar nicht einrichten? Deine Antwort kann man leider zweideuten.


Und wie würde die Konfiguration aussehen, wenn ich die beiden bestehenden/verschiedenen Netze beibehalten möchte?


Besten Dank im Voraus

Mfg
slickwilly2000
Mitglied: Atti58
Atti58 15.01.2005 um 22:20:09 Uhr
Goto Top
Warum ich zwei Netze benutze hat folgenden
Grund:
Im PC1 sind ja zwei Netzwerkkarten verbaut,
eine für den Router über RJ45 und
eine für die anderen 2 PC's über
BNC. Wenn jetzt beide im selben
Netz/IP-Bereich liegen, dann weiß PC1
ja nicht mehr, über welches Netz er ins
Internet gehen soll?

Wieso? es gibt nur ein Netz ...


Eines habe ich aber an deiner Beschreibung
nicht ganz verstanden! Muß ich jetzt
eine Brücke einrichten zwischen den
beiden Karten in PC1 oder nicht und einfach
nur keine Daten in den IP-Einstellungen oder
die Brücke erst gar nicht einrichten?
Deine Antwort kann man leider zweideuten.

Nein, keine Brücke einrichten ...



Und wie würde die Konfiguration
aussehen, wenn ich die beiden
bestehenden/verschiedenen Netze beibehalten
möchte?

... dann musst Du auf dem PC1 folgende statischen Routen einrichten:

route add -p 192.168.0.1 mask 255.255.255.255 192.168.1.1
route add -p 192.168.1.0 mask 255.255.255.0 192.168.0.1


LAN2:
IP: 192.168.1.1 (2) (3)
Subnet: 255.255.255.0
Gateway: ()(192.168.1.1)(192.168.1.1)
DNS:192.168.1.1

Gruß

Atti

PS: Angaben auf Grund der Zeit unter Vorbehalt ;-) face-wink ...
Mitglied: slickwilly2000
slickwilly2000 15.01.2005 um 23:05:09 Uhr
Goto Top
Hi,

ich hab es jetzt hinbekommen, aber ein bisschen anders, als du mir es vorgeschlagen hast.

Auf PC1 eine Brücke eingerichtet, und zwar zwischen den beiden Netzwerkkarten. Brücke heißt ja in dem Sinn nichts anderes, als daß die beiden Karten zu einer zusammengefasst werden.

PC1 Brücke:
IP: 192.168.0.1
Subnet: 255.255.255.0
Gateway: 192.168.0.254 (Router)
DNS: 192.168.0.254 (Router)


Wenn diese Brücke aktiv ist, dann kann man für die einzelnen Karten keine jeweiligen IP-Adresse vergeben, was ja auch logisch ist, denn die beiden Karten werden, wie bereits oben erwähnt zu einer zusammengefasst.

PC2:
IP: 192.168.0.2
Subnet: 255.255.255.0
Gateway: 192.168.0.254 (Router)
DNS: 192.168.0.254 (Router)


PC3:
IP: 192.168.0.3
Subnet: 255.255.255.0
Gateway: 192.168.0.254 (Router)
DNS: 192.168.0.254 (Router)



Jetzt funktioniert das einwandfrei, daß alle Rechner ins Netz können.

Trotzdem danke für deine Bemühungen, aber in deiner Variante ging das leider nicht.


Mfg
Alex
Mitglied: Atti58
Atti58 16.01.2005 um 11:18:29 Uhr
Goto Top
Schön, dass es läuft, so ganz kann ich allerdings nicht nachvollziehen, was bei meinen Vorschlägen nicht geklappt hat ... na ja, das leidige Thema "ROUTING" ;-) face-wink ...

Tust Du mir zum Abschluss dieses Threads noch einen Gefallen und postest mal den Inhalt der Textdateien ipconfig.txt und route.txt, die Du erstellst, wenn Du auf PC 1 in der Eingabeaufforderung eingibst:

"ipconfig /all >C:\ipconfig.txt"

"route print >C:\route.txt.txt"

Danke und schönen Sonntag,

Atti.
Mitglied: bonanza2002
bonanza2002 01.04.2007 um 15:16:30 Uhr
Goto Top
Hallo,

den Beitrag gibt es zwar schon eine weile, aber ich hoffe das dieser noch nicht geschlossen ist und hier mir noch hilfe angeboten werden kann.

Ich habe eigentlich fast das gleiche Problem, aber konnte auch nach dieser Anleitung mein Problem nicht lösen.

Ich habe einen Router, ein PC, ein Laptop.

Router

IP 192.168.0.254

PC
LAN-Adapter-1 (verbunden mit Router)
192.168.0.2
255.255.255.0
192.168.0.254
192.168.0.254


LAN-Adapter-2
192.168.0.1
255.255.255.0

Laptop
Lan-Adapter
192.168.0.3
255.255.255.0
192.168.0.254
192.168.0.254

Ich habe es auch schon geschafft, das der Laptop die IP automatisch bezieht. Aber habe keine Verbindung zum Internet mit dem Laptop bekommen.

Ich habe gerade mal 2 LAN-Adapter. Die müssen sich doch problemlos miteinander verbinden, routen, britgen lassen.

Ich möchte keine XP Netzwerkbrücke erstellen. Ich möchte manuell Routen. Mein ziehl ist es dann mal mit einer WLan ad-hoc Verbindung den Laptop in ein LAN einzubinden.

Also nochmal ganz kurz...
Ich benötige für jeden Adapter...
IP, Mask, GW, DNS
was kann ich noch mit "route add" erreichen? Benötige ich das unbedingt?
Windows hat ja das Problem mit der 192.168.0.1 als "muß-Gateway"
Muß ich das Häckchen setzen bei Internetfreigabe? Wenn ja, bei welchem Adapter?

Gruß Bonanza
Mitglied: Atti58
Atti58 01.04.2007, aktualisiert am 18.10.2012 um 18:31:48 Uhr
Goto Top
So kann das nicht gehen, wenn in einem Rechner zwei Netzwerkkarten im selben Netz hängen, kann die zweite nie angesprochen werden, siehe hier:

https://www.administrator.de/links/call_link_frame.php?nr=798adccbea4dab ...

Sieh Dir mal mein Tutorial hier:

https://www.administrator.de/wissen/zwei-netze-%c3%bcber-wlan-miteinande ...

an und denke Dir das WLAN einfach als LAN,

Gruß

Atti.
Mitglied: bonanza2002
bonanza2002 02.04.2007 um 00:27:45 Uhr
Goto Top
Danke, danke, danke,

die Bilder der Netzwerke mit der Beispielkonfiguration aus dem 2. Link haben mir gefehlt.

Ich habe bei dem LAN-Adapter, der mit dem Laptop verbunden war immer eine IP und alles mögliche eingetragen.

Den 1. Link werde ich mir mal in einer ruhigen Minute komplett und genau durchlesen.

Ich wollte zwar keine Netzwerkbrücke erstellen, da ich die Hintergründe einer Netzwerkbrücke lernen und verstehen wollte. Aber so ist es erstmal nach Tagelangem "Versuch und Irrtum" ein Lichtblick.

Der Laptop bezieht jetzt sogar seine IP automatisch.

Kennst Du vielleicht auch noch so super Links, wo mir die Netzwerkbrücke erklärt wird, anhand von Beispielen und wie man sowas auch manuell erstellen kann?

Ich habe bei MS was gefunden, aber das ist ja noch komplizierter als alles so schon ist.
http://support.microsoft.com/kb/309640/de

nochmals danke


gruß bonanza2002
Mitglied: bonanza2002
bonanza2002 02.04.2007 um 01:03:07 Uhr
Goto Top
Ich habe das ganze jetzt auch über WLan hinbekommen per ad-hoc.

Seit einer weile habe ich das Problem, das der ander Laptop sich immer mit einem Netgear-Netzwerk verbindet. (Ein Nachbar vielleicht)
Eine WLan Verbindung mit meinem Router funktioniert problemlos. Wenn ich aber mich mit dem ad-hoc verbinden will, dann verbindet er mich trotzdem mit dem Netgear, zeigt aber im Try an, das er mit dem ad-hoc verbunden ist und in den Netzwerkeigenschaften zeigt es an, das es mit dem Netgear verbunden ist.

Jetzt habe ich das WEP eingerichtet und dachte, das würde helfen. Jetzt kommt aber keine verbindung zustande. Es wird versucht die IP zu beziehen, das scheitert dann aber. Ich denke er will trotzallem wieder auf das Netgear zugreifen.

Auf dem Laptop habe ich nur antivir und einen AVM Firewall.

Auf dem anderen Laptop, wo alles funktioniert habe ich Norton Antivir drauf. da habe ich mal vor einiger zeit beobachtet, das mein PC sich in andere WLAN's verbinden wollte. War dummerweise so eingestellt, das er sich mit allen verbinden kann. Da kam bei 2 WLAN, auch bei dem Netgear, das eine Art Worm blockiert wurde. Kann es sein, das der eine Laptop sich mit etwas infiziert hat?
Der Adressbereich ist der gleiche wie bei meinem WLAN.
Mitglied: bonanza2002
bonanza2002 02.04.2007 um 16:06:49 Uhr
Goto Top
Hat jemand für mich eine Erklärung.

Mein Bruder hat sein Netzwerk so konfiguriert...

Router
192.168.178.1

PC
LAN-Adapter (verbunden mit Router)
alles automatisch beziehen

WLAN-Adapter
192.168.0.1
255.255.255.0
192.168.0.1
192.168.0.1

Laptop
WLAN-Adapter
alles automatisch beziehen

Verbindung PC-WLAN mit Laptop WLAN per ad-hoc.

Der Laptop bekommt sein IP und er kann in Internet surfen.

gleiche Einstellungen bei mir.. no way.

habe die Antwort gerade selber gefunden...
Bei dem LAN-Adapter vom PC muß noch die Internetfreigabe aktiviert sein.
Bei dem WLAN-Adapter am PC braucht außerdem kein GW und kein DNS angegeben werden.

Jetzt habe ich auch meine Antwort wie das ganze ohne Netzwerkbrücke funktioniert.
Mitglied: Atti58
Atti58 02.04.2007 um 16:17:35 Uhr
Goto Top
... diese Diskussion hier führen zu wollen, ist sicherlich nicht zweckmässig, da der Thread ja doch schon älter als zwei Jahre ist und folglich auch nur die bisher beteiligten Personen benachrichtigt wwerden.

Mit dem AdHoc-Modus habe ich wenig Erfahrungen, deshalb kann ich Dir leider nicht helfen, mach doch bitte einen neuen Beitrag auf und schildere Dein Problem und nenne vor allen Dingen Deine Hardwarekomponenten, denn WEP ist nicht bei allen Herstellern gleich WEP ;-) face-wink ...

Gruß,

Atti.
Mitglied: bonanza2002
bonanza2002 02.04.2007 um 17:35:05 Uhr
Goto Top
wo kann ich den Betrag dann reinstellen? für mich paßt das in verschiedene Kategorien. kannst du den Beitrag verschieben und mir dann den Link senden?
Mitglied: Atti58
Atti58 02.04.2007 um 17:41:48 Uhr
Goto Top
Nein, diesen Beitrag kann ich nicht verschieben, leg doch Deinen neuen Beitrag einfach hier:

Startseite > Netzwerke > LAN, WAN und Wireless

an,

Gruß

Atti.
Heiß diskutierte Beiträge
info
Bundeswehr lässt Retro Funkgeräte für 600 Millionen Euro produzierenhacktorVor 1 TagInformationHardware6 Kommentare

Dachte zuerst das ist ein verspäteter Aprilscherz Die saufen da offensichtlich zu viel Club-Cola au banan. ...

general
DSL-Modems am F-Buchse statt N-Buchse - warum?Windows10GegnerVor 1 TagAllgemeinDSL, VDSL19 Kommentare

Hallo zusammen, es sind jetzt hier die Fernmeldetechniker gefragt. Normalerweise wird ja ein DSL-Modem mit der F-Buchse einer TAE-NFN-Dose verbunden. Was ist der genau Grund ...

question
Einrichtung Unify Security Gateway gelöst markaurelVor 1 TagFrageLAN, WAN, Wireless9 Kommentare

Hallo zusammen und bitte um eure Hilfe! Wie der Titel schon sagt Folgende Situation: Ich hab ein Netzwerk in folgenden IP-Bereich: 192.168.10.x. Als Gateway dient ...

question
Neue Verschlüsselung TLS 1.3eberhartIIVor 18 StundenFrageDrucker und Scanner11 Kommentare

Hallo, es geht um eine Verschlüsselung, die die Telekom seit 02. September 2021 einsetzt. Ab diesem Datum müssen die E-Mails mit dem Schlüssel TLS 1.3 ...

question
Zentrales Nutzermanagement Windows ServerDeltaDragonVor 19 StundenFrageWindows Server3 Kommentare

Hallo zusammen, Ich suche hier heute Euren Rat zum Thema Nutzermanagement auf einem Windows-V-Server Kenntnisse Ich bin zwar seit zehn Jahren Softwareentwickler (Java), habe jedoch ...

question
Selbsterstelltes VBScript führt zu Fehlermeldung: Diese App kann auf dem PC nicht ausgeführt werden gelöst PeterleBVor 1 TagFrageBatch & Shell9 Kommentare

Hallo Mädels und Jungs, habe ein kleines VBScript geschrieben, welches den Namen einer ausführbaren Datei (*.exe) um die Dateiversion ergänzen soll, wenn eine vorhanden ist. ...

question
Hyper-V 2016 shutdown VM bei niedrigem Akkustand der USV gelöst keine-ahnungVor 1 TagFrageWindows Server3 Kommentare

Moin at all, mir hat es heute meine 15 Jahre alte APC Smart-UPS zerschossen - steht ihr zu, wie ich meine. Habe so ein Ding ...

question
In der Suche nach einem IPsec Lan-to-Lan Travel RouterJohanspbVor 1 TagFrageRouter & Routing3 Kommentare

Hallo zusammen, zuhause habe ich einen FritzBox 7590, auf welchem ich VPN-Server eingerichtet habe. Die Aufgabe ist folgendes: Ich reise gern und übernachte oft in ...