Azure AD-Connect

samrein
Goto Top
Guten Morgen,

da wir mittlerweile relativ viele O365 User im Einsatz haben, wollte ich das SSO mit Azure verwenden.

Das hat soweit alles funktioniert, die Erstsyncronisierung war tadellos, und die Benutzer können ohne weitere Kennworteingabe die O365 Palette benutzen.

Aber leider funktioniert die Syncroniserierung nicht wirklich. Hierzu hab ich im www einen Eintrag gefunden bei dem

O365 Sync Link

Hier gab es das Problem das SyncCycleEnabled auf false gesetzt war nach der Installation. Jetzt wollte ich das bei mir mal prüfen und habe gemerkt das ich nicht mal

Get-ADSyncScheduler

ausführen kann ohne Fehlermeldung. Hier bekomme ich einen Authentification Fehler. Für den AD Connect hab ich einen eigenen User angelegt der Berechtigungen im AD hat. Leider finde ich im Moment nichts hilfreiches und frage einfach mal hier nach?

Folgende Meldung erhalte ich hier:


Azure ist für mich Neuland, ich frage mich, an welche Stelle hier die Berechtigung fehlt?


Grüße
Stefan

Content-Key: 1650875419

Url: https://administrator.de/contentid/1650875419

Ausgedruckt am: 10.08.2022 um 17:08 Uhr

Mitglied: NixVerstehen
NixVerstehen 23.12.2021 um 12:47:46 Uhr
Goto Top
Hi Stefan,

eigentlich ist AAD Connect recht komfortabel einzurichten. Ich kann mich aber nicht erinnern, ein "Service"-Konto manuell angelegt zu haben. Das Setup von AAD-Connect legt das Konto im lokalen AD als auch im Azure-AD automatisch an. AAD-Connect sollte auch nicht auf einem DC installiert werden.

Welchen M365-Plan nutzt ihr denn? Beim Business Standard z.B. geht kein Self-Service Kennwort Reset und du musst die User, die in M365 hinzugefügt werden sollen, im lokalen AD anlegen. Den Sync in die Cloud macht dann AAD Connect. Anders herum geht glaube ich erst mit den E-Plänen.

Gruß NV
Mitglied: samrein
samrein 23.12.2021 um 13:21:32 Uhr
Goto Top
Hey NV,

danke für Deine Nachricht.

Das Setup hat auch problemlos funktioniert, auch die Anmeldedaten zu Azure und meinem AD funktionieren. Die Erst Syncronisierung war auch fehlerfrei.

Ich nutze die Azure Free Lizenz, das lediglich für die SSO Anmeldung verwendet werden kann. Die Benutzer haben Office 365 im Einsatz.

Normalerweise, so hab ich es verstanden läuft aber nach der Einrichtung der Sycronisierungsdienst, der Änderungen in der ausgewälten OU nach Azure übermittel.

Wenn ich die GUI vom Syncronisierungsdienst öffne und die Sycroniserung manuell anstarte läuft diese ebenfalls fehlerfrei durch und zeigt mir meine getätigten Änderungen auch an. Allerdings überträgt er diese nicht zu Azure.

Deshalb bin ich ja auf die Idee gekommen per Powershell mal die Einstellungen auszulesen. Und hier scheiterts bei mir.

Get-ADSyncScheduler > funktioniert nicht

Das scheint ein Problem mit der Authentifzierung zu sein, im Windows Event Log finde ich noch folgende Einträge, die Google Suche und MS haben mir bislang nicht weitergeholfen.




Die von Microsoft angegeben Seiten hab ich per GPO eingetragen ins lokale Intranet.

Grüße
Stefan
Mitglied: 7Gizmo7
7Gizmo7 23.12.2021 um 16:19:58 Uhr
Goto Top
Hi,

Kannst du nochmal den Konfigurationassisten durchlaufen lassen ? Firewall Richtung Office 365 ist offen ?

Mit freundlichen Grüßen
Mitglied: spaceman127
spaceman127 23.12.2021 um 17:57:37 Uhr
Goto Top
Moin,

was für einen Benutzer hast du verwendet, um dich mit dem Azure AD zu verbinden?

Viele Grüße
René
Mitglied: NixVerstehen
NixVerstehen 27.12.2021 um 11:30:49 Uhr
Goto Top
Moin,

klapper am Besten mal das HowTo von MS Schritt für Schritt durch, auch die zusätzlichen Links in dem Dokument:

AAD Connect - Benutzerdefinierte Installation

Wie du oben schon richtig erwähnt hast, sync't der Kram vollständig automatisiert, wenn richtig eingerichtet.
Ich rate mal noch ins Blaue...Modern Authentication im M365-Admincenter ist aktiviert?

Gruß NV
Mitglied: samrein
samrein 29.12.2021 um 08:28:33 Uhr
Goto Top
Hallo zusammen,

danke erstmal für Euere Rückmeldungen.

der Konfigurationsassistenz läuft fehlerfrei durch. Als Benutzer hatte ich hier den Azure Admin account verwendet also.... admin@FIRMA.onmicrosoft.com

Werde mir heute aber auch nochmal das Dokument von AAD Connect reinziehen, vielleicht habe ich was übersehen.. ich meld mich dazu nochmal...

Hoffe Ihr habt frei zwischen den Tagen face-smile

Grüße
Stefan
Mitglied: samrein
samrein 29.12.2021 um 09:59:22 Uhr
Goto Top
Ich habe in meinem AAD Connect einige Einstellungen gar nicht.

Die Seite im Anhang sehe ich erst gar nicht, Azure AD sign-in.

Ich hatte bei der Auswahl am Anfang die Benutzeranmeldung konfiguriert, siehe Bild 2, mit der Kennwort-Hashsyncroniseriung.
azure_2
azure_1
Mitglied: 7Gizmo7
Lösung 7Gizmo7 29.12.2021 um 19:13:19 Uhr
Goto Top
Kannst du mal dein Azure AD Connect als Admin starten ! Hast du die Express-Konfiguration gewählt ? eigentlich ja nicht, da Dienstkotno für AD verwendet.

Hast du denn im ersten Bild Konfiguration ändern gemacht beim Assistenten ?
Mitglied: samrein
Lösung samrein 30.12.2021 um 08:41:46 Uhr
Goto Top
Ja ich hatte Konfiguration ändern gemacht gehabt.

Ich hatte bei der Installation die Express-Einstellungen verwendet. Nach meinen gemachten Änderungen von gestern ist auch die ErstSyncronisierung in Richtung Azure wieder durchgelaufen. Es scheint aber so, als hätte das Dienstkonto ein Problem sich bei Azure zu authentifzieren.


Die Frage ist warum... ich deinstalliere Azure nochmal komplett und versuche es nochmal ohne die Expresseinstellungen...


Mitglied: samrein
Lösung samrein 30.12.2021 um 09:47:05 Uhr
Goto Top
So, es lag tatsächlich am Dienstkonto. Man kann entweder ein eigenes verwenden oder von Azure eines erstellen lassen. Ich hatte ein eigenes verwendet gehabt, das sich nicht mit Azure verbinden konnte, obwohl es eigentlich vorhanden war. Da hat aber das SSO scheinbar nicht funktioniert.

Nachdem ich bei der Neuinstalltion dann eines hab erstellen lassen, funktioniert die Syncronisierung.

Danke

Viele Grüße
Stefan