niklasschaefer
Goto Top

Clients regestrieren sich nicht im DNS

Hallo alle zusammen,

bei uns ergibt sich folgendes Problem. Wir haben einen weiteren Standort dazu bekommen. Dieser ist über eine Richtfunkstrecke angebunden ca.300m Luftlinie. Das heißt Server und alles drum und dran ist weiterhin im Hauptstandort. Das heißt auch DHCP, DNS, DC. Jetzt haben wir in dem neuen Netz 10.32.0.0/16 mehrere Vlans mit /24 /23 etc. Die Rechner bekommen auch alle beim einstecken eine IP vom DHCP zugewiesen. Was komisch ist das diese sich aber nicht im DNS regestrieren und somit keine Namensauflösung möglich ist. Im DNS sind sichere und nicht sichere Updates zugelassen.

2

PTR ist angelegt und im DHCP sind folgende Einstellungen getätigt worden:

1

Habt ihr eine Idee wo ich noch schauen könnte? Ein ipconfig/registerdns schafft auch keine Hilfe . Im Eventlog taucht keine Fehlermeldung auf.


Grüße Niklas

Content-Key: 489742

Url: https://administrator.de/contentid/489742

Printed on: July 20, 2024 at 05:07 o'clock

Member: gammelobst
gammelobst Aug 29, 2019 at 10:39:44 (UTC)
Goto Top
Hallo,

in der Kiste mit dem Spannungsabfall?

oder

Glaskugel leider in Werkstatt.

oder mehr Infos

cya
Member: niklasschaefer
niklasschaefer Aug 29, 2019 at 11:06:18 (UTC)
Goto Top
Hallo,

wenn du mir sagst was du noch brauchst bekommst du Info gerne.


Grüße
Member: gammelobst
gammelobst Aug 29, 2019 at 12:14:34 (UTC)
Goto Top
Die Ausgabe von ipconfig /all ist mal ein anfang.

Wie sieht das topologisch zwischen Client und Server aus?

cya
Member: SeaStorm
SeaStorm Aug 29, 2019 at 13:55:22 (UTC)
Goto Top
hi

Was komisch ist das diese sich aber nicht im DNS regestrieren und somit keine Namensauflösung möglich ist
Ähm was genau ist jetzt der Fall? Der Client kann Namen nicht zur IP auflösen? Oder kann der Clientname, also sein DNS-Name, nicht von anderen Clients aufgelöst werden, weil dieser nicht im DNS steht?
Wenn ein Client im neuen Netz keine DNS-Querys an den Server stellen kann, dann wird wohl Routing oder eine Firewall das Problem sein, weil die 2 nicht miteinander reden können.
Wenn DNS Querys funktionieren, der Client mit seinem Namen+IP aber nicht im DNS registriert wird, dann wird wohl der DNS die Erstellung des Eintrags ablehnen.

Erzähl mal etwas mehr über deine Umgebung.
IP-Range der Clients,
IP-Einstellungen (ipconfig /all) des Clients
IPs der DNS Server
usw
Member: emeriks
emeriks Aug 29, 2019 at 19:31:01 (UTC)
Goto Top
Hi,
hast Du in allen Scopes den betreffenden DNS-Server mitgegeben? Und den Router natürlich auch?
Auf dem DNS-Server schon mal das Debug-Logging bemüht? Und/oder ein Wireshark?

E.
Member: niklasschaefer
niklasschaefer Aug 30, 2019 updated at 06:23:44 (UTC)
Goto Top
Moin,

sorry für die spätre Rückmeldung anbei ein Screenshot von ipconfig/All

ipconfig

DHCP-SCOPE für das betreffende VLAN:

bereichsoptionen
& DHCP Lease Übersicht.
leases

Zu dem Netz ist es so wir haben an dem alten Standort wo die ganze RZ Infrastruktur steht ein 10.30.0.0/16 Subnetz in 10.30.20.1-254 stehen die Server. Router in diesem Netz ist 10.30.1.5 ein HPE Comware 5700 mit Default Route für alles was nicht bekannt ist auf 10.30.1.1 unsere Watchguard M400 Firewall. Der neue Standort hat auch ein 10.32.0.0/16 hier haben wir Teilnetze aufgebaut und arbeiten dementsprechend mit VLAN´s. DIe Clients haben hauptsächlich Windows 10 Prof installiert. Client Netze sind 10.32.50.0/23 und 10.32.52.0/22. Routing in dem neuen Standort funktioniert ohne Probleme und auch ein Zugriff auf Ressourcen im anderen Standort funktioniert Internetzugang auch. DHCP-Leases werden bezogen und laufen auch alle sauber ab. DHCP und DNS Server haben die IP-Adresse 10.30.20.10, zweiter DC ist nur DNS mit 10.30.20.2. Leases werden bei beiden Servern nicht aktualisiert. Wenn ich einen statischen Eintrag anlege mit PTR. Dauert es 1-2Minuten und sehe die Änderung auf beiden DNS-Servern.
Ein nslookup funktioniert auch.

nslookup

Wireshark Mitschnitt: Onedrive - Wireshark

Ich hoffe das bringt ein bisschen mehr licht ins dunkele.

Grüße Niklas
Member: emeriks
emeriks Aug 30, 2019 updated at 18:21:22 (UTC)
Goto Top
Du meinst sicher, die Records werden nicht aktualisiert?

Am Rande:
Ich hoffe nicht, dass das die Ursache ist.
Zuerst zeigst Du uns die Eigenschaften des Scopes 10.32.50.0. Das Problem gibst Du aber für den Bereich 10.32.52.0 an. Im 52' sollte dann auch angehakt sein "DNS immer aktualisieren".
Welchen DNS-Server hat denn der DHCP-Server selbst eingetragen? Denn dort wird er versuchen, die Records zu aktualisieren.
Member: niklasschaefer
niklasschaefer Sep 02, 2019 at 05:54:38 (UTC)
Goto Top
GUten Morgen Emeriks,


das Problem lässt sich sowohl im 50.0 als auch im 52.0 nachstellen. Der DC01 hat als Hauptdnsserver den DC02 eingetragen.

Grüße Niklas
Member: emeriks
emeriks Sep 02, 2019 at 15:44:36 (UTC)
Goto Top
Und, hast Du am DC02 schon mal das Debug-Log des DNS-Servers aktiviert und ausgewertet?