Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

DC-Migration von Server 2003 auf Server 2008 - Problem

Mitglied: TuXHunt3R
Hallo ans Forum

Nach viel zu langer Zeit ( :-) face-smile ) melde ich mich mal wieder mit einem Problem.

Ich wollte gerade mal frisch fröhlich mein AD vom alten 2003-Server auf den neuen 2008-Server zügeln. Habe also die Rolle "Active Directory Domain Service" per Server-Manager hinzugefügt und habe auf dem alten Domänencontroller (der übrigens der einzige Domänencontroller in der Domäne ist, ist also Schemamaster und Infrastrukturmaster) die folgenden Befehle ausgeführt (mit einer Kaffeepause dazwischen):
adprep.exe /forestprep
adprep.exe /Domainprep /Gpprep

Der erste Befehl ist ohne Probleme durchgelaufen. Es gab keine Fehlermeldungen in der Konsolenausgabe, im Eventlog war auch nichts und dcdiag.exe reklamierte auch nicht.
Danach habe ich sicherheitshalber 5 Minuten gewartet und habe dann den zweiten Befehl ausgeführt. Dieser spuckt mir nun die folgende Meldung aus:

Ich hab dann nochmals 5 Minuten gewartet und habe es einfach mal versucht: Ich habe auf dem neuen 2008er-Server dcpromo gestartet, habe angegeben, dass dieser Server als zusätzlicher DC in der bereits vorhanden Domäne arbeiten soll. Als ich dann aber auf "Weiter" klicken wollte, kam folgende PopUp-Fehlermeldung:

Als ich die obigen 2 Befehle ausgeführt habe, habe ich die aktuelle Version der adprep.exe genommen (Version 6.*), welche auf der Server 2008er DVD mitgeliefert wurde.

Googeln hat nichts gebracht. Auch ein Reboot der beiden Server nicht (habe ich allerdings auch nicht erwartet).

Wisst ihr noch was?

Edit:
Hier noch das Log von der dcdiag.exe, falls es euch hilft:

Grüsse aus der Schweiz.
TuXHunT3R

Content-Key: 101578

Url: https://administrator.de/contentid/101578

Ausgedruckt am: 18.09.2021 um 12:09 Uhr

Mitglied: Yusuf-Dikmenoglu
Yusuf-Dikmenoglu 11.11.2008 um 23:41:01 Uhr
Goto Top
Bonjour,

Konfigurieren Sie die Domäne so, dass sie im einheitlichen Modus ausgeführt wird, und führen Sie "do 06.mainprep" erneut aus.

ist diese Meldung nicht eindeutig genug?
Damit das ADPREP /DOMAINPREP /GPPREP von der 2008er DVD ausgeführt werden kann, muss sich der Domänenfunktionsmodus
im "einheitlichen" Modus befinden. Dies kann der Modus "Windows 2000 pur" oder "Windows Server 2003" sein.

In den einheitlichen Modus kannst du aber nur wechseln, wenn sich keine älteren DCs mehr in der Domäne befinden.
Ansonsten ist das Hochstufen der Domäne nicht möglich.

Den Domänenfunktionsmodus bzw. Gesamtstrukturfunktionsmodus kann man während dem Betrieb umstellen. Es sind quasi
"drei Klicks" und die Domäne bzw- Gesamtstruktur ist umgestellt. Es ist eben darauf zu achten, dass damit, je
nach Ebene, älterere DCs nicht mehr existieren dürfen/können.

In einen anderen Domänenmodus kann man nur dann wechseln, wenn alle bestehenden DCs die neue Ebene unterstützen.
Bedeutet, möchte man in den Domänenfunktionsmodus "Windows Server 2003", dann dürfen kein 2000 DCs mehr in der Domäne
existieren, da ansonsten das Heraufstufen nicht möglich ist.

Das gleiche gilt für die Gesamtstruktur. Möchte man die Gesamtstruktur auf den Gesamtstrukturfunktionsmodus
"Windows Server 2003" heraufstufen, müssen vorher alle bestehenden Domänen in dem Domänenfunktionsmodus
"Windows Server 2003" sein.

Bestehende Vertrauensstellungen sind davon nicht betroffen bzw. haben mit dieser Umstellung kein Problem und
funktionieren weiterhin.

Falls mehrere Domänen in einer Gesamtstruktur existieren, dann sollte die Umstellung der einzelnen Domänen respektive
Gesamtstruktur "zügig" vollzogen werden. Denn wenn man sich dabei Zeit lässt, können Replikationsprobleme auftauchen.

Das Heraufstufen des Domänenfunktionsmodus kann entweder über das Snap-In „Active Directory-Benutzer und –Computer“
oder „Active Directory-Domänen und -Vertrauensstellungen“ erledigt werden (mit einem Rechtsklick auf den FQDN),
wobei die Gesamtstruktur ausschließlich im Snap-In „Active Directory-Domänen und -Vertrauensstellung“
heraufgestuft werden kann. Beides lässt sich ebenfalls durch bearbeiten (mit LDP.exe oder ADSIEdit.msc) des Attributs
msDS-Behavior-Version herauf stufen.


Für den Gesamtstrukturfunktionsmodus ist im Attribut "msDS-Behavior-Version", dass sich im folgenden Pfad befindet
<CN=Partitions,CN=Configuration,DC=Root-Domäne,DC=TLD> als Wert 2 einzutragen.

Für den Domänenfunktionsmodus ist im Attribut "msDS-Behavior-Version", dass sich im folgenden Pfad befindet
<DC=DeineDomäne,DC=Root-Domäne,DC=TLD> als Wert 2 einzutragen.


Für weitere Details siehe:

[Yusufs Directory Blog - Domänen- und Gesamtstrukturfunktionsmodus]
http://blog.dikmenoglu.de/PermaLink,guid,c14f0260-846e-4cb2-b14e-aa705d ...

[Yusufs Directory Blog - Den ersten Windows Server 2008 DC zu einer Windows 2000/2003/R2 Gesamtstruktur hinzufügen]
http://blog.dikmenoglu.de/PermaLink,guid,58a3c79f-f34e-4635-bc5f-0bfc67 ...


Viele Grüße und ein HELAU aus Mainz
Yusuf Dikmenoglu
Mitglied: TuXHunt3R
TuXHunt3R 12.11.2008 um 19:07:20 Uhr
Goto Top
Hallo Yusuf

Herzlichen Dank für die sehr ausführliche Antwort. Hat mir echt weitergeholfen. Mein Problem war, dass der Domänenfunktionsmodus auf "Windows 2000 pur" gestellt war und die Gesamtstruktur auf Windows 2003. Habe nun beide heraufgestuft. Momentan bootet der 2008er gerade. Scheint allerdings so, als sei das Problem gelöst.
Mitglied: Yusuf-Dikmenoglu
Yusuf-Dikmenoglu 12.11.2008 um 20:31:33 Uhr
Goto Top
Mein Problem war, dass der Domänenfunktionsmodus auf "Windows 2000 pur"
gestellt war und die Gesamtstruktur auf Windows 2003

Das kann nicht das Problem gewesen sein. Denn der Domänen-Modus "Windows 2000 pur"
ist einer der einheitlichen Modis und das hätte bereits funktionieren MÜSSEN. Der Gesamtstrukturfunktionsmodus
spielt dabei überhaupt keine Rolle.


Gruß, Yusuf
Mitglied: TuXHunt3R
TuXHunt3R 12.11.2008 um 22:01:54 Uhr
Goto Top
Whatever, habe beide auf Server 2003 gestellt, adprep /domainprep nochmals durchlaufen lassen, mich durch dcpromo geklickt und das Ding gebootet. Hat geklappt. Beim alten Server habe ich nun mal den DNS-Server Dienst deaktiviert. Nun lasse ich das Ganze mal ein paar Tage laufen und wenns keine Probleme gibt, werde ich den DNS-Server auf dem alten 2003er deinstallieren. Mit dem AD weiss ich noch nicht so ganz, was ichs machen soll.


Wir werden sehen....

Ist auch nicht so wichtig. Ist meine private Domäne, ist also nicht geschäftskritisch....
Heiß diskutierte Beiträge
question
Netzwerkperformance - Mikrotik - Wo ist mein Fehler? gelöst BirdyBVor 1 TagFrageNetzwerke39 Kommentare

Moin zusammen, ich stehe gerade etwas auf dem Schlauch und weiß nicht so recht was mein Fehler ist. Gegeben ist mein heimisches Netzwerk: Also eigentlich ...

info
Hunderttausende MikroTik-Router sind seit 2018 angreifbarkilltecVor 1 TagInformationMikroTik RouterOS24 Kommentare

Mehrere MikroTik Router angreifbar. Hier der Link zu Heise: Hunderttausende MikroTik-Router sind seit 2018 angreifbar Gruß ...

question
Neue Firmennetzwerkstruktur und ein glühender KopfDerWachnerVor 1 TagFrageNetzwerke28 Kommentare

Moin zusammen, nun hab ich jahrelang hier nur mitgelesen, nun stehe ich allerdings selbst vor nem Problem was mir seit Tagen Kopfschmerzen bereitet. Also wir ...

general
Neue Herausforderungen auf unserer englischen SeiteFrankVor 1 TagAllgemeinOff Topic14 Kommentare

Auf unserer englischen Seite gibt es neue Herausforderungen: Find who restarted DB server und Wanted: Network Node Manager 6.4 wer kann helfen? Generell findet ihr ...

question
Windows Server 2012 R2 frisst SSDs (cbs.log)drahtbrueckeVor 1 TagFrageWindows Server14 Kommentare

Hallo, ich habe vor etwa 2 Monaten eine nur etwa 3 Monate alte SSD gegen eine neue getauscht (Samsung OEM Datacenter SSD SM883) in einem ...

question
RDS CALs und normale CALs - Wie richtig lizensierentim.riepVor 1 TagFrageWindows Server19 Kommentare

Hallo liebe User, ich habe eine Frage zur richtigen Lizensierung: Wenn eine natürliche Person zum Beispiel drei Accounts auf einem Windows Server 2016 hat, braucht ...

question
2 Netzwerkkarten für 2 verschieden Netze auf einem Windows-ServerglasscolaVor 17 StundenFrageWindows Server6 Kommentare

Hallo zusammen, im Rahmen meiner Bachelorthesis baue ich ein Labor auf, das folgend aussieht. Ich habe einen Server und auf ihm laufen 2 VMs (1 ...

info
Phishingwelle Volksbanklcer00Vor 1 TagInformationSicherheit10 Kommentare

Hallo zusammen, bei uns häufen sich gerade Phishing-Emails mit Ziel Volks-Raiffeisen-Bank. Geködert wird zum Teil auch mit der Erwähnung der SecureGo Smartphone-App. Grüße lcer ...