Eigene CA - Chrome ERR CERT COMMON NAME INVALID

schneerunzel
Goto Top
Moin zusammen,

ich habe eine eigene CA erstellt, die ich auch am Windows Client importiert ist.
Jetzt habe ich einen Webserver mit einem Zertifikat von der CA ausgestattet.

Rufe ich die Seite mit dem IE auf, ist das Zertifikat gültig. Importiere ich die CA im Firefox, ist das Zertifikat auch gültig.
Rufe ich die Seite mit Chrome, Brave oder Edge auf, ist das Zertifikat nicht gültig. Fehlermeldung:
NET::ERR_CERT_COMMON_NAME_INVALID

Klicke ich dann das Zertifikat an, ist es angeblich doch gültig.
1
2
3

Hats jemand einen Tipp für mich?

p.s. Domain stimmt, das hab ich schon gecheckt. (Sonst würde es im IE bzw. FF ja auch nicht funktionieren)
Das Problem habe ich an drei unterschiedlichen Clients nachstellen können...

Content-Key: 1491745300

Url: https://administrator.de/contentid/1491745300

Ausgedruckt am: 13.08.2022 um 02:08 Uhr

Mitglied: mbehrens
mbehrens 10.11.2021 um 20:03:07 Uhr
Goto Top
Zitat von @schneerunzel:

ich habe eine eigene CA erstellt, die ich auch am Windows Client importiert ist.
Jetzt habe ich einen Webserver mit einem Zertifikat von der CA ausgestattet.

Rufe ich die Seite mit dem IE auf, ist das Zertifikat gültig. Importiere ich die CA im Firefox, ist das Zertifikat auch gültig.
Rufe ich die Seite mit Chrome, Brave oder Edge auf, ist das Zertifikat nicht gültig. Fehlermeldung:
NET::ERR_CERT_COMMON_NAME_INVALID

War es nicht so, dass die Domain im subjectAltName enthalten sein musste?
Mitglied: Looser27
Looser27 10.11.2021 um 20:04:32 Uhr
Goto Top
Yep. Der SAN muss mit in der Zertifikat.

Gruß Looser
Mitglied: schneerunzel
Lösung schneerunzel 21.11.2021 um 18:08:47 Uhr
Goto Top
Danke für den Tipp. Der SAN war es