digidiver
Goto Top

Erreichbarkeit meines Webservers nicht mehr gegeben

Hallo zusammen, ich weiss nicht mehr weiter. Daher versuche ich das Schwarm wissen zu nutzen. Danke schon vorab. Ja ich habe schon viele Suchen per Google gemacht. Leider stelle ich entweder die falschen Fragen oder ... wer weiß.

Folgendes Szenario:
Ich habe über meine ISP eine feste IP Adresse. Bei meinem Hosting Provider sind die Domains mit der IP verknüpft. Soweit so gut.

Es hat auch schon funktioniert. Da ich aber nach jedem Update nicht zwingend meine Domains prüfe, habe ich leider nicht festgestellt, seit welcher Änderung das ganze nicht mehr geht.

Ich habe eine FritzBox7580 habe dort meinen Mikrotik als Exposed Host eingetragen. "Somit sollte jede Anfrage auch an den MT gehen."

In der Firewall des Mikrotik habe ich den Port 80 und 443 freigegeben. Ob mans braucht?

Im NAT habe ich die Weiterleitung der Ports an die Syn Nas gemacht und sollte, denke ich, auch so funktionieren. In der Syn ist die Fritzbox als DNS hinterlegt. DHCP wird vom MT gemacht.

Wenn ich aus dem lokalen Netz, Port 80 http auf die Nas gehe, kommt auch die definierte Fehlerseite. Wenn ich von Außen über die IP des ISP versuche auf diese Seite zuzugreifen, passiert nichts. Wenn ich die NAT Weiterleitung abschalte, kommt das Anmeldefenster des MT. Scheinbar komme ich zumindest ins Haus.

Gibt es eine Möglichkeit zu sehen, wie die Anfragen laufen? Ich logge bereits die NAT Freigabe. Hier wird nur angegeben, ISP IP --> Fritzbox IP des MT. Mehr leider nicht.
Auch auf der NAS kann ich nicht erkennen, ob Anfragen ankommen. Gibt es da Möglichkeiten?

Danke schon vorab.

VG

Content-Key: 33965320304

Url: https://administrator.de/contentid/33965320304

Printed on: May 26, 2024 at 05:05 o'clock

Member: Nebellicht
Nebellicht Mar 25, 2024 at 12:59:00 (UTC)
Goto Top
Hallo, dass was mir einfällt wäre die SSL Verschlüsselung. Bzw. ein fehlendes Zertifikat (443, https)
Member: commodity
commodity Mar 25, 2024 at 13:14:02 (UTC)
Goto Top
Mikrotik verwenden heißt: Dokumentation lesen - und verstehen. face-smile
Gibt es eine Möglichkeit zu sehen, wie die Anfragen laufen?
Steht auch in der Doku. Genau deshalb verwendet man den Mikrotik ja so gern. Ich nehme dafür immer Torch.

Viele Grüße, commodity
Member: Digidiver
Digidiver Mar 25, 2024 at 13:22:28 (UTC)
Goto Top
Zitat von @Nebellicht:

Hallo, dass was mir einfällt wäre die SSL Verschlüsselung. Bzw. ein fehlendes Zertifikat (443, https)

Das ist der Grund, weshalb ich auf http mit Port 80 teste. Damit ich das Zertifikat Problem umgehe.

Da sollte das ganze erstmal angezeigt werden.
VG
Member: Digidiver
Digidiver Mar 25, 2024 at 13:25:23 (UTC)
Goto Top
Zitat von @commodity:

Mikrotik verwenden heißt: Dokumentation lesen - und verstehen. face-smile
Gibt es eine Möglichkeit zu sehen, wie die Anfragen laufen?
Steht auch in der Doku. Genau deshalb verwendet man den Mikrotik ja so gern. Ich nehme dafür immer Torch.

Viele Grüße, commodity

Wenn ich wüsste, wonach ich suchen müsste, dann wäre das eine Option. Deshalb stelle ich die Frage in diesem Forum.
Was mir auffällt, in Foren wird immer mehr auf etwas verwiesen als sich mit dem Problem auseinanderzusetzen. Somit sehe ich solche Posts nur teilweise als Hilfreich. Danke trotzdem.
Member: DivideByZero
DivideByZero Mar 25, 2024 at 14:27:17 (UTC)
Goto Top
Moin,

Zitat von @Digidiver:
Gibt es eine Möglichkeit zu sehen, wie die Anfragen laufen? Ich logge bereits die NAT Freigabe. Hier wird nur angegeben, ISP IP --> Fritzbox IP des MT. Mehr leider nicht.

Zitat von @commodity:
Gibt es eine Möglichkeit zu sehen, wie die Anfragen laufen?
Steht auch in der Doku. Genau deshalb verwendet man den Mikrotik ja so gern. Ich nehme dafür immer Torch.

Wenn ich wüsste, wonach ich suchen müsste, dann wäre das eine Option. Deshalb stelle ich die Frage in diesem Forum.
Was mir auffällt, in Foren wird immer mehr auf etwas verwiesen als sich mit dem Problem auseinanderzusetzen. Somit sehe ich solche Posts nur teilweise als Hilfreich. Danke trotzdem.

?? Das ist doch die Antwort auf Deine Frage. Und dass dann ein bisschen Selbststudium für die Funktion gefordert ist, ist wohl in einem Administrator-Forum angezeigt.

Außerdem:
wenn ich das richtig verstehe, ist die Fritz!Box nur für das Internet zuständig, keine Geräte im LAN der Fritz!Box außer Mikrotik, und dahinter dann Dein Lan. Von außen (feste IP) mutmaße ich, kommst Du ohne VPN rein. Dann natürlich auch fremdes Netz. Ist in der Synology die Firewall an? Kennt die das Netz? Sonst da auch mal probeweise die Firewall aus und schauen, ob Du rein kommst.

Und ich würde es auch auf Port 443 probieren. Denn wenn in der Synology die automatische Umleitung von http auf https aktiv ist, könnte das auch ein Stolperstein sein.

Mutmaßliches Problem also:
  • falsche Konfiguration des Mikrotik
  • falsche Konfiguration der Synology

Denn bis zum Mikrotik-Router kommst Du ja.

Gruß

DivideByZero
Member: commodity
commodity Mar 25, 2024 updated at 21:49:49 (UTC)
Goto Top
in Foren wird immer mehr auf etwas verwiesen als sich mit dem Problem auseinanderzusetzen.
Alter Finne! Beschreibt sich selbst als zur Nutzergruppe "Administratoren" zugehörig und dann so ein Spruch?
Unhöflich und sachlich falsch oben drein. Hart an der Grenze zur Unverschämtheit.

1. Setzen sich die allermeisten Kollegen hier mit dem Gefragten auseinander. Auch ich. Deshalb
2. bekommst Du (in meinem Fall) eine Antwort, die Dir den Weg weist. Und zwar im konkreten Fall zielgenau bis zum letzten Datenpaket.
Leider willst Du
3. weder die Doku des von Dir selbst gewählten Gerätes lesen, bevor Du Probleme hast, noch
4. dies tun, wenn Du Probleme hast. Nicht einmal,
5. wenn man Dir den passenden Link direkt vor die Nase legt. Denn Du willst
6. eigentlich ja nur die Stelle gesagt bekommen, wo Du das Kreuzchen setzen musst. Wahrscheinlich mit Foto.
Dafür, lieber TO, ist dieses Forum aber nicht da. Ist nicht wünschdirwasdeundlassanderefürdichdenken.de, sondern administrator.de - nochmals: Administrator-Punkt-DE - übrigens mit recht gut erläuterten Forenregeln face-wink
Administratoren lesen übrigens nicht nur Dokumentationen, sie schreiben auch welche. Doch das ist ein anderes Thema.

Aus Bequemlichkeit und/oder Denkfaulheit dann auch noch rumzuranzen ist schon ein bemerkenswerter Move. Vielleicht schämst Du Dich bei Gelegenheit ein bisschen. Danach kannst Du ja einfach mal den Dir servierten Link anklicken, lesen und umsetzen. Am Ende merkst Du vielleicht, dass der Lernerfolg langfristig x-mal größer ist, wenn man sanft zur Lösung geleitet wird, als wenn man die Lösung nur kopiert.
Und wenn Du das nicht für Dich annehmen kannst, eine letzte, ebenfalls zielführende Lösung: Verkauf den Mikrotik. Denn er ist in diesem Fall viel zu schade für Dich.

Bye und Tschüs, dies war meine letzte Botschaft an Dich.
commodity
Member: Mombro
Mombro Mar 26, 2024 at 07:17:53 (UTC)
Goto Top
Hast du mal von außen getestet, oder prüfst du das immer von innen?

Ich glaube mich zu erinnern, dass das manchmal zu Routing-Problemen führt, wenn man vom internen Netz die eigene externe IP öffnen will. Also einfach mal mit dem Handy ausprobieren.

Und ansonsten den Klassiker machen: Schritt für Schritt prüfen, ob die einzelnen Einstellungen greifen. Wenn du in der FritzBox auf Mikrotik umleitest, leite doch mal von FB auf die Synology um. Ist zwar uncool, aber besser als nix, und in 5 Minuten hat dich da auch noch niemand gehackt.

Prüfe, ob die URL wirklich auf die IP auflöst, auf die es auflösen soll, bzw. nimm einfach deine IP statt der URL.

Du kannst auch von extern mal einen Port Scan machen und schauen, ob dein Gerät prinzipiell erreichbar ist. Es gibt nicht viele Webseiten, die das kostenlos machen, und danach kriegt man bisschen Spam ins Postfach, aber gibt schon welche, und Port 80/443 machen die meisten.

-

Und offtopic: Der Flame hier ist ja lustig. Leute, chillt euch mal. Das ist ein Anfänger und Anfänger lesen keine logs. Wir haben nicht 1994 und nicht jeder ist 'n Profi-Admin, der Logs lesen kann/will.

Andererseits: Ich würde bei administrator.de keine Anfängerfragen stellen, weil die Leute hier genau so drauf sind und "mehr" gewohnt sind. Ich würde dir raten, eher so ein Forum wie https://www.computerbase.de/forum/ anzusteuern oder so, aber ich will dich nicht vergraulen. Nur so eine Idee.
Member: commodity
commodity Mar 26, 2024 at 18:03:26 (UTC)
Goto Top
Leute, chillt euch mal. Das ist ein Anfänger und Anfänger lesen keine logs. Wir haben nicht 1994 und nicht jeder ist 'n Profi-Admin, der Logs lesen kann/will.
Total gechillt face-smile
Natürlich ist das ein Anfänger - der aber im Profil angibt, Administrator zu sein (ist ja auch kein geschützter Begriff face-big-smile)
Es geht auch nicht ums Logs lesen, sondern um die Produktdokumentation, aka Handbuch oder Manual.

Wer dazu zu bequem ist, sich stattdessen hier die Windeln wickeln lässt und dann auch noch rum mault, weil er nicht mal einen Link klicken kann, hat einen kleinen Flame mehr als verdient - und, wie Du korrekt anmerkst, eher bei CB eine Heimat. Lernwillige und höfliche Anfänger sind auch hier sehr gern gesehen.

Viele Grüße, commodity
Member: jschneppe
jschneppe Apr 01, 2024 at 10:23:51 (UTC)
Goto Top
Moin,

Wenn du doch ne feste IP hast, warum schmeißt du dann nicht die Fritte weg? Wär schonmal eine potentielle Fehlerquelle weniger
Member: Mombro
Mombro Apr 01, 2024 at 16:39:00 (UTC)
Goto Top
Ist zwar nicht mein beitrag, aber ich sehe nicht, wie das eine mit dem anderen zusammenhängen soll.

Die FritzBox übernimmt in der Regel die Einwahl in das Netzwerk. Die feste IP ist halt dem Haus Anschluss bzw der Mac des Einwahl Gerätes zugewiesen.