Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

ICS Internetverbindungsfreigabe bei 3 Netzen

Mitglied: erebos

ICS bei 2 C-Class-LANs

Ich such nun schon länger nach einer Lösung aber ich finde keine entsprechen Anleitung, und selbst habe ich auch schon endlos probiert.

Folgendes LAN habe ich:

Internet (Modem Cable)
|
|
ext.: IP autom. beziehen
WLAN (Router)
int.: 192.168.0.254
|
|
ext.: 192.168.0.1 (ICS aktiviert)
Server
int.: ??? (probiert habe ich schon 192.168.50.1, 192.168.0.2, 10.0.0.1)
|
|
Client01 (IP:??? probiert entsprechend den Versuchen am Server)


Eine Verbindung zwischen Server und Client ist immer da. Ping auf Server OK. Zugriff auf Freigaben OK. Nur Surfen will der Client einfach nicht.
Pingen auf irgendwas oberhalb vom Server ist nicht möglich. Was mache ich da bloß falsch?

Content-Key: 6275

Url: https://administrator.de/contentid/6275

Ausgedruckt am: 18.06.2021 um 02:06 Uhr

Mitglied: Atti58
Atti58 am 30.01.2005
Dein "interner Server" muss in einem anderen Netz liegen, also z.B. in 192.168.1.1 ohne Standardgateway und die Clients entsprechend dort mit Standardgateway und DNS 192.168.1.1.

Mache diese Eintragungen bitte mal und poste dann das Ergebnis auf dem Server aus:

"route print >C:\route.txt"

Gruß

Atti.
Mitglied: erebos
erebos am 31.01.2005
Konfig gemacht. Hatte ich auch schon so. Ping zueinander OK.

Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 0f 3d ad e9 37 ...... D-Link AirPlus DWL-G520 Wireless PCI Adapter(rev.B) - Paketplaner-Miniport
0x3 ...00 02 44 34 3b 04 ...... SURECOM EP-320X-R-100/10/M-PCI-Adapter - Paketplaner-Miniport
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.0.254 192.168.0.1 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.1 192.168.0.1 20
192.168.0.1 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.0.255 255.255.255.255 192.168.0.1 192.168.0.1 20
192.168.1.0 255.255.255.0 192.168.1.1 192.168.1.1 20
192.168.1.1 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.1.255 255.255.255.255 192.168.1.1 192.168.1.1 20
224.0.0.0 240.0.0.0 192.168.0.1 192.168.0.1 20
224.0.0.0 240.0.0.0 192.168.1.1 192.168.1.1 20
255.255.255.255 255.255.255.255 192.168.0.1 192.168.0.1 1
255.255.255.255 255.255.255.255 192.168.1.1 192.168.1.1 1
Standardgateway: 192.168.0.254
St?ndige Routen:
Keine
Mitglied: Atti58
Atti58 am 01.02.2005
Welches Betriebssystem hast Du denn auf dem Server? Wenn es XP ist, kannst Du eine Netzwerkbrücke einrichten, dann sollte es eigentlich gehen,

Gruß

Atti
Mitglied: Atti58
Atti58 am 01.02.2005
... dieses "ICS" ist die Internetfreigabe - sehe ich das richtig? Dann Muss Dein Router in ein anderes Netz als Dein "Server extern", z.B. 192.168.1.1 für den Router, dann konfigurierst Du die Internetfreigabe auf der 192.168.0.1 auf dem Server und bei Deinem Client01 richtest Du IP automatisch beziehen ein ...

Gruß

Atti
Mitglied: erebos
erebos am 02.02.2005
Wenn ich eine Netzwerkbrücke versuche, kommt ein Hinweis der besagt, dass das nur geht wenn man keine ICS verwendet.

Übrigens Danke für deine Hilfe...
Mitglied: erebos
erebos am 02.02.2005
ICS Internet Connection Sharing... Jup des is die Internetverbindungsfreigabe...

Router bekommt die IP 81.10.xxx.xxx
Intern hat der Router dann 192.168.0.254
Und vom Server zu dem Client hab ich dann 192.168.1.x
Mitglied: Atti58
Atti58 am 02.02.2005
Router und Netzwerkkarte müssen in unterschiedlichen Netzen liegen und die ICS braucht zwingend die freie IP 192.168.0.1, also muss der Router im 192.168.1.X oder 192.168.2.X ... liegen ... Die internen Karten sollten die IP direkt über DHCP beziehen,

Gruß

Atti
Mitglied: erebos
erebos am 03.02.2005
Die 192.168.0.1 an meiner WLAN-Karte im Server eingestellt. Hat sie automatisch bekommen als ich ICS aktivert habe.
Der WLAN-Router hat dann die IP 192.168.0.254. Würde ich 192.168.1.x konfigurieren wäre keine Verbindung mehr möglich, da sie ja nicht mehr im selben Netz wären.
IP's vergibt mein "Server" nicht es eigentlich nur ein Win2k Prof. ist und nur 2 Clients dranhängen.

Vielleicht mach ich heute Abend ein Bild meines Netzwerkes um mein LAN etwas zu verdeutlichen.
Mitglied: erebos
erebos am 03.02.2005
Was siehst du oder kontrollierst du nun anhand der Route Table?
Mitglied: Atti58
Atti58 am 03.02.2005
... warum sollte das, was hier:

https://www.administrator.de/Problem_mit_ICS.html

funktioniert, nicht auch bei Dir gehen?

Gruß

Atti
Mitglied: erebos
erebos am 06.02.2005
mhh... eigentlich kann es dann doch nicht mehr funzen, oder?

wenn die wlan-karte wie in dem bsp von dir 192.168.0.1 (ics aktivert) und dem router ne 192.168.1.254 geb, dann sind beide nicht füreinander erreichbar, da diese ja in unterschiedlichen netzen liegen...

hab das kurz ausprobiert und es hat nicht geklappt... muss ich dann vielleicht die subentmask auf 255.255.0.0 ändern?
Mitglied: erebos
erebos am 07.02.2005
Also Fakt ist ich habe 2 Netze die nicht im selben Bereich liegen.

WLAN zu Router 192.168.0.x
Netzwerkkarte zu Client-PC 192.168.1.x

Somit müsste ICS zwischen diesen beiden routen... Tuts aber nicht. Kann ich sonst noch etwas kontrollieren?
Mitglied: Atti58
Atti58 am 07.02.2005
... so wie ich das sehe, muss Deine Strecke, also Router und PC-extern im 192.168.1.X Netz liegen und die interne Adresse im PC zu Deinem Client muss die 192.168.0.1 mit aktiviertem ICS haben, sieh Dir mal diese Seite an:

http://gw.renner.bei.t-online.de/windowsxp/icsinst.htm

Der Unterschied zu Dir sollte nur sein, dass Du nicht mit PPPoE in's Internet gehst sondern mit einer "festen" IP zu Router,

Gruß

Atti
Mitglied: erebos
erebos am 08.02.2005
Du hattes vollkommen recht mit der IP-Konfig. Hab das mal wieder richtig gestellt, da ich das schon mal so hatte.
Der Link ist gut, und ich hab jetzt auch mal die Server-Client-Seite auf DHCP umgestellt. Witzig ist das ich am Client keine gültige IP bekomme. Also allem Anschein nach ist sowohl der DHCP- als auch der DNS-Dienst am Server nicht erreichbar.
Wird dieser Dinest eigentlich angezeigt? Bei mir zumindest nicht.
Will ich ICS neu einrichten gibt er nicht meiner LAN-Karte die 192.168.0.1 sondern meiner WLAN-Karte zum Router bzw. zum Internet.
Stelle ich alles wieder auf die richigen IP's ein, wie von dir bzw. in der Anleitung beschrieben.

Zur Ergänzung: Der "Server" ist derzeit XP, "Client" ist W2KProf. (Eigentlich sollte es umgekehrt sein, aber es hat andersrum ebenfalls nicht gegeht.

Ich werd heute Abend die WLAN-Karte ausbauen und ne LAN wieder einbauen. Somit bekäme die eine LAN meine INET-IP per DHCP vom Kabelmodem. Vielleicht gehts dann.
Mitglied: erebos
erebos am 08.02.2005
Stelle ich alles wieder auf die richigen
IP's ein, wie von dir bzw. in der Anleitung
beschrieben.


, hab ich wieder das alte Problem wie gehabt.


(Sry. Gibt anscheinend kein Bearbeiten der Posts.)
Mitglied: Atti58
Atti58 am 08.02.2005
... so langsan versteh' ich gar nichts mehr ;-) face-wink ... Angenommen, in Deinem PC steckt 'ne ISDN-Fritzkarte, dann holt die sich aus dem Internet ihre Daten, wenn Du dann Deine "interne" Netzwerkkarte per ICS bearbeitest, wird ja dann die doch wohl zur 192.168.0.1 - oder sehe ich das falsch? Ich werd' wohl mal so eine Situation nachbauen müssen, ach, wie schön einfach ist's mit 'nem Switch :-) face-smile ...

Gruß

Atti
Mitglied: erebos
erebos am 08.02.2005
Naja... ich war mehrere Wochen mit dem Problem allein, und da ich nicht weiterkomme, nehme ich alle Wege in Kauf. Aber Danke für deine Geduld! :) face-smile

Deine Annahme ist richtig. So sollte es sein. Nur bei mir ist es umgekehrt. Ich aktivere ICS auf meiner Netzwerkkarte und die 192.168.0.1 bekommt mein WLAN-Adapter der zuvor noch gerade 192.168.1.1 hatte. Cool, oder? Aber ich kann es auch nochmal umgekehrt machen...

Es gibt noch in den Netzwerkverbindungen unter Erweitert/Erweiterete Einstellungen eine Möglichkeit die Verbindungen in eine andere Reihenfolge zu bringen, aber auch das brachte keine Änderung bei mir.

Mehr Infos heute Abend oder Morgen Früh...
Mitglied: Atti58
Atti58 am 08.02.2005
... gehst Du denn nicht mit dem WLAN-Adapter über den Router in's Internet? Wenn ja, ist das doch richtig mit der 192.168.0.1 auf dem WLAN-Adapter ... so langsam solltest Du wohl mal eine Skizze machen, wie Dein Netz aussieht mit IP-Adressen ...

Gruß

Atti
Mitglied: erebos
erebos am 08.02.2005
http://members.liwest.at/bluesystem/!!!/HomeLAN-2004_2.jpg

Ich hab schon PC getauscht, Karten ein und ausgebaut, Protokolle de und installiert, IP's geändert so das WLAN Netz die 192.168.0x hat, und endlos herumgesucht...
Mitglied: Atti58
Atti58 am 09.02.2005
... kannst Du auf Deinem Router statische Routen eintragen? Wenn ja, versuche bitte mal folgendes:

Ziel Maske Interface
192.168.0.0 255.255.255.0 192.168.1.1

Versuche dann mal, wenn der Router es kann, ein Ping vom Router auf 192.168.0.2 abzusetzen und vom Client01 den Router zu pingen ... wenn's nicht geht, setze auf Client01 mal eine statische Route mit:

"route add -p 192.168.1.254 192.168.0.1" ... und probier's noch einmal :-) face-smile ...

Was technisch hinter dem ICS steckt, habe ich noch nicht rausgefunden, ich setze es selber nicht ein und bin mir auch nicht 100%-ig sicher, dass es das ist, was Du brauchst - eigentlich sehe ich es dazu, eine DFÜ-Vebindung in's Inet zu sharen.

Für Deine Zwecke sollte eigentlich eine Brücke reichen, wir müssen nur dem Router mitteilen, wie er Dein internes Netz findet ...

Gruß

Atti
Mitglied: erebos
erebos am 09.02.2005

Was technisch hinter dem ICS steckt, habe
ich noch nicht rausgefunden, ich setze es
selber nicht ein und bin mir auch nicht
100%-ig sicher, dass es das ist, was Du
brauchst - eigentlich sehe ich es dazu, eine
DFÜ-Vebindung in's Inet zu sharen.

Für Deine Zwecke sollte eigentlich eine
Brücke reichen, wir müssen nur dem
Router mitteilen, wie er Dein internes Netz
findet ...


Diese deiner Worte haben mich gehörig ins Grübeln gebracht, da ich auch eigentlich nur DFÜ und ICS in Kombi gesehen hab. Dass das Ganze in einem Netzwerk (=Kabelmodem zu meinem LAN) nicht benötigt wird, ist mir auch erst jetzt klar, aber immer noch nicht durchsichtig. Zumal ich vor meinem Umstieg auf WLAN eine direkte Verbindung zum Server hatte, und ICS aktiv war und funktioniert hat. *grübbel*
Außerdem hab ich mir nie einen Kopf über das Thema Netzwerkbrücke gemacht. Der Unterschied zu beiden Verfahren würd mich trotzdem sehr interessieren.

Aber ich muss gestehen jetzt funktioniert es. Wieso hast das nicht gleich gesagt? ;)
Hab ICS entfernt, beide LAN-Karten makiert, Nerzwerkbrücke eingerichtet => 1 Stk. TCP/IP zum Einstellen
Die 192.168.1.1 eingetragen am Server, am Client die 192.168.1.2, und die IP vom Router ist wie gehabt 192.168.1.254... => Taaattaa... *hehe*

Falls ich nochmal ein Prob hab, poste ich nochmal. Aber zur Sicherheit sag ich herzlichen Dank für Alles, und wennst du mal in meiner Gegend bist, ist ein Bier auf alle Fälle drin.
Mitglied: Atti58
Atti58 am 09.02.2005
Hey, super ;-) face-wink ... danke für Dein Feedback, für alle anderen "DAU"'s hier wäre es supernett von Dir, wenn Du Deine Grafik auf den neusesten Stand bringen und als Lösung in Deinen Hauptbeitrag stellen könntest - mit einem Hinweis auf die Brücke :-) face-smile ...

Gruß

Atti.
Heiß diskutierte Beiträge
Administrator.de Feedback
Neue Administrator Version
FrankVor 1 TagInformationAdministrator.de Feedback74 Kommentare

Hallo User, heute Nacht haben wir Release 5.9 unserer Seite veröffentlicht. Diese bringt ein paar grundlegende Neuerungen für unsere User mit sich: Die Suche nach ...

Windows 10
Windows 11 Vorabversion aufgetaucht
NixVerstehenVor 1 TagTippWindows 1023 Kommentare

Auf Deskmodder.de ist ein Bericht über eine im Netz aufgetauchte Vorabversion von Windows 11 aufgetaucht. Der Bericht: Deskmodder.de - Windows 11 Vorabversion Bericht Download der ...

Internet Domänen
Domaine Join via VPN
SpryceeVor 1 TagFrageInternet Domänen4 Kommentare

Hallo, ich bin gerade dabei die namen einiger rechner umzubenennen dabei verwende ich ein Powershell script welches auf dem rechner ausgeführt wird. Jetzt gibt es ...

Windows Server
Durchgeschliffener Drucker funktioniert auf dem Server nicht
Disse1987Vor 1 TagFrageWindows Server12 Kommentare

Hallo zusammen, wieder einmal muss ich mich an euch wenden da wir mit unserem Latein am Ende sind. Seid ein paar Tagen hat eine Kundin ...

Hardware
PC und Monitor über Entfernung verbinden
gelöst ben1300Vor 23 StundenFrageHardware14 Kommentare

Guten Morgen :) folgende IST Situation: Ich habe einen Gaming PC, welchen meine Freundin gerne nutzt, z.B. für das "legendäre" Spiel Sims 4 ;) Normalerweise ...

Netzwerke
Internetprobleme seit Serverinstallation
beepboopVor 16 StundenFrageNetzwerke13 Kommentare

Guten Tag zusammen Bei einem Kunden habe ich ein sehr merkwürdiges Problem. Wir haben vor zwei Wochen einen Server beim Kunden installiert. Vorher waren nur ...

Windows Server
Auf Active Directory Benutzer und Computer von Windows 10 zugreifen
RealThoreVor 1 TagFrageWindows Server9 Kommentare

Hallo zusammen, da wir in der Abteilung (10 Leute) uns regelmäßig um die RDP Sessions auf unseren DCs (2012 R2) prügeln, wolle ich mal nachfragen, ...

Sonstige Systeme
Womit ist eine Nextcloud am Besten zu betreiben. Linux-PC oder RaspiPI
gelöst frosch2Vor 18 StundenFrageSonstige Systeme15 Kommentare

Hallo, wieder einmal möchte ich eure Meinungen. Es soll eine nextcloud in einer produktiven Umgebung eingesetzt werden. Ca. 6 Aussendienst- und 7 Innendienstmitarbeiter. Zusammen 13 ...