Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

keine Verbindung mit der 2. Netzwerkkarte ins Internet

Mitglied: 71697

Meine Aufgabe ist es einen HotSpot aufzubauen. Meine aktuelle Verbindung: Internet -> Speedport (Router) -> NIC1-> Server (Win Server 2003) -> NIC2 -> WLAN-Router (AP)

Hallo an alle,

ich bin langsam wirklich am verzweifeln. Habe schon mehrere beiträge gefunden die zu mir passen und trotzdem klappt es nicht. Ich hoffe ihr könnt mir helfen ist sehr wichtig.

Mein Auftrag ist es einen HotSpot mit zwei Access Points zu erstellen.

Das Internet geht über den Speedport zum Server (NIC1). Damit komm ich auch super ins Internet. Nun habe ich eine 2. Netzwerkkarte am Server die mit einem AP angeschlossen ist.
Ich versuch die ganze Zeit mit meinem Laptop über den AP ins Internet zu kommen aber schaff es nicht.

Mir persönlich ist es einmal wichtig, wenn ich die Verbindung über den AP hinbekäme. Ich bin nicht gerade sehr fit in dem Thema deswegen würde ich mich über detallierte Antworten freuen. Falls ihr noch mehr fragen habt oder mehr detaills wissen wollt, dann stellt sie mir bitte.

Danke!

Content-Key: 101330

Url: https://administrator.de/contentid/101330

Ausgedruckt am: 04.08.2021 um 01:08 Uhr

Mitglied: dasfranky
dasfranky 07.11.2008 um 15:37:29 Uhr
Goto Top
was für access-points?
sind die/der access-point konfiguriert?
ist das routing auf dem server an?
Mitglied: roberth
roberth 07.11.2008 um 15:56:24 Uhr
Goto Top
hallo,

verstehe ich richtig das der 1. AP der Speedport ist ?

also

inet - speedport - server ------> damit gehts ?

und mit

inet - speedport - server - ap ------> damit gehts nicht ?
Mitglied: 71697
71697 07.11.2008 um 16:02:24 Uhr
Goto Top
also der access-point ist ein billiger wlan router!
ich weiß nicht genau welche einstellungen ich da vornehmen muss am ap!

genau mit der server direkt komm ich ins i-net aber, dann über den ap mit dem laptop komm ich nicht rein.
Mitglied: dasfranky
dasfranky 07.11.2008 um 16:28:35 Uhr
Goto Top
du musst den 2ten billig router als access-point konfigurieren, die option gibts bei den meisten routern. eine IP in deinem subnet zuweisen,SSID einrichten und verschlüsselung und athentifizierung einstellen (WEP / WPA usw)
dann müsste die sache laufen.

wenn das routing im server richtig eingestellt ist, also von nic2 zu nic1. alterntiv würd ich dir raten, einen switch dazwischen zu hängen. das vereinfacht die sache um einiges.
Mitglied: roberth
roberth 07.11.2008 um 16:32:32 Uhr
Goto Top
also ich orakle jetzt mal folgendes:

es funktioniert mit dem speedport weil du dich direkt auf den speedport connectest und von dort aus dann ins internet kommst.
der server spielt hier keine rolle. (??)

dann nimm den 2 AP steck ihn in nen Switch das er im Netz hängt. Darauf achten das nur EINE Stelle im Netzwerk IP Adressen verteilt. Dann mal schauen welche IP der AP hat, diese muss natürlich zum Netz passen.
Mitglied: 71697
71697 07.11.2008 um 16:42:08 Uhr
Goto Top
Gut den AP, hab ich jetzt als AP konfuguriert, SSID auch vergeben nur mein Lapotop verbindet sich erst garnicht mit AP.

Ich gehe auch davon aus das nicht richtig geroutet wird.
Wie mach ich die Routen???

@ roberth

ja genau hier hat der server nichts zu tun.
Ja aber ich wollte das über 2 Netzwerkkarten über den Server basteln und mit der einen Netzwerkkarte komm ich auch ins Internet ich geh mal davon aus das nicht nicht richtig geroutet wird. Aber wie löse ich das problem
Mitglied: roberth
roberth 07.11.2008 um 18:32:06 Uhr
Goto Top
also dein gewünschtes vorhaben lautet:

server 2003 mit dann 3 (!) Netzwerkkarten, eine fürs normale netz, die beiden anderen für die AP´s ? Sollen die alle im selben Netz sein ?
Mitglied: aqui
aqui 07.11.2008 um 18:57:35 Uhr
Goto Top
Sieh dir mal dieses Tutorial an, da steht eigentlich alles drin was du machen musst damit es problemlos funktioniert:

https://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...

Das ist die erste Lektüre... !
Wie du einen billigen WLAN Router zum Accesspoint machst kannst du hier genau nachlesen:

https://www.administrator.de/Kopplung_von_2_Routern_am_DSL_Port.html#toc ...

Wenn du das beides umgesetzt hast sollte dein Netz auf Anhieb funktionieren !!


Am besten solltest du das aber komplett lassen mit dem Win Server denn es gibt eine technisch erheblich bessere Lösung:

Siehe hier:

https://www.administrator.de/WLAN_oder_LAN_Gastzugang_einrichten_mit_ein ...
Mitglied: roberth
roberth 07.11.2008 um 19:02:19 Uhr
Goto Top
super !!
gruß,
roberth
Mitglied: 71697
71697 08.11.2008 um 15:57:09 Uhr
Goto Top
Also Danke erste einmal für die Infos!

Bin jetzt soweit das ich folgendes gemacht habe:

Einstellung am Router:

IP: 192.168.178.1
Maske: 255.255.255.0
DHCP-Bereich: 192.168.178.20-200

Route über die Kommandozeile hinzugefügt:
Ziel 193.169.1.0 Maske 255.255.255.0 GW 193.169.1.1

NIC1:
IP: 192.168.178.10
Maske: 255.255.255.0
DNS/GW: 192.168.178.1

NIC2:
IP: 193.169.178.1
Maske:255.255.255.0
GW/DNS: kein eintrag

AP:
IP: 193.169.178.2
Maske: 255.255.255.0
GW: 193.169.178.1
Range: 193.169.178.20-40

Routing ist auch aktiviert.

Erstens ich komm über WLan nicht an den AP dran, stellt also keine Verbindung auf!
Zweitestens hab ich meinen Laptop über Lan den AP angeschlossen:
Daten vom Laptop

IP: 193.169.178.20
Maske: 255.255.255.0
SG: 193.169.178.2

Aber irgendwie komm ich trotzdem nicht ins netzt über meinen schlappi. Was mach ich nur falsch. Ich hoffe ihr könnt mir helfen?!
Mitglied: Magglite
Magglite 08.11.2008 um 21:31:05 Uhr
Goto Top
hi,

1.
da der Lapptop im selben Netz ist wie der AP stimmt vermutlich das GW nicht.

2.
193.169.178.0/24 ist ein öffentliches Netz und gehört nicht zum privaten Addressbereich

3.
wo hast du die Route hinzugefügt, am Server oder am Router ???
Der Server kennt beide direkt angeschlossenen Netze an NIC1 und NIC2 von selbst. Der Router kennt das Netz hinter dem Server aber nicht (NIC2). Daher musst du am Router eine statisch Route (über die Weboberfläche) konfigurieren.

also eher

NIC2:
IP: 192.168.179.1
Maske:255.255.255.0
GW/DNS: kein eintrag

AP:
IP: 192.168.179.2
Maske: 255.255.255.0
GW: kein eintrag

LAPTOP:
IP: 192.168.179.20
Maske:255.255.255.0
GW: 192.168.179.1
DNS: 192.168.178.1


Router:
route add 192.168.179.0 255.255.255.0 via 192.168.178.10
Mitglied: aqui
aqui 09.11.2008 um 14:23:08 Uhr
Goto Top
"Route über die Kommandozeile hinzugefügt:
Ziel 193.169.1.0 Maske 255.255.255.0 GW 193.169.1.1
" ;

Das ist FALSCH !! Du musst doch logischerweise ein Gateway im gleichen Netzwerk angeben um in das Zielnetz zu kommen !!!
Wie soll die Route denn den Weg finden ins Zielnetz wenn du das gateway im Zielnetz selber plazierst....das ist Unsinn !
Der Server ist ja der Router hier...

Richtig muss es heissen:
Route über die Kommandozeile hinzugefügt:

Ziel 193.169.1.0 Maske 255.255.255.0 GW 192.168.178.10

Sorry, aber das steht im Tutorial auch explizit so drin wenn man sich das genau durchliesst !!

Das du am Laptop nicht ins Internet kommst ist klar, denn dein AP vergibt vermutlich sich selber per DHCP als Gateway an den Laptop. Es muss aber der Server sein...logisch der ist ja auch Router !
Der AP selber ist natürlich Unsinn und kann dann nicht funktionieren, denn das Gateway muss ja logischerweise die IP des Server NICs sein.
Auch das steht genau so im Tutorial !
Analog gilt das für die DNS Auflösung ! Das muss entweder auch die Server IP sein sofern du auf dem Server selber einen eigenen DNS betreibst sonst muss es hier die Router IP vom Internetrouter sein, denn der ist ja DNS Proxy.
Also mal genau ins Tutorial sehen, da steht alles drin um es richtig zu machen !!!

Deine Settings müssen also SO sein damit es funktioniert:

Einstellung am Router:

IP: 192.168.178.1
Maske: 255.255.255.0
DHCP-Bereich: 192.168.178.20-200

Route im Internet Router !! hinzugefügt: (nicht im Server !!)
Ziel 193.169.1.0 Maske 255.255.255.0 GW 192.168.178.10
(Kannst du keine statische Route im Router !! einrichten musst du zwangsweise ICS im Server/PC nutzen wie im
Tutorial beschrieben !!)
NUR dann ist diese statische Route im Internet Router ! nicht erforderlich !

NIC1:
IP: 192.168.178.10
Maske: 255.255.255.0
DNS/GW: 192.168.178.1

NIC2:
IP: 193.169.178.1
Maske:255.255.255.0
GW/DNS: kein eintrag

AP:
IP: 193.169.178.2
Maske: 255.255.255.0
GW: 193.169.178.1
Range: 193.169.178.20-40
(Achtung AP muss hier 193.169.178.1 als Gateway und/oder DNS vergeben an die Clients oder als DNS die 192.168.178.1 wenn du keinen DNS auf dem Server betreibst !!)

Routing ist auch aktiviert im Server/PC.

Daten vom Laptop

IP: 193.169.178.20
Maske: 255.255.255.0
SG: 193.169.178.1
DNS: 192.168.178.1 (oder 193.169.178.1)

Damit es nicht nochmal schiefläuft weil du das Tutorial nicht liest hier ein Bild wie es aussehen MUSS:
Achtung: Die Zeichnung geht von einer geänderten RFC 1918 konformen IP Adresse aus mit 172.16.178.0 /24 ! Du musst also alle o.a. Angaben von ursprünglich 193.169.178.0 /24 auf DIESES IP Netz ändern solltest du das Netz so konform machen wollen.
Wenn nicht blässt du es halt bei der unglücklich gewählten 193.169.178.0 oder nimmst eine RFC 1918 IP Adresse deiner Wahl im 10er, 172er oder 192.168er Bereich !!

1644519dd62ee6004096ae138a24f81f-hspwin
Der Laptop muss diese Daten haben damits funktioniert !
Damit sollte das ganze Szenario dann einwandfrei funktionieren !!

Nochwas:
193.169.178.0 /24 ist kein privates Netz !! sondern gehört
AT&T in England wie du selber nachprüfen kannst:
http://www.heise.de/netze/tools/whois-abfrage
(Dort die Netzwerk Adresse 193.169.178.0 eingeben )

Diese Wahl ist also höchst unglücklich denn dir gehört diese öffentliche IP (vermutlich) nicht, was dir früher oder später mal Probleme bereiten kann. Gerade wenn du das Netz in einem öffentlichen Hotspot benutzt obwohl es dir nicht gehört !!
Du solltest also besser RFC 1918 adresskonform sein und dir sowas wie 172.16.178.0 /24 aussuchen !!
Siehe hier:
http://de.wikipedia.org/wiki/Private_IP-Adresse

Wie bereits gesagt: Die ganze Frickelei mit Server usw. kannst du dir mit einem zigarrenschachtelgroßen Gerät oder einem uralt PC der nur ein CD Laufwerk hat ersparen wenn du dieses Tutorial für deinen Hotspot umsetzt:

https://www.administrator.de/WLAN_oder_LAN_Gastzugang_einrichten_mit_ein ...
Mitglied: Magglite
Magglite 09.11.2008 um 20:40:03 Uhr
Goto Top
sehr gut aqui,
super ausführlich :-) face-smile.

grüße magglite
Mitglied: 71697
71697 09.11.2008 um 23:02:15 Uhr
Goto Top
Vielen Dank, erste einmal das ihr euch da so viel Mühe gibt.

Tut mir leid das ich mich da so blöd anstelle.

Jetzt hab ich alles so gemacht wie ihr es beschrieben habt.
Nur jetzt hab ich noch ein problem.

Ich komm ins Internet, aber nur dann wenn ich meinem Laptop die IP-Adresse fest vergebe, aber die Leute sollen ja ohne eingabe der IP drauf kommen.

Ich hab gemerkt , dass der das falsche GW nimmt wenn ich beim AP DHCP aktiviert habe und zwar die vom AP und wenn ich es ausschalte und das GW von der NIC2 eingeben funktionierts.

Wie kann ich das umgehen???
Mitglied: Magglite
Magglite 10.11.2008 um 00:30:08 Uhr
Goto Top
da das GW sich am AP nicht umkonfigurieren lässt, musst du hierzu DHCP am AP deaktivieren und einen DHCP - Server auf dem NIC2 vom Windows aufsetzen. Dabei darf sich der IP-Range nicht mit der fest eingestellten IP des AP überschneiden.

siehe http://www.educheck.de/pdf/Step_6_DHCP_DNS_WINS_deutsch.pdf
Heiß diskutierte Beiträge
question
Backup-Konzept für HeimgebrauchmossoxVor 1 TagFrageBackup13 Kommentare

Guten Tag zusammen, ich bin mir nicht sicher, ob ich das richtige Unterforum gewählt habe, denn meine Frage berührt auch den Bereich Hardware und Netzwerke. ...

question
Günstiges Open-Source NAS für HeimgebrauchpanguuVor 1 TagFrageSAN, NAS, DAS10 Kommentare

Hallo, mit NAS-Systemen hatte ich bisher gearbeitet: Synology, QNAP, Buffalo, etc. Dabei kommen proprietäre Betriebssysteme zum Einsatz, die sich natürlich von Hersteller zu Hersteller unterscheiden ...

question
Domains, die mir gehören gelöst IT-EinsteigerVor 1 TagFrageInternet Domänen5 Kommentare

Hi, Ich habe verschiedene Domain, bei verschiedenen Hostern. Da ich hier und da nur eine Domain gekauft habe, um den Hoster zu testen, habe ich ...

question
Ipv6 RouterliodiceVor 1 TagFrageDSL, VDSL10 Kommentare

Hallo zusammen, ich hoffe ihr könnt mir weiterhelfen, ich benötigen einen ADSL Router (Kabelgebundenen) der IPv4 und IPv6 kann, also Dual Stack (DHCP Extern und ...

question
SSH Login nur möglich bei eingelogtem USERhell.wienVor 1 TagFrageLinux Netzwerk21 Kommentare

habe einen Server (Debian) mit SSH (nur mit Public Key und auf einem Custom Port) und ufw aktiv. Ich kann mich nicht einlogen. Wenn ich ...

question
PC geht ohne Vorwarnung aus und fährt wieder hochWasserstrahlbiegezangeVor 1 TagFrageHardware14 Kommentare

Hi, vor einiger Zeit hat mein PC angefangen sich merkwürdig zu verhalten. Er stürzte einfach ab, ging dabei teilweise ohne Vorwarnung aus, und fuhr wieder ...

question
Server 2019 std. auf deutsch umstellenBender999Vor 10 StundenFrageWindows Server19 Kommentare

Hallo, kann mir einer erklären wie um alles in der Welt ich meinen Server 2019 std. auf deutsch umstellen kann? ...

question
Prozess bzw. Programm zu Verbindung auf IP herausfinden gelöst dcmindenVor 1 TagFrageWindows Netzwerk8 Kommentare

Wir bekommen bei diversen Kunden regelmäßig (alle 6 - 8 Tage) Alarmmeldungen von der Firewall zu einer geblockten Verbindung zu 68.183.140.225 Port 443. Jetzt möchten ...