KMS Server - 0C004F074

samrein
Goto Top
Hallo zusammen,

wir haben 2 Domänen, in Domäne 1 ist der KMS Server installiert. Die entsprechenden Einträge für das Abfragen des KMS Server in der zweiten Domäne wurden ebenfalls gemacht. Das hat in der Vergangenheit (> 2 Jahre) auch wunderbar funktioniert. Seit einiger Zeit funktioniert aber die Aktiverung aus der 2. Domäne nicht mehr, aufgefallen ist das mir erst als Windows mitteilte das die Aktivierung erneuert werden müsste.

Vielleicht hängt das mit einem Windows Update aus der Vergangenheit zurück, der Aktivierungszeitraum sind ja eigentlich 180 Tage, übrig sind jetzt noch 22 Tage. Kann also durchaus ein Grund sein, hab aber nichts im Netz dazu gefunden. Beim Versuch zu aktivieren sehe ich im Log das die Anfrage an den KMS Server versendet wird, im Firewall-Log sehe ich auch den Connect über Port 1688.

Dennoch erhalte ich das der Schlüsselverwaltungsserver nicht gefunden werden kann.

Fehler 0xC004F074

Ich habe den KMS Schlüssel auch noch mal neu installiert, Cache gelöscht.

Der KMS Server an sich funktioniert einwandfrei, die Aktivierungen in der 1 Domäne sind alle einwandfrei.

Wo könnte ich noch suchen?

Grüße
Stefan
kms

Content-Key: 3196948973

Url: https://administrator.de/contentid/3196948973

Ausgedruckt am: 15.08.2022 um 18:08 Uhr

Mitglied: emeriks
emeriks 28.06.2022 um 08:41:48 Uhr
Goto Top
Hi,
kann der betreffende Client den KMS-Server denn überhaupt erreichen? Rein netzwerktechnisch?

E.
Mitglied: samrein
samrein 28.06.2022 um 08:58:56 Uhr
Goto Top
Hi Emeriks,

ja klar, ich sehe ja auch die Verbindungsanfrage an den KMS Server im Firewall-Log über Port 1688.

Ich kann auch die Server auf dem KMS Server manuell hinzufügen, erhalten dann aber die gleiche Meldung wenn ich versuche den Client zu aktivieren das der Lizenzierungsserver


Mitglied: samrein
samrein 28.06.2022 um 09:03:02 Uhr
Goto Top
wenn ich beim KMS Server netstat -a ausführe, müsste ich doch eigenltich auch den Port 1688 unter TCP Verbindungen aufgeführt bekommen oder? Den sehe ich aber nicht... vielleicht nimmt der KMS Server die Anfragen tatsächlich
erst gar nicht korrekt an...
Mitglied: emeriks
emeriks 28.06.2022 um 09:03:15 Uhr
Goto Top
Zitat von @samrein:
Ich kann auch die Server auf dem KMS Server manuell hinzufügen, erhalten dann aber die gleiche Meldung wenn ich versuche den Client zu aktivieren das der Lizenzierungsserver
Egal ob über IP-Adresse oder FQDN?
Mitglied: emeriks
emeriks 28.06.2022 aktualisiert um 09:05:53 Uhr
Goto Top
Zitat von @samrein:
wenn ich beim KMS Server netstat -a ausführe, müsste ich doch eigenltich auch den Port 1688 unter TCP Verbindungen aufgeführt bekommen oder?
Jain. Diese Verbindungen sind nur sehr kurzlebig. Wenn, dann müsstest Du Dir das unmittelbar dann anzeigen lassen, wenn Du das ATO auf dem KMS Client ausführst.
Mitglied: Franz-Josef-II
Franz-Josef-II 28.06.2022 aktualisiert um 09:28:22 Uhr
Goto Top
Servas

Frage: Welche Server sind involviert? Ein KMS auf einem 2012R2 kann z.B. keinen 2022er aktivieren.


Nachsatz:
Weil im Screenshot "Datacenteredition" steht, somit Server ...... sonst hätte ich eh nicht daran gedacht, bei Win 10 und 11 weiß ich es jetzt nicht genau, bei den Servern bin ich mir hingegen sicher.
Mitglied: samrein
samrein 28.06.2022 um 09:46:57 Uhr
Goto Top
Hi Franz-Josef,

der KMS Server ist ein 2019 Datacenter. Die Clients aus der benachbarten Domäne sind auch alles 2019er.

Das kuriose ist ja, das das bislang über 2 Jahre problemlos lief.

Jetzt hab ich gerade mal über telnet den KMS Server angesprochen, und auch hier erhalte ich die Message das der Server nicht erreicht werden kann. Ich hänge jetzt mal zum testen ein 2 Netzwerkkarte in den Server damit der Client im selben Netzsegment ist wie der KMS Server. Meine Vermutung ist, das der KMS Server einfach keine Anfragen über Port 1688 annimmt. Ich habe die Firewall testweise auf beiden Machinen mal komplett deaktviert.
Mitglied: Franz-Josef-II
Franz-Josef-II 28.06.2022 aktualisiert um 10:12:04 Uhr
Goto Top
Ok

Werden irgendwelchen anderen Systeme, z.B. Windows 10 oder 11 aktiviert? Betrifft das somit nur Server oder eben ....

Hast Du schon einmal die "Domänenaktivierung" ausprobiert? Seitdem ich diese eingestellt habe, bin ich im KMS nicht mehr .... ganz sicher 😂

Zweite Netzwerkkarte = andere IP. Wie hast Du den KMS "bekanntgemacht"? DNS-Einträge?

nslookup -type=all _vlmcs._tcp>kms.txt

Ergibt was?



Wenn er ihn nicht erreicht, was passiert nach einem
slmgr -skms IP_oder_FQDN_des_KMSServers und anschließenden
slmgr -ato?
Mitglied: samrein
Lösung samrein 28.06.2022 um 11:02:07 Uhr
Goto Top
So, danke nochmal für Euren Unterstützung. Ich konnte das Problem lösen.


nslookup -type=all _vlmcs._tcp
zeigte mir die korrekten Daten an.



Sehr skurill. Nachdem ich dem Server eine Netzwerkarte aus dem selben Segement gegeben haben, in dem auch der KMS Server steckt, hab ich beim der Aktvierung eine andere Fehlermeldung erhalten, nämlich das nicht genügend Clients vorhanden wären.

Nachdem sich 25 Clients aktivert haben funktionierte die Aktivierung wieder. Die Fragen die zurückbleiben, warum haben sich zu wenige Clients in der Vergangenheit am KMS Server gemeldet, normalerweise melden die sich ja eigentlich alle paar Tage beim Server, und warum erhalte ich eine Fehlermeldung das der KMS Server nicht antwortet wenn es doch eigentlich an der fehlenden Clientzahll lag.

Ich bin außerdem davon ausgegangen das der KMS Server nur initial die 25 Clients abfragt, aber scheinbar stellt er auch keine Lizenzen mehr aus wenn im Laufe der Zeit weniger Clients im Netz sind.
Bei uns sind es aber deutlich mehr als 25, von daher muss ich noch mal weiter schauen warum nicht genügend Anfragen von den Clients kamen.
Mitglied: Franz-Josef-II
Franz-Josef-II 28.06.2022 um 11:06:11 Uhr
Goto Top
Nein, er zählt immer mit und wenn es zuwenig werden stellt er ein.

Installierst Du oder clonst Du? Ein Clone hat diesselbe ID und ist somit derselbe PC
Mitglied: samrein
samrein 28.06.2022 um 11:36:15 Uhr
Goto Top
Ich habe tatsächlich viele geklonte Maschinen... das könnte natürlich ein Problem sein, komisch nur, das es nach so langer Zeit erst auftritt. Ich prüfe die ID gleich mal, aber Du hast wahrscheinlich recht. Theoretisch müsste man dann ein Sysprep machen um eine neue ID zu erhalten...
Mitglied: Franz-Josef-II
Franz-Josef-II 28.06.2022 um 11:42:02 Uhr
Goto Top
Irgendwo kann man die Anzahl der Aktivierungen auslesen. Wenn es nur knapp drüber war und einer ausgefallen ist .....


Auch ein Grund warum ich auf die Domänenaktivierung umgestiegen bin ..... keine Mindestanzahl.
Mitglied: samrein
samrein 28.06.2022 um 12:00:59 Uhr
Goto Top
Ich habe eigentlich die Domänenaktivierung aktivert. Jetzt wirds ja ganz komisch. Da muss es ja noch woanders haken...
kms2
Mitglied: Franz-Josef-II
Franz-Josef-II 28.06.2022 um 12:48:15 Uhr
Goto Top
Dann mache am KMS ein:

slmgr -dlv all

.... sollte eigentlich alle relevanten Daten auslesen.