sat-fan
Goto Top

Link Aggregation HexRouter Wol

Hi,
im Moment koppele ich zum Lastenausgleich zwei Ports meines Nas mit Link Aggregation mit meinem GS1900-8.
Leider funktioniert in dem Modus kein wol, da dieses Paket nicht über den switch kommt. Single Port funktioniert.
Nun meine Frage. Ist es evtl. möglich das mein neuer Hex router das wol iwi mit LA weiter leitet ?

Danke

Content-Key: 81917999185

Url: https://administrator.de/contentid/81917999185

Printed on: February 25, 2024 at 12:02 o'clock

Member: aqui
aqui Oct 06, 2023 updated at 07:18:51 (UTC)
Goto Top
Grade mal mit Wireshark getestet an einem GS1900-5 und an einem RB750G3 und beide übertragen die WoL Pakete problemlos auf einem LACP LAG. Wäre auch sehr verwunderlich wenn nicht, denn ein Switch muss Broadcasts immer zwingend fluten auf allen Ports. Das wäre ein grober Firmware Bug würden sie es nicht tun.
Das klappt sowohl mit UDP 9 als auch mit nackten Layer 2 WoL Paketen.
Ist dein 1900 auf die aktuellste Firmware geflasht?!
Member: sat-fan
sat-fan Oct 06, 2023 updated at 07:56:12 (UTC)
Goto Top
Glaube es liegt an 802.3ad dynamic of LACP Link Aggregation Da wird wohl was geblockt. Habe im Qnap forum dazu folgendes gefunden, da ich mit dem Problem wohl nicht alleine bin. Lacom switch verhält sich wie der Zycel.
Die Diskussionen und meine Tests sind aber auch 3 Jahre alt.


Bei mir geht das auch nicht und das liegt schlichtweg daran, dass bei Portbündelung gemäß der 802.3ad Spek über >diese Ports im Power-OFF oder Standby des Ziels (also Deiner NAS) lediglich MAC Multicast Pakete übertragen >werden >müssen.

WOL Pakete sind aber keine Multicast Pakete und werden deshalb von manchen Switchs (ich hab nen LANCOM) >schlichtweg nicht übertragen

Über ein LACP Ports werden - solange das Bündel noch nicht steht - ggf. lediglich Multicast Pakete übertragen und >dann funktioniert WOL nicht.


Wenn ich Ports als LACP Ports definiere werden dort - wie vermutet - nur noch MAC Multicast Pakete übertragen.
Das konnte ich in den Paketstatistiken der entsprechenden Ports nachvollziehen.


Also: LANCOM Switch verhält sich komplett Spek-konform, denn WLAN Pakete müssen schlichtweg nicht übertragen >werden.
Ist ja eigentlich auch nachvollziehbar:

Aus logischer Sicht ist bei einem Port, der als LACP Mitglied definiert ist schlichtweg keine Verbindung vorhanden, >wenn gegenüber kein LACP fähiger Port da ist.

Und das ist eben im Sleep / Standby / Shutdown der NAS der Fall..
Member: aqui
aqui Oct 06, 2023 updated at 13:53:42 (UTC)
Goto Top
LACP Link Aggregation Da wird wohl was geblockt.
Nein, das ist technsicher Quatsch. Auch ein LACP LAG muss sich Standard konform verhalten im Layer 2!
Der Grund ist in der Regel nicht der LACP LAG sondern das im Standby die Port Speed auf 100 oder 10 Mbit runtergetaktet wird um Energie zu sparen und der angeschlossene Switch das oft nicht mitmacht solange es keinen Link Down Event gibt. Es obliegt dann dem Endgerät nach dem Runtertakten eine neue Port Speed- und Dublex Negotiation zu initiieren.
Durch dieses Firmware Fehlverhalten kommt es deshalb oftmals zu einem Speed- und Duplex Mismatch am Port und das Engerät kann den Frame dann nicht mehr empfangen.
Sowas sollte heutzutage mit aktuellen FW Releases nicht mehr auftreten. Wireshark zeigt ja auch ganz klar das diese Frames vom Switch erwartungsgemäß geforwardet werden.
Member: sat-fan
sat-fan Oct 06, 2023 at 08:56:25 (UTC)
Goto Top
super... danke ! dann werde ich mal FW prüfen oder ggf. den Hex bemühen
Member: aqui
aqui Oct 24, 2023 at 14:02:32 (UTC)
Goto Top
Wenn es das war bitte nicht vergessen deinen Thread hier als erledigt zu markieren!