Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mikrotik Gast-Wlan keine Verbindung zum Internet?

Mitglied: dirkschwarz

dirkschwarz (Level 1) - Jetzt verbinden

25.08.2019 um 09:13 Uhr, 776 Aufrufe, 14 Kommentare

Guten Morgen,

habe ein wahrscheinlich einfaches Problem, bei dem ich aber nicht wirklich weiter komme....
Ich möchte ein Gast-Wlan auf einem Router (Capsman) erstellen.

Folgende Schritte habe ich bereits auf dem "Capsman-Router" vorgenommen:

  • virtuelle "Gast"-Interface erstellt
  • neue "bridge-gast" erstellt und dieser die virtuellen Gast-Interface zugeordnet (Port)
  • Bridge eine IP zugeordnet (192.168.18.1/24 = Gastnetz) zugeordnet
  • auf der Bridge einen DHCP-Server erstellt (IP-Range entsprechend Gastnetz, Gateway 192.168.18.1/bridge-gast, DNS 8.8.8.8)

Die Klienten können sich nun problemlos mit dem Gastnetz verbinden - bekommen auch eine IP aus dem Gastnetz....ABER ES KANN KEINE VERBINDUNG ZUM INTERNET aufgebaut werden.

Was habe ich in meinem Setup vergessen?


Herzlichen Dank & noch einen schönen Sonntag!
Mitglied: 140913
25.08.2019, aktualisiert um 10:06 Uhr
  • Default-Route am Mikrotik auf den DSL-Router erstellt? 0.0.0.0/0 => IP Internet-Router
  • Statische Route am Internet-Router zum Gastsubnetz angelegt? Netz: 192.168.18.0 MASKE 255.255.255.0 GW [IP DES MIKROTIK am Port zu Internet-Router]
  • Wenn der Internet-Router keine statische Routen zulassen sollte(kommt vor bei billigen Speedports) dann am Mikrotik als Alternative SRCNAT für das Gastnetzwerk machen Beispiel: /ip firewall nat add chain=srcnat src-address=192.168.18.0/24 out-interface=ether1 action=MASQUERADE
Routing sollte man aber immer bevorzugen, denn doppeltes NAT kostet nur Performance und bringt noch andere Nachteile mit sich.
  • Firewall Regeln angelegt (z.B. Forwarding Chain geblockt)?
Bitte warten ..
Mitglied: dirkschwarz
25.08.2019, aktualisiert um 11:36 Uhr
Herzlichen Dank für deine Antwort...

Hier noch einmal als Bild:

mikrotik-gast-ap - Klicke auf das Bild, um es zu vergrößern

statische Routen auf der Fritz!box:
  • 192.168.17.0/24 - Gateway 192.168.178.11 (OpenWRT)
  • 192.168.18.0/24 - Gateway 192.168.178.11 (OpenWRT) - ist das eigentlich notwendig?

statische Routen auf OpenWRT:
  • 192.168.18.0/24 - Gateway 192.168.17.11 (Capsman, Router)

zwischen OpenWRT/ Fritz!box kein NAT. Auf der Gast-Bridge ist auch reger Netzwerkverkehr....nur bei den Klienten kommt nichts an

vermute, dass die Pakete nicht geroutet werden...

seitens Klient:

ping 192.168.18.1 = okay
ping 192.168.17.11 = okay
ping 192.168.17.1 = klappt nicht
ping 8.8.8.8 = klappt nicht
Bitte warten ..
Mitglied: 140913
25.08.2019, aktualisiert um 11:38 Uhr
Die Routen sind soweit alle i.O. Mach doch mal vom Client ein tracert auf die IP der Fritzbox und auf eine Internet-IP, damit kannst du feststellen wo die Pakete auf ihrem Weg hängen bleiben.
Ich tippe auf den OpenWRT, der das Forwarding des ihm unbekannten Subnetzes das vom Mikrotik kommt in seiner Forwarding Chain blockt.
Am einfachsten die Export-Config des Mikrotik und des OpenWRT posten dann müssen wir nicht die Glaskugel bemühen.
Bitte warten ..
Mitglied: dirkschwarz
25.08.2019 um 11:49 Uhr
habe jetzt noch ein Forward-Regel auf dem Capsman-Router eingerichtet:

firewall-forward - Klicke auf das Bild, um es zu vergrößern

jetzt klappt auch ein ping auf 192.168.17.1 (OpenWRT)

ping 8.8.8.8 klappt weiterhin nicht.
Bitte warten ..
Mitglied: 140913
25.08.2019, aktualisiert um 12:04 Uhr
Zitat von dirkschwarz:

habe jetzt noch ein Forward-Regel auf dem Capsman-Router eingerichtet:

firewall-forward - Klicke auf das Bild, um es zu vergrößern

jetzt klappt auch ein ping auf 192.168.17.1 (OpenWRT)
Nein, eine Forward Regel ist hier nicht nötig sofern überhaupt keine anderen Regeln existieren, denn per Default lässt die Firewall des Mikrotik ohne existierende Regeln alles durch!
ping 8.8.8.8 klappt weiterhin nicht.
Deswegen sagte ich ja mach ein tracert und schalte die Firewall auf dem OpenWRT temp. komplett ab!

Außerdem sollte LocalForwarding im Capsman Profil erst mal auf No stehen, so dass der Capsman das Interface des Caps verwaltet.
Grundlagen dazu erst mal anlesen
https://blog.effenberger.org/2017/08/27/wlan-zentral-verwalten-mit-capsm ...

Es bringt nichts wenn wir dir hier sagen was du machen sollst du aber immer wieder andere sinnlose Dinge machst und unsere Fragen nicht beantwortest und auch nicht entsprechende Configs im Klartext postest🙃 !!
Bitte warten ..
Mitglied: dirkschwarz
25.08.2019 um 12:17 Uhr
alle Interfaces laufen über den Capsman!

capsman - Klicke auf das Bild, um es zu vergrößern

ein traceroute OHNE forwarding:

Bitte warten ..
Mitglied: aqui
25.08.2019 um 12:38 Uhr
Hier gibt es noch ein paar Anregungen für das MT Gastnetz mit CP:
https://www.mikrotik.com.my/hotspot-server-with-captive-portal-and-walle ...

Der Traceroute bliebt ja bei .18.1 hängen. Ergo geht es ab da mit einer Default Route Richtung Internet nicht weiter. Sprich hier rennt also das Routing ins Nirwana.
Da gibt es jetzt mehrere Optionen an diesem Punkt (.18.1)
  • fehlende Default Route
  • NAT Regel greift nicht
  • Firewall Regel blockiert
Sinnvoll wäre es mit dem Ping Toll am .18.1er Endgerät dort die 8.8.8.8 zu pingen und einmal ins Log zu sehen was da passiert.
Bitte warten ..
Mitglied: 140913
25.08.2019, aktualisiert um 14:53 Uhr
Zitat von dirkschwarz:

alle Interfaces laufen über den Capsman!
Gut, dann ist das schon mal geklärt.
ein traceroute OHNE forwarding:
Falsch, forwarden tut der Mikrotik per Default immer wenn keine Filter Regeln existieren!!
Gut, danke das du unsere Fragen zumindest teilweise beantwortest. Zum OpenWRT hast du bisher nichts beantwortet und ob du dort die FW schon abgeschaltet hast.
Für den Mikrotik bitte ich dich die Config hier doch bitte zu Posten (hatte ich übrigens auch schon drum gebeten), das geht ganz einfach indem du auf der Konsole ein export hide-sensitive absetzt das ganze kopierst und hier mit Codetags rein pastest!

Offensichtlich bleiben die Pakete hier schon zwischen Mikrotik und OpenWRT hängen, also fehlt hier entweder die Default-Route im Mikrotik oder am OpenWRT blockt die Firewall das Forwarding.
Kurz mit Wireshark am Mikrotik oder OpenWRT gecaptured würde dir das ebenfalls direkt zeigen.

So jetzt bist du dran uns die nötigen Infos zu liefern, aber bitte diesmal komplett,ohne daß wir dir alles zweimal aus der Nase ziehen müssen, DANKE!
Bitte warten ..
Mitglied: dirkschwarz
25.08.2019 um 19:19 Uhr
Ich hoffe Ihr habt noch ein wenig Geduld....

ich denke die Anfragen werden vom OpenWRT nicht weiter gereicht.

Syslog OpenWRT:
die "export" Datei vom Mikrotik:

Wenn ich das richtig sehe, fehlt mir die NAT-Regel am Mikrotik bei der Umsetzung der Anfragen aus dem 192.168.18.0 Netz über das LAN 192.168.17.0 Netz ins Internet...

oder liegt der Ansatz beim OpenWRT?


Danke & noch einen schönen Abend!
Bitte warten ..
Mitglied: Lochkartenstanzer
25.08.2019, aktualisiert um 19:22 Uhr
Zitat von dirkschwarz:

Wenn ich das richtig sehe, fehlt mir die NAT-Regel am Mikrotik bei der Umsetzung der Anfragen aus dem 192.168.18.0 Netz über das LAN 192.168.17.0 Netz ins Internet...

oder liegt der Ansatz beim OpenWRT?

Entweder du schaltet NAT beim Mikrotik ein oder Du sagst dem OpenWRT, daß hinter der Microtik auch ein "lokales" Netz ist (vermutlich Firewall-regeln).

lks
Bitte warten ..
Mitglied: 140913
25.08.2019, aktualisiert um 19:37 Uhr
So, dir fehlt erstens die statische Default-Route in deiner Mikrotik Config, wie ich schon ganz zu Anfang vermutet hatte, also als erstes nachtragen!

/ip route add distance=1 gateway=192.168.17.1

Die ist Grundvoraussetzung für alles weitere.

Dann noch im OpenWRT das 192.168.18.0/24 Netz in der Forwarding-Chain (Firewall des OpenWRTs) freischalten und schon läuft dat! NAT brauchst du nicht, wäre natürlich möglich ist aber nur Performancefresser, Route wenn du kannst NATe wenn du musst!
Bitte warten ..
Mitglied: dirkschwarz
26.08.2019 um 09:53 Uhr
folgende Änderungen - leider ohne Erfolg

Mikrotik:


OpenWRT
.. vielleicht noch eine Idee?
Bitte warten ..
Mitglied: 140913
26.08.2019, aktualisiert um 11:51 Uhr
Ja, s.oben. Wireshark anwerfen oder hier mal die OpenWRT Config posten.
Bitte warten ..
Mitglied: aqui
30.08.2019 um 10:44 Uhr
Hier steht doch alles Schritt für Schritt wie es geht:
https://administrator.de/wissen/mikrotik-vlan-konfiguration-routeros-ver ...
Bitte warten ..
Ähnliche Inhalte
MikroTik RouterOS
MikroTik als Gast-WLAN-Client
gelöst Frage von Alex29MikroTik RouterOS23 Kommentare

Hallo zusammen, ich benötige mal wieder Eure Hilfe. Ziel ist es einen MikroTik-Router (HAP-AC2) an einem beliebigen Gastnetzwerk zu ...

Router & Routing

VLAN + Rouing für Gast-WLAN mit TP-Link AC500, Mikrotik und Speedport für Internet

Frage von undertaker1753Router & Routing15 Kommentare

Hallo Zuallererst: Ich bin im normalen Leben Programmierer, von Netzwerk also kein Expertenwissen :( Das ist auch der Grund, ...

Netzwerke

Gast WLAN einrichten

Frage von Hajo2006Netzwerke25 Kommentare

Hallo, also ich bin gerzeit dabei nachforschungen anzustellen um ein Gast-WLAN zu realisieren. Da ich das bisher noch nie ...

LAN, WAN, Wireless

WLAN Gast Zugang mit Registrierung

Frage von ahmedahmedLAN, WAN, Wireless4 Kommentare

Hallo, ich möchte gerne ein WLAN Hotspot aufbauen. Dabei sollte es möglich sein, sich zu verbinden und registrieren. Nach ...

Neue Wissensbeiträge
Sicherheit
Corona Malware über manipulierte Router
Information von sabines vor 2 StundenSicherheit

Heise berichtet über Malware, die in Zusammenhang zum Suchethema Corona steht und über DNS Einstellungen bei D-Link und Linksys ...

Windows 10
Windows 10 Update KB4535996 fehlerhaft
Information von Frank vor 9 StundenWindows 101 Kommentar

Laut Microsoft ist das Update KB4535996 die Ursache für aktuelle Verbindungsprobleme bei Virtual Private Networks (VPNs). Microsoft arbeitet bereits ...

Administrator.de Feedback
Entwicklertagebuch: Der neue Ticker ist da
Information von admtech vor 9 StundenAdministrator.de Feedback2 Kommentare

Hallo User, mit dem aktuellen Release haben wir den neuen "Ticker" zur Seite hinzugefügt. Oben im Hauptmenü findet ihr ...

Windows Tools

Erfahrungsbericht Reiner SCT TimeCard Zeiterfassung und Zutrittskontrolle

Erfahrungsbericht von radiogugu vor 1 TagWindows Tools5 Kommentare

Hallo miteinander. Wir setzen seit 2015 die Zeiterfassung von ReinerSCT mit der Erweiterung um die auf Chips basierte Zutrittskontrolle ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Verrücktes Netzwerkproblem in einer alten SBS 2008 Domäne
Frage von PA-PeterNetzwerkmanagement36 Kommentare

Hallo zusammen, ich bin hier leider sehr verzweifelt und ersuche deshalb in Eurer Community ein paar Ideen oder Ansätze ...

Microsoft Office
Lang lebe die Cloud
Information von HenereMicrosoft Office18 Kommentare

Ein Grinsen kann ich mir nicht verkneifen. Henere

Windows Server
Erreichbarkeit von Freigaben auf Server 2019 durch ältere Linux-basierte Geräte
gelöst Frage von SarekHLWindows Server13 Kommentare

Hallo zusammen, ich habe hier zwei Geräte, einen Kopierer (Ricoh MP2554) und eine WebCam (Trendnet TV-IP311IP), die trotz korrekter ...

Firewall
PFsense OPENVPN nur RDP zulassen
gelöst Frage von schicksalFirewall12 Kommentare

Hallo zusammen, ich will folgendes konfigurieren: Ich habe einige OPENVpn Cilents bei diesen funktioniert der Tunnel. Nur folgendes, es ...