Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Netzwerk zu langsam!

Mitglied: cpb
Guten Tag,

Ich habe ein kleines Netzwerk eingerichtet. 3 PC's, einer davon dient als File-Server. Der File-Server hat Win XP Home. Von den Workstation hat die eine Win XP Home und die andere Win Millennium.

Wenn ich nun mit der XP Workstation z.B. einen Ordner auf dem File-Server öffnen möchte dauert das ewig.
Wenn ich das selbe mit der Millennium Workstation mache, geschiet dies sofort.

IP-Adressen sind alle fest verteilt. Die drei Rechner sind über einen Switch verbunden.
Alle drei Rechner haben eine 10/100 MB Karte.

Was kann ich tun, damit es auch von der XP Workstation schneller geht?

Vielen Dank im voraus!

Gruss

Content-Key: 5685

Url: https://administrator.de/contentid/5685

Ausgedruckt am: 21.10.2021 um 14:10 Uhr

Mitglied: fritzo
fritzo 16.01.2005 um 20:10:11 Uhr
Goto Top
Hi,

poste mal Deine Netzwerkeinstellungen (ipconfig /all) von allen drei Rechnern, sonst ist die Analyse recht schwierig.

Grüße,
fritzo
Mitglied: Fungo
Fungo 16.01.2005 um 22:40:07 Uhr
Goto Top
Hi,
Ich kenne dein Problem nur zu gut. Das liegt an Win XP. Das System fragt die SID ab und noch einige Sicherheiten. Das wirst du auch nicht wegbekommen. Ich bin dann auf Win 2000 umgestiegen. Damit klappt alles bestens. Wär ein Tip von mir.

MfG Fungo
Mitglied: fritzo
fritzo 17.01.2005 um 02:56:00 Uhr
Goto Top
Hi,

"Ich habe Probleme mit meinem Mercedes!"
"Ok, verkauf ihn und hol Dir stattdessen einen BMW, da läuft alles"

Also, wenn Du schon das System wechselst, dann nimm XP Professional. Für mich die erste Wahl. XP Home ist schon recht merkwürdig, weil es irgendwie kastriert anmutet. Aber anyway, nur weil das Connecten zu Shares ein wenig länger dauert als normal, mußt Du nicht wechseln.

Ok, erhältst Du Fehlermeldung im Log, mit denen man was anfangen kann? Was passiert, wenn Du Dich über die IP auf das Share verbindest, dauert es dann auch so lange?

Grüße,
fritzo
Mitglied: Fungo
Fungo 17.01.2005 um 08:46:55 Uhr
Goto Top
Hi,
Ich finde dein Vergleich nicht ganz passend. :-) face-smile Ich hätte vielleicht dazu sagen soll, das ich die Probleme mit XP Pro hatte. Die beiden Versionen nehmen sich nicht viel in der hinsicht.
Ich rede nur aus Erfahrung. Wenn er warten will beim Zugriff ist das ok, mich hats tierisch angenervt. Ausserdem läuft 2000 wesentlich stabiler wie XP. Nach meiner Erfahrung her. Und günstiger ist es auch. :-) face-smile

Fungo
Mitglied: 5528
5528 17.01.2005 um 09:41:07 Uhr
Goto Top
Hallo,

Unter umständen hast du Probleme mit der Namensauflösung.
Versuch einmal nur mit der IP-Adresse auf dem Fileserver zuzugreifen
und nicht mit dem Namen des Servers.


sg
Mitglied: Devian
Devian 17.01.2005 um 10:44:16 Uhr
Goto Top
Was für ein Switch ist das denn?

Hatte mal das gleiche Problem und da war der Switch der Flaschenhals...

Signed
Devian
Mitglied: pudelpointer
pudelpointer 17.01.2005 um 10:59:43 Uhr
Goto Top
Verbinde die freigegebenen Festplatten oder Verzeichnisse auf dem Fileserver von den Workstations aus als Netzlaufwerke. Das bringt meist (eigene Erfahrung) einen erheblichen Geschwindigkeitsgewinn.

Sag mal Bescheid, obs hinhaut.

CU
Pudelpointer
Mitglied: Fungo
Fungo 17.01.2005 um 11:18:56 Uhr
Goto Top
am DNS liegt das nicht, da der Millenium rechner keine Probleme hat. Das ist so, da er diese idiotischen Sicherheitsabfragen bzw. Sicherheitsrichtlinien von XP nicht hat und verwendet. Das liegt auch net am Switch sondern ganz einfach an dem Fileserver mit XP.

Fungo
Mitglied: cpb
cpb 17.01.2005 um 19:18:20 Uhr
Goto Top
am DNS liegt das nicht, da der Millenium
rechner keine Probleme hat. Das ist so, da
er diese idiotischen Sicherheitsabfragen
bzw. Sicherheitsrichtlinien von XP nicht hat
und verwendet. Das liegt auch net am Switch
sondern ganz einfach an dem Fileserver mit
XP.

Fungo

Was kann ich denn dagegen tun?

Die Shares sind bereits als Netzlaufwerke verbunden!
Per IP Adresse gehts auch nicht schneller.
Mitglied: Devian
Devian 17.01.2005 um 20:23:57 Uhr
Goto Top
Hast du mal einen Geschwindigkeitstest via FTP (z.B. mit dem FileZilla Server und Client) gemacht? Welche Performance liefert der XP-Rechner denn damit?

Devian
Mitglied: cpb
cpb 17.01.2005 um 20:36:41 Uhr
Goto Top
Hast du mal einen Geschwindigkeitstest via
FTP (z.B. mit dem FileZilla Server und
Client) gemacht? Welche Performance liefert
der XP-Rechner denn damit?

Devian

Nein, hab ich noch nicht gemacht. Kann ich mal probieren.

Bin jedoch erst am Wochenende wieder vor Ort.
Mitglied: fritzo
fritzo 17.01.2005 um 21:29:53 Uhr
Goto Top
Hi fungo,

Ich finde dein Vergleich nicht ganz passend.

Dafür ist er aber lustick *grins* Nicht sauer sein, war nicht ernst gemeint.

2000 wesentlich stabiler wie XP.

Hm, bei mir war es umgekehrt. Anyway...

Und günstiger ist es auch. :-) face-smile

Das stimmt wohl, aber er hat ja bereits XP und wird sich nicht noch ein OS zulegen wollen. Datt wäre dann teurer im Endeffekt. Na, sehen wir halt mal zu, daß das möglichst ohne Neuinstallation gelöst wird.

Viele Grüße,
fritzo
Mitglied: fritzo
fritzo 17.01.2005 um 21:34:38 Uhr
Goto Top
Sind die Authentifizierungs-Einstellungen in gpedit.msc bei beiden XP-Maschinen gleich? Wird NTLM verwendet oder ist bei einer Kiste noch LM eingestellt? Was sagt das Eventlog, werden Fehler angezeigt?

Grüße,
fritzo
Mitglied: cpb
cpb 17.01.2005 um 21:59:01 Uhr
Goto Top
Sind die Authentifizierungs-Einstellungen in
gpedit.msc bei beiden XP-Maschinen gleich?
Wird NTLM verwendet oder ist bei einer Kiste
noch LM eingestellt? Was sagt das Eventlog,
werden Fehler angezeigt?

Grüße,
fritzo

Also in gpedit habe ich nichts geändert. Sollte ich da was ändern?

Und was ist NTLM und LM?

Könntest du das ein bisschen genauer erklären?
Mitglied: fresch-heit
fresch-heit 18.01.2005 um 19:17:41 Uhr
Goto Top
wenn du xp hast darfste doch auf 2000 downgraden...

....welches sp läuft den auf den xp-rechnern?

ps ...xp als fileserver geht nur bis 10 rechner;)

da installier ich lieber nt (20 gleichzeitige zugriffe auf shares)

mal was anderes warum nimmste als fileserver keinen linux mit samba??? kostet doch gar nix (is fast auf jeder cd zu linuxheften)

ich find xp is nur was zum spielen... ;)

wenn man(n) vernünftig damit arbeiten will muss man es so kastrieren, dass es 200o auch nix nimmt. nur das läuft inzwischen stabiler (is halt ausgereifter)
Mitglied: fritzo
fritzo 18.01.2005 um 20:20:22 Uhr
Goto Top
wenn du xp hast darfste doch auf 2000
downgraden...

hm.. auch von XP Home aus? Würde mich wundern.

ps ...xp als fileserver geht nur bis 10
rechner;)

Es sind nur zwei andere Rechner im Netz, sollte daher ausreichen ;)

mal was anderes warum nimmste als fileserver
keinen linux mit samba??? kostet doch gar nix
(is fast auf jeder cd zu linuxheften)

Würde ich wahrscheinlich auch so machen, wenn XP Home die Alternative wäre.

ich find xp is nur was zum spielen... ;)

XP Home, boy. Aber XP Pro ist schon schnuckelig. Jedenfalls finde ich es allemale sauberer als W2K früher.

Grüße,
fritzo
Mitglied: fritzo
fritzo 18.01.2005 um 20:30:38 Uhr
Goto Top
Also in gpedit habe ich nichts
geändert. Sollte ich da was
ändern?

Nein, laß es so , wie es ist.

Und was ist NTLM und LM?
Könntest du das ein bisschen genauer
erklären?

Authentifizierungsarten. Du findest zB hier Infos darüber: http://support.microsoft.com/kb/147706/DE/

Ist aber egal, wenn Du nix in der Lokalen Sicherheitsrichtlinie geändert hast.

Versuch mal folgendes: da Du keinen DNS oder WINS-Server hast, wird im Netz nach anderen Maschinen gebrowst. Jeder Client hält normalerweise eine Liste der anderen Maschinen vor. (Frage - ist der Browsingdienst evtl. deaktiviert oder sind andere Dienste deaktiviert?) Die Suche kann länger dauern. Damit man von allen Maschinen jede andere Maschine auflösen kann, kannst Du auch das hosts-File benutzen - dies stammt aus den Zeiten, in denen es noch keine übergreifenden name resolution services wie DNS gab. Ruf das hosts-File wie folgt auf:

notepad %systemroot%\system32\drivers\etc\hosts

Hier findest Du wahrscheinlich folgendes:

  1. 102.54.94.97 rhino.acme.com # Quellserver
  2. 38.25.63.10 x.acme.com # x-Clienthost

127.0.0.1 localhost

So, jetzt trägst Du Deine Kisten dort ein, immer mit "IP-Adresse" --> TAB --> "Hostname". Also zB:

192.168.0.1 Rechner1
192.168.0.2 Rechner2
192.168.0.3 Rechner3

Speicher es ab und kopier es auf die anderen Rechner. Anschließend prüf mal, ob sich die Geschwindigkeit evtl. verbessert.

Grüße,
fritzo
Mitglied: cpb
cpb 19.01.2005 um 19:46:37 Uhr
Goto Top
Ok, vielen Dank. Werd ich am Wochenende mal ausprobieren.

Dienst habe ich noch keine deaktiviert. Habe gehört, dass ich den Qos (oder so ähnlich) deaktivieren soll? Sollte ich das tun?

Wenn ich in die Einträge in die Hosts Datei mache, muss ich dann dann den DNS server deaktivieren. Wenn ja, wie muss ich das tun?

Gruss
claudio
Mitglied: fritzo
fritzo 19.01.2005 um 20:52:47 Uhr
Goto Top
Hi,

Dienst habe ich noch keine deaktiviert. Habe
gehört, dass ich den Qos (oder so
ähnlich) deaktivieren soll? Sollte ich
das tun?

Nein, laß das erst mal alles auf default. Sonst kann man den Fehler nicht eingrenzen.

Wenn ich in die Einträge in die Hosts
Datei mache, muss ich dann dann den DNS
server deaktivieren. Wenn ja, wie muss ich
das tun?

;-) face-wink ok, dazu ich muß wieder ein bißchen ausholen: bei Dir läuft wahrscheinlich kein DNS-Server (es sei denn, Du hast entweder einen Router, auf dem einer läuft oder einen kommerziellen auf einer Deiner Workstations nachinstalliert). Was Du wahrscheinlich meinst, ist der DNS-Client-Service. Dieser stellt Verbindungen zum DNS-Server Deines Providers her. Deaktivier ihn nicht.

Ändere einfach mal die hosts-Datei wie oben erwähnt und schau, ob die Probleme weg sind. Du kannst prüfen, ob das Auswerten des hosts-Files funktioniert, indem Du mal einen nicht existenten Host und eine IP einträgst, abspeicherst und ihn dann anpingst. Also meinetwegen

10.10.10.1 nirvana

und dann setz in der dosbox mal einen ping auf das System ab:

C:\temp>ping nirvana
Ping nirvana [10.10.10.1] mit 32 Bytes Daten:
Zeitüberschreitung der Anforderung.

oder rückwärts mit
C:\temp>ping -a 10.10.10.1
Ping nirvana [10.10.10.1] mit 32 Bytes Daten:
Zeitüberschreitung der Anforderung.

Danach schmeiss den Eintrag wieder raus und speicher ab.

Wenn Du alle Hosts dort einträgst, dann sollte es zumindest bei der Namensauflösung keine Probleme geben. Wenn das Problem dann weg ist, alles klar. Wenn nicht, müssen wir woanders weitersuchen.

Grüße,
fritzo
Mitglied: cpb
cpb 19.01.2005 um 22:29:39 Uhr
Goto Top
Ok, danke. Werde ich ausprobieren.

ICh melde mich dann wieder!
Mitglied: Lobster
Lobster 10.02.2005 um 16:20:13 Uhr
Goto Top
Hallo,

ich hatte mal ein ähnliches Problem. Peer to Peer-Netzwerk mit 4 (schnellen) Rechnern unter Windows XP Pro.
Habe einige Modifikationen durchgeführt und nach 2 Wochen war die Netzwerkperformance super.
Also, SMB ausschalten (den nachfolgenden Teil kopieren und in eine neue Datei speichern, als Dateiname vielleicht SMB-aus.reg nehmen.)

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
"EnableSecuritySignature"=dword:00000000
"RequireSecuritySignature"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
"RequireSecuritySignature"=dword:00000000
"EnableSecuritySignature"=dword:00000000

Zum einschalten nimmst Du überall den Wert 00000001

Probier mal.
Mitglied: cpb
cpb 13.02.2005 um 18:51:02 Uhr
Goto Top
Vielen Dank werde ich ausprobieren!

Ich hoffe es liegt an dem. Die anderen Sachen haben nicht geholfen.
Mitglied: Lobster
Lobster 14.02.2005 um 07:32:46 Uhr
Goto Top
Wenns nicht geholfen hat, habe ich noch andere Sachen zum probieren.

Nimm die Änderung vorsichtshalber mal an beidem XP-Rechnern vor!
***

Wieder eine Registryänderung (vorgehensweise wie schon beschrieben):

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}]
@="Printers"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]
@="Geplante Tasks"

Und das hier:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"IOPageLockLimit"=dword:00133333

Und das hier:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
"NtfsDisableLastAcessUpdate"=dword:00000001


Und dann gibt es noch das hier:

Windows XP prüft beim Zugriff auf verfügbare Shared-Verzeichnisse im Netzwerk, ob auf anderen Netzwerkrechnern ebenfalls geplante Tasks aktiv sind. Dies kostet beim Dateizugriff unnötig Zeit. Das Problem läßt sich durch einen Registryeintrag beheben. Öffnen Sie die Registry (Start-> Ausführen-> regedit) und navigieren Sie zu:

HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ RemoteComputer\ NameSpace

Löschen Sie im linken Teilfenster den Eintrag: {D6277990-4C6A-11 CF-8D87-00AA0060F5 BF}

Um die Tasksuche wieder zu aktivieren, den Unterschlüssel wieder anlegen.



Viel Erfolg.
Mitglied: 27186
27186 07.06.2006 um 14:43:01 Uhr
Goto Top
Hmmmh...Hier legt er den(die) Schlüssel an, obwohl es ihn (sie) sowieso schon gibt...

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}]
@="Geplante Tasks"

...und hier soll er den Unterschlüssel gleich wieder löschen???

Löschen Sie im linken Teilfenster den
Eintrag: {D6277990-4C6A-11
CF-8D87-00AA0060F5 BF}

...um ihn dann später vielleicht doch wieder anzulegen....while (1)

Um die Tasksuche wieder zu aktivieren, den
Unterschlüssel wieder anlegen.

Viel Erfolg.

Da ist der Erfolg vorprogrammiert :-) face-smile
Heiß diskutierte Beiträge
question
IT Dienstleister und VPN Zugang gelöst Eduard.DVor 23 StundenFrageZusammenarbeit33 Kommentare

Hallo zusammen, ich habe eine Frage zu einem Thema welches viele Unternehmen betrifft und ich bin neugierig wie andere dies gelöst haben. Ich bin mir ...

question
Multi-WAN-Netzwerk fürs StudentenwohnheimHutzeljaegerVor 1 TagFrageLAN, WAN, Wireless17 Kommentare

Hallo allerseits. Für die Internetversorgung unseres Studentenwohnheims muss ich nun sehen, dass ich eine kostengünstige Lösung eines Multi-WAN Netzwerks hinbekomme, wohl am besten per Multi-WAN-Bonding. ...

question
RDP funktioniert auf 2 Monitoren, nicht aber auf 3spufi77Vor 1 TagFrageWindows 109 Kommentare

Hallo ich habe meinen Laptop über eine DockingStation USB-C an zwei Monitore angeschlossen. Wenn ich nun eine RDP Verbindung aufbaue, bekomme ich die trotz Haken ...

question
Arbeitsordnern Beine machen? gelöst dertowaVor 1 TagFrageWindows Netzwerk1 Kommentar

Hallo zusammen, mein HomeLab lässt mich leider noch nicht los. Nachdem ich gestern Abend soweit erfolgreich war und nach einer Test-VM mein Notebook umgestellt habe ...

tip
KB5006670 macht Drucker-ProblemeLochkartenstanzerVor 23 StundenTippWindows Update10 Kommentare

Moin, Seit Montag haben diverse Kunden Probleme mit dem Drucken. Nach Recherchen hat sich herausgestellt, daß KB5006670 dazu führt, daß statt einen Ausdruck nur noch ...

question
Suche einfaches Filesharing od. Sharing-CloudYan2021Vor 1 TagFrageCloud-Dienste17 Kommentare

Hallo Ihr Lieben ;-) Chef hat mal wieder ne neue Idee. Wir wollen für Kunden anbieten, dass sie Dateien über Internet mit uns austauschen können. ...

question
Windows 11 verhindernpitamericaVor 8 StundenFrageWindows 1116 Kommentare

Hallo zusammen, verstehe ich es richtig, dass Windows 11 nur installiert wird, wenn man aktiv in der Suche bei Windows Update auf das Update klickt ...

question
PowerEdge T640 Server (ESXi) mit "normalen" SSDs erweitern?ralfiiiVor 1 TagFrageServer-Hardware7 Kommentare

Ìch habe einen PowerEdge T640 Server. Die von Dell angebotenen Festplatten sind ja absurd teuer (ich nehme mal an spezielle Serverhardware, robust etc), da hab ...