Nvidia-Treiber ausrollen ohne WSUS, ohne SCCM

Mitglied: DerWoWusste

DerWoWusste (Level 5) - Jetzt verbinden

26.11.2015 um 15:06 Uhr, 1843 Aufrufe, 15 Kommentare

Moin.

Angelehnt meine vorige Frage https://www.administrator.de/forum/nvidia-sicherheitslücke-geht-um- ...
->kann man diese Treiber überhaupt non-interactive installieren über Startskripte? Gelingt bei mir nicht, siehe Thread. Auch nicht über WSUS Package Publisher/LUP.
Hat jemand mal einen Nvidia-Treiber ausgerollt bekommen, ohne SCCM oder WSUS?
Mitglied: -ricardo-
26.11.2015 um 15:16 Uhr
NVidia nicht, aber ich habe mal eine ATI Treiber Probleme gehabt und habe mittels Script, in dem einfach das DPinst parametrisiert aufgerufen wird, einer andere Version verteilt.

Vielleicht klappt das ja in deinem Fall auch.

Gruß
Bitte warten ..
Mitglied: DerWoWusste
26.11.2015 um 15:18 Uhr
Hi. Bitte den verlinkten Thread lesen. So klappt es nicht.
Bitte warten ..
Mitglied: Chonta
26.11.2015, aktualisiert um 15:56 Uhr
Hallo,

hast Du das hier schon versucht?
http://www.drwindows.de/windows-8-allgemein/80392-nvidia-treiber-silent ...
Habe derzeit keine Rehncer mit Nvidia.

Gruß

Chonta

Nachtrag: Sorry eben erst den verlinkten gelesen...
Bitte warten ..
Mitglied: -ricardo-
26.11.2015, aktualisiert um 15:48 Uhr
Zitat von @DerWoWusste:

Hi. Bitte den verlinkten Thread lesen. So klappt es nicht.

Hmmm, wenn ich den richtig überflogen habe, hast du es auch mit der setup.exe versucht.... und nicht mir dem DPInst...

Ich habe keinen Rechner mit einer NVidea zur Hand aber habe mal den Treiber runter geladen, dpinst64.exe ins Display.Driver Verzeichnis gepackt und mal gestartet. Der erkennt direkt die Verion 10.18.13.5900 im Ordner.
Ein Blick in die Parameterliste von DPinst ... da würde ich schnell auf /Q /F tippen...



Verwendung: C:\NVIDIA\DisplayDriver\359.00\Win10\International\Display.Driver\DpInst64.exe [/U INF-Datei][/S | /Q][/LM][/P][/F][/SH][/SA][/A][/PATH Pfad][/EL][/L Sprach-ID][/C][/D][/LogTitle Titel][/SW][/? | /h | /help]

/U INF-Datei Deinstallation eines Treiberpakets (INF-Datei).
/S | /Q Unbeaufsichtigter (stiller) Modus. Unterdrückt den Geräteinstallations-Assistenten sowie alle vom Betriebssystem ausgelösten Popup-Dialoge.
/LM Legacymodus. Akzeptiert unsignierte Treiberpakete und Pakete, in denen Dateien fehlen. Diese Pakete werden auf der neuesten Version von Windows nicht installiert.
/P Dialog, wenn das Treiberpaket, das installiert werden soll, nicht besser als das aktuelle ist.
/F Installation erzwingen, wenn das Treiberpaket nicht besser als das aktuelle ist.
/SH Überprüft die Hardware nach passenden Geräten und kopiert und installiert nur die Treiber, für die ein Gerät vorhanden ist. Gilt nur für Plug & Play-Treiber.
/SA Unterdrückt den Eintrag unter "Programme hinzufügen/entfernen", der normalerweise für jedes Treiberpaket erstellt wird.
/A Alle oder keine installieren.
/PATH Pfad Sucht unter dem angegebenen Pfad nach Treiberpaketen.
/EL Aktiviert alle Sprachen, die nicht ausdrücklich in der XML-Datei aufgeführt sind.
/L Sprach-ID Versucht, die angegebene Sprache auf allen Benutzeroberflächen zu verwenden. Nützlich für Lokalisierungstests.
/SE Unterdrückt das EULA.
/C Protokollierungsausgabe auf angeschlossener Konsole speichern (Windows XP und höher).
/D Binärdateien des Treibers nach der Deinstallation löschen.
/SW Unterdrückt den Geräteinstallations-Assistenten. Das Betriebssystem löst möglicherweise dennoch Popup-Dialoge aus.
/? | /h | /help Zeigt diese Hilfe an.
Bitte warten ..
Mitglied: Meierjo
26.11.2015, aktualisiert um 16:44 Uhr
Hallo

hast Du das hier schon versucht?
http://www.drwindows.de/windows-8-allgemein/80392-nvidia-treiber-silent ...
Habe derzeit keine Rehncer mit Nvidia.

Habe das grade erfolgreich durchgeführt, mit den im Beitrag ganz unten erwähnten Optionen.
Nvidia Geforce 9600 GT erfolgreich (ohne integrieren in eine WIM, da nur 1 System mit Nvidia Grafik vorhanden, da rechnet sich der Aufwand nicht).

Gruss
Bitte warten ..
Mitglied: DerWoWusste
26.11.2015, aktualisiert um 17:04 Uhr
Hi @Meierjo.
Wie hast Du es durchgeführt? Skript manuell gestartet/Domänenstartskript/...?
Manuell läuft das Skript ja, das schrieb ich schon. Nur eben nicht als Startskript/Task/WSUS-Package.
Bitte warten ..
Mitglied: Meierjo
26.11.2015 um 16:58 Uhr
Hallo

Manuell läuft das Skript ja, das schrieb ich schon. Nur eben nicht als Satrtskript/Task/WSUS-Package.

Sorry, wo hast du das geschrieben, habe ich nicht gesehen :-( face-sad

Habe mit einem angemeldeten Benutzer (Admin-Rechte, logischerweise) ein CMD-Fenster geöffnet, und dort den Befehl
setup.exe /passive /nosplash /noeula /clean /noreboot
ausgeführt.

Gruss
Bitte warten ..
Mitglied: DerWoWusste
26.11.2015, aktualisiert um 17:05 Uhr
Wo? Tja, oben:
kann man diese Treiber überhaupt non-interactive installieren über Startskripte? Gelingt bei mir nicht, siehe Thread...
Das DPInst wird auch nicht klappen, jede Wette, aber ich probier's gleich mal.
Bitte warten ..
Mitglied: -ricardo-
26.11.2015 um 17:28 Uhr
Wetteinsatz?
Bitte warten ..
Mitglied: DerWoWusste
26.11.2015, aktualisiert um 17:55 Uhr
Zu spät, schon getestet, geht nur interaktiv, nicht als Startskript. Alles Grütze, was nvidia da programmiert :-( face-sad
Bitte warten ..
Mitglied: Meierjo
27.11.2015, aktualisiert um 09:27 Uhr
Hallo

Was bei mir auch funktioniert hat, ist

In HKLM\Software\Microsoft\Windows\RunOnce einen REG_SZ
D:\Temp\Setup.exe /s /Passive /nosplash /noeula /clean /noreboot
erstellen.

Dann wird der Treiber im Hintergrund installiert, ohne Benutzer-Anmeldung

Gruss
Bitte warten ..
Mitglied: DerWoWusste
27.11.2015 um 09:56 Uhr
Moin.

Danke für die Idee, aber auch mit runonce geht es bei mir nicht. Der Schlüssel wird gelöscht, also wird er verarbeitet, aber nichts ändert sich an der Version, während ich
Setup.exe /s /Passive /nosplash /noeula /clean /noreboot
manuell erfolgreich durchführen kann. Verstehe nicht, wieso das bei Dir geht - welches OS? Wir haben hier nur noch 8.1 oder 10.
Bitte warten ..
Mitglied: Meierjo
27.11.2015, aktualisiert um 10:03 Uhr
Hallo

Win7 64Bit, Domänenrechner

Authentifizierte Benutzer und System haben Zugriff auf das Quell- Verzeichnis??

Gruss
Bitte warten ..
Mitglied: Chonta
27.11.2015 um 10:50 Uhr
Hallo,

schon sehr komisch, das eine Installation über die Komandozeile als eingelogter Benutzer geht aber so nicht...
Gans blöde Idee die setup.exe über runas mit Benutzerlogin starten. Oder schon versucht über eine Remote-PS-Sitzung auszuführen (mit und ohne aktive eingelogtem Benutzer)

Ansonsten mal bei Nvidia Stunk machen das deren Treiber rumspinnen.

Gruß

Chonta
Bitte warten ..
Mitglied: DerWoWusste
27.11.2015 um 11:07 Uhr
So, nun hätte ich auch eine Lösung: psexec. Werde es wohl darüber machen müssen.
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 20 StundenFrageWindows 1036 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 15 StundenFrageOff Topic17 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 16 StundenTippHumor (lol)8 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Windows Userverwaltung
Account Aktivierung über VPN
Phill93Vor 1 TagFrageWindows Userverwaltung3 Kommentare

Hallo, ich muss mir für eine RDP Umgebung für einen Verein eine Lösung für die Account Aktivierung ausdenken. Meine Idee ist die folgende: 1. ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 1 TagFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...