Problem L3 Switch - DHCP Ip Bind Mac

Mitglied: AyhanGunay

AyhanGunay (Level 1) - Jetzt verbinden

21.04.2021 um 15:01 Uhr, 516 Aufrufe, 5 Kommentare

Hallo Freunde,

bin seit Tagen am verzweifeln und komme nicht mehr weiter.

Wie folgt ist mein Netzwerk aufgebaut

Router: Draytek 3910 mit 3x VDSL Anschlüsse jeweils 75 Mbit/s
Switch: Ein Layer3 ARUBA 2930f

Verbindung Router zum Switch "Router on a Stick"
Auf dem Router sind die Subnetze und Vlan`s eingerichtet mit jeweils aktivierter DHCP Funktion - quasi Router verteilt die Adressen - Als Gateway wurde die IP vom zugehörigen Vlan Schnittstelle des Switches eingegeben, damit das Inter-Vlan-Routing durch den Switch erfolgt, was soweit ganz gut funktioniert

Auf dem Switch sind auch dementsprechend die Vlan`s eingerichtet.

Die Clients bekommen auch sauber die IP von dem Router durch DHCP und sind in den Subnetzen für welche die auch bestimmt sind.

Nun möchte ich aber auf dem Router spezielle Routingregeln einrichten und spezielle Client auf z.B.: VPN Verbindung nutzen zu lassen oder dass bestimmte Clients einen bestimmten WAN als Ausgangsleitung nutzt.

Funktioniert auch ganz gut aber habe folgendes Problem:

Angenommen ein Client "Apple iPad" - soll immer die selbe IP durch den DHCP bekommen, damit auch mein Routing-Regel für diesen Klienten immer existiert.
Mit dem IP Bind Mac auch soweit gelöst aber genau hier kommt ein Problem - egal ob Wired oder Wireless, der Client kann nach eine unbestimmten Zeit x nicht mehr surfen.
Es funktioniert erst wieder, wenn ich auf dem Router die IP Adresse von dem betroffenen Nutzer / Client aus der Ip Bind Mac liste entferne.

Bin echt am Verzweifeln und am Ende mit mein Latein und weis nicht woher das kommt.
Habe auf dem Switch auch Ip Helper und DHCP-Relay aktiviert und auch DHCP-snooping etc. deaktiviert, komme aber nicht weiter.


Hoffe dass mir soweit jemand helfen kann.

Bedanke mich jetzt schon mal im Voraus.
Mitglied: aqui
21.04.2021, aktualisiert um 19:09 Uhr
Auf dem Router sind die Subnetze und Vlan`s eingerichtet mit jeweils aktivierter DHCP Funktion
Bedeutet dann das du den Aruba als reinen Layer 2 Switch betreibst so wie es HIER beschrieben ist, richtig ?!
Habe auf dem Switch auch Ip Helper und DHCP-Relay aktiviert
Ist kompletter Quatsch, denn nach deiner o.a. Beschreibung nutzt du den L3 Switch ja gar nicht im L3 Modus sondern als reinen Layer 2 VLAN Switch. Routen soll ja nach deinen Angaben der Router und nicht der L3 Switch !
DHCP Relay ist einzig nur dann relevant wenn man mit dem Switch auch routet was bei dir ja NICHT der Fall ist. Das kannst du auch gleich wieder entfernen, denn es ist im Setup kontraproduktiv !
soll immer die selbe IP durch den DHCP bekommen
KEINs der gängigen VPN Protokolle nutzt DHCP zur Client IP Adressvergabe. Hier ist vermutlich schon der erste Fehler deiner Argumentation und Denkweise !!
Da du leider auch nicht mitteilst welches der zahllosen VPN Protokolle du nutzt kann man dir auch nicht zielführend helfen und es bleibt nur die Kristallkugel ! :-( face-sad
Fazit:
Kein Wunder das du verzweifelst, denn im VPN wird in der Regel kein DHCP genutzt !

Vielleicht erhellen dich die hiesigen Tutorials zu den gängigen VPN Protokollen etwas. Mit ensprechender Konfig im VPN Server Setup kann man Clients dort auch immer problemlos feste IP Adressen zuweisen. Es ist aber vom Setup Protokoll spezifisch.
IPsec:
https://administrator.de/tutorial/ipsec-vpn-fuer-mobile-benutzer-auf-der ...
L2TP:
https://administrator.de/wissen/pfsense-opnsense-client-vpn-l2tp-protoko ...
https://administrator.de/content/detail.php?id=562927&token=111#comm ...
OpenVPN:
https://administrator.de/tutorial/merkzettel-vpn-installation-openvpn-56 ...
https://administrator.de/content/detail.php?id=359367&token=695#comm ...
WireGuard:
https://administrator.de/tutorial/merkzettel-vpn-installation-mit-wiregu ...
Bitte warten ..
Mitglied: AyhanGunay
21.04.2021, aktualisiert um 19:27 Uhr
Der Switch wird durchaus als L3 genutzt, habe auf dem Router die Subnetze erstellt damit die als DHCP Server dienen und ich keine statischen Routen einrichten muss.
Als Gateway wurde immer die IP vom Vlan im Switch eingetragen.

Es geht nicht direkt VPN selbst - mir ist schon bewusst, dass VPN kein DHCP kann.
Habe ein L2L VPN Verbindung zwischen Deutschland und Türkei - einpaar Rechner in der Türkei sollen die Internetverbindung vom Standtort Deutschland nutzen.
Deshalb muss ich unter Route Policy eine Regel erstellen und sagen, Client X und Y sollen diesen VPN Tunnel nutzen.
Diese Endgeräte beziehen die IP`s über DHCP.
Da DHCP immer eine freie IP verteilt, wollte ich mittels IP Bind Mac, dass die Geräte immer die selbe IP bekommen, damit ich nicht jedesmal die Regel Route Policy anpassen muss.

Genau da ist mein Problem, sobald der Client im Statischen IP MAC Liste ist, passiert es dass es nicht mehr ins internet kommt oder richtig träge. Erst wenn dieser aus der Liste entfernt wird, funktioniert er wieder normal
bildschirmfoto 2021-04-21 um 20.15.26 - Klicke auf das Bild, um es zu vergrößernbildschirmfoto 2021-04-21 um 20.15.37 - Klicke auf das Bild, um es zu vergrößernbildschirmfoto 2021-04-21 um 20.22.19 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
22.04.2021, aktualisiert um 11:29 Uhr
Der Switch wird durchaus als L3 genutzt,
Das widerspricht dann aber komplett der Beschreibung von dir oben. Damit hast du die Community hier dann gehörig in die Irre geführt. Das macht ein zielführendes Troubleshooting dann nicht gerade einfacher... :-( face-sad
Gut, dann gehen wir mal von einem reinen Layer_3_Konzept aus was dann abgesehen von deinen individuellen IP Adressen im Grundaufbau ungefähr so aussehen sollte:
l3 - Klicke auf das Bild, um es zu vergrößern
OK, das dann erstmal zum Thema VLAN Konzept....

Habe ein L2L VPN Verbindung
Was soll das sein ?? So ein VPN Protokoll gibt es gar nicht. Vermutlich meinst du wohl L2TP kann das sein ?!
https://de.wikipedia.org/wiki/Layer_2_Tunneling_Protocol
Hier ein paar Praxis Beispiele dazu:
https://administrator.de/tutorial/pfsense-vpn-mit-l2tp-ipsec-protokoll-f ...
https://administrator.de/content/detail.php?id=562927&token=111#comm ...
Ist es das was du meinst ?
Deshalb muss ich unter Route Policy eine Regel erstellen und sagen, Client X und Y sollen diesen VPN Tunnel nutzen.
Das ist richtig !
Du darfst dann hier kein Split Tunneling Konzept im VPN fahren sondern musst zwangsweise einen Gateway Redirect aktivieren. Sprich der gesamte Traffic der VPN Clients soll bei aktivem VPN in den Tunnel geroutet werden. Auch das ist mit L2TP ohne Probleme möglich. (Siehe Tutorials oben)
Dazu sind aber keine statischen Routen oder sowas nötig, das wäre Unsinn.
Der L2TP VPN Server injiziert bei Tunnelaufbau einfach eine Default Route in den Client so das der dann aktiven Traffic komplett in den Tunnel routet. Das ist ein simpler Mausklickt im L2TP Server Setup !
Dein Setup oben sieht nach Draytek Router Hardware aus ?! Leider fehlen davon dann die L2TP Setup Screenshots.
Mit deinem "Client Routing" begehst du vermutlich einen VPN Denkfehler der in die Sackgasse führt ?!
Bitte warten ..
Mitglied: AyhanGunay
22.04.2021 um 12:36 Uhr
Mit L2L meinte ich Lan to Lan VPN zwischen zwei Draytek Router.
Habe aber mittlerweile da Problem lösen können.
Ursache war das zusätzliche aktivieren von Inter LAN Routing zwischen den Subnet`s im Draytek.
Sobald diese deaktiviert sind, funktioniert alles wie gehabt.

Danke nochmals für die Zeit und die Mühen
Bitte warten ..
Mitglied: aqui
22.04.2021 um 13:25 Uhr
Mit L2L meinte ich Lan to Lan VPN zwischen zwei Draytek Router.
Ahhsoo...sorry. Ist auch etwas ungeschickt ausgedrückt...
Danke nochmals für die Zeit und die Mühen
Immer gerne ! ;-) face-wink
Bitte warten ..
Heiß diskutierte Inhalte
Router & Routing
FB und Archer 2 getrennte Netze mit einer WAN-Verbindung
neuhier14Vor 1 TagFrageRouter & Routing26 Kommentare

Hallo, ich habe eine Fritzbox 7490 und einen Archer C5 mit OpenWRT. Die Fritzbox ist mein Hauptrouter. Ich würde daneben gerne ein komplett getrenntes ...

Netzwerke
PFSense und Transferprobleme
Xaero1982Vor 1 TagFrageNetzwerke25 Kommentare

Moin Zusammen, leidiges Thema PFSense - ich hab mich mal wieder ran gewagt. Ich hab hier so ein paar VLANs laufen und nen ESX. ...

Linux
Bootable Win7 stick from Raspberry commandline
winlinVor 22 StundenFrageLinux12 Kommentare

Hallo zusammen Ich benötige einen bootfähigen Win7 USB Stick. Muss diesen über meine Raspberry erstellen. Was ist die beste Variante habe schon ein paar ...

Exchange Server
Postfach für öffentliche Ordner ist voll
gelöst Tommy525600Vor 1 TagFrageExchange Server6 Kommentare

Hallo an alle, ich habe folgendes Problem: Mein primäres Postfach für öffentliche Ordner ist voll (99,58 GB) (und ja, ich kann auch nix dafür). ...

Windows Server
Kein Netzwerkzugriff auf Windows Server 2019?
Henk86Vor 1 TagFrageWindows Server8 Kommentare

Ich habe mir einen neuen "Heimserver" mit Windows Server 2019 (evaluation vorerst) aufgesetzt. Gestern habe ich von meinem Hauptrechner einige Daten auf den Server ...

Windows Server
Problem bei Windows 10 Deployment mit MDT
gelöst neophyte2021Vor 1 TagFrageWindows Server7 Kommentare

Hallo, ich habe folgendes Problem, ich habe in einem Artikel auf englisch gelesen, das wenn man mit dem MDT Windows 10 ausrollen will und ...

Netzwerke
Verständnisfrage pfSense mit Fritzbox, VLAN und Switch
newbie1Vor 1 TagFrageNetzwerke9 Kommentare

Hallo, ich bin kurz davor mir eine pfSense einzurichten via ISO-Image auf einem alten PC. Vorhaben: Fritzbox -> pfSense -> Switch -> Endgeräte Was ...

Exchange Server
Mails fehlen im Exchange-Server 2016
it-basixsVor 1 TagFrageExchange Server4 Kommentare

Moin, moin zusammen. Ich habe leider ein Problem mit einem Exchange Server 2016 CU20 inkl. aller Patches. Laut Ereignisanzeige von POPcon, werden die Mails ...