estefania
Goto Top

RDP-Verbindung dauerhaft halten - Ist das möglich?

Hallo

Ich habe eine Frage an Erfahrene von euch.
Ich kann es mir nicht erklären, aber es gibt bei mir Server wo ich dauerhaft verbunden bin und andererseits andere Server und Clients, wo ich nach gewisser Zeit zur erneuten
Passwortabfrage aufgefordert werde.
Ich meine das ist auch Sinn der Sache, denn es geht um die Sicherheit.
Aber es gibt ein paar Server bzw. Clients wo ich gerne dauerhaft verbunden wäre, ausser ich logge mich selbst aus bzw. schliesse die Session.

Kann da jemand weiterhelfen?

Content-Key: 384107

Url: https://administrator.de/contentid/384107

Printed on: May 21, 2024 at 11:05 o'clock

Member: Estefania
Estefania Aug 22, 2018 at 21:32:31 (UTC)
Goto Top
Jetzt habe ich selbst was gefunden...

Unter
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

den Schlüssel "SecurityLayer" von 2 auf 1 oder 0 umstellen und den Rechner rebooten.

Ist das die Lösung oder gibt es noch was feineres? Weil so wie es aussieht, wird es durch die Einstellung dauerhaft so sein.
Nur wie ist es dann, wenn ich die Session einfach beende? Damit meine ich nicht mit Ausloggen.
Member: BassFishFox
BassFishFox Aug 22, 2018 at 23:41:29 (UTC)
Goto Top
Hallo,

Warum machst Du das per Registry? Geht doch eleganter per Richtlinie.

https://www.host.ag/blog/increase-the-security-of-your-windows-server-20 ...

Pruefe einfach mal nach, ob per Gruppenrichtlinie bei Euch TimeOuts gesetzt sind fuer die Sitzungen.
Wenn nicht stelle es einheitlich ein.

BFF
Member: Estefania
Estefania Aug 23, 2018 at 06:05:51 (UTC)
Goto Top
Security Layer 0 – With a low security level, the remote desktop protocol is used by the client for authentication prior to a remote desktop connection being established. Use this setting if you are working in an isolated environment.

Security Layer 1 – With a medium security level, the server and client negotiate the method for authentication prior to a Remote Desktop connection being established. As this is the default value, use this setting only if all your machines are running Windows.

Security Layer 2- With a high security level, Transport Layer Security, better knows as TLS is used by the server and client for authentication prior to a remote desktop connection being established. We recommend using this setting for maximum security.
Member: anteNope
anteNope Aug 23, 2018 at 08:26:36 (UTC)
Goto Top
Das hat damit nichts zu tun. Wonach du mal gucken solltest sind die Energie-Einstellungen für das Timeout des Displays sowie Einstellungen für den Bildschirmschoner ;)

Eine RDP-Verbindung hat selbige Timeouts für die Übertragung. Ist dann "Anmeldeseite bei Reaktivierung" aktiviert, bekommst du die Login-Seite =)
Member: Estefania
Estefania Aug 23, 2018 at 09:43:45 (UTC)
Goto Top
Das habe ich bereits. Dort ist es auf "High Performance" eingestellt und alles was mit Timeouts zu tun hat, ist ausgeschaltet. Aich kein Bildschirmschoner ist aktiv.

Eine RDP-Verbindung hat selbige Timeouts für die Übertragung. Ist dann "Anmeldeseite bei Reaktivierung" aktiviert, bekommst du die Login-Seite =)

Wo stelle ich es ein? Im RDP-Client selbst? Ich sehe dort nur "Verbindung erneut herstellen, falls diese getrennt wird" Aber das ist wohl nicht das gleiche oder
Member: anteNope
anteNope Aug 23, 2018 at 17:32:00 (UTC)
Goto Top
Auf dem Host-System. Ich meine diese Einstellungen hier:

clipboard01

clipboard02
Member: Estefania
Estefania Aug 24, 2018 at 13:20:25 (UTC)
Goto Top
ja genau, beides ist bei mir ausgeschaltet bzw. Kein Bildschirmschoner und bei dem anderen auf "Never" eingestellt
Member: anteNope
anteNope Aug 24, 2018 at 14:22:10 (UTC)
Goto Top
Hm seltsam, bei mir werden die Verbindungen dann "ewig" gehalten face-sad
Member: BassFishFox
BassFishFox Aug 24, 2018 at 17:20:19 (UTC)
Goto Top
Hallo,

Schau die Richtlinien an auf den Servern / Klients (die das RDP-Ziel sind) was dort eingestellt ist, wann inaktive Sitzungen "gekillt" werden.
Wenn dort nix aktiviert ist, heisst das nicht dass es zu einem Timeout kommen kann.
Selbiges hatten wir mit W7-Geraeten als RDP-Ziel. Es war nix eingestellt, nach ca 30 Min flogen die Leute aus der Sitzung.

Das Bild ist von einem W10.

2018-08-24 13_15_42-microsoft store

BFF
Member: Estefania
Estefania Aug 28, 2018 at 18:20:24 (UTC)
Goto Top
Habe nun alle Einstellungen probiert, aber es hat nichts gebracht.
Member: BassFishFox
BassFishFox Aug 28, 2018 updated at 19:12:53 (UTC)
Goto Top
Hi,

Dann duerfte wohl de Blick in die Ereignisprotokolle Aufschluss geben wer und wo die Verbindungen unterbricht.

Habe nun alle Einstellungen probiert, aber es hat nichts gebracht.

Tolle FEhlermeldung. Wie probiert? GPO, Lokal?
Meiner Erfahrung nach ist es zu 25% der Client der die Verbindung unterbricht und 75% das Ziel.
Da Du nie erklaerst hast was konkret Du hast, von wo (OS) zu was (OS), Domaene oder nicht, ist Dir extrem schwer zu helfen.

BFF
Member: Estefania
Estefania Aug 28, 2018 at 20:32:40 (UTC)
Goto Top
Ich habe mit dem Befehl gpedit.msc die Änderungen vorgenommen und anschließend mit dem Befehl gpupdate /force die Änderungen forciert.
Es handelt sich um einen Domänen Rechner. Benutzt wird Windows 10 V1803
Member: BassFishFox
BassFishFox Aug 28, 2018 at 22:09:31 (UTC)
Goto Top
Hi,

Und kommen auch Deine unbekannten Aenderungen beim RPD-Ziel an?
Oder hast Du das eingestellt fuer den Computer welcher die RDP-Quelle ist?

BFF
Member: Estefania
Estefania Aug 29, 2018 at 20:38:20 (UTC)
Goto Top
Ich habe es lediglich auf dem betroffenen Rechner eingerichtet.
Member: BassFishFox
BassFishFox Aug 29, 2018 at 21:12:27 (UTC)
Goto Top
Was ist den nun der betroffenen Rechner. Quelle oder Ziel?

Freunde Dich mit dem Gedanken an, dass Quell- und Zielcomputer Verbindungen kicken koennen.

Bei der Masse an Auskunfstfreudigkeit musst Du nun allein weiter suchen. Sorry.

BFF