Reparatur eines Hardware-RAID 1

Mitglied: smguenther

smguenther (Level 1) - Jetzt verbinden

15.06.2016 um 08:10 Uhr, 1224 Aufrufe, 8 Kommentare

Guten Morgen,

wir haben von einem unserer Kunden einen Windows 2008 Server erhalten, den wir nicht installiert/konfiguriert haben und der auch nicht dokumentiert ist.

Wir wissen, dass der Rechner 2 x 300 GB und 3 x 500 GB Festplatten und einen INTEL RAID Controller hat. Die 500 GB HDDs bilden ein RAID5, die anderen Platte haben wohl ein RAID1 gebildet. Zumindest schließen wird dies aus den Aussagen des Kunden hinsichtlich des Speicherplatzes. Wobei der Speicherplatz des RAID5 wohl nie genutzt wurde, sondern nur das vermutete RAID1.

Die Kiste ist plötzlich ausgefallen und hat nach dem Start das RAID1 verloren. Im Controller BIOS werden die beiden 300er als "unconfigured" angezeigt. Beim Start meldet der Controller, dass er eine "fremde" Konfiguration gefunden hat, laut Dokumentation soll man diese Konfiguration laden und dann wäre alles gut - aber das ist hier nicht der Fall.

Nun hatte ich die Hoffnung gehabt, dass ich dem Controller sage, die beiden Platten bilden ein RAID1, verzichte dann aber auf die Initialisierung des RAIDs, damit die bestehenden Daten nicht überschrieben werden.

Aber wenn ich das RAID1 bilden will, werden mir die beiden Platten erst gar nicht angeboten (siehe Screenshots).

Jetzt bin ich mit meinem Latein am Ende und frage mich, ob das System überhaupt noch zu retten ist.

Vielen Dank schon einmal für jeden Tipp/Kommentar.

Viele Grüße,

Stefan Günther
img_0721 - Klicke auf das Bild, um es zu vergrößernimg_0723 - Klicke auf das Bild, um es zu vergrößernimg_0722 - Klicke auf das Bild, um es zu vergrößern
Mitglied: Deepsys
15.06.2016 um 08:20 Uhr
Hi,

was steht denn da im 1. Bild in gelb?
Ist ein Backup vorhanden um das RAID komplett neu zu erstellen?

Ja,, diesen Controller kenne ich auch noch, als Zicke ...

VG,
Deepsys
Bitte warten ..
Mitglied: Lochkartenstanzer
15.06.2016 um 08:34 Uhr
Moin,

Ist ein funktionierendes backup vorhanden?

  • wenn ja

platten löschen und backup einspielen.

  • wenn nein

ein Image ziehen, deses Image mal mit testdisk durchschauen und ggf daraus ein Backup-image erstellen. RAID neu erstellen und image zurückspielen.

Ein Image der Platten würde ich auf jeden Fall erstellen, damit man im fehlerfall wieder auf den Stand "vorher" zurückkehren kann, auch wenn ein Backup vorhanden sein soltle.

lks
Bitte warten ..
Mitglied: smguenther
15.06.2016 um 09:07 Uhr
Hi,

es gibt ein Backup, aber das ist 3 Wochen alt. Danach ist das Backup fehlgeschlagen, weil der Controller unter Last schon Probleme gemacht hat, die aber niemanden aufgefallen sind.

Das Erstellen eines Image ist schwierig: Wenn ich das System beispielsweise mit einem Linux-Rettungssystem starte, dann wird mir nur das nicht formatierte RAID 5 angezeigt. Die anderen beiden Platten werden mir unter keinem OS als Verbund oder als einzelne Platten angezeigt.

@Deepsys: Gelb ist die zweite 300 GB Platte, die auch als "unconfigured" markiert ist, so wie die erste Platte.

Danke & Gruß,

Stefan
Bitte warten ..
Mitglied: Pjordorf
15.06.2016 um 09:15 Uhr
Hallo,

Zitat von @smguenther:
Wir wissen, dass der Rechner 2 x 300 GB und 3 x 500 GB Festplatten und einen INTEL RAID Controller
Und? Welchen Intel RAID Controller? Wie viele Enclosures hängen denn dort dran? Datensicherung vorhanden?

laden und dann wäre alles gut - aber das ist hier nicht der Fall.
Sondern?

Aber wenn ich das RAID1 bilden will, werden mir die beiden Platten erst gar nicht angeboten (siehe Screenshots).
Sind die Platten bzw. das Enclosure denn noch in Ordnung? Von den Platten (300 GB) mal die S.M.A.R.T. Werte geprüft? Mit einen anderen OS (Live Linux) mal versucht dort zu schauen ob da noch alle Daten lesbar sind? Beim RAID 5 wird es etwas schwieriger die Daten von den Platten zu lesen. Was sagt Intel dazu? Wer hat alles dort schon rumgemacht bzw. was wurde dort schon alles versucht?

Gruß,
Peter
Bitte warten ..
Mitglied: Lochkartenstanzer
15.06.2016 um 09:15 Uhr
Zitat von @smguenther:

Das Erstellen eines Image ist schwierig: Wenn ich das System beispielsweise mit einem Linux-Rettungssystem starte, dann wird mir nur das nicht formatierte RAID 5 angezeigt. Die anderen beiden Platten werden mir unter keinem OS als Verbund oder als einzelne Platten angezeigt.

  • Platte rausziehen
  • in anderen rechner stecken,
  • kopieren, mit testdisk druchschauen.

lks

PS: Normarlerweise sollte der MegaRAID-Adapter (ist doch so einer oder?) auch von Linux erkannt udn die unkonfigurierten Platten angezeigt werden. Gibt mal genauere Infos, welcher Controller udn welches Motherboard das ist (mit lspci/dmidecode/acpidump unter linux einfach herauszufinden).
Bitte warten ..
Mitglied: Deepsys
15.06.2016 um 09:15 Uhr
Zitat von @smguenther:
es gibt ein Backup, aber das ist 3 Wochen alt.
Immerhin ....

Danach ist das Backup fehlgeschlagen, weil der Controller unter Last schon Probleme gemacht hat, die aber niemanden aufgefallen sind.
Dann würde ich den Controller nicht mehr verwenden!
Und ja, man muss Backups IMMER kontrollieren, aber das sollte der Kunde nun auch wissen ..

Das Erstellen eines Image ist schwierig: Wenn ich das System beispielsweise mit einem Linux-Rettungssystem starte, dann wird mir nur das nicht formatierte RAID 5 angezeigt. Die anderen beiden Platten werden mir unter keinem OS als Verbund oder als einzelne Platten angezeigt.
Nee, bau die Platten aus, aber merke dir sicherheitshalber wo welche Platte dranhing, und versuche einzeln auf die Platte zu kommen.

@Deepsys: Gelb ist die zweite 300 GB Platte, die auch als "unconfigured" markiert ist, so wie die erste Platte.
Tja, eigentlich sollte es mit dem Einlesen gehen, wenn der Controller OK wäre ...
Bitte warten ..
Mitglied: Pjordorf
15.06.2016, aktualisiert um 10:58 Uhr
Hallo,

Zitat von @smguenther:
nicht formatierte RAID 5 angezeigt.
Und, sind die Formatiert bzw. sind dort noch Daten vorhanden? Seit ihr die Ersten die sich da Versuchen?

Gelb ist die zweite 300 GB Platte
Nur das wir nicht den Text lesen können. Die Programmierer der Software für deinen uns unbekannten RAID Controller haben sich dir farben nicht aus Langeweile ausgesucht. Die wollen dir damit etwas sagen. Was? Steht in dein Handbuch. Entweder Platten oder Enclosure oder Kabel oder RAID Controller ist hin. Anderen RAID Controller und Konfiguration einlesen wäre auch noch eine Option...

Gruß,
Peter
Bitte warten ..
Mitglied: Chonta
15.06.2016 um 10:32 Uhr
Hallo,

SATA oder SAS Platten?
RAID1 ist ja normales spiegeln der Platten also sollten die jede für sich, sofern in Ordnung, allein angeschlossen auch booten bz. der Zugriff auf die Daten sollte über einen anderen Rechenr möglich sein.

Wurde von beiden RAID1 Platten am Anfang schon ein Image gezogen?
Es gibt einige Bespiele bei der durch das laden von Konfigurationen im Fehlerfall die Platten formatiert wurden, also hoffe ich ihr habt von den Platten vorher ein Image gezogen.

Sind die Platten noch in Ordnung? (SMART)

Wenn der RAIDcontroller hinüber ist einen andeen verwenden oder wenn möglich die normalen Mainboardanschlüsse

Gruß

Chonta
Bitte warten ..
Heiß diskutierte Inhalte
Cloud-Dienste
Server mieten - wo?
ZZaaiiggaaVor 1 TagFrageCloud-Dienste10 Kommentare

Hallo zusammen, suche einen Windows Server für SQL zum mieten, mit mindestens: 256GB SSD 32GB Ram Welche Anbieter eignen sich am besten? Und muss ...

Switche und Hubs
Frage zu Jumbo Frames
gelöst White-Rabbit2Vor 1 TagFrageSwitche und Hubs14 Kommentare

Hallo. Vielleicht ist dies keine Frage, die man pauschal beantworten kann - vielleicht kann es aber doch jemand halbwegs einschätzen: Wir haben hier Cisco ...

LAN, WAN, Wireless
MikroTik: kaskadisches Core-Netzwerk CCR-CRS-CRS mit Satelliten-Swichtes+APs - ein Versuch einer Anleitung von A-Z
gelöst PackElendVor 1 TagFrageLAN, WAN, Wireless7 Kommentare

Hallo zusammen, da ich mit der gelieferten Konfiguration meiner MikroTiks nicht so zufrieden bin, fange ich von vorne an. Das liegt daran, dass ich ...

Internet
ARD und ZDF Live Stream
gelöst ben1300Vor 22 StundenFrageInternet14 Kommentare

Guten Morgen ! wir haben zwei Samsung Monitore im Einsatz (Modell DM48E), welche via Netzwerk mit unserem MagicInfo Server verbunden sind. Hierdrüber möchte ich ...

Netzwerkgrundlagen
VLANs und unterschiedliche Subnetze
m8ichaelVor 1 TagFrageNetzwerkgrundlagen8 Kommentare

Hallo zusammen, ich habe einmal eine generelle Frage an die Netzwerkspezialisten: Wir haben unser Netzwerk in verschiedene VLANs eingeteilt und es stellt sich nun ...

Backup
Backupstrategie
Xaero1982Vor 12 StundenFrageBackup16 Kommentare

Nabend Zusammen, wir bekommen es ja leider alle immer wieder mal mit, dass es auch große Firmen gibt, die von irgendwelchen Verschlüsselungstrojanern verseucht werden. ...

SAN, NAS, DAS
Hardware oder Software RAID
CrunkFXVor 22 StundenFrageSAN, NAS, DAS12 Kommentare

Mahlzeit, Kurz vorab eine Einigung darauf dass es kein Hardware RAID gibt, ich aber trotzdem differenziere zwischen: Software RAID ( reine Software auf einem ...

LAN, WAN, Wireless
SFP mit SFP+ verbinden
maximum3012Vor 20 StundenFrageLAN, WAN, Wireless10 Kommentare

Hallo zusammen, mich würde folgendes interessieren, ist es eigentlich möglich, ein SFP Switch mit einem SFP+ Switch zu verbinden? Es gibt ja die Möglichkeit ...