SBS 2003 und Drucker hinzufügen

michael-24
Goto Top
Hallo,

ich habe eine Frage zu SBS 2003 R2 und den Netzwerkdruckern.

Es sind am Server zwei USB Dymo Drucker und übers Netzwerk ist ein Laserjet angeschlossen.

Jetzt möchte ich auf den 3 Clients diese Drucker bereitstellen. Jedoch ohne zutun sind die Drucker auf den Clients vorhanden. Jedoch passiert es ab und zu das diese Drucker alle doppelt vorhanden sind. Einmal z. B. HP laserjet an server und einmal HP Laserjet (von server). So lauten die Namen in der Druckerverwaltung auf den Clients. Lösche ich alle Drucker und starte den Client neu, sind wieder alle Drucker automatisch verbunden, obwohl ich weder ein Script dafür habe noch sonst irgendwas. Es ist aber auch schon vorgekommen, das die Drucker nicht mehr verbunden werden.

Jetzt möchte ich eine Lösung, die kontrolliert abläuft. Ich denke an eine Lösung wie z. B. hier beschrieben.

http://www.gruppenrichtlinien.de/HowTo/rundll32_printui.htm

Wie schaffe ich es aber, das erstmal keine Drucker automatisch verbunden werden. Dann möchte ich mit dem Befehl rundll32 printui.dll,PrintUIEntry /in /n /y \\SERVER1\PRITNER bestimmte Drucker wieder hinzufügen.

Die Funktion automatisch nach Netzwerkordner und Druckern suchen ist bereits auf allen Clients ausgeschaltet. Trotzdem verbindet er mir die Drucker automatisch.

Hat jemand von Euch einen Tipp wie ich das abschalten kann?

Oder gibts vielleicht noch eine schönere Lösung oder vielleicht eine onboard lösung?

Clients sind XP SP3

Gruß
Michael

Content-Key: 97781

Url: https://administrator.de/contentid/97781

Ausgedruckt am: 20.05.2022 um 10:05 Uhr

Mitglied: GuentherH
GuentherH 24.09.2008 um 20:33:05 Uhr
Goto Top
Hallo.

Starte den Assistenten für die Gerätekonfiguration -> Client Computern Anwendungen hinzufügen ->
- klicke im Fenster "Zuweisen von Anwendunge" auf den Button Erweitert ->
- deaktiviere die Checkbox "Drucker" und stelle den Assistenten fertig.

Du kannst nun auf den Clients die nicht erwünschten Drucker löschen. Sie sollten nicht wieder automatisch verbunden werden.

LG Günther
Mitglied: Michael-24
Michael-24 27.09.2008 um 06:25:43 Uhr
Goto Top
Hallo Günther,

ich habe deine Anweisung durchgeführt. ich hab die checkbox deaktiviert und danach alle clients nochmal neugestartet und angemeldet, sodass die änderung auf den clients aktualisiert wird.

ist aber leider nicht so.

ich nehme mal an, das das der befehl "\\SERVER01\Clients\Setup\setup.exe /s SERVER01", der in der SBS_LOGIN_SCRIPT.bat in der Freigabe netlogon, steht.
selbstverständlich ist das script immer noch den users zugewiesen. hab da nix verändert.

In der serververwaltungskonsole auf dem server sind die drucker eingerichtet. ansonsten hab ich nix gemacht.

wenn ich alle drucker auf den clients lösche danach einen neustart mache, dauert es vielleicht 10 sekunden bis alle drucker wieder automatisch eingefügt worden sind.

und zwar immer Druckername und dann in Klammern (von server01). Wenn ich einen Drucker manuell hinzufügen, heißt der drucker dann Druckername an server01.

Hab grad noch gesehen, das im Assi steht, "auch durch deaktivieren der checkboxen werden anwendungen nicht mehr entfernt". also anscheinend einmal den assistenten gestartet sind die einstellungen auf dem client. aber weg bekomm ich sie so einfach nicht mehr. das würde auch das verhalten erklären, hat sich nix verändert.

noch jemand einen tipp?

Gruß
Michael
Mitglied: bugmenot123
bugmenot123 08.10.2008 um 15:06:17 Uhr
Goto Top
Hallo Michael,

dass bei dir Drucker angezeigt werden, die in Klammern (von Server01) stehen haben liegt daran, dass du dich wahrscheinlich über Remotedesktop auf die PCs aufschaltest und die Drucker von deinem PC mit verbindest. Also in diesem Fall schaltest du dich von server01 auf die Client PCs via RDP auf und verbindest die Drucker mit. Einfach den Haken "Drucker" unter den RDP Ressourceneinstellungen rausnehmen. Bei einer lokalen Anmeldung am PC sollten diese Drucker nicht erscheinen.

Nachdem ich den Haken (wie Günther beschrieben hat) rausgenommen, danach alle Drucker gelöscht und PC neu gestartete habe, wurden die Drucker nicht mehr verbunden.

Schöne Grüße
Philipp
Mitglied: Michael-24
Michael-24 11.10.2008 um 13:13:51 Uhr
Goto Top
Hallo Philipp,

vielen Dank für Deine Nachricht.

Bin erst jetzt zum Testen gekommen und siehe da du hast Recht.

Jetzt läufts so wie ich es mir vorstelle!!!

Vielen Dank an euch alle, die mir geholfen haben!

Gruß
Michael